Jump to content
Latest News: (loading..)

John P

Members
  • Content count

    19
  • Joined

  • Last visited

1 Follower

Profile Information

  • Real Name
    John
  1. John P

    AJAX Attribute Manager support

    Hi all, I installed the latest version V2.8.14 on a fresh OSC 2.3.4. While opening/editing a product in admin with catergories.php, the index.php is loaded on the spot where the ajax attribute handler supposed to be loaded. This actually only happens when force use cookies is set to true in configuration/sessions/. If this setting is set to false, the handler is loaded correctly. This is the same issue as discussed on page on page 62, raised by xtrgeo, all the solutions discussed after that did not really solved the issue me. Anyone else faced this issue and eventually have solved? Please share. BR John
  2. Hello All, I have upgrade my shop to 2.3.3.4 and then found out that the special character conversion didn't work. Instead of converting the special characters, it just removed them from the URL. ie. Category /mydomain/Sportausrüstung ü=>ue should produce /mydomain/Sportausruestung Anywhere else on my site all special characters are displayed correctly. My Database is UTF-8 with uft8_unicode_ci My list of conversion in the admin Ü=>Ue,ü=>ue,Ö=>Oe,ö=>oe,Ä=>Ae,ä=>ae,ß=>ss I've re-instaled this addon, but if didn't help. In this topic I've read people facing same problem but no solution was mentioned. Any advise for me where to look for a solution. Wish all a happy 2014.
  3. Thanks Rainer for your quick response. I give it a go first. Best regards, John
  4. Hello Rainer, This mobile addon works excellent. One question, in the desktop shop we have the possibility to use filters like we choose an manufacturer and then we select ie t-.shirt from this manufacturer, the link would look like index.php?manufacturers_id=10&sort=3a&filter_id=50. Now I'm also using banners from the banner manager. These filters doesnot work in the mobile shop. My question, where can I add thes filter functions to the mobile shop? Best regards, John
  5. Hi Rainer, the issue with language redirect has been solved, it was a general problem in xampp. Online the mobile module works well. BR John
  6. Hi Rainer, I've installed the SEO URL addon for mobile OSC. My project is not yet online. Come back to you once I have this online. BR John
  7. Hi Rainer, I'm facing a new issue, read the forum but couldn't realy find an answer yet. I have a shop with 3 languages whereas the default language is german. The mobile runs. I can change the language while visiting any page. ie. I'm at conditions.php (german) I change the language by clicking on the language link adn then choose ie. english. The last page conditions.php is shown in english. However if I leave this page for ie home (index.php) then the languge changed back to german. Pls give me a hint how to solve this. The language function in catalog/includes/functions/html_output.php: // Ultimate SEO URLs v2.2d // The HTML href link wrapper function function tep_href_link($page = '', $parameters = '', $connection = 'NONSSL', $add_session_id = true, $search_engine_safe = true) { global $seo_urls; if ( !is_object($seo_urls) ){ if ( !class_exists('SEO_URL') ){ include_once(DIR_WS_CLASSES . 'seo.class.php'); } global $languages_id; $seo_urls = new SEO_URL($languages_id); } return $seo_urls->href_link($page, $parameters, $connection, $add_session_id); } //// The language funtion in catalog/inlcudes/classes/seo.class.php: * SEO_URL class constructor * @@author Bobby Easland * @version 1.1 * @@param integer $languages_id */ function SEO_URL($languages_id){ global $session_started, $SID; $this->installer = new SEO_URL_INSTALLER; $this->DB = new SEO_DataBase(DB_SERVER, DB_SERVER_USERNAME, DB_DATABASE, DB_SERVER_PASSWORD); $this->languages_id = (int)$languages_id; $this->data = array(); $this->turnOffBrokenUrls(); // Turn off experimental oscommerce search engine friendly urls catalog/includes/application_top.php: // set the language if (!tep_session_is_registered('language') || isset($HTTP_GET_VARS['language'])) { if (!tep_session_is_registered('language')) { tep_session_register('language'); tep_session_register('languages_id'); } include(DIR_WS_CLASSES . 'language.php'); $lng = new language(); if (isset($HTTP_GET_VARS['language']) && tep_not_null($HTTP_GET_VARS['language'])) { $lng->set_language($HTTP_GET_VARS['language']); } else { $lng->get_browser_language(); } $language = $lng->language['directory']; $languages_id = $lng->language['id']; } BR John
  8. Hi Rainer, Thanks for solving my problem. In html_output.php the image function was defined as require_once(DIR_FS_CATALOG . DIR_WS_CLASSES . 'image.php'); I delete DIR_FS_CATALOG and the mobile site runs now. BR John
  9. Hi Rainer, Thanks for your Quick answer. it was indeed the configure.php file. The previous error has disappeared. Now with the corrected configure.php I have following error: Warning: require_once(c:/xampp/htdocs/dev2/../includes/classes/image.php) [function.require-once]: failed to open stream: No such file or directory in C:\xampp\htdocs\dev2\includes\functions\html_output.php on line 73 I think this line is causing the trouble (defined('MOBILE_SESSION') ? define('DIR_WS_INCLUDES', '../includes/') : define('DIR_WS_INCLUDES', 'includes/')); I keep changing this in order to get it working but then one error disappears, then next one is coming up. My configure file looks like this: <?php define('HTTP_SERVER', 'http://127.0.0.1'); define('HTTPS_SERVER', ''); define('ENABLE_SSL', false); define('HTTP_COOKIE_DOMAIN', 'http://127.0.0.1'); define('HTTPS_COOKIE_DOMAIN', ''); define('HTTP_COOKIE_PATH', '/dev2/'); define('HTTPS_COOKIE_PATH', ''); define('DIR_WS_HTTP_CATALOG', '/dev2/'); define('DIR_WS_HTTPS_CATALOG', ''); define('DIR_WS_CACHE', 'cache/'); //BOF Mobile define('HTTP_MOBILE_SERVER', HTTP_SERVER); define('HTTPS_MOBILE_SERVER', HTTPS_SERVER); define('DIR_WS_HTTP_MOBILE', DIR_WS_HTTP_CATALOG . 'mobile/'); define('DIR_WS_HTTPS_MOBILE', DIR_WS_HTTPS_CATALOG . 'mobile/'); (defined('MOBILE_SESSION') ? define('DIR_WS_IMAGES', HTTP_SERVER . DIR_WS_HTTP_CATALOG . 'images/') : define('DIR_WS_IMAGES', 'images/')); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); (defined('MOBILE_SESSION') ? define('DIR_WS_INCLUDES', '../includes/') : define('DIR_WS_INCLUDES', 'includes/')); //EOF Mobile define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); //BOF Mobile define('DIR_MOBILE_IMAGES', 'images/'); define('DIR_MOBILE_INCLUDES','includes/'); define('DIR_MOBILE_MODULES', DIR_MOBILE_INCLUDES . 'modules/'); define('DIR_MOBILE_CLASSES', DIR_MOBILE_INCLUDES . 'classes/'); define('DIR_MOBILE_HEADERS', DIR_MOBILE_INCLUDES . 'headers/'); define('DIR_MOBILE_LANGUAGES', DIR_MOBILE_INCLUDES . 'languages/'); //EOF Mobile //BOF Mobile (defined('MOBILE_SESSION') ? define('DIR_WS_DOWNLOAD_PUBLIC', HTTP_SERVER . DIR_WS_HTTP_CATALOG . 'pub/') : define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/')); //EOF Mobile define('DIR_FS_CATALOG', 'c:/xampp/htdocs/dev2/'); //BOF Mobile define('DIR_FS_MOBILE', DIR_FS_CATALOG . 'mobile/'); //EOF Mobile define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/'); define('DB_SERVER', 'localhost'); define('DB_SERVER_USERNAME', 'root'); define('DB_SERVER_PASSWORD', ''); define('DB_DATABASE', 'testbank'); define('USE_PCONNECT', 'false'); define('STORE_SESSIONS', 'mysql'); ?> BR John
  10. Hello, I installed this great addon over the weekend, I've it it running on other shops but I can't get it working on my server. This below error appears when I change from classic site to mobile site. In fact this error message appears all the time when I try to open the mobilesite. I have SEO_URL and Headertags installed. Any ideas where I should look for a solution? Warning: require() [function.require]: http:// wrapper is disabled in the server configuration by allow_url_include=0 in C:\xampp\htdocs\dev2\includes\application_top.php on line 41 Warning: require(http://127.0.0.1/dev2/includes/functions/compatibility.php) [function.require]: failed to open stream: no suitable wrapper could be found in C:\xampp\htdocs\dev2\includes\application_top.php on line 41 Fatal error: require() [function.require]: Failed opening required 'http://127.0.0.1/dev2/includes/functions/compatibility.php' (include_path='.;C:\xampp\php\PEAR') in C:\xampp\htdocs\dev2\includes\application_top.php on line 41 Best regards, John
  11. John P

    Official PayPal IPN Support Thread

    Dear Morton, I have exactly the same problem since mid of April, I wonder whether Paypal or my host Strato changed something. except for adding new articles I have not change anything else. I have tried the IPN simulator in the sandbox toolbox but that seems not to reach me IPN.php, the simulator say html error 503 although if I enter the full address in the browser I do get an empty page. One strange issue I found is that once I change the CMOD of the EXT path into 755 and a minute later I check the CMOD of this again it shows 600 instead. Anyone facing the same issue? Please post your solution. John
×