Jump to content

djp120

Members
  • Content count

    23
  • Joined

  • Last visited

  1. Yep...Nice one...Thank you for that!
  2. Cool, I've done pretty much everything but that, must have missed that one. I'll give it a whirl a let you know... Thanks
  3. Hi... Have just started using STS and belive its quite awesome.. One issue I'm having... I have a mixture of category, product and default templates on my site. The parent category page is using its own template and I have set "Check parent templates" to false and therefore any sub-categories (unless template created) is using the default template. However, I need this to work also for the product_info pages. I have the case where a template has been created for the parent category (e.g. index.php?cPath=21) and the product that belongs to this category has no specified template. I need the product_info.php page to use the default template, however, it is using the parent category template...not good for me?! If anyone has any ideas, I would be internally grateful! D
  4. Hi...Great Contribution.... One problem i'm having, when I click through to the product information page (product_info.php) and then click the back button (not the browser back button), the sub-category header does not revert back...instead the sub-category header is the product header... ..Any Ideas? Thanks,
  5. djp120

    Select your country!

    Any ideas?
  6. Cool, i'll give them both a try thanks, Dan
  7. At the mo, $email = require(DIR_WS_MODULES . 'email_invoice/processed.php'); But having no luck, $email is used as the 4th field. I am thinking that i would need to use require to run the processed.php page first, else the information for that particular order will not be found??? I basically want to use that php page for the body.
  8. Hi Jim, Thanks for the quick response, I think I may have had my own syntax wrong. I meant that to say that a "1" was displayed in the body of the email and that nothing is returned. oops, sorry! Basically the php pages processed.php is a html email with variables to display the products ordered as used from the order.php class. I guess what i am wondering is there a way of using something like echo with a require in order to display the html email as the body. Thanks, Dan
  9. Hi, Please could anyone help me with the following... I am trying to include a php page as the body of an email. $email = require(DIR_WS_MODULES . 'email_invoice/processed.php'); tep_mail($order->customer['name'], $order->customer['email_address'], 'Your order has been processed', $email, STORE_OWNER, STORE_OWNER_EMAIL_ADDRESS); The email is sending but returning nothing but the character "1". Any ideas? Thanks
  10. djp120

    CSS Buttons - Hover Over

    I understand you'll prob have something that looks like this: <?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT) . '" class="cssbutton">' . TEXT_BUTTON_CONTINUE . '</a>'; ?> I think when i said duplicate, i think i forgot to change any of the parameters. The bit which has a.cssbutton is basically your link, so you make this whatever color, background etc you want it to look like before the mouse goes over. Sorry if its a bit dazy, i'm a bit new to this oscommerce thing myself. Trying to get my site up and running. P.s. site is looking good so far. Dan
  11. djp120

    What does .pd mean?

    Cool, thank you!
  12. djp120

    CSS Buttons - Hover Over

    Hi Alex, Try duplicating the code for the link. a.cssbutton:hover { color: black; background: #FEDFB8; display: block; } to have a.cssbutton { color: black; background: #FEDFB8; display: block; } and you'll have to add the class to the <a href=YOURLINK class="cssbutton"> so for example <?php echo '<a href="' . YOUR CODE . '" class="cssbutton">YOUR TEXT LINK</a>'; ?>
  13. djp120

    CSS Buttons - Hover Over

    Oops, sorry try changing the top part as well.. so it looks like, a.cssbutton:hover {
  14. djp120

    CSS Buttons - Hover Over

    Hi Alex, I had the same problem, i think. Try adding the code line display: block; to the css style.
  15. "select p.products_id, pd.products_name, p.products_price, p.products_tax_class_id, p.products_image, s.specials_new_products_price from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd, " . TABLE_SPECIALS . " s where p.products_status = '1' and p.products_id = s.products_id... In the above what does the p., s. and pd. mean before each table field?
×