Latest News: (loading..)

adrianconchie

Members
  • Content count

    22
  • Joined

  • Last visited

About adrianconchie

Profile Information

  • Real Name
    A Conchie
  • Gender
    Male
  1. RE: Message Stack Not Working Hi. I installed this contribution around 6 months ago and it has worked like a charm so far for what I have needed - its a fantastic contribution. However now I want to use the "upload image" function so that customers can upload image files for engraving. Everything seems to work fine - the images upload OK to the image upload directory, but the problem is that none of the message stack errors (or successes) show up at all, so that from the customer's point of view, it is a bit confusing as to whether the image has uploaded or not. The main message I need to show is the "SUCCESS_FILE_SAVED_SUCCESSFULLY" one, preferably on the shopping cart once the image is uploaded. I have searched high and low and been through the code from scratch to check that I've installed it correctly and it seems OK - I just can't work out why none of the messagestack messages show. Maybe there is something missing from my "header.php" or "application_top.php" file but I can't work out what. I hope someone can help! Thanks
  2. I have recently installed this contribution which I think is fantastic! I had a few problems but managed to work through each one successfully. Now everything works fine except 1 small thing. I have a Text Input field as an attribute which I would like to add to all of my products. When a customer completes the text in the input field - and then chooses to pay by Paypal - the text shows successfully all the way through to checkout confirmation page and also shows OK in order history / invoice and packing slip after the order is placed, but on the Paypal page itself, the attribute value is showing as "CUSTOMER-INPUT" instead of the text. This isn't really a big problem, as I can still see the text on the invoices and confirmation email etc after the customer has placed the order but from the customer's point of view, they may think that the text has been lost between my site and Paypal and therefore abandon the purchase. I may be looking in the wrong place but I have had a look at the Paypal IPN code in modules/payment and it looks like it passes the value through as the attribute's "value_id" $order->products[$y]['attributes'][$z]['value_id'] In the case of the text input attribute I assume the default value id is "0", which would make it show CUSTOMER-INPUT, rather than the text entered by the customer. Has anyone else has this issue? Is there a code modification I need to do? It does seem to be passing the information through OK somewhere, as the correct text shows after the order is placed in admin. I hope someone can help!. Thanks. p.s. I've already modified 1 line of code in the Paypal IPN module so that the text from the customer input field does go through to the admin (as before it showed as CUSTOMER-INPUT aswell on the invoice and packing slip in admin). This modification fixed this issue: $sql_data_array = array('orders_id' => $insert_id, 'orders_products_id' => $order_products_id, 'products_options' => $attributes_values['products_options_name'], // BOF - Zappo - Option Types v2 - ONE LINE - Update insert query. changed to use value from $order->products. 'products_options_values' => $order->products[$i]['attributes'][$j]['value'], // EOF change added by ADM 'options_values_price' => $attributes_values['options_values_price'], 'price_prefix' => $attributes_values['price_prefix']);
  3. Hi Jack - Thanks for the suggestion. I have uploaded a fresh unmodified version of the product_info.php file as a test, but the same problem happens. I have compared the application_top.php file with a clean version also - but I can't see anything there which is that different than the original. The other thing that I thought of which may or may not affect it, is that I'm running the shop on a Zeus server (rather than Apache), so instead of an .htaccess file, I have a rewrite.script file (the script was converted to zeus). This is the rewrite.script file: RULE_0_START: # get the document root map path into SCRATCH:DOCROOT from / # initialize our variables set SCRATCH:ORIG_URL = %{URL} set SCRATCH:REQUEST_URI = %{URL} # prepare to search for file, rewrite if its not found set SCRATCH:REQUEST_FILENAME = %{SCRATCH:DOCROOT} set SCRATCH:REQUEST_FILENAME . %{SCRATCH:REQUEST_URI} look for file at %{SCRATCH:REQUEST_FILENAME} if not exists then look for dir at %{SCRATCH:REQUEST_FILENAME} endif RULE_0_END: RULE_1_START: match URL into $ with ^(.*)-p-(.*).html if matched then set URL=/product_info.php?products_id=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-c-(.*).html if matched then set URL=/index.php?cPath=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-m-(.*).html if matched then set URL=/index.php?manufacturers_id=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-pi-(.*).html if matched then set URL=/popup_image.php?pID=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-by-(.*).html if matched then set URL=/all-products.php?fl=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-t-(.*).html if matched then set URL=/articles.php?tPath=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-a-(.*).html if matched then set URL=/article_info.php?articles_id=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-au-(.*).html if matched then set URL=/articles.php?authors_id=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-pr-(.*).html if matched then set URL=/product_reviews.php?products_id=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-pri-(.*).html if matched then set URL=/product_reviews_info.php?products_id=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-f-(.*).html if matched then set URL=/faqdesk_info.php?faqdesk_id=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-fc-(.*).html if matched then set URL=/faqdesk_index.php?faqPath=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-fri-(.*).html if matched then set URL=/faqdesk_reviews_info.php?faqdesk_id=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-fra-(.*).html if matched then set URL=/faqdesk_reviews_article.php?faqdesk_id=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-i-(.*).html if matched then set URL=/information.php?info_id=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-links-(.*).html if matched then set URL=/links.php?lPath=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-pm-([0-9]+).html if matched then set URL=/info_pages.php?pages_id=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-n-(.*).html if matched then set URL=/newsdesk_info.php?newsdesk_id=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-nc-(.*).html if matched then set URL=/newsdesk_index.php?newsPath=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-nri-(.*).html if matched then set URL=/newsdesk_reviews_info.php?newsdesk_id=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-nra-(.*).html if matched then set URL=/newsdesk_reviews_article.php?newsdesk_id=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-po-([0-9]+).html if matched then set URL=/pollbooth.php?pollid=$2&% goto QSA_RULE_START endif RULE_1_END: QSA_RULE_START: # append the query string if there was one originally # the same as [QSA,L] for apache match SCRATCH:ORIG_URL into % with \?(.*)$ if matched then set URL = %{URL}&%{SCRATCH:QUERY_STRING} endif goto END QSA_RULE_END:
  4. Hi, I have been trying to get this contribution working properly for a while now - Everything works fine, except the "Add to Cart" button doesn't work on the product_info.php page. It should load the shopping cart and show the added product in the cart, but instead it just seems to refresh the product_info page and doesn't add the product to the cart. Here's an example of a URL after the "Add to Cart" button is pressed on the product_info.php page: http://www.mywebsite.co.uk/101-tropical-freshwater-fish-dvd-p-44933.html?action=add_product I get the feeling that the "?action=add_product" part of the URL should have a product ID included, as it does when SEO URLs is switched off. The "buy_now" button in the product listing module works fine however. I have searched the forums and there are plenty of people with problems with the "add to cart" button, but not on the product_info page, or their problem has been with the buy now button (which is the opposite of my problem), so I can't find an answer. Can anyone help with this? Thanks in advance. The version I am using is 2-2.2d-12
  5. OK - the problem seems to be resolved in my last post. I now have One Page Checkout working correctly (version 1.5) but with 2 issues (this happens with both Paypal IPN Module and Worldpay Junior): 1. When a user clicks on continue on OPC to proceed to Paypal / Worldpay, the order confirmation email is generated and sent to the customer before they have input any payment details into Paypal / Worldpay instead of being generated on the checkout_success page. 2. The order status in admin is set incorrectly to "Payment Received", when it should be "Preparing - Payal IPN" at this point also, before the customer has input any payment details. When I switch One Page Checkout off, Worldpay and Paypal IPN modules work correctly as they should. I assume there is few lines of code somewhere which tell the payment module when to generate the email and at what point to update the order status, but I am unable to find it and not sure what to change it to, to resolve this problem. I would be grateful if anyone could help. Thanks.
  6. Hi all, I have installed this contribution onto my site and it seems to work perfectly in Firefox and Chrome, but in IE 9, all the fields are squashed, making the layout look messy and it would definitely put people off. I have looked at another forum thread relating to this problem and they suggest that it is because IE9 is running in compatibility mode and this needs to be turned off - however my compatibility mode is switched off and it still seems to have squashed fields. As 85% of the site's visitors are using IE, I am reluctant to use this contribution unless I can solve this problem, but I do need a one page checkout. I hope someone can help. Thanks in advance.
  7. Hi, I have just installed this contribution on my website and it seems to work well, however, as I am in the UK there is a problem with the TAX (VAT amount). It seems to be working the tax ( UK VAT ) out based on the original amount of the items before the discount was applied. Everything else is fine. Example: Sub-Total (Inc VAT): £114.03 (Correct) Voucher - 10% Discount (gdx45t10) -£11.40 (Correct) Standard Delivery (Inc VAT) 13.079 kg(s)): £7.99 (Correct) Total (Inc VAT): £110.62 (Correct) UK VAT 20% (included in price): £20.34 (Wrong - Should be £18.44). In the UK - we have to show our prices with tax (VAT) included on our stores and if a discount is applied to an order, we have to charge the VAT on the new amount (after discount) - not the original amount. Therefore the VAT amount of £110.62 Including VAT should be £18.44. Maybe I'm doing something wrong. I can't be the only one with this problem? I hope someone can help. Thanks.
  8. Just installed this on v2.2 and I'm getting an error 500 page in admin/cross_sell.php Why would this be? Please help!
  9. I managed to sort out the Zeus problem. I had to convert the .htaccess Apache script to a Zeus "rewrite.script" file by modifying the script. It seems to work now, although I've not fully tested it. There doesn't seem to be anywhere else on the web which gives you the script, or refers to this problem so, In case anyone else is on a Zeus server and is having the same problem - here is the rewrite script I used: RULE_0_START: # get the document root map path into SCRATCH:DOCROOT from / # initialize our variables set SCRATCH:ORIG_URL = %{URL} set SCRATCH:REQUEST_URI = %{URL} # prepare to search for file, rewrite if its not found set SCRATCH:REQUEST_FILENAME = %{SCRATCH:DOCROOT} set SCRATCH:REQUEST_FILENAME . %{SCRATCH:REQUEST_URI} look for file at %{SCRATCH:REQUEST_FILENAME} if not exists then look for dir at %{SCRATCH:REQUEST_FILENAME} endif RULE_0_END: RULE_1_START: match URL into $ with ^(.*)-p-(.*).html if matched then set URL=/product_info.php?products_id=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-c-(.*).html if matched then set URL=/index.php?cPath=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-m-(.*).html if matched then set URL=/index.php?manufacturers_id=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-pi-(.*).html if matched then set URL=/popup_image.php?pID=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-by-(.*).html if matched then set URL=/all-products.php?fl=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-t-(.*).html if matched then set URL=/articles.php?tPath=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-a-(.*).html if matched then set URL=/article_info.php?articles_id=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-au-(.*).html if matched then set URL=/articles.php?authors_id=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-pr-(.*).html if matched then set URL=/product_reviews.php?products_id=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-pri-(.*).html if matched then set URL=/product_reviews_info.php?products_id=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-f-(.*).html if matched then set URL=/faqdesk_info.php?faqdesk_id=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-fc-(.*).html if matched then set URL=/faqdesk_index.php?faqPath=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-fri-(.*).html if matched then set URL=/faqdesk_reviews_info.php?faqdesk_id=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-fra-(.*).html if matched then set URL=/faqdesk_reviews_article.php?faqdesk_id=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-i-(.*).html if matched then set URL=/information.php?info_id=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-links-(.*).html if matched then set URL=/links.php?lPath=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-pm-([0-9]+).html if matched then set URL=/info_pages.php?pages_id=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-n-(.*).html if matched then set URL=/newsdesk_info.php?newsdesk_id=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-nc-(.*).html if matched then set URL=/newsdesk_index.php?newsPath=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-nri-(.*).html if matched then set URL=/newsdesk_reviews_info.php?newsdesk_id=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-nra-(.*).html if matched then set URL=/newsdesk_reviews_article.php?newsdesk_id=$2&% goto QSA_RULE_START endif match URL into $ with ^(.*)-po-([0-9]+).html if matched then set URL=/pollbooth.php?pollid=$2&% goto QSA_RULE_START endif RULE_1_END: QSA_RULE_START: # append the query string if there was one originally # the same as [QSA,L] for apache match SCRATCH:ORIG_URL into % with \?(.*)$ if matched then set URL = %{URL}&%{SCRATCH:QUERY_STRING} endif goto END QSA_RULE_END:
  10. I've just spoke to my host and they have said that it is a Zeus server and the Rewrite function is for Apache servers. They suggested using a conversion script. I will have a look online for one. Any suggestions in the meantime?
  11. re: my previous post above I forgot to include the version of the contribution - V2.2d
  12. Hi, I hope someone can help. I have installed this contribution and it seemed fairly straight forward to install, however I am getting a 404 page for all of the URL's. The admin section works fine and when I switch the contribution off in the admin cp, the site works fine again. I have read about the RewriteBase / function and that if this is not configured correctly, then this can cause 404 pages (not loading), but my catalog is set in the root directory of the site, so I have set it to RewriteBase / but this still does not work. My site is http://www.thelightershop.co.uk the catalog is located in the root directory. This is my .htaccess file: # Begin Ultimate SEO V2.2d Options +FollowSymLinks RewriteEngine On RewriteBase / RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING} RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING} RewriteRule ^(.*)-by-(.*).html$ all-products.php?fl=$2&%{QUERY_STRING} RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING} RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-au-(.*).html$ articles.php?authors_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-f-(.*).html$ faqdesk_info.php?faqdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-fc-(.*).html$ faqdesk_index.php?faqPath=$2&%{QUERY_STRING} RewriteRule ^(.*)-fri-(.*).html$ faqdesk_reviews_info.php?faqdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-fra-(.*).html$ faqdesk_reviews_article.php?faqdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-links-(.*).html$ links.php?lPath=$2&%{QUERY_STRING} RewriteRule ^(.*)-pm-([0-9]+).html$ info_pages.php?pages_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-n-(.*).html$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-nc-(.*).html$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING} RewriteRule ^(.*)-nri-(.*).html$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-nra-(.*).html$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-po-([0-9]+).html$ pollbooth.php?pollid=$2&%{QUERY_STRING} # End Ultimate SEO V2.2d In my configure.php file, I have the line: define('DIR_FS_CATALOG', '/content/Hosting/t/h/thelightershop.co.uk/web/'); so, I have also tried: RewriteBase /content/Hosting/t/h/thelightershop.co.uk/web/ and RewriteBase /web/ But none of these work either. I have also double checked that I have edited and installed all of the files properly. Please help! Thanks