Jump to content

adamjnz

Members
  • Content count

    4
  • Joined

  • Last visited

  1. adamjnz

    Official PayPal IPN Support Thread

    All of a sudden all payment attempts through PayPal are now generating the following error when it transfers to PayPal: Unable to process payment. Please contact the merchant as the shipping address provided by the merchant is invalid, and the merchant has requested that your order must be shipped to that address. The addresses are certainly valid and this has just started happening (No config changes at our end what so ever. Running version 2.3.3 I have tried Googling but was not able to come up with anything useful. Any suggestions?
  2. adamjnz

    Official PayPal IPN Support Thread

    OK so here is what has happened recently 1) Tried to setup another (Hard coded) store and used the PayPal integrated shipping thing to work out the shipping 2) Noticed that shipping no longer got charged through osCommerce. Did some googling and saw that I cant used the PayPal shipping as this breaks the PP IPN. Cleared the shipping out but didnt fix it. Upgraded to latest version of the PP IPN - That fixed the shipping, but now no status change. 3) 2 Weeks ago the site was moved to a new server, the site doesnt get a lot of orders (1-3 a week) and I have a feeling the status thing may have been happening since then, but havent got a clue where to start looking if its a server config thing. We had some permission issues with the server move, but fixed all the ones it warned me about. Is there perhaps another file somewhere that could have wrong permissions that would accept a response back from the IPN?
  3. adamjnz

    Official PayPal IPN Support Thread

    Futher to my above post. The payment is fully accepted and cleared in PayPal, and email notification is recieved at both ends confirming this. Behavior is exactly the same in both live and sandbox modes.
  4. adamjnz

    Official PayPal IPN Support Thread

    I'm having an issue with osCommerce 2.2-MS2 and osCommerce PayPal IPN Module v2.3.2 For 2.2MS2. When the customer makes the payment and the payment is accepted the order status does not change from "Preparing [PayPal IPN]" to "Processing" as it used to, it just stays the same. I had read that this can take some time however I have orders processed over 24 hours ago that havent changed. I've done a whole lot of googing but can't find a solution to this. Is anyone able to shed some light? Not sure if any of this info helps: Server Host: ********************** Database Host: localhost (127.0.0.1) Server OS: Linux 2.6.9-55.ELsmp Database: MySQL 4.1.22-standard Server Date: 11/15/2007 14:52:41 Datebase Date: 11/15/2007 14:52:41 Server Up Time: 14:52:41 up 49 days, 2:24, 0 users, load average: 1.13, 1.21, 1.14 HTTP Server: Apache/1.3.39 (Unix) mod_auth_passthrough/1.8 mod_log_bytes/1.2 mod_bwlimited/1.4 FrontPage/5.0.2.2635.SR1.2 mod_ssl/2.8.30 OpenSSL/0.9.7a PHP-CGI/0.1b PHP Version: 5.2.3 (Zend: 2.2.0)
×