Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

balloons

Members
  • Content count

    144
  • Joined

  • Last visited

Everything posted by balloons

  1. balloons

    [Contribution] STS v4

    After a bit of struggling I have managed to make a template for the index page by calling it 'index.php_0.html' so that page displays and when you go to other pages the default template is displayed. So, what I would now like to know is what do I need to name the templates for other pages that I want to have specific templates for? I have added a few new pages to my information box and would like to have specific pages for them etc but not sure as to what I name them etc. Can anyone again point me in the right direction?
  2. balloons

    [Contribution] STS v4

    After reading the previous post about having a template for a specific page I thought I would again try to get it working on my site. I have one template that acts for every category including the index page easy enough, now I made a quick test template by simply leaving out the '$content' and naming it 'index.php.html' to see if it worked. Now when I have that file on my site then it works which is great but whenever I go to another page then it is the same, no content which means it is reading from the test index file and not from my main template. Can anyone tell me where I am going wrong?
  3. balloons

    [Contribution] STS v4

    Can anyone tell me what name I need to save the cartbox as to make the infobox template for the cartbox appear? I have tried saving it as 'infobox_cartbox.php' and 'infobox_cart.php' but whichever I save it as the box does not appear? Thanks.
  4. balloons

    [Contribution] STS v4

    Well after a long trying to figure out the infobox problem I have to say that I am still stuck deep in the mud! I found that if I remove all the infobox templates and switch infobox templates on then it registers a problem in that it cant find them, but the text is the size it should. Now, if I ten place the basic infobox template in then the text goes to a larger size for some reason and its this problem that I am still trying to figure out. I have tried to make the text smaller on dreamweaver and while this works when it is previewed as soon as I switch on sts infoboxes then the text goes large again. I am really stuck and its driving me mad and really not sure how to correct this, any ideas as I am all out even after trying all the suggestions so far.
  5. balloons

    [Contribution] STS v4

    I was having probs getting the infoboxes to work but eventually got them to work by inserting the header and main content for each box, but the header part is pretty much blank as this was the only way I could get them to work. Here is the code for the category box: <table width="130" border="0" cellspacing="0" cellpadding="0"> <tr> <th scope="col"><img src="../../images/cat-box-top2.jpg" width="130" height="27"></th> </tr> <tr> <td background="../../images/cat-box-middle2.jpg"><table width="100%" border="0" cellspacing="0" cellpadding="0"> <tr> <th width="8%" scope="col"> </th> <th width="88%" scope="col"><font size="-2"> $content</th> <th width="4%" scope="col"> </th> </tr> </table></td> </tr> <tr> <td><img src="../../images/cat-box-bottom2.jpg" width="130" height="11"></td> </tr> </table> And here is the code for category header box: <table width="0" border="0" cellspacing="0" cellpadding="0"> <tr> </table></td> </tr> <tr> <td> </td> </tr> </table> As you can see the header box is pretty much empty, but thats the only way I could get them to work. When I just have the main content up then the only image that displays is the lower half of the box, not the middle or top for some reason which is why I have a near empty header which then works. I deleted the header files from each box and tested to see what would happen, and when I did that each box displayed the lower half image and the text all through the site went bigger. I am not sure but it seems that some other file is for some reason over riding the css file and I am not sure where that could be!
  6. balloons

    [Contribution] STS v4

    I have downloaded and installed the web developer tools for firefox and had a look at the files when the infoboxes are off and on but cant see where it is making the change. It does have the link to the style sheet when the infoboxes are turned on but I cannot see what could be making the change through the whole of the site when the infoboxes are turned on. I am really not sure as to what is causing this even after looking at the code!!
  7. balloons

    [Contribution] STS v4

    Does anybody have an answer to my above question? I have been trying to solve it all day but to no avail and am really stumped. It would seem that when the sts infobox templates are switched on for some reason the site no longer follows the css file specified for it and some other file takes over. I cant seem to find that file anywhere and cannot understand why all the text all through my site is affected. Hopefully someone can help me find an answer as its driving me mad!!!!
  8. balloons

    [Contribution] STS v4

    Well I have had a look at each of the files but cannot see where it is getting the adjustments. On my main css file I have the font set at 70% which displays a nice neat font all through the template from each of the infoboxes to the main content area. However, as soon as I soon as I switch on the infobox templates then all the text from the infoboxes to the main content become bigger and its as if something somewhere is over riding the main css file to make the content text bigger. Does anybody know how I can specify the text size when the infobox templates are turned on?
  9. balloons

    [Contribution] STS v4

    Thank you for the reply Tracy, but I cant seem to adjust the font in the infoboxes. In the template I made I specified the font using the spanclass but it did not change it at all on the site. I also tried linking it to my main css template that I know makes the text smaller when the infobox templates are off and that did not change it either. Any ideas where I am going wrong?
  10. balloons

    [Contribution] STS v4

    Cheers for the links to the contributions bill they are great! However, I still have a slight problem with the infoboxes in regards to the font size. On my style sheet I have specified a certain font size and all works well, but when I turn on the infobox templates the font goes to a larger size than I want and I am not really sure how to adjust the size of the font. I have tried adjusting the size via the infobox but that doesnt seem to make any difference as the font in all the infoboxes are larger than I want. Where can I change to font size on the infoboxes?
  11. balloons

    [Contribution] STS v4

    Please disregard the above post as I have now found the answer. I added the 'width' tag on the style sheet and things are looking and working great and the infobox templates work great too. The only problem is when I use a fixed width 3 column css template then after I specify the width the image items are ok but when I go to log in the same problem as before occurs, but at least I now know where the problem lies. What I would like to ask is how am I able to insert a small image before each category in the category infobox. I have seen other oscommerce sites that have that as well as a dotted line between each category but I have no idea how to do that, can someone enlighten me at all? Thanks for the help.
  12. balloons

    [Contribution] STS v4

    I have tried looking at the float to see whats causing the problem but the main content does not have a float. It seems no matter what design I do as soon as I turn on infobox templates the whole of the main content appears lower than the footer when displayed in internet explorer only, when viewed in firefox it appears normal and level with the categories menu as it should. Every design I have used css and have used a fixed width with one left side bar, a fixed width with a left and right side bar and even if I use a liquid layout so that it expands to fill the screen the main content always appears lower than the main content when infobox templates are turned on! I am at a loss as to what to do to make things appear correct in internet explorer and have even thought about designing the whole site using tables, but I keep reading that tables are now outdated and to stick to css?! Has anyone got any ideas as to whats going wrong? I have pasted the css code below for a fixed width with one left had side bar: @charset "utf-8"; body { font: 90% Verdana, Arial, Helvetica, sans-serif; background: #666666; margin: 0; padding: 0; text-align: center; color: #000000; } .thrColFixHdr #container { width: 780px; background: #FFFFFF; margin: 0 auto; text-align: left; } .thrColFixHdr #header { background:url(images/header3.jpg); background-repeat:no-repeat; height:130px; padding: 0 10px 0 20px; } .thrColFixHdr #header h1 { margin: 0; padding: 10px 0; } .thrColFixHdr #sidebar1 { float: left; width: 130px; background: #ffffff; padding: 15px 10px 15px 20px; } .thrColFixHdr #sidebar2 { float: right; width: 130px; background: #ffffff; padding: 15px 10px 15px 20px; } .thrColFixHdr #mainContent { margin: 0 180px; padding: 0 10px; } .thrColFixHdr #footer { padding: 0 10px 0 20px; background:#DDDDDD; } .thrColFixHdr #footer p { margin: 0; padding: 10px 0; }
  13. balloons

    [Contribution] STS v4

    Thanks again for the reply bill. I will try to work on the main content as I did believe that it worked the same as a infobox, but never mid we all learn! But in the mean time surprise surprise I have another problem! I am working on a template using css and a set width at 780px. Now I have set my images to display in rows or two so that there is more room for the infoboxes. Now, when I test a 2 or 3 column css template and view it in firefox and internet explorer then things view fine and as I want them to display. However, when I enable the templates for infoboxes if I view them in firefox things look ok, but viewed in internet explorer it seems that the main content is too big and displays lower than the lowest end of my template and when I switch off infobox templates things go back to as they should. Does anybody kow what I am doing wrong and how to fix things?
  14. balloons

    [Contribution] STS v4

    I have now found out how to insert a login and logoff button and put them onto my site. But, I am still stuck as to what I need to name the infobox that contains the main content ($content)? I have made templates for the other infoboxes and they look fine but I am still not sure what I need to name toe infobox for that template to work? Again, I have tried all the names I can think but to no avil so really do need some help to finish it off? Does anybody know?
  15. balloons

    [Contribution] STS v4

    Thanks for the reply bill but I am looking to make a infobox that will surround the main content. I have made infoboxes for categories, information, whats new and for the search but cannot see what I should name the file for the infobox for the main content? I have tried all the names I can think of but none of them seem to work like 'infobox_product_listing_.php.html' and 'infobox_content.php.html' but I cant seem to find the name that applies to the infobox I want to change? Also, another question is I have inserted the tag '$loginofflogo' and it displays 'log in' in text and 'log off' in text and I would like to know if there is a way that I can change that log in text from text to an image?
  16. balloons

    [Contribution] STS v4

    I am setting up the infoboxes and have got all the boxes working and know what to name them aprt from the main content box! I know that to include the infobox for the whats new box I would call the file 'infobox_whats_new.php.html', but I dont know what to call the infobox for the content that displays in the middle as I have tried all the names I thought it would be but to no avail? Can anyone tell me what I should name it?
  17. balloons

    [Contribution] STS v4

    I am still trying to figure out how these pesky infoboxes work! Now, I have tried putting the link to the images on the website but that does not work even though I have tried allsorts of link combinations. However, I have had a rather strange success! If I create the infobox template that contains the infobox images and upload that, then with the infobox_header I removed all the code except the for code below, then the infobox now displays as it should and it looks like no errors are coming from it and its working great! I know that this is pehaps not the ideal way to do it but if it so far works then I shall see if it works for all the other infoboxes unless someone can tell me whats going wrong? Why would the infobox only work if there is a nearly blank infobox_header template?? <table width="0" border="0" cellspacing="0" cellpadding="0"> <tr> </table></td> </tr> <tr> <td> </td> </tr> </table>
  18. balloons

    [Contribution] STS v4

    Thanks for the help bill. Yes I did know that it was not the right thing to do to put the body and header with the same code, but I wanted to try every angle as to why the box does not appear! I did try the link straight to the image but to no avail. I tried to keep everything in one template and uploaded that and named it infobox_information.php.html but it just wont have it which is whay I have been clutching at straws!!
  19. balloons

    [Contribution] STS v4

    Well things just get more strange by the minute! I have been playing around with the infoboxes but still not getting things to display correctly. However, as a test I saved the box I was working on in dreamweaver as 'infobox_information.php.html' and saved it again as 'infobox_information_header.php.html'. Now, when I went to view my site the box appeared fully formed and working great except that there was another infobox above but that was only displaying the lower half of the image! Now, try as I might I cannot get things to work right with just one box and I have tried all different combinations that I can think of! I know it is finding the correct path to the images as the test above showed. Can anyone shed anymore light on this strange occurance? Heres the code once again: <table width="150" border="0" cellspacing="0" cellpadding="0"> <tr> <th scope="col"><img src="../../images/boxtop3.jpg" width="150" height="31"></th> </tr> <tr> <td background="../../images/boxmiddle3.jpg"><table width="150" border="0" cellspacing="0" cellpadding="0"> <tr> <th width="10" scope="col"> </th> <th width="129" scope="col">$content</th> <th width="11" scope="col"> </th> </tr> </table></td> </tr> <tr> <td><img src="../../images/boxbottom3.jpg" width="150" height="27"></td> </tr> </table>
  20. balloons

    [Contribution] STS v4

    I am looking into changing the design of my info boxes and am in nheed of some help! I have designed a basic box in photoshop and sliced it up into three images, top, middle and bottom. When I go to dreamweaver and make a table of 150 width with a three rows and the top in the top row, the bottom in the bottom row and the middle set as a background so that it tiles and expands down. When I test this in my browser it works great but when I upload it to my site and test it the middle image is missing and so does not tile! Can anyone tell me what I am missing or doing wrong?
  21. balloons

    [Contribution] STS v4

    Thanks bill. What is confusing me about the link is when I click it, it shows me the page for 'sts tutorial for version 4', but when I scroll down it says the cost of the ebook is £16.99!!! I have had a look but cant see a free download link anywhere on the site! Sorry for being slow but I have had a real good look but cant seem to find the link!
  22. balloons

    [Contribution] STS v4

    Thanks for the info and the link bill. I have to ask tho to get the tutorials on how to make better info boxes do I need to purchase them from you?
  23. balloons

    [Contribution] STS v4

    I am trying to make box templates for the infoboxes but am pretty stuck! I have searched all around about how to make boxes but cant seem to find anything. If I look at the information header box in dreamweaver it gives me three boxes in which to make the header, now what ever way I do it I cannot make the box stretch and have a nice round corner on the left an the right. I have tried background for the middle image and set it to 100% and 99% but they just seem to stack on top of each other instead of making one long header. Does anyone know of any tutorials about how to make my boxes using tables?
  24. balloons

    [Contribution] STS v4

    I am in the process of changing the look of my store from a two column to a three column using css. When I use STS to change over templates things look as they should and work great when viewed using firefox, however, when viewed using internet explorer instead of the products on the entry page appearing at the top as in firefox they appear way down so that you have to scroll to find them, this also happens on the contact us and may account page? Does anybody know why this is just happening in internet explorer and how to fix it? I have looked for the maximum numbers in admin to display only 2 rows across instead of 3 as I have now but cant find that so I am stuck as to how to correct this simple problem? Cheers.
  25. balloons

    [Contribution] STS v4

    I am still trying to get the templates for sts infoboxes working but am having a few probs still!! I would like to know how I am able to test the changes I make to my store without changing the store design while there are customers about? I do not want to have to wait until the site is clear before I cna test the changes and I do not want to put up a temporary redirect page up? Anyone got any idea how I can do this? Also, my basic template design is a flexible design using css, and when I turn on sts infobox templates then they seem to work ok but when I click on a single item then the boxes stretch all the way down past the template? Do I need to specify a certain minimum height for my template to accomodate the infoboxes? Cheers.
×