Jump to content
Latest News: (loading..)

suscrofa

Members
  • Content count

    127
  • Joined

  • Last visited

Profile Information

  • Real Name
    Lark Burnham

Recent Profile Visitors

4,700 profile views
  1. Different versions of UPSXML have been installed in both Edge and old and both did the same thing: not listed in admin/shipping modules, BUT indicates there are more choices than it shows for installing. I thought the problem was with the modules.php file in admin, but that didn't make any difference. Does anyone recognize what is happening? Our old UPSXML in a Gold version stopped working sometime this year. Thanks for your help. Lark Burnham Horton, KS, USA
  2. suscrofa

    Code for modules.php for shipping

    Sorry for the delay, I had to get the Edge file modified. I added the code as directed, but I am still not seeing UPS as a choice in admin shipping. Please send the entire block of code as it should be. Thank you. Lark
  3. suscrofa

    Code for modules.php for shipping

    Thank you for that clarification. Does the code that is to be inserted need to be updated as well? if( is_array( $value ) ){ $value = implode( ", ", $value); $value = preg_replace ("/, --none--/", "", $value); } Thanks again. Thanks again. Lark
  4. suscrofa

    Code for modules.php for shipping

    This is from the installation directions for USPS newest version available at addons.oscommerce.com. Similar instructions appear in UPSXML.: ***************************************** Find This code somewhere around line 43: ***************************************** if (tep_not_null($action)) { switch ($action) { case 'save': reset($HTTP_POST_VARS['configuration']); while (list($key, $value) = each($HTTP_POST_VARS['configuration'])) { *********************************************** INSERT THE FOLLOWING CODE AFTER THE ABOVE LINE: *********************************************** if( is_array( $value ) ){ $value = implode( ", ", $value); $value = preg_replace ("/, --none--/", "", $value); } This is the closest I can find in edge version of modules.php: if (tep_not_null($action)) { switch ($action) { case 'save': foreach ($_POST['configuration'] as $key => $value) { tep_db_query("update " . TABLE_CONFIGURATION . " set configuration_value = '" . $value . "' where configuration_key = '" . $key . "'"); Your suggestion would not work in this instance. Thank you for your help (again), Jack. Lark
  5. The code changes listed on the most recent version of UPSXML and USPS installation instructions for modules.php in admin are for an earlier version of osc. Edge requires different modifications to make UPS and USPS work. I looked for an appropriate thread, but found none. Surely someone has dealt with this problem. I tried to install shipping modules on Edge and they did not appear as a choice without modifying modules.php in admin. Please point me to a thread that contains the proper code changes for modules.php. Thank you. Lark Burnham, Horton, KS
  6. suscrofa

    Upgrading to the latest version

    Dear Jack; After I set up Edge with a few products, I wanted to make sure my payment and shipping modules worked. I tried to do a fake order, but every time I tried to 'buy' (place in shopping cart), I got an Internal server error message. I contacted my server, and they said my version was already old. I dl the version on the top of this post, installed the db, and changed the configure.php files. I then tried to 'buy' one of the products that came with the package and I get the same error message. I changed php version to 5.6 just in case. Still get eror message. Any clues to what is going on? Thanks for your help. Lark Burnham, Horton, Kansas, USA
  7. suscrofa

    how to install ??

    I got to the credentials page, entered e-mail, password, and Merchant ID, but do not know how to find API sig. I saved what was entered, but still getting the message under payment module about configuring API credentials. What is the API sig and how do I find it? Is that what is holding things up? Thanks. Lark
  8. suscrofa

    how to install ??

    I found 'Start', put in the account e-mail, and tried to put in the country, but the button will not let me procede.
  9. suscrofa

    how to install ??

    Dear Jack; After you recommended uploading the PayPal app, I decided to go to the Edge version, which already has it installed. I have been over the module several times, but I cannot find where to input the e-mail address of our account. I keep being told the module will not run without it. Please enlighten me. Thanks. Lark Burnham Horton, KS, USA
  10. suscrofa

    Reply to Jack_mcs about Error (60) e-mails

    How is the "payPal app' different from the PayPal module? The only threads I find about it are the current discussion. Lark
  11. suscrofa

    Reply to Jack_mcs about Error (60) e-mails

    Yes, we have TLS 1.2, according to this analysis. I am wondering now if re-installing the two payment modules would help. Thanks. Lark
  12. suscrofa

    Reply to Jack_mcs about Error (60) e-mails

    The cert was nstalled to authorize.net as to your directions, it does not have BOM and yet I still get error messages. I installed PayPal Express in both stores and all was working fine until late fall. I get the same error message for PayPal orders as I do for those with authorize.net, even when the latter has been updated as described in the thread. There is a PayPal cert listed in ext/modules/payment/paypal/. These are two separate modules/certs, yet both trigger the same error message.
  13. suscrofa

    Reply to Jack_mcs about Error (60) e-mails

    Dear Jack; Sorry for the delay, I have made several attempts to repeat the sequence as described in this thread: https://forums.oscommerce.com/topic/410623-curl-error-60-peer-certificate-cannot-be-authenticated-with-given-ca-certificates/?tab=comments#comment-1752918 However, I still get this e-mail message: Error from cURL: Error [60]: SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed experienced by customer with id 1 Lark Burnham on 2018-02-11 20:20:57 I was able to save with no BOM via Notepad ++, which is what I used to change the code. To complicate matters, we have 2 stores, both originally sent error messages, both got the same changed CA. Only one still gets the above error message. I changed the verify SSL to 'true'. I get the same error message with PayPal orders. I went through the whole routine as described in your replies, step-by-step, at least three times, with the same result. Any suggestions? Thanks. Lark
  14. suscrofa

    Reply to Jack_mcs about Error (60) e-mails

    Chatted with Support, said .crt files cannot be uploaded via File Manager, had to use FTP. I see it in the right place in Filezilla, but hasn't appeared in File Manager yet. I will check again tomorrow, then change check SSl, and do a test sale. First time something didn't upload in FM. Do you have the correct crt for PayPal? Thanks. Lark
  15. suscrofa

    Reply to Jack_mcs about Error (60) e-mails

    I have saved your code to the file of the same name as the old cert, deleted the old cert, but everytime I try to upload it to the server, it doesn't see it until I click 'all files', and then when I try to save it to the sevrer, nothing is there. I have tried this sevral times. Do you have the correct cert for PayPal? Thanks. Lark
×