Jump to content

zdat

Members
  • Content count

    36
  • Joined

  • Last visited

Posts posted by zdat


  1. I installed v21d updated by FWR Media.

     

    I'm seeing this as a URL: http://mydomain.com/dir/pillows-c-21.html?...4d9f465da460c4d. This is the link for my first category. (This is my staging site in one dir removed from the root, and that's reflected in the .htaccess file as directed.)

     

    I've searched extensively, but haven't seen an example of SEO URLs in action; is the above URL on the right track?

     

    My USU staging site seems to load more slowly than the live site w/o USU. Is this normal, or did I do something wrong?

     

    I'm on a Linux server; PHP 5.2.6. My .htaccess is below. I'm not sure what other information would be helpful.

     

    Please, any help would be most appreciated. Thx!

     

     

    #
    # Apache/PHP/Drupal settings:
    #
    
    # Protect files and directories from prying eyes.
    <FilesMatch "\.(engine|inc|info|install|module|profile|po|sh|.*sql|theme|tpl(\.php)?|xtmpl)$|^(code-style\.pl|Entries.*|Repository|Root|Tag|Template)$">
     Order allow,deny
    </FilesMatch>
    
    # Don't show directory listings for URLs which map to a directory.
    Options -Indexes
    
    # Follow symbolic links in this directory.
    Options +FollowSymLinks
    
    # Customized error messages.
    ErrorDocument 404 /index.php
    
    # Set the default handler.
    DirectoryIndex index.php
    
    # Override PHP settings. More in sites/default/settings.php
    # but the following cannot be changed at runtime.
    
    # PHP 4, Apache 1.
    <IfModule mod_php4.c>
     php_value magic_quotes_gpc                0
     php_value register_globals                0
     php_value session.auto_start              0
     php_value mbstring.http_input             pass
     php_value mbstring.http_output            pass
     php_value mbstring.encoding_translation   0
    </IfModule>
    
    # PHP 4, Apache 2.
    <IfModule sapi_apache2.c>
     php_value magic_quotes_gpc                0
     php_value register_globals                0
     php_value session.auto_start              0
     php_value mbstring.http_input             pass
     php_value mbstring.http_output            pass
     php_value mbstring.encoding_translation   0
    </IfModule>
    
    # PHP 5, Apache 1 and 2.
    <IfModule mod_php5.c>
     php_value magic_quotes_gpc                0
     php_value register_globals                0
     php_value session.auto_start              0
     php_value mbstring.http_input             pass
     php_value mbstring.http_output            pass
     php_value mbstring.encoding_translation   0
    </IfModule>
    
    # Requires mod_expires to be enabled.
    <IfModule mod_expires.c>
     # Enable expirations.
     ExpiresActive On
     # Cache all files for 2 weeks after access (A).
     ExpiresDefault A1209600
     # Do not cache dynamically generated pages.
     ExpiresByType text/html A1
    </IfModule>
    
    # Various rewrite rules.
    <IfModule mod_rewrite.c>
     RewriteEngine on
    
     # If your site can be accessed both with and without the 'www.' prefix, you
     # can use one of the following settings to redirect users to your preferred
     # URL, either WITH or WITHOUT the 'www.' prefix. Choose ONLY one option:
     #
     # To redirect all users to access the site WITH the 'www.' prefix,
     # (http://example.com/... will be redirected to [url="http://www.example.com/...)"]http://www.example.com/...)[/url]
     # adapt and uncomment the following:
     # RewriteCond %{HTTP_HOST} ^example\.com$ [NC]
     # RewriteRule ^(.*)$ [url="http://www.example.com/$1"]http://www.example.com/$1[/url] [L,R=301]
     #
     # To redirect all users to access the site WITHOUT the 'www.' prefix,
     # (http://www.example.com/... will be redirected to [url="http://example.com/...)"]http://example.com/...)[/url]
     # adapt and uncomment the following:
     # RewriteCond %{HTTP_HOST} ^www\.example\.com$ [NC]
     # RewriteRule ^(.*)$ [url="http://example.com/$1"]http://example.com/$1[/url] [L,R=301]
    
     # Modify the RewriteBase if you are using Drupal in a subdirectory and
     # the rewrite rules are not working properly.
     #RewriteBase /drupal
    
     # Rewrite old-style URLs of the form 'node.php?id=x'.
     #RewriteCond %{REQUEST_FILENAME} !-f
     #RewriteCond %{REQUEST_FILENAME} !-d
     #RewriteCond %{QUERY_STRING} ^id=([^&]+)$
     #RewriteRule node.php index.php?q=node/view/%1 [L]
    
     # Rewrite old-style URLs of the form 'module.php?mod=x'.
     #RewriteCond %{REQUEST_FILENAME} !-f
     #RewriteCond %{REQUEST_FILENAME} !-d
     #RewriteCond %{QUERY_STRING} ^mod=([^&]+)$
     #RewriteRule module.php index.php?q=%1 [L]
    
     # Rewrite current-style URLs of the form 'index.php?q=x'.
     RewriteCond %{REQUEST_FILENAME} !-f
     RewriteCond %{REQUEST_FILENAME} !-d
     RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]
    </IfModule>
    
    Options +FollowSymLinks
    RewriteEngine On 
    RewriteBase /stagingsite/
    
    RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
    RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}
    RewriteRule ^(.*)-m-([0-9]+).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}
    RewriteRule ^(.*)-pi-([0-9]+).html$ popup_image.php?pID=$2&%{QUERY_STRING}
    RewriteRule ^(.*)-t-([0-9]+).html$ articles.php?tPath=$2&%{QUERY_STRING}
    RewriteRule ^(.*)-a-([0-9]+).html$ article_info.php?articles_id=$2&%{QUERY_STRING}
    RewriteRule ^(.*)-pr-([0-9]+).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}
    RewriteRule ^(.*)-pri-([0-9]+).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}
    RewriteRule ^(.*)-i-([0-9]+).html$ information.php?info_id=$2&%{QUERY_STRING}
    
    
    
    
    # $Id: .htaccess,v 1.81.2.3 2007/09/21 12:24:22 drumm Exp $
    AddHandler allowoverrideoptions .htaccess
    


  2. For those of you who are using UltraPics v1, when you go back to edit an existing product through admin, do you see the names of the additional images displayed on the page near the appropriate fields?

     

    I love UltraPics, thought I had it working correctly, but if I go back to edit an existing product (with several additional images), the image names are not displayed; if I continue the update, and the fields are still blank, it saves that way and the images disappear.

     

    Works fine if I simply add a new product with new images; all info is saved and images display correctly in shop. But when I go back, the info is missing. (Same thing for my New Fields with Easy Populate, but this may be unrelated.)

     

    Anyone know how I can fix it? Thanks.


  3. I'm using this addon with EP 2.76. Everything works except within the update for a product in admin. (product info?) The problem is that if I open an existing item to update, the information for the extra fields isn't displayed. (The fields display with empty boxes.) The correct information exists in the database, and downloading a complete CSV file through EP confirms this; but the info is not there when I open the product to edit in admin or in the Update page to finalize the edit.

     

    Can anyone tell me where to edit so the field information displays in the product update page along with the rest of the information for that item? Thanks.


  4. I installed USU v2.5, made the suggested changes in .htacess to add the directory name. The option does show in Admin; everything is set to default and everything looks fine. I've pored through a ton of pages to try and get all the hints and tips, but I haven't found this error anywhere.

     

    Here's what's happening:

    If I click on the first category, the URL that appears is: domain.com/directory/category1-c-21.html, but it's simply the home page reloaded.

    Same thing for second category: domain.com/directory/category2-c-22.html.

     

    This happens even if I click on the "What's New" item on the front page: domain.com/directory/productname-p-559.html and I still get the home page.

    In this case, the directory is osc5, as indicated in .htaccess. (My staging site.)

     

     

    What the heck did I do wrong?? Can I provide any other info so someone can tell me where to start to fix this? Thanks.

     

     

    #
    # Apache/PHP/Drupal settings:
    #
    
    # Protect files and directories from prying eyes.
    <FilesMatch "\.(engine|inc|info|install|module|profile|po|sh|.*sql|theme|tpl(\.php)?|xtmpl)$|^(code-style\.pl|Entries.*|Repository|Root|Tag|Template)$">
     Order allow,deny
    </FilesMatch>
    
    # Don't show directory listings for URLs which map to a directory.
    Options -Indexes
    
    # Follow symbolic links in this directory.
    Options +FollowSymLinks
    
    # Customized error messages.
    ErrorDocument 404 /osc5/index.php
    
    # Set the default handler.
    DirectoryIndex /osc5/ index.php
    
    # Override PHP settings. More in sites/default/settings.php
    # but the following cannot be changed at runtime.
    
    # PHP 4, Apache 1.
    <IfModule mod_php4.c>
     php_value magic_quotes_gpc                0
     php_value register_globals                0
     php_value session.auto_start              0
     php_value mbstring.http_input             pass
     php_value mbstring.http_output            pass
     php_value mbstring.encoding_translation   0
    </IfModule>
    
    # PHP 4, Apache 2.
    <IfModule sapi_apache2.c>
     php_value magic_quotes_gpc                0
     php_value register_globals                0
     php_value session.auto_start              0
     php_value mbstring.http_input             pass
     php_value mbstring.http_output            pass
     php_value mbstring.encoding_translation   0
    </IfModule>
    
    # PHP 5, Apache 1 and 2.
    <IfModule mod_php5.c>
     php_value magic_quotes_gpc                0
     php_value register_globals                0
     php_value session.auto_start              0
     php_value mbstring.http_input             pass
     php_value mbstring.http_output            pass
     php_value mbstring.encoding_translation   0
    </IfModule>
    
    # Requires mod_expires to be enabled.
    <IfModule mod_expires.c>
     # Enable expirations.
     ExpiresActive On
     # Cache all files for 2 weeks after access (A).
     ExpiresDefault A1209600
     # Do not cache dynamically generated pages.
     ExpiresByType text/html A1
    </IfModule>
    
    # Various rewrite rules.
    <IfModule mod_rewrite.c>
     RewriteEngine on
    
     # If your site can be accessed both with and without the 'www.' prefix, you
     # can use one of the following settings to redirect users to your preferred
     # URL, either WITH or WITHOUT the 'www.' prefix. Choose ONLY one option:
     #
     # To redirect all users to access the site WITH the 'www.' prefix,
     # (http://example.com/... will be redirected to [url="http://www.example.com/...)"]http://www.example.com/...)[/url]
     # adapt and uncomment the following:
     # RewriteCond %{HTTP_HOST} ^example\.com$ [NC]
     # RewriteRule ^(.*)$ [url="http://www.example.com/$1"]http://www.example.com/$1[/url] [L,R=301]
     #
     # To redirect all users to access the site WITHOUT the 'www.' prefix,
     # (http://www.example.com/... will be redirected to [url="http://example.com/...)"]http://example.com/...)[/url]
     # adapt and uncomment the following:
     # RewriteCond %{HTTP_HOST} ^www\.example\.com$ [NC]
     # RewriteRule ^(.*)$ [url="http://example.com/$1"]http://example.com/$1[/url] [L,R=301]
    
     # Modify the RewriteBase if you are using Drupal in a subdirectory and
     # the rewrite rules are not working properly.
     #RewriteBase /drupal
    
     # Rewrite old-style URLs of the form 'node.php?id=x'.
     #RewriteCond %{REQUEST_FILENAME} !-f
     #RewriteCond %{REQUEST_FILENAME} !-d
     #RewriteCond %{QUERY_STRING} ^id=([^&]+)$
     #RewriteRule node.php index.php?q=node/view/%1 [L]
    
     # Rewrite old-style URLs of the form 'module.php?mod=x'.
     #RewriteCond %{REQUEST_FILENAME} !-f
     #RewriteCond %{REQUEST_FILENAME} !-d
     #RewriteCond %{QUERY_STRING} ^mod=([^&]+)$
     #RewriteRule module.php index.php?q=%1 [L]
    
     # Rewrite current-style URLs of the form 'index.php?q=x'.
     RewriteCond %{REQUEST_FILENAME} !-f
     RewriteCond %{REQUEST_FILENAME} !-d
     RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]
    </IfModule>
    
    # Ultimate SEO URLs BEGIN
    Options +FollowSymLinks
    RewriteEngine On
    RewriteBase /osc5/
    
    
    RewriteCond %{QUERY_STRING} ^options\=(.*)$
    RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2%1
    RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
    RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}
    RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}
    RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING}
    RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING}
    RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING}
    RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}
    RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}
    RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING}
    RewriteRule ^(.*)-links-(.*).html$ links.php?lPath=$2&%{QUERY_STRING}
    # Added polls and newsdesk
    #RewriteRule ^(.*)-po-([0-9]+).html$ pollbooth.php?pollid=$2&%{QUERY_STRING}
     RewriteRule ^(.*)-n-(.*).html$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING}
     RewriteRule ^(.*)-nc-(.*).html$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING}
     RewriteRule ^(.*)-nri-(.*).html$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING}
     RewriteRule ^(.*)-nra-(.*).html$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING}
    # BOF: Faqdesk support added by faaliyet
     RewriteRule ^(.*)-f-(.*).html$ faqdesk_info.php?faqdesk_id=$2&%{QUERY_STRING}
     RewriteRule ^(.*)-fc-(.*).html$ faqdesk_index.php?faqPath=$2&%{QUERY_STRING}
     RewriteRule ^(.*)-fri-(.*).html$ faqdesk_reviews_info.php?faqdesk_id=$2&%{QUERY_STRING}
     RewriteRule ^(.*)-fra-(.*).html$ faqdesk_reviews_article.php?faqdesk_id=$2&%{QUERY_STRING}
    # EOF: Faqdesk support added by faaliyet
    # Ultimate SEO URLs END
    
    # Block Bad Bots
    RewriteCond %{HTTP_USER_AGENT} ^BlackWidow [OR]
    RewriteCond %{HTTP_USER_AGENT} ^Bot\ mailto:craftbot@yahoo.com [OR]
    RewriteCond %{HTTP_USER_AGENT} ^ChinaClaw [OR]
    RewriteCond %{HTTP_USER_AGENT} ^Custo [OR]
    RewriteCond %{HTTP_USER_AGENT} ^DISCo [OR]
    RewriteCond %{HTTP_USER_AGENT} ^Download\ Demon [OR]
    RewriteCond %{HTTP_USER_AGENT} ^eCatch [OR]
    RewriteCond %{HTTP_USER_AGENT} ^EirGrabber [OR]
    RewriteCond %{HTTP_USER_AGENT} ^EmailSiphon [OR]
    RewriteCond %{HTTP_USER_AGENT} ^EmailWolf [OR]
    RewriteCond %{HTTP_USER_AGENT} ^Express\ WebPictures [OR]
    RewriteCond %{HTTP_USER_AGENT} ^ExtractorPro [OR]
    RewriteCond %{HTTP_USER_AGENT} ^EyeNetIE [OR]
    RewriteCond %{HTTP_USER_AGENT} ^FlashGet [OR]
    RewriteCond %{HTTP_USER_AGENT} ^GetRight [OR]
    RewriteCond %{HTTP_USER_AGENT} ^GetWeb! [OR]
    RewriteCond %{HTTP_USER_AGENT} ^Go!Zilla [OR]
    RewriteCond %{HTTP_USER_AGENT} ^Go-Ahead-Got-It [OR]
    RewriteCond %{HTTP_USER_AGENT} ^GrabNet [OR]
    RewriteCond %{HTTP_USER_AGENT} ^Grafula [OR]
    RewriteCond %{HTTP_USER_AGENT} ^HMView [OR]
    RewriteCond %{HTTP_USER_AGENT} HTTrack [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} ^Image\ Stripper [OR]
    RewriteCond %{HTTP_USER_AGENT} ^Image\ Sucker [OR]
    RewriteCond %{HTTP_USER_AGENT} Indy\ Library [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} ^InterGET [OR]
    RewriteCond %{HTTP_USER_AGENT} ^Internet\ Ninja [OR]
    RewriteCond %{HTTP_USER_AGENT} ^JetCar [OR]
    RewriteCond %{HTTP_USER_AGENT} ^JOC\ Web\ Spider [OR]
    RewriteCond %{HTTP_USER_AGENT} ^larbin [OR]
    RewriteCond %{HTTP_USER_AGENT} ^LeechFTP [OR]
    RewriteCond %{HTTP_USER_AGENT} ^Mass\ Downloader [OR]
    RewriteCond %{HTTP_USER_AGENT} ^MIDown\ tool [OR]
    RewriteCond %{HTTP_USER_AGENT} ^Mister\ PiX [OR]
    RewriteCond %{HTTP_USER_AGENT} ^Navroad [OR]
    RewriteCond %{HTTP_USER_AGENT} ^NearSite [OR]
    RewriteCond %{HTTP_USER_AGENT} ^NetAnts [OR]
    RewriteCond %{HTTP_USER_AGENT} ^NetSpider [OR]
    RewriteCond %{HTTP_USER_AGENT} ^Net\ Vampire [OR]
    RewriteCond %{HTTP_USER_AGENT} ^NetZIP [OR]
    RewriteCond %{HTTP_USER_AGENT} ^Octopus [OR]
    RewriteCond %{HTTP_USER_AGENT} ^Offline\ Explorer [OR]
    RewriteCond %{HTTP_USER_AGENT} ^Offline\ Navigator [OR]
    RewriteCond %{HTTP_USER_AGENT} ^PageGrabber [OR]
    RewriteCond %{HTTP_USER_AGENT} ^Papa\ Foto [OR]
    RewriteCond %{HTTP_USER_AGENT} ^pavuk [OR]
    RewriteCond %{HTTP_USER_AGENT} ^pcBrowser [OR]
    RewriteCond %{HTTP_USER_AGENT} ^RealDownload [OR]
    RewriteCond %{HTTP_USER_AGENT} ^ReGet [OR]
    RewriteCond %{HTTP_USER_AGENT} ^SiteSnagger [OR]
    RewriteCond %{HTTP_USER_AGENT} ^SmartDownload [OR]
    RewriteCond %{HTTP_USER_AGENT} ^SuperBot [OR]
    RewriteCond %{HTTP_USER_AGENT} ^SuperHTTP [OR]
    RewriteCond %{HTTP_USER_AGENT} ^Surfbot [OR]
    RewriteCond %{HTTP_USER_AGENT} ^tAkeOut [OR]
    RewriteCond %{HTTP_USER_AGENT} ^Teleport\ Pro [OR]
    RewriteCond %{HTTP_USER_AGENT} ^VoidEYE [OR]
    RewriteCond %{HTTP_USER_AGENT} ^Web\ Image\ Collector [OR]
    RewriteCond %{HTTP_USER_AGENT} ^Web\ Sucker [OR]
    RewriteCond %{HTTP_USER_AGENT} ^WebAuto [OR]
    RewriteCond %{HTTP_USER_AGENT} ^WebCopier [OR]
    RewriteCond %{HTTP_USER_AGENT} ^WebFetch [OR]
    RewriteCond %{HTTP_USER_AGENT} ^WebGo\ IS [OR]
    RewriteCond %{HTTP_USER_AGENT} ^WebLeacher [OR]
    RewriteCond %{HTTP_USER_AGENT} ^WebReaper [OR]
    RewriteCond %{HTTP_USER_AGENT} ^WebSauger [OR]
    RewriteCond %{HTTP_USER_AGENT} ^Website\ eXtractor [OR]
    RewriteCond %{HTTP_USER_AGENT} ^Website\ Quester [OR]
    RewriteCond %{HTTP_USER_AGENT} ^WebStripper [OR]
    RewriteCond %{HTTP_USER_AGENT} ^WebWhacker [OR]
    RewriteCond %{HTTP_USER_AGENT} ^WebZIP [OR]
    RewriteCond %{HTTP_USER_AGENT} ^Wget [OR]
    RewriteCond %{HTTP_USER_AGENT} ^Widow [OR]
    RewriteCond %{HTTP_USER_AGENT} ^WWWOFFLE [OR]
    RewriteCond %{HTTP_USER_AGENT} ^Xaldon\ WebSpider [OR]
    RewriteCond %{HTTP_USER_AGENT} ^Zeus
    RewriteRule .* - [F]
    
    
    # $Id: .htaccess,v 1.81.2.3 2007/09/21 12:24:22 drumm Exp $
    


  5. I installed PWA 2.0g, but I don't have the original changes for the IPN module, so I can't replace anything. I searched back through at least 15 versions of PWA, all the way back to the beginning but can't find mention of IPN.

     

    What needs to be added to paypal_ipn.php, and where does it go?? I'm not using a Tracking addon. THANKS.

     

    Here's what I have from 2.0g.

     

    ######################PAY_PAL IPN/TRACKING######################
    in catalog/includes/modules/payment/paypal_ipn.php --- This is part of PayPal IPN contribution, so if you don't have PayPal IPN contribution installed you don't need to do this step. THis step MAY also require Package Tracking Contribution.
    
    [color="#FF0000"]***FIND:
                       // PWA BOF
                      (($customer_id == 0)? '' : EMAIL_TEXT_INVOICE_URL . ' ' ."<a HREF='" . tep_href_link(FILENAME_ACCOUNT_HISTORY_INFO, 'order_id=' . $insert_id, 'SSL', false) . "'>" . tep_href_link(FILENAME_ACCOUNT_HISTORY_INFO, 'order_id=' . $insert_id, 'SSL', false) . "</a>\n") .
                       // PWA EOF[/color]
    ***REPLACE WITH:
                      (($order->customer['is_dummy_account'])? '' : EMAIL_TEXT_INVOICE_URL . ' ' ."<a HREF='" . tep_href_link(FILENAME_ACCOUNT_HISTORY_INFO, 'order_id=' . $insert_id, 'SSL', false) . "'>" . tep_href_link(FILENAME_ACCOUNT_HISTORY_INFO, 'order_id=' . $insert_id, 'SSL', false) . "</a>\n") .
    


  6. 1. Is it possible to use IPSP v1.0 with USPS? Is it possible to set a type of USPS shipping depending upon product?

     

    2. I've tried to install this contrib three times, using the 13 Feb 2007 version. I've tried using fresh OSC files for each install. Nothing appears in Admin to enable; I see no evidence that the contribution is installed. I followed all instructions, database was modified, etc. Obviously, some other people are getting this add-on to work, so has anyone else had this problem??? Anyone know what might be wrong?

     

    thx


  7. It looks like Individual Shipping Methods would be a better mod to use.

     

    Have you tried this contrib yet? I've followed all instructions several times, doing a new file each time to make sure, and I can't get the option to appear in admin. I'm also using the USPS contrib, Easy Populate, and UltraPics so I don't know if other modifications are necessary to make it work with my store. It'd be good to know whether the the contrib works as suggested.


  8. Use individual shipping contribution.

     

    This will allow You to define shipping cost per product.

    As You have charged the amount now You can decide by what Youi want to ship.

     

    Satish

     

    I had the same question. Are you directing us to Individual Product Shipping Prices - v1.0, http://addons.oscommerce.com/info/1333

     

    or Individual Product Shipping Methods, http://addons.oscommerce.com/info/4674 ??

    thanks


  9. ... when the customer goes to checkout and STILL has to complete the registration form then clicks continue.......the customer returns back to the login.php screen and is asked to choose again. So, I have a loop........has anyone else experienced this ???

     

    I just installed PWA2.0c today, and am testing it. I do not have the loop you mention. Sorry I can't tell you what's causing it, but I'm sure someone here can.


  10. ... I installed OSC PayPal IPN contribution only because I thought the stock module PayPal WPS did not have the IPN feature. ... So, PayPal WPS has the IPN feature.

     

    Alan, can't thank you enough for communicating this. I installed the stock WPS, then installed the IPN mod, then uninstalled stock WPS. I think I'll reverse that again.

     

    Sorry to hear about the invoice #. Hope you get it figured out. At present, my shipping charges aren't being displayed when buyer logs into Paypal (sandbox), but it is correct at site and in confirmation. It's always something ...

     

     

    best,

    Terri


  11. ...I am in the middle of installing the latest IPN and will let you know how it works. I already had the default IPN working then it broke. I added the files and am hoping it works now.

     

    Thanks, Suzi. I found the default Website Payments Standard option in OSC admin, of course, and installed that. PayPal then confirmed there's an IPN module built into Standard; but also said to install the latest IPN OSC module, so I'm back at square one. The IPN module looks like the Standard module to me.

     

    The other big question: Are you using a specialized URL and script to communicate with PP using IPN? (Or e-mail or other choice.) Is this necessary, do you know? PP discusses IPN, PDT, etc., and I'm uncertain how this is all integrated with OSC's PP modules, what extra needs to be done.

     

    thanks and hope your module is working again --

     

    terri


  12. I'm still trying to clarify what's needed with IPN and/or Website Standard payments.

     

    1. Saw this post and wondered if anyone had the problem of installing the latest IPN contrib (as noted above) and not having it appear in the admin area? I've read through all the files, installed the contrib files and triple-checked, yet the contrib doesn't appear in the Modules/Payment area. I have the Website Standards option, and all of the related ones that came with a fresh install of OSC, but the IPN contrib doesn't appear for installation.

     

    2. Is there an IPN contrib built into the latest OSC Website Standard Payments unit already?? (Duh.)


  13. Update: I found that the PayPal Express button must be included not only on the final checkout page, but also on the shopping cart page and other applicable pages, along with other rules. It's a TOS issue. Drat.


  14. The newest version of OSC seems to place a Checkout Now Paypal button on the "What's in my cart" page, along with my regular "Checkout" button.

     

    The PP button takes one directly to PP, bypassing the shipping options. My regular "Checkout" button takes one to the shipping options and also the option to pay by money order/check OR Paypal express. (The only two choices at this time.)

     

    I do not want the secondary Paypal button on the initial checkout page, as it is superfluous and causes confusion. Anyone know how to get rid of this step, or where the code is located? I've looked through all the files I can think of. I want the Paypal button only on the final checkout page.

     

    Thanks.


  15. First, I love EP, couldn't do without it.

     

    After learning about the "apostrope catastrope" highlighted in another post, I added the escape slash to all apostrophes. (from ' to \') While I'm able to read in my .csv file perfectly, the result online shows the backward slash most of the time. ??? (That\'s All) I can't go back and forth between online admin and .csv file adding and removing the slash, obviously. There must be a better way.

     

    I've looked everywhere for an answer to this. Need help, please.

     

    Below is my EP config. I'm also using UltraPics. I added extra fields manually. -- Thanks!

     

    EP vers: 2.76g-MS2

    osCommerce 2.2-MS2

    OS: Linux 2.6.22-9_1.BHsmp

    HTTP: Apache/2.2.8 (Unix) mod_ssl/2.2.8 OpenSSL/0.9.8g DAV/2 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635

    DB: MySQL 5.0.45-community-log

    PHP: 5.2.5 (Zend: 2.2.0)

     

    Temp Directory:

    /...temp/

    Temp Dir is Writable

    Magic Quotes is: off

    register_globals is: on

    Split files on: 300 records

    Model Num Size: 12

    Price with tax: false

    Calc Precision: 2

    Replace quotes: false

    Field seperator: comma

    Excel safe output: true

    Preserve tab/cr/lf: false

    Category depth: 10

    Enable attributes: true

    SEF Froogle URLS: false

    More Pics: false

    Unknown Pics: true

    HTC: false

    SPPC: false

    Extra Fields: false


  16. Update in case anyone else has this problem. (I'm using USPS Methods 2.9.2 with uppercase and insurance.)

     

    I finally found the source of my errors: admin > config > shipping/packaging > Larger packages - percentage increase.

     

    The default value is 10%, which is exactly what was being added to my orders. Must be a bug somewhere, since I was not checking out with "larger" packages. I set it to 0, and it works, but I'm not sure what happens when we do have large packages.


  17. I have USPS methods up and running, and the int'l shipping options seem available at first, but then I click to edit the module and there are no choices, no radio boxes.

     

    1st screen:

    Int'l Shipping Methods

    GLOBAL EXPRESS,GLOBAL EXPRESS NON-DOC RECT, GLOBAL EXPRESS NON-DOC NON-RECT, EXPRESS MAIL INT, EXPRESS MAIL INT FLAT RATE ENV, PRIORITY MAIL INT, PRIORITY MAIL INT FLAT RATE ENV, PRIORITY MAIL INT FLAT RATE BOX, FIRST-CLASS MAIL INT

     

    2nd screen:

     

    Domestic Shipping Methods

    Select the domestic services to be offered:

     

    EXPRESS

    PRIORITY

    FIRST CLASS

    PARCEL

    BPM

    LIBRARY

    MEDIA

     

    Int'l Shipping Methods

    Select the international services to be offered: [completely blank]

     

     

    US/Canada to $50

    US/Canada insurance total up to $50

    ...etc.

     

     

    Would love to know what I'm doing wrong! Please!

×