Jump to content

Moxamint

♥Ambassador
  • Content count

    235
  • Joined

  • Last visited

  • Days Won

    4

Everything posted by Moxamint

  1. Moxamint

    Search add-on Reviews

    @@Gergely Hi Gergely I see this differently, though. Customer's search result could turn out a big listing of items sharing similar description when the products themselves may look very differently. Showing thumbnails in the drop down will be very helpful in this case. I guess it all depends on what you sell. Regards, Eddy
  2. Moxamint

    Search add-on Reviews

    Agreed. I think it's better that the functionality being consistent throughout the site so that customers do not need to spend too much time on learning how to use your site.
  3. Global weather weirdness - Taiwan is being hit by a super typhoon Nepartak with level 17 gust, breaking the records in 16 years!

    1. Moxamint

      Moxamint

      Thanks Gary - one county in the south badly suffered, but the rest of the island survived.

    2. Gyakutsuki

      Gyakutsuki

      send us a video

  4. @@Tsimi It does fix the problem by removing 'async' from that line. This fix also solved the problem where the misbehaived 'list/grid' buttons sometimes threw me to the home page. Thank for your help!
  5. I installed this add-on and it's working beautifully on my test site. Thank you very much @@auzStar! Because my product images are all very large (800 x 800 pixels), I've been using 'KissIT Image Thumbnailer' to create thumbnails. Dominic helped me customize this 'Twitter Typeahead Autocomplete Search' so that it uses tep_image() instead of HTML method to re-size product images shown in drop-down of the search result. The following are code changes to achieve it: In "catalog\ext\typeahead\js\ht-twitter-typeahead.js.php", find this code: return "<div style='padding: 0px 10px 0px 5px;'><table border='0' width='100%' cellspacing='0' cellpadding='0'><tr><td valign='center' align='center' width='10%' style='padding-right: 6px;'><img src='"+data.image+"' width='40' height='' /></td>"+ replace with: return "<div style='padding: 0px 10px 0px 5px;'><table border='0' width='100%' cellspacing='0' cellpadding='0'><tr><td valign='center' align='center' width='10%' style='padding-right: 6px;'>"+data.image+"</td>"+ In "catalog\ext\modules\header_tags\twitter_typeahead\autocomplete.php", find this code: if (tep_not_null($results['products_image'])) { $results_array['img'] = DIR_WS_IMAGES . $results['products_image']; } else { $results_array['img'] = (MODULE_HEADER_TAGS_TWITTER_TYPEAHEAD_DISPLAY_NO_IMAGE_ICON == 'true' ? DIR_WS_IMAGES . 'no_img.png' : ''); } replace with: if (tep_not_null($results['products_image'])) { $results_array['img'] = tep_image(DIR_WS_IMAGES . $results['products_image'], NULL, '40', ''); } else { $results_array['img'] = (MODULE_HEADER_TAGS_TWITTER_TYPEAHEAD_DISPLAY_NO_IMAGE_ICON == 'true' ? tep_image(DIR_WS_IMAGES . 'no_img.png', NULL, '40', '') : ''); } Now the search result of 'Twitter Typeahead Autocomplete Search' will use thumbs created by 'KissIT Image Thumbnailer' instead of using the original product images. For those who are interested in this lovely add-on, please PM me if you want to see it in action on my test site. Cheers, Eddy
  6. @@Tsimi Mine is: <script src="ext/jquery/jquery-1.11.1.min.js" async></script>
  7. @@Tsimi I just found an issue with 'XS Categories Menu'. After I arrived desired category through clicking on the dropdowns built by either 'Horizontal Categories Menu' or 'XS Categories Menu', 'XS Categories Menu' stopped working. The 'XS Categories Menu' would not pull down anymore until I refresh the browser. The 'Horizontal Categories Menu' will still work as expected if I expand the browser window from small views to full size even when 'XS Categories Menu' has ceased functioning. Still looking if it's an issue introduced by myself... Thanks, Eddy
  8. @@Tsimi I see what you meant by 'ugly space' :D I have not looked carefully into the code, but I managed to eliminate the ugly space by adding the condition if (MODULE_CONTENT_HEADER_CATMENU_PARENT_LINK == 'True') in front of $result .= '<li><a href="' . tep_href_link(FILENAME_DEFAULT, 'cPath=' . $category_link) . '">' . $root_link_title . '</a></li>'; Is it the right way of doing it? Thanks again, Eddy
  9. @@Tsimi Hi Lambros, I set 'Enable parent category link' to false in 'Horizontal Categories Menu' but 'XS Categories Menu' still shows the parent category links. How do I let ''XS Categories Menu' inherit the setting in ''Horizontal Categories Menu''? Thanks in advance for your help. Cheers, Eddy
  10. Moxamint

    Product listing

    OK @@raiwa I think I can put up with it. Thanks for your efforts again.
  11. Moxamint

    Product listing

    Thanks @@raiwa! I think it would be convenient if that's included in the configuration settings. Thanks again, Eddy
  12. Moxamint

    Product listing

    @@raiwa, Is it possible to apply opacity to the watermark? Many thanks, Eddy
  13. Moxamint

    Product listing

    @@raiwa Hi Rainer, This is to confirm that the new fix works. Thanks so much! Cheers, Eddy
  14. Moxamint

    Product listing

    Hi @@raiwa, It's working correctly now. Thanks again, Eddy
  15. Moxamint

    Product listing

    @@raiwa, This add-on works great on my BS [edge] site except it makes my languages and card acceptance boxes act weird. Before KissIT: After KissIT: Did I do something wrong? My KissIT version is r19. Thanks in advance for your time and help.
  16. Moxamint

    Google XML Sitemap SEO

    @@Jack_mcs Thanks for the detailed information. I did set all sitemap*.xml file permissions to 755 and turned "Enable Standard Pages Map" and a couple of other options on. All .xml files were generated OK except sitemappages.xml Did I miss anything else? Thanks again.
  17. Moxamint

    Google XML Sitemap SEO

    @@Jack_mcs Hi Jack, I applied the fix you supplied in post #1416 and this add-on mostly worked except "Google Pages Sitemap". What could be the problem? And what is "site map standard pages" anyway? Thanks in advance. The following are the output: ============================================================================ Opening /home/httpd/vhosts/mydomain.com/subdomains/shop/httpdocs/sitemapproducts.xml FS_CAT /home/httpd/vhosts/mydomain.com/subdomains/shop/httpdocs/ Server http://shop.mydomain.com Save Path /home/httpd/vhosts/mydomain.com/subdomains/shop/httpdocs/ WS_CAT / Write /home/httpd/vhosts/mydomain.com/subdomains/shop/httpdocs/sitemapproducts.xml Generated Google Product Sitemap Successfully Opening /home/httpd/vhosts/mydomain.com/subdomains/shop/httpdocs/sitemapcategories.xml FS_CAT /home/httpd/vhosts/mydomain.com/subdomains/shop/httpdocs/ Server http://shop.mydomain.com Save Path /home/httpd/vhosts/mydomain.com/subdomains/shop/httpdocs/ WS_CAT / Write /home/httpd/vhosts/mydomain.com/subdomains/shop/httpdocs/sitemapcategories.xml Generated Google Category Sitemap Successfully Opening /home/httpd/vhosts/mydomain.com/subdomains/shop/httpdocs/sitemapimages.xml FS_CAT /home/httpd/vhosts/mydomain.com/subdomains/shop/httpdocs/ Server http://shop.mydomain.com Save Path /home/httpd/vhosts/mydomain.com/subdomains/shop/httpdocs/ WS_CAT / Write /home/httpd/vhosts/mydomain.com/subdomains/shop/httpdocs/sitemapimages.xml Generated Google Images Sitemap Successfully Opening /home/httpd/vhosts/mydomain.com/subdomains/shop/httpdocs/sitemapmanufacturers.xml FS_CAT /home/httpd/vhosts/mydomain.com/subdomains/shop/httpdocs/ Server http://shop.mydomain.com Save Path /home/httpd/vhosts/mydomain.com/subdomains/shop/httpdocs/ WS_CAT / Write /home/httpd/vhosts/mydomain.com/subdomains/shop/httpdocs/sitemapmanufacturers.xml Generated Google Manufacturers Sitemap Successfully ERROR: Google Pages Sitemap Generation FAILED! Opening /home/httpd/vhosts/mydomain.com/subdomains/shop/httpdocs/sitemapindex.xml FS_CAT /home/httpd/vhosts/mydomain.com/subdomains/shop/httpdocs/ Server http://shop.mydomain.com Save Path /home/httpd/vhosts/mydomain.com/subdomains/shop/httpdocs/ WS_CAT / Write /home/httpd/vhosts/mydomain.com/subdomains/shop/httpdocs/sitemapindex.xml Generated Google Sitemap Index Successfully Array ( [QUERY] => Array ( [PRODUCTS] => Array ( [sTATUS] => success [NUM_ROWS] => 166 ) [CATEOGRY] => Array ( [sTATUS] => success [NUM_ROWS] => 100 ) [iMAGES] => Array ( [sTATUS] => success [NUM_ROWS] => 166 ) [MANUFACTURERS] => Array ( [sTATUS] => success [NUM_ROWS] => 1 ) ) [sAVE_FILE_XML] => Array ( [0] => Array ( [file] => /home/httpd/vhosts/mydomain.com/subdomains/shop/httpdocs/sitemapproducts.xml [status] => success [file_exists] => true ) [1] => Array ( [file] => /home/httpd/vhosts/mydomain.com/subdomains/shop/httpdocs/sitemapcategories.xml [status] => success [file_exists] => true ) [2] => Array ( [file] => /home/httpd/vhosts/mydomain.com/subdomains/shop/httpdocs/sitemapimages.xml [status] => success [file_exists] => true ) [3] => Array ( [file] => /home/httpd/vhosts/mydomain.com/subdomains/shop/httpdocs/sitemapmanufacturers.xml [status] => success [file_exists] => true ) [4] => Array ( [file] => /home/httpd/vhosts/mydomain.com/subdomains/shop/httpdocs/sitemapindex.xml [status] => success [file_exists] => true ) ) ) Completed!
  18. Moxamint

    Popup Window

    There is an addon coded by @@De Dokta for 234BS: http://addons.oscommerce.com/info/9204
  19. For using option types in 2.3.x, you may want to check this post: http://forums.oscommerce.com/topic/338661-contribution-option-types-v2/page__view__findpost__p__1621086
  20. Richard, The download package is corrupted. Can you take a look? Thanks, Eddy
  21. Moxamint

    [Contribution] Products Specifications

    Hi Jim, I have a couple of questions: 1. On the website you mentioned previously (www.binding-machine.net), in any of the product info page, if I click "submit" button in the fourth tab, which is a "Ask a Question" tab, without entering required information, I do not get to see the prompted warning message because the page refreshed and brought me back to the first tab. Is it a normal behavior of PS? 2. Are there any code changes need to be done on the X-Sell contribution before installing your PS version 1.1.11? The X-Sell you suggest us to use (http://addons.oscommerce.com/info/1415) seem to be a ms2 version. Thanks in advance for your time. Best wishes, Eddy
  22. Thanks for your help. I'll make a note of this for my new installation of osC v 2.3.1 when I put your USU5 PRO in. Thanks again.
  23. Hi, Is this fix in application_top.php still valid with Security Pro? /** * Reliably set PHP_SELF as a filename .. platform safe */ function setPhpSelf() { $base = ( array( 'SCRIPT_NAME', 'PHP_SELF' ) ); foreach ( $base as $index => $key ) { if ( array_key_exists( $key, $_SERVER ) && !empty( $_SERVER[$key] ) ) { if ( false !== strpos( $_SERVER[$key], '.php' ) ) { preg_match( '@[a-z0-9_]+\.php@i', $_SERVER[$key], $matches ); if ( is_array( $matches ) && ( array_key_exists( 0, $matches ) ) && ( substr( $matches[0], -4, 4 ) == '.php' ) && ( is_readable( $matches[0] ) ) ) { return $matches[0]; } } } } return 'index.php'; } // end method $PHP_SELF = setPhpSelf(); Many thank! BTW, I've been enjoying your contributions very much.
  24. First thing first, thanks for the great contribution! One question, though. FCKeditor seems to be working fine in my firefox, but its editor won't show in IE (version 6). Any ways to fix this problem? Cheers, Eddy
  25. I installed ultimate seo urls version 2.1d and it works wonderfully. Great contribution! One question, though. Many of my products have a "-" in their name. This "-" is removed automatically by this contribution. Is there a way to fix that? Any help or pointers is highly appreciated. My site: http://bugdorm.megaview.com.tw Eddy form Taiwan
×