Jump to content

Amrahp

Members
  • Content count

    74
  • Joined

  • Last visited

Everything posted by Amrahp

  1. Amrahp

    One Page Checkout Support

    Have done som serious testing now and there are some problems at least in my case: 1. The checkout is waaaaaay to slow with all the ajax/java updating... Customers will most likely click on "update cart" several times since nothing seems to be happening. It takes way too long to update shipping and billing information as well and customers will think that there is something wrong. Has happened on my store several times already. 2. When I did try it on a test site did the customer registration work well. Once installed on my main site is there a problem of having customers being registered two or three times! Furthermore are all the new e-mail adresses registered without the "@". *sigh* :blink: :blink: :blink:
  2. Amrahp

    One Page Checkout Support

    Well this is really a great contribution!! I have finally got it to work with STS. :D Still having the "fatal error" if only one payment module is installed though. :angry: Another small bug is that the "Sign In-pop up" don't work. Nothing happens when entering a correct e-mail+password. Is anyone else having this error? Any clues? My guess is that it's STS/javascript related... :blink:
  3. Amrahp

    One Page Checkout Support

    Hi, That only helps/works if I have two or more payment modules installed. If I have only one (which is what I want), I still get the error. Thanks.
  4. Amrahp

    How to add column to product listing

    I need to add another column as well apart from the ones that already are there. I have searched over and over without luck. <_< (Your post was just an answer on how to show/hide the ones that already are there I guess.) So any ideas on how to do this and have it shown in the product listing is highly appreciated! Thanks.
  5. Yes this is an awesome contribution! Questions: 1. Has anyone got it to work with STS? The javascript won't work for me with the tick box "Shipping address same as billing address". I did try to include the javascript in the checkout.php.html but with no luck. 2. Will it be possible to have support for "Customer MUST AGREE to TERMS and CONDITIONS http://addons.oscommerce.com/info/5750" Thanks!
  6. Well in case someone else wonders did I get to know that this excellent addon not toggles the shipping information on/off if the "Shipping address same as billing address" is ticked. Instead it copies the information to the shipping fields. Nice work!
  7. Nice work!!!! IMHO is this what Osc really needs! I have installed it now and testing it... First problem that has come up now is that the "toggle shipping" doesn't seem to work properly for me. I am using STS and did try to implement the javascript in the checkout.php.html header but then received code errors...
  8. Amrahp

    Alertpay - having same problem as paypal

    Hello, Did you come up with a solution? There is another thread for this contribution as well.. It seems like the customers don't get redirected to checkout_success.php and could that be why the orders aren't recorded? I am having the same problem... Regards
  9. Amrahp

    AlertPay Module

    Hi, Has anyone got this module to work 100%. My customers get sent to Alertpay with the right amount and everything. So far so good. But they don't get sent to checkout_success.php (neither before or after) and by that isn't the order written down to the database. Any ideas? Thanks!
  10. Hi, First of all: Wonderful contribution! Now... I recieve an error just out of nowhere and have no clue how where it came from. Have searched and it seems like I am alone on this??!! 1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND coupons_id="testcode"' at line 4 SELECT dc2u.customers_id FROM discount_coupons_to_customers dc2u WHERE customers_id= AND coupons_id="testcode" [TEP STOP] Any help is highly appreciated since this is "quite" urgent. Thanks!
  11. Amrahp

    [Contribution] U HTML Emails

    Many thanks for your answer hardball! I'm not sure if I follow you all the way though. "..of which you edit through the newsletter.php script." Do you talk about: mydomain.com/admin/newsletters.php? I have tried non html code as well as html code here. Both mails come out as plain code... :blink: :blink: In simple words: How and where do I edit my newsletter code?
  12. Amrahp

    [Contribution] U HTML Emails

    Hi Olof, Awesome contribution! Many thanks! A question: When sending customers automatic email (create_account, orders etc) everything works fine. When sending newletters though is the html code sent in its pure form and the newsletter mail look like this: <html><head><meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"></head><body style="margin: 0px; padding: 0px; background-color:#edf6ff;"><font face="Times New Roman, Times, serif"><table width="100%" height="75px" border="0" background..............................border-color: #F96861;background-color:#FFFFFF;">Newsletter test text here.</div></font></body></html> Any thoughts on why this happens? Kind regards!
  13. Hi, I am now receiving this error right out of nowhere!!!! Since this is quite an old thread and there is a relation to STS in the application_bottom.php by default I figure that the problem lies elsewhere. I have checked the admin and everything is ok there according to your post Bill. Any clues?
  14. Hi, Great contribution!!!! But: Does anybody have any idea why some of my products get "osCsid=291a487xxxxxxxxxxxxxxxxxx" added to the URL and some don´t? (About 50/50). Thanks.
  15. Amrahp

    [Contribution] STS v4

    Well... I did manage to solve my problem by myself. :rolleyes: Here is what I did if someone else has the need for it (show model in $cartbox) In includes/boxes/shopping_cart.php around line 43 find: $cart_contents_string .= $products[$i]['name'] . '</span></a></td></tr>'; Replace it with: $cart_contents_string .= $products[$i]['name'] . ', ' . $products[$i]['model'] . '</span></a></td></tr>';
  16. Amrahp

    [Contribution] STS v4

    Hi, Bill could you help me out again and explain how to add weight and model to the $cartbox? I want my customers to keep that information and have it visible during the whole checkout- and shopping procedure. Thanks in advance as usual! Kind regards.
  17. Amrahp

    [Support] Category Fields

    Hi, This contribution got me interested and I have got it partly working. In admin I can add fields and more. The thing is though that the fields won´t show up in my category pages!? Any ideas? Thanks!
  18. Amrahp

    [Contribution] STS v4

    Thanks Bill! Sorry for being a deadhead and thank you for trying to help me out but I just can`t get this to work! I did like you said with the sts_user_code.php Here is an example then of the code from my table (I tried to put the $startform $addtocartbutton $endform before AND after the link just to see if it would work) <tr bgcolor="#EFEFEF"> <td>$startform $addtocartbutton $endform<a href="/product_info.php?products_id=140">My Product</a>$startform $addtocartbutton $endform</td> When hovering the button the link just shows as: mystore.com/product_info.php?action=add_product When the button is clicked i just get to the shopping cart which is empty - no product is added. <_< Thanks again for your efforts!
  19. Amrahp

    [Contribution] STS v4

    As always: Thanks for your time. That contribution doesn't seem to include the product attributes does it..? Anyway I am happy with the look of my list now if I could just get the buy link to work I'd be REALLY happy! This "add to cart" problem isn't easy. I am NOT a skillfull programmer and did try these lines in my "allproducts.php.html" with no luck: <td><?php echo tep_draw_hidden_field('/product_info.php?cPath=10&products_id=50, $product_info['/product_info.php?cPath=10&products_id=50]) . tep_image_submit('button_buy_now.gif', IMAGE_BUTTON_IN_CART); ?><BR> </a></td> When doing this i get this error: Fatal error: Call to a member function on a non-object in /home/xxxxx/public_html/includes/functions/html_output.php on line 129 Line 129 is: "$src = $sts->image_button($image,$language);" :angry: Any example on how to achieve this is HIGHLY appreciated. Thanks!
  20. Amrahp

    [Contribution] STS v4

    Hi Bill and everyone else, I have "manually" created an All Products list. With manually do I mean that I created a table in dreamweaver and copied my products and links in to it. There are probably some nice php-code to achieve this but my coding skills aren't that good yet hehe. Anyway.. I've added the code and pages needed (sts_user_code, filenames, all_products.php in root and language folder) for the page to work properly. What I want: When a product is clicked in this list I want it to be added to the shopping cart. I tried just to add "&action=add_product" to the links but no luck of course haha. Any tips on how to do this? Kind regards! /J
  21. Amrahp

    [Contribution] STS v4

    You truly are a star with you answers, knowledge and willingness to help!! I will look into these things you have suggested and send out a big thanks again! :thumbsup: :thumbsup: :thumbsup:
  22. Amrahp

    [Contribution] STS v4

    Hello Guru! :thumbsup: Well Bill first of all... I did install HTC just recently and that was AFTER I had problems with the category text listing. :'( I did follow your directions to 100% and didn't install anything on the catalog side. In my /sts_templates/full/ I have: index.php_0.html index.php_21.html ->index.php_72.html I also have sts_template.html and index.php.html but are yet not sure if they ever are used anymore? :blink: Furthermore (probably not that interesting): about_us.php.html contact_us.php.html create_account_success.php.html faq.php.html login.php.html logoff.php.html popup_image.php.html privacy.php.html shipping.php.html shoppping_cart.php.html My /sts_templates/full/content/ is empty. I really don´t care anymore if I can't use the product_info.php_XX.html template. I will manage to make a good looking product.info.php, from what I have learned from you and the forum, that will make me satisfied enough I guess. All I want now (well almost) is HTC to work ok... :blush: Thanks!! :thumbsup:
  23. Amrahp

    [Contribution] STS v4

    What I have done now is to set "Use template for product info page" to false. In that way the categories text won´t show under my products! So I have been forced to edit the "product_info.php" to get the look I want for the time being. That is ok for now since I haven't been able to find what is causing my problem. But after I did this I can´t get HTC to work properly! :angry: It worked really nice before I disabled the product template and showed title tags for all my categories and products. Now the titel tag is only shown in the categories pages, not in the products! :angry: :angry: Maybe this is supposed to be posted in the HTC thread (if so I'm sorry!) but since you are familiar with my problem Bill maybe you have any thoughts on this. Thanks again! :thumbsup:
  24. Amrahp

    [Contribution] STS v4

    A small update regarding my problem... As a test; I did create some sub categories and copied my products into them in the admin panel. The categoy text is NOT listed! A small step forward or not.. I´m not sure yet. >_<
  25. Amrahp

    [Contribution] STS v4

    Ok... :thumbsup: Thanks for your time and effort Bill! I have already started my "reverse quest" and will see where it takes me! ;)
×