Jump to content

Farrukh

Members
  • Content count

    457
  • Joined

  • Last visited

Posts posted by Farrukh


  1. Hi hpdl

     

    Excellent work on the new development server.

     

    I have just installed SmartSVN and checked out oscommerce_3.0a2

     

    I have wanted to make some changes to the core files in the Products Deatils Insertion area.

     

    I will test it out and when its ready, how do I submit the changes ?

     

    The installation was a breeze though there are some bugs i found. Where do i report them.


  2. arm, i am using the latest version

     

    But i got an email from 2Checkout after first successful order in Version 2

    We attempted to create the following product but couldn't find all the required paramters.
    
    The following paramters are required for product creation:
    c_prod
    c_name
    c_price
    c_description
    
    For this product: c_prod_0 = IPM-007
    We received the name properly : c_name_0 = Eternity Men Perfume Oil We did NOT receive a description, it should have been sent as c_description_0 We did NOT receive a price, it should have been sent as c_price_0


  3. here is the email after update

     

     

    We attempted to create the following product but couldn't find all the required paramters.
    
    The following paramters are required for product creation:
    c_prod
    c_name
    c_price
    c_description
    
    For this product: c_prod_2 = MUB-001
    We did NOT receive a name, it should have been sent as c_name_2 We did NOT receive a description, it should have been sent as c_description_2 We did NOT receive a price, it should have been sent as c_price_2


  4. Now, I updated the Module

     

    This is the email I received from 2Checkout after placing a Demo order.

     

    We attempted to create the following product but couldn't find all the required paramters.
    
    The following paramters are required for product creation:
    c_prod
    c_name
    c_price
    c_description
    
    For this product: c_prod_1 = ABM-064
    We did NOT receive a name, it should have been sent as c_name_1 We did NOT receive a description, it should have been sent as c_description_1 We did NOT receive a price, it should have been sent as c_price_1


  5. I have tested it,

     

    The order does go through the Database and you can see it in the Admin.

     

    Even an email is sent.

     

    its working fine with me.

     

    Did you remove the 2Checkout Module version 1.


  6. I found out the problem with Force Cookies Settings

     

    it was the folder

      define('HTTP_COOKIE_PATH', 'cookies/');
    define('HTTPS_COOKIE_PATH', 'cookies/');

     

    I changed it to

      define('HTTP_COOKIE_PATH', '/');
    define('HTTPS_COOKIE_PATH', '/');

     

    Now the products are being added to the Shopping cart.


  7. define('HTTP_SERVER', 'http://www.domain.com'); 
     define('HTTPS_SERVER', 'https://www.domain.com');
     define('ENABLE_SSL', true);
     define('HTTP_COOKIE_DOMAIN', 'www.domain.com');
     define('HTTPS_COOKIE_DOMAIN', 'www.domain.com');
     define('HTTP_COOKIE_PATH', 'cookies/');
     define('HTTPS_COOKIE_PATH', 'cookies/');
     define('DIR_WS_HTTP_CATALOG', '/');
     define('DIR_WS_HTTPS_CATALOG', '/');
     define('DIR_WS_IMAGES', 'images/');
     define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
     define('DIR_WS_INCLUDES', 'includes/');
     define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
     define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
     define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
     define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
     define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');


  8. I am getting this message after enabling Force Cookies.

     

    We have detected that your browser does not support cookies, or has set cookies to be disabled.
    
    To continue shopping online, we encourage you to enable cookies on your browser.
    
    For Internet Explorer browsers, please follow these instructions:
    
      1. Click on the Tools menubar, and select Internet Options
      2. Select the Security tab, and reset the security level to Medium
    
    We have taken this measurement of security for your benefit, and apologize upfront if any inconveniences are caused.
    
    Please contact the store owner if you have any questions relating to this requirement, or to continue purchasing products offline.


  9. There is one problem.

     

    By Enabling Force Cookie, the browser gives out a message that your Cookies are not enabled.

     

    This would discourage alot of customers.

     

    Even by enabling the cookies, the message it still there and the cart does not forward.

     

    is there a way to install the contribution without enabling the cookie.

×