Jump to content

jsi

Members
  • Content count

    122
  • Joined

  • Last visited

Everything posted by jsi

  1. jsi

    [Contribution] SEO-G

    Looks like hundreds of people ask for help and not a single one gets answered. Kinda defeats the purpose of having a forum doesnt it? I know its all voluntary but if the only action in this thread is people asking for help and nobody answers them, why even bother having this thread? Its obviously non attended by anyone. If anyone can explain this I would appreciate it a lot. Its been months since my last post. Hope it doesnt take another few months to get a reply. SEO-G has a "G-Reports" link on the left admin. I have to manually go in EVERYDAY and delete all in order for site to not be so slow! Can anyone tell me what this reports table is for and how I can disable it indefinitely without it affecting the contribution? Can it just read from the controller and not use this reports table? Or at least tell me how to setup a cron to automatically delete all on a schedule? I really hate this reports section. Makes my site SUPER SLOW. Thanx. P.S. If you are reading this and its been a few weeks or months after it was posted . . . DO NOT WASTE YOUR TIME WITH THIS CONTRIBUTION. IT HAS NO SUPPORT WHATSOEVER. Unless you're a developer and dont need support, you can consider it. If not, use at your own risk. You will be left high and dry with support.
  2. jsi

    [Contribution] SEO-G

    HELP! SEO-G has been working great but is extremely slow. I have edited the configuration already and still it is very slow. I noted that when I go to G-Reports, I delete all and then the site is super fast for a few days. Then when the reports fill up again, the site is slow again. My question is, how can I make my site fast? Below you can see my configuration on how I have it setup. Is there a way to simply not use the reports table? Or maybe run a cron to delete it every week or so? I dont have many products, but the system adds the links when they are added to cart, buy, etc and all those only slow down the system. Or is there a way for the system to only add the actual products without adding the add to cart, buy now links, etc? Any suggestions? How do businesses with thousands of products do it? I have edited configuration as follows: SEO-G Master Switch true SEO-G Extension .html SEO-G Error Header 404 SEO-G Redirect 404.php SEO-G Strict Validation false SEO-G Safe Mode false SEO-G Auto Names Builder true SEO-G Continuous Check false SEO-G Process Secure Pages true SEO-G Redirection Table false SEO-G Parts Separator - SEO-G Words Separator - SEO-G Inner Separator - SEO-G Minimum Words Length 1
  3. Thank you for everything Kenowen.

    I have now successfully added the contribution but will make some modifications to control some things from admin.

    Last question . . .

    Is it possible to edit the certificate design with a background image or image border? Just so it can look like an actual gift certificate.

    Not sure how to do that. Any ideas?

    Thanx.

  4. Thank you kenowan,

    This may sound stupid but how exactly are these certificates usable? Once someone buys it, I know they can print and bring to the store, but what if they are in another state? Can they still use it to buy products kind of like a coupon?

    Thanx.

  5. Hey Kenowen,

    Thanx for the Gift Certificates Module!

    I was wondering if there is a support thread in the forum for this. I have it all complete. However, I cannot get the certificate to display as a product. However, I'm stumped cause I didnt edit the Products_info page at all, so where do I look at for the error?

    Thanx.

  6. chillin' like a villain

  7. Ok I got the --none-- fixed in the main customers.php. However, I tried to show it on the main admin index page in Admin>includes>modules>index>customers.php I miserably failed. haha I'm not good with PHP. Here is the code I used, Hopefully someone can see my mistake and tell me what to fix?? <table border="0" width="100%" cellspacing="0" cellpadding="4"> <tr class="dataTableHeadingRow"> <td class="dataTableHeadingContent"><?php echo ADMIN_INDEX_CUSTOMERS_TITLE; ?></td> <td class="dataTableHeadingContent"><?php echo ADMIN_INDEX_CUSTOMERS_DATE; ?></td> <td class="dataTableHeadingContent"><?php echo TABLE_HEADING_REFERRED_BY; //rmh referral ?></td> </tr> <?php $customers_query = tep_db_query("select c.customers_id, c.customers_lastname, c.customers_firstname, ci.customers_info_date_account_created from " . TABLE_CUSTOMERS . " c, " . TABLE_CUSTOMERS_INFO . " ci where c.customers_id = ci.customers_info_id order by ci.customers_info_date_account_created desc limit 26"); //rmh referral start $source_query = tep_db_query("select customers_info_source_id from " . TABLE_CUSTOMERS_INFO . " where customers_info_id = '" . $customers['customers_id'] . "'"); $source = tep_db_fetch_array($source_query); $entry_referral = tep_get_sources_name($source['customers_info_source_id'], $customers['customers_id']); //rmh referral end while ($customers = tep_db_fetch_array($customers_query)) { echo ' <tr class="dataTableRow" onmouseover="rowOverEffect(this);" onmouseout="rowOutEffect(this);">' . ' <td class="dataTableContent"><a href="' . tep_href_link(FILENAME_CUSTOMERS, 'cID=' . (int)$customers['customers_id'] . '&action=edit') . '">' . tep_output_string_protected($customers['customers_firstname'] . ' ' . $customers['customers_lastname']) . '</td>' . ' <td class="dataTableContent">' . $customers['customers_info_date_account_created'] . '</td>' . ' <td class="dataTableContent">' . $entry_referral . '</td>' . ' </tr>'; } ?> </table> I was not able to fix the problem in Reports>stats_referral_sources.php Still shows 121 instead of just 1. Your help is greatly appreciated.
  8. Great Contrib. LITTLE PROBLEM. :blink: Admin>customers.php does not update. All customers say --none-- Any idea how to fix this? Where should I look to fix this? Also in Reports>stats_referral_sources.php Dropdown choices show the real number of referrals from each. However, I only have one Other field and it has 121 instead of 1. 121 people have not entered other. Only 1. Any idea how to fix that? I triple checked instructions and all is exactly as directions indicate. Thanx in advance for you help. :blush:
  9. jsi

    fast easy checkout

    I want to see a preview of this checkout system but the sample site given at the beginning of the thread is no good: http://seelily.com/ Can anyone give me a link to see how this works/looks? Not sure if this is what I would need, so I really need the visual. Can anyone give me a link or preview image of each step? I'm wondering what it looks like when anonymous tries to checkout, when new user checks out and when member checks out. Thank you.
  10. jsi

    USPS not adding Weight Properly

    YEAH!!! That fixed it. I had it setup on 2 and it should have been set to .2 haha Thanx!
  11. I realize that ounces are not supported so we have to use decimals. Lets say I have two items. One weighs 0.21 pounds and another 0.24 pounds. The total should be 0.45 pounds (7 ounces) which rounded off should charge me for 1 pound of shipping. However, my USPS module rounds them off first, then adds which results in overcharging. It sees it as first item weighing 1.21 pounds and second item 1.24 pounds and when added it quotes for an order weighing 2 pounds 7 ounces! It literally doubles shipping! How can I fix this? Is there a fix for this? Please help.
  12. jsi

    USPS not adding Weight Properly

    What would that do? and how do I check that? What should it be set to?
  13. jsi

    Sitemap SEO

    I installed the 1.3 version by Chemo as you recommended but it does not generate SEO urls. They are all the default http://www.mysite.com/product_info.php?products_id=30 I dont see Chemo having a forum to discuss this so what do you suggest? How did you get it to work? By the way I have the SEO-G contribution not the ultimate SEO contribution. Thank you Jack
  14. jsi

    Sitemap SEO

    Hey Jack, I'm getting the articles manager installed since I notice it works with this contribution. Which version of Articles Manager do you recommend? The latests? Articles Manager V 1.57_1??? Thanx.
  15. jsi

    Sitemap SEO

    This is probably faster. However I didnt really follow the clearing table. How does one do that? phpMyAdmin??? Thanx. - Regarding the Google XML thing, you're right. Its best to keep them apart. Any thoughts on when the next version is coming out for the translation of titles? Thanx. P.S. Will send you the spanish versions tomorrow. Kinda booked at the moment.
  16. jsi

    Sitemap SEO

    Post #3 answered this problem: As for the multi-select, at line 406 in the admin/includes/functions/sitemap.php file, change else to this: else if (tep_not_null($selected_vals))
  17. jsi

    Sitemap SEO

    Hey Jack, Great contribution!!! 2 little things . . . 1. When I go to Configuration>SiteMap SEO I notice you can change the heading text. However it does not support other languages. Is there a fix so it can support more languages? I need to add spanish. 2. Is there a way to add a button to generate a sitemap XML file? sitemap.xml However, it would be best to not auto send to google. I do advanced SEO manually and its best if I send to google myself after I play with the file. You may want to add a second button to create and send to google for other people if you want but I think its best to keep them separate. Just a generate sitemap.xml file is good enough for me. What do you think? Thanx Jack and great work! P.S. My site is english/spanish. I'll give you the spanish translations to this if you want them for others to use. I already translated them. Let me know if you would like this.
  18. jsi

    Dynamic SiteMap

    Awesome! I'll give that a test drive tomorrow morning. Happy New Year! Thanx Jack.
  19. jsi

    Dynamic SiteMap

    Just got this working. Looks good but . . . I have the SEO-G contribution for Search engine optimization. All my links generated on the site maps are the default: http://www.mysite.com/product_info.php?products_id=28 but they should be like this: http://www.mysite.com/product-name.html Any idea how to fix this? Also, is there a way to show my products on the sitemap? Only categories are showing and I have a little bit of products so showing them would be ideal. Can anyone help with this? I can pay if necessary. I need this fixed ASAP. Thanx.
  20. This is in reference to: Specials & Products_new sort category & sub-category dropdown menu http://addons.oscommerce.com/info/5785 How would I go about adding this to the Advanced_Search_Results page? Thanx.
  21. jsi

    [Contribution] SEO-G

    I figured out how to do this so came back to share it. SEO-G has to read the link in order to create it. It was not reading the drop down. So I had to figure out a way for the manufacturer link to appear but not on a drop down. So I went to Configuration, then Product Listing. Under "Display Product Manufaturer Name" I put "1" Then you click on a category. On the list of items you will also get a manufacturer name and link. Since SEO-G just read it, it has now added it and will work from then on. After this I went back to Display Manufacturer Name and put it back to "0" cause I dont want it displayed. I only displayed it temporarily so SEO-G can read it and create its link. I'm sure there are other ways of doing this, perhaps even easier, but this is how I came across a solution.
  22. jsi

    [Contribution] SEO-G

    They should work together without a problem. If they dont, then you probably made a mistake somewhere during the install. This usually happens when you overwrite some text. If I were you I would use the backup before you installed SEOG and reinstall it again. Except when you overwrite anything, dont simply overwrite, look at the code and find out what is being added and only add the little bit of code that is being added. That way you will not overwrite anything from your imagemagic contribution.
  23. Whenever the product is marked "Out of Stock", featured items auto removes or does not show it as a featured item. That is great!! However, what if the item is In Stock but the Quantity set to Zero?? Anyone have an idea how to make it behave the same if quantity is set to zero?? I want to show some items In Stock but with Quantity of Zero and have the Featured not show it. Is this possible? This is my issue, I installed the Show Sold Items contrib. However, the Wolfen Featured Sets still show the Buy Now button when the Quantity is zero. Rather than editing all the Buy Now images, I figure it would be easier and faster for the Featured Sets to simply not show them if quantity is set to zero. Show Sold Out Items contrib. in case you are curious about what I'm talking about: http://addons.oscommerce.com/info/4884 So how can I make the featured items dissappear is quantity is zero???
  24. jsi

    [Contribution] SEO-G

    Manufacturers left box that has a drop down is not generating SEO links. If I use the left drop down menu it will take me here for example: http://www.aliviovital.com/index.html?manufacturers_id=9 SEO works on the Right manufacturers Info Box. When I click on the Other Products link, it will take me here: http://www.aliviovital.com/hewlett-packard.html So this tells me its not a problem with SEO G but rather the Manufacturers Box has to be edited to work with SEO G. So it reads from the SEO links. Any idea how to do this?
  25. jsi

    Header Tags SEO

    Nevermind. I got it, thanx.
×