Jump to content

jsi

Members
  • Content count

    122
  • Joined

  • Last visited

1 Follower

About jsi

  • Birthday 04/07/1978

Profile Information

  • Real Name
    JC
  • Gender
    Male
  • Location
    California
  • Interests
    Web design, art & music
  1. jsi

    [Contribution] SEO-G

    Looks like hundreds of people ask for help and not a single one gets answered. Kinda defeats the purpose of having a forum doesnt it? I know its all voluntary but if the only action in this thread is people asking for help and nobody answers them, why even bother having this thread? Its obviously non attended by anyone. If anyone can explain this I would appreciate it a lot. Its been months since my last post. Hope it doesnt take another few months to get a reply. SEO-G has a "G-Reports" link on the left admin. I have to manually go in EVERYDAY and delete all in order for site to not be so slow! Can anyone tell me what this reports table is for and how I can disable it indefinitely without it affecting the contribution? Can it just read from the controller and not use this reports table? Or at least tell me how to setup a cron to automatically delete all on a schedule? I really hate this reports section. Makes my site SUPER SLOW. Thanx. P.S. If you are reading this and its been a few weeks or months after it was posted . . . DO NOT WASTE YOUR TIME WITH THIS CONTRIBUTION. IT HAS NO SUPPORT WHATSOEVER. Unless you're a developer and dont need support, you can consider it. If not, use at your own risk. You will be left high and dry with support.
  2. jsi

    [Contribution] SEO-G

    HELP! SEO-G has been working great but is extremely slow. I have edited the configuration already and still it is very slow. I noted that when I go to G-Reports, I delete all and then the site is super fast for a few days. Then when the reports fill up again, the site is slow again. My question is, how can I make my site fast? Below you can see my configuration on how I have it setup. Is there a way to simply not use the reports table? Or maybe run a cron to delete it every week or so? I dont have many products, but the system adds the links when they are added to cart, buy, etc and all those only slow down the system. Or is there a way for the system to only add the actual products without adding the add to cart, buy now links, etc? Any suggestions? How do businesses with thousands of products do it? I have edited configuration as follows: SEO-G Master Switch true SEO-G Extension .html SEO-G Error Header 404 SEO-G Redirect 404.php SEO-G Strict Validation false SEO-G Safe Mode false SEO-G Auto Names Builder true SEO-G Continuous Check false SEO-G Process Secure Pages true SEO-G Redirection Table false SEO-G Parts Separator - SEO-G Words Separator - SEO-G Inner Separator - SEO-G Minimum Words Length 1
  3. The color of the certificate border is specified by GC_BORDERCOLOR in catalog/includes/configure.php. To include a background image of border image, you have to edit the catalog/images/gift_certificate.ps file which is in postscript. To avoid problems with the automatic generation of the certificate, the edits probably have to be made by hand.

  4. Thank you for everything Kenowen.

    I have now successfully added the contribution but will make some modifications to control some things from admin.

    Last question . . .

    Is it possible to edit the certificate design with a background image or image border? Just so it can look like an actual gift certificate.

    Not sure how to do that. Any ideas?

    Thanx.

  5. This is an on-line certificate. The gift certificate code is used to pay for products on the same site. You will note the that there is a box (catalog/includes/boxes/gc_code_entry.php) which is the entry form for the gift certificate. The fact that the certificate can be printed is for giving. It is not required for fulfullment.

  6. Thank you kenowan,

    This may sound stupid but how exactly are these certificates usable? Once someone buys it, I know they can print and bring to the store, but what if they are in another state? Can they still use it to buy products kind of like a coupon?

    Thanx.

  7. jsi

    Good to see you setting up the gift certificates module. The reason you didn't have to make any changes to product_info is because gift certificates are just like other products, set up in the admin interface.

  8. Hey Kenowen,

    Thanx for the Gift Certificates Module!

    I was wondering if there is a support thread in the forum for this. I have it all complete. However, I cannot get the certificate to display as a product. However, I'm stumped cause I didnt edit the Products_info page at all, so where do I look at for the error?

    Thanx.

  9. chillin' like a villain

  10. Ok I got the --none-- fixed in the main customers.php. However, I tried to show it on the main admin index page in Admin>includes>modules>index>customers.php I miserably failed. haha I'm not good with PHP. Here is the code I used, Hopefully someone can see my mistake and tell me what to fix?? <table border="0" width="100%" cellspacing="0" cellpadding="4"> <tr class="dataTableHeadingRow"> <td class="dataTableHeadingContent"><?php echo ADMIN_INDEX_CUSTOMERS_TITLE; ?></td> <td class="dataTableHeadingContent"><?php echo ADMIN_INDEX_CUSTOMERS_DATE; ?></td> <td class="dataTableHeadingContent"><?php echo TABLE_HEADING_REFERRED_BY; //rmh referral ?></td> </tr> <?php $customers_query = tep_db_query("select c.customers_id, c.customers_lastname, c.customers_firstname, ci.customers_info_date_account_created from " . TABLE_CUSTOMERS . " c, " . TABLE_CUSTOMERS_INFO . " ci where c.customers_id = ci.customers_info_id order by ci.customers_info_date_account_created desc limit 26"); //rmh referral start $source_query = tep_db_query("select customers_info_source_id from " . TABLE_CUSTOMERS_INFO . " where customers_info_id = '" . $customers['customers_id'] . "'"); $source = tep_db_fetch_array($source_query); $entry_referral = tep_get_sources_name($source['customers_info_source_id'], $customers['customers_id']); //rmh referral end while ($customers = tep_db_fetch_array($customers_query)) { echo ' <tr class="dataTableRow" onmouseover="rowOverEffect(this);" onmouseout="rowOutEffect(this);">' . ' <td class="dataTableContent"><a href="' . tep_href_link(FILENAME_CUSTOMERS, 'cID=' . (int)$customers['customers_id'] . '&action=edit') . '">' . tep_output_string_protected($customers['customers_firstname'] . ' ' . $customers['customers_lastname']) . '</td>' . ' <td class="dataTableContent">' . $customers['customers_info_date_account_created'] . '</td>' . ' <td class="dataTableContent">' . $entry_referral . '</td>' . ' </tr>'; } ?> </table> I was not able to fix the problem in Reports>stats_referral_sources.php Still shows 121 instead of just 1. Your help is greatly appreciated.
  11. Great Contrib. LITTLE PROBLEM. :blink: Admin>customers.php does not update. All customers say --none-- Any idea how to fix this? Where should I look to fix this? Also in Reports>stats_referral_sources.php Dropdown choices show the real number of referrals from each. However, I only have one Other field and it has 121 instead of 1. 121 people have not entered other. Only 1. Any idea how to fix that? I triple checked instructions and all is exactly as directions indicate. Thanx in advance for you help. :blush:
  12. jsi

    fast easy checkout

    I want to see a preview of this checkout system but the sample site given at the beginning of the thread is no good: http://seelily.com/ Can anyone give me a link to see how this works/looks? Not sure if this is what I would need, so I really need the visual. Can anyone give me a link or preview image of each step? I'm wondering what it looks like when anonymous tries to checkout, when new user checks out and when member checks out. Thank you.
  13. jsi

    USPS not adding Weight Properly

    YEAH!!! That fixed it. I had it setup on 2 and it should have been set to .2 haha Thanx!
  14. jsi

    USPS not adding Weight Properly

    What would that do? and how do I check that? What should it be set to?
  15. I realize that ounces are not supported so we have to use decimals. Lets say I have two items. One weighs 0.21 pounds and another 0.24 pounds. The total should be 0.45 pounds (7 ounces) which rounded off should charge me for 1 pound of shipping. However, my USPS module rounds them off first, then adds which results in overcharging. It sees it as first item weighing 1.21 pounds and second item 1.24 pounds and when added it quotes for an order weighing 2 pounds 7 ounces! It literally doubles shipping! How can I fix this? Is there a fix for this? Please help.
×