Latest News: (loading..)

IVUM

Members
  • Content count

    315
  • Joined

  • Last visited

1 Follower

About IVUM

Profile Information

  1. Thanks for the contribution! I just wanted to ask if there has been any progress on the category side of things?
  2. The problem has nothing to do with step 8 or 9. The problem is that you haven't uploaded the following 2 files to your server: includes/functions/pages.php includes/boxes/pages.php If you upload them then the error will go away as it will be able to find the above files.
  3. As the creator of Club osCommerce Featured Products decided to lock the contribution I was unable to add a bug fix to the contribution. When you use the contribution you can't duplicate products as it throws the following error at you: 1136 - Column count doesn't match value count at row 1 To fix the problem do the following: Open admin/categories.php and do the following: Find the following code: tep_db_query("insert into " . TABLE_PRODUCTS . " (products_quantity, products_model,products_image, products_price, products_date_added, products_date_available, products_weight, products_status, products_featured, products_tax_class_id, manufacturers_id) values ('" . tep_db_input($product['products_quantity']) . "', '" . tep_db_input($product['products_model']) . "', '" . tep_db_input($product['products_image']) . "', '" . tep_db_input($product['products_price']) . "', now(), " . (empty($product['products_date_available']) ? "null" : "'" . tep_db_input($product['products_date_available']) . "'") . ", '" . tep_db_input($product['products_weight']) . "', '0', '" . (int)$product['products_tax_class_id'] . "', '" . (int)$product['manufacturers_id'] . "')"); Replace that code with the following: tep_db_query("insert into " . TABLE_PRODUCTS . " (products_quantity, products_model,products_image, products_price, products_date_added, products_date_available, products_weight, products_status, products_featured, products_tax_class_id, manufacturers_id) values ('" . tep_db_input($product['products_quantity']) . "', '" . tep_db_input($product['products_model']) . "', '" . tep_db_input($product['products_image']) . "', '" . tep_db_input($product['products_price']) . "', now(), '" . tep_db_input($product['products_date_available']) . "', '" . tep_db_input($product['products_weight']) . "', '0', '" . (int)$product['products_featured'] . "', '" . (int)$product['products_tax_class_id'] . "', '" . (int)$product['manufacturers_id'] . "')"); Sorry if this is the wrong place but thought I'd post it, hopefully Burt will see it and update his package!
  4. I've ran into 2 problems which are below, would be great if someone knew how to fix them! As a customer I can add a product, when I click to Manage my products and then click on edit and edit the product and click Preview I am sent to my index.php file and the alterations are discarded. As a customer when I click on Manage my products and click on one of the products I just get a blank page rather then it automatically goes to the edit page like the admin section. Would really appreciate any help with this!
  5. Am sorry but looking at the replies I haven't explained right. I have got PayPal IPN installed and its working, when someone clicks confirm order my clients gets the order through the admin section without a problem but they are just not continuing to pay, only 3 out of 9 has paid, all the orders are being recorded no problem. The client who is using the RC1 version has now gone back to his old website with the normal html PayPal buttons that you get from PayPal's website because the orders were just not being completed.
  6. Well taking a look at the index.php file they provide they have removed the following code <tr> <td><?php include(DIR_WS_MODULES . FILENAME_NEW_PRODUCTS); ?></td> </tr> This code appears twice in the index file so download a fresh copy and compare the 2 and add in the code where it is missing.
  7. You could try Product Attributes - Option Type Feature although on the product page the visitor will HAVE to fill in the box that you put on there, it will not be optional unless you alter some files. http://www.oscommerce.com/community/contributions,160
  8. Thanks for that, I will try it on the Milestone 2 one but 1 out of the 2 is already running the RC1. Has anyone got any other ideas?
  9. I've installed this onto 2 websites owned by my clients, both times most of the orders fail. Take for example one of my clients in the last 7 days has had 9 people go through checkout and go to PayPal but only 3 has ended up paying! I have tried 2 other PayPal IPN modules but they still produce the same error. Has anyone else had the same problems? If anyone has PayPal IPN files which rarely produce the order failing would it be possible to send them to me for me to check if it is the files or just the customers!?
  10. You want to install the module below, this will allow you to set a quantity for each option. http://www.oscommerce.com/community/contributions,888
  11. Its not a bug as such, when you pay using the standard Paypal module the user HAS to return to the website to the success page for the database to update with the order. The Paypal IPN module updates the database when the customer clicks on confirm order, so even know the payment hasn't been made it gets recorded in the admin, when the order has been completed the database is updated so the owner knows payment has been made. I have never used authorize.net so can not comment but it could well be, if you are having problems have you tried to retrieve the orders from the database? Not sure if it works for authorize.net but does for Paypal and it doesn't make you look unprofessional as you don't need to phone the customer to find out what they ordered!
  12. To me it sounds like you have the standard Paypal module, you want the Paypal IPN payment module which can be found at the link below. http://www.oscommerce.com/community/contributions,2679
  13. Well the quicker fix for it is to go into the admin section and go to Minimum Values and set them all to 0 apart from what is needed, otherwise you will need remove a lot more coding so you get the purchase without account page required fields not required, you may even need to create a new file as the purchase without account page might use the same file as the create account page. By doing it the 'quicker' way you would then make the required fields on the create account page not required, I have been thinking about this for the last 5-6 days as it was an idea which was suggest to one of my clients but he decided against it so never got to test it out but have been meaning to get round to doing it! It should work with out a problem.
  14. This is sort of like the problem I had with skipping the login, the problem I had is my client's postage modules were setup so they are based on the postcode, as you skip the login there is no postcode so they don't show up. The only solution I came up with was to install the purchase without account module, remove all the boxes apart from what is required from the shipping module by the looks of it for UPS its City, State and Zip Code. Then set it up so when they click checkout on the shopping cart page they get direct to the purchase without account page, they only have to fill in these 3 boxes and they can continue checkout...