Latest News: (loading..)

redrum

Members
  • Content count

    221
  • Joined

  • Last visited

1 Follower

About redrum

Profile Information

  • Real Name
    Fredrik
  • Gender
    Male
  1. Where is "V2.1 - bugfixes, enhancements" available for download?
  2. I have some issues with Quantity Price Breaks for Separate Pricing Per Customer. I cant get the discounted price to be displayed unless I add two pcs of the same product (the total number of items must of course meet the criteria I have set up in the discount table). But if I go to shopping_cart.php and hit the Update Cart-button then the correct price with the discount is shown. I have set up a price table as follows; 1-4 pcs: $39 5+ pcs: $33 And then assign the products to the same discount category. This scenario work: Adding: 2 pcs of Product-A, 2 pcs of Product-B and 2 pcs of Product-C. or Adding: 3 pcs of Product-A and 2 pcs of Product-B. This scenario don't work: Adding: 2 pcs of Product-A, 1 pcs of Product-B, 1 pcs of Product-C, 1 pcs of Product-D or Adding: 4 pcs of Product-A, 1 pcs of Product-B, 1 pcs of Product-C, 1 pcs of Product-D or Adding: 4 pcs of Product-A and 1 pcs of Product-B I have spent some time trying to fix this but havent been able to find a solution. What could be wrong and where should I looking, does anyone have an idea?
  3. will it work with osCommerce 2.2-MS2?
  4. Does anyone have any idea of why the name of the categories disappear after this update, and how to solve that?
  5. Well, this contribution keeps confusing me. I noticed that the settings in admin was changed; Cache system was chaned from "file" to "sqlite" uri format was changed from "rewrite" to "standard" So the settings was reverted to default. I thougth it was very odd, but just changed it back. A few hours later it was back to default again. I then checked the database tables for usu5 and noticed that the time for date_added was just recently. So for some reason usu5 reinstalls for me. help, anyone?
  6. Did you find a solution for this? I hope I dont speak to mylelf here. After changing from "sqlite" to "file", the only error message in the log that I have received during 40 hrs is PHP Fatal error: Call to a member function store() on a non-object in /xxx/includes/modules/ultimate_seo_urls5/main/usu5.php on line 78 it occured 42 times during a period of 1,5 minute. I searched this thread and found that some other have had the same problem, but I couldnt find any soultion for it. The closest thing I found was the qoute above. I find it confusing that this contribution generate so many error massage for me, as faar as I know Robert is a skilled programmer.
  7. I have some more errors in my log since the last post and one of them is new. Here it is: PHP Warning: SQLiteDatabase::query() [<a href='sqlitedatabase.query'>sqlitedatabase.query</a>]: database disk image is malformed in /xxx/includes/modules/ultimate_seo_urls5/cache_system/sqlite.php on line 136 I have switched "cache system" in admin from "sqlite" to "file". So lets see how that turns out. Another question. As for the different cache systems, which is the best, next best, and so on? Thanks, Fredrik
  8. I have switched from Chemos SEO URLs to this one by FWR Media I first received this error in my logs PHP Warning: SQLiteDatabase::query() [<a href='sqlitedatabase.query'>sqlitedatabase.query</a>]: column cache_name is not unique in /xxx/includes/modules/ultimate_seo_urls5/cache_system/sqlite.php on line 130 I then updated sqlite.php from http://forums.oscommerce.com/topic/336702-ultimate-seo-urls-5-by-fwr-media/page__st__2920#entry1573002 and reset USU5 Cache from admin Then after a couple of minutes these error messages appeared in the logs PHP Warning: SQLiteDatabase::query() [<a href='sqlitedatabase.query'>sqlitedatabase.query</a>]: column cache_name is not unique in /xxx/includes/modules/ultimate_seo_urls5/cache_system/sqlite.php on line 136 PHP Warning: SQLiteDatabase::query() [<a href='sqlitedatabase.query'>sqlitedatabase.query</a>]: unable to open database file in /xxx/includes/modules/ultimate_seo_urls5/cache_system/sqlite.php on line 136 These error messages have occured 5 times during 4 hours. The folder includes/modules/ultimate_seo_urls5/cache_system/sqlite have the rights 777 I use Ultimate Seo Urls 5 PRO ( r205 ) at http://addons.oscommerce.com/info/6768 PHP Version: 5.2.17 OSC Version: 2.2 rc2a Any idea how to fix there errors?
  9. json needs to fetch the database info in utf8, my database is in latin1 and have special character such as å, ä and ö, This returend to display some products as "null". So you need to encode how the data is fetched from the database if you encounter this problem. Find array_push($return_arr, $row['products_name']); in autocomplete.php and replace with array_push($return_arr, utf8_encode($row['products_name']));
  10. Does this contributions have some limitations? I have around 2000 active products and 1000 inactive. I only get an autocomplete list when I type in the letters "ai". If I type the letters "do" no products get listed. But I do get a searh result when searching for "do". Why is it like that? //Fredrik
  11. Thanks for your reply. Does it support propperly so the payment options and shipping options changes when you changing country, depending on what each country allows?
  12. When I try the demo I get the message "No shipping available to the selected country". Can you set up the demo that allows shipping to some countrys, and so it changes the payment and shipping options depending on country. So we can see how this is updated. If this work propperly you have some good stuff here. Keep up the good work. Cheers, Fredrik
  13. I have a custom made one-page-checkout (namned checkout.php). In the country pull down menu I used to have Sweden as pre-selected. That pre-selection was disapeared after the upgrade to rc2a. This is due to the new function tep_draw_pull_down_menu in includes/functions/html_output.php So if I use the rc2a: function tep_draw_pull_down_menu($name, $values, $default = '', $parameters = '', $required = false) { global $HTTP_GET_VARS, $HTTP_POST_VARS; $field = '<select name="' . tep_output_string($name) . '"'; if (tep_not_null($parameters)) $field .= ' ' . $parameters; $field .= '>'; if (empty($default) && ( (isset($HTTP_GET_VARS[$name]) && is_string($HTTP_GET_VARS[$name])) || (isset($HTTP_POST_VARS[$name]) && is_string($HTTP_POST_VARS[$name])) ) ) { if (isset($HTTP_GET_VARS[$name]) && is_string($HTTP_GET_VARS[$name])) { $default = stripslashes($HTTP_GET_VARS[$name]); } elseif (isset($HTTP_POST_VARS[$name]) && is_string($HTTP_POST_VARS[$name])) { $default = stripslashes($HTTP_POST_VARS[$name]); } } for ($i=0, $n=sizeof($values); $i<$n; $i++) { $field .= '<option value="' . tep_output_string($values[$i]['id']) . '"'; if ($default == $values[$i]['id']) { $field .= ' SELECTED'; } $field .= '>' . tep_output_string($values[$i]['text'], array('"' => '"', '\'' => ''', '<' => '<', '>' => '>')) . '</option>'; } $field .= '</select>'; if ($required == true) $field .= TEXT_FIELD_REQUIRED; return $field; } no country is pre-selected. If I use the old ms2: function tep_draw_pull_down_menu($name, $values, $default = '', $parameters = '', $required = false) { $field = '<select name="' . tep_output_string($name) . '"'; if (tep_not_null($parameters)) $field .= ' ' . $parameters; $field .= '>'; if (empty($default) && isset($GLOBALS[$name])) $default = stripslashes($GLOBALS[$name]); for ($i=0, $n=sizeof($values); $i<$n; $i++) { $field .= '<option value="' . tep_output_string($values[$i]['id']) . '"'; if ($default == $values[$i]['id']) { $field .= ' SELECTED'; } $field .= '>' . tep_output_string($values[$i]['text'], array('"' => '"', '\'' => ''', '<' => '<', '>' => '>')) . '</option>'; } $field .= '</select>'; if ($required == true) $field .= TEXT_FIELD_REQUIRED; return $field; } the store country is pre-selected just as it should. This is how my code for selecting country looks like: <?php echo tep_get_country_list('country', ($HTTP_POST_VARS['country'] ? $HTTP_POST_VARS['country'] : $order->billing['country']['id']),'onchange="sb=1;copy_shipping(document.getElementsByName(\'ship_as_bill\')[0],true);sb=0;getbillstatewithshipp();" class="checkoutCountry" style="width:145px;"') . ' ' . (tep_not_null(ENTRY_COUNTRY_TEXT) ? '<span class="inputRequirement">' . ENTRY_COUNTRY_TEXT . '</span>': ''); ?> Should I stick to the old ms2 function tep_draw_pull_down_menu? Or can anyone help me out modify the code for selecting country in my checkout.php? Thanks, Fredrik
  14. I looked into this abit more. And it does update as it should. The problem is that if you continue and hit the "Preview" button the value in the field "Products Quantity:" over-write the the value AJAX Attribute Manager set in 'products_quantity'. So it would be nice with a solution for this.
  15. There is still a bug when using QTpro; The field 'products_quantity' in table 'products' is not updated. If you use the QTpro manager to update the attributes stock this table gets updated as well (and not only 'products_stock'). Example: If you have two attributes and 5 pcs of each you have a total of 10 pcs in 'products_quantity'. If you then go and edit this product and update the attribute stock to 10 pcs of each you should have a total of 20 pcs in 'products_quantity'. But it still ends up with a total of 10 pcs. This could be very crucial If you have set your store so your products become inactive while they are out of stock, then your product will be inactive in the store before its actually out of stock. It’s become inactive when 'products_quantity' in table 'products' has the value 0, even thou you have a positive value in the field 'products_stock_quantity' in the 'table products_stock'. Does anyone have a fix or thoughts about this? //Fredrik