Jump to content

safoo

Members
  • Content count

    485
  • Joined

  • Last visited

Posts posted by safoo


  1. i ran the quries though my database and noe on my shopping cart i get this

     

    1146 - Table 'trotp_osc1.TABLE_VENDORS' doesn't exist

     

    select p.products_id, pd.products_name, p.products_model, p.products_image, p.products_price, p.products_weight, p.products_tax_class_id, v.vendors_id, v.vendors_name from products p, products_description pd, TABLE_VENDORS v where p.products_id = '40' and pd.products_id = p.products_id and v.vendors_id = p.vendors_id and pd.language_id = '1'

     

    [TEP STOP]

    im out of clues

    PLZ help my dumbass

     

    Sean,

     

    You need to go through your instructions again. This is basic stuff.

     

    You are missing a define for TABLE_VENDORS in includes/database_tables.php


  2. Hey,

     

    I was wondering if anyone can explain to me how to take a cart and turn it to an order. Since I been using paypal, some orders don't show, but they show up in the recover cart tool. I was wondering if there was an easy way to take the stuff in the cart(has already been ordered) and move it to the order.

     

    Someone just posted a contribution for that today:

    http://www.oscommerce.com/community/contributions,4763

     

    It is too much work though! Why don't you try installing the oscommerce paypal ipn module. Installation is simple and the only real work is entering the configuration values for the module (such as your email address etc.)

     

    http://www.oscommerce.com/community/contri...l/search,paypal


  3. Hi Craig,

     

    Thanks for the quick response. The log file that I posted previously was from just one order, I too thought it should be much shorter. The only methods of shipping I have enabled are ground and standard. Any idea why so many requests are being sent for just one package? I'm still unclear why it says "United Parcel Service (XML) (2 pkg(s), 65 lbs total)" when there is only one package. Anyway, hope this info helps you get a clearer understanding of what exactly I'm seeing. Thanks in advance!

     

    Sam

     

    What is your setting in admin for configuration -> shipping/packaging -> 'enter maximum package weight' ?

     

    If you set it to, for example, 30 pounds and the total shopping cart weight is 45 pounds, then OSC gets a quote for 2 packages, 1 at 30 pounds and 1 at 15 pounds. I'm guessing that is why your UPS rates show two packages.


  4. I just tried it on another server and its still not working, I even had somebody else try it, and they couldnt get it working either they recieved the same generic error, but whatever that doesnt help any.

     

    So if it's not your mod then maybe it is a php.ini or apache setting, so

    can somebody who has it working be kind enough to post there files.

     

    What would it hurt?

     

    Thanks

     

    negativerad,

     

    Are you using a real credit card or one of the test card numbers? Try putting osc and authorize.net in live mode and use a real credit card (your own). Sometimes the test card numbers don't quite work.


  5. Just comment out the complete old function and add the new functions. Yes, the functions look completely different; this is because these functions will get information from the new tax class and most of the code that you don't see is in the class definition.


  6. Double check your database.php additions. There should be a define for "TABLE_VENDOR_CONFIGURATION". If you look in the file, you will know what I mean.

     

    Any time you have an error similar to this one, OSC is missing the definition for that place holder. In this case: TABLE_VENDOR_CONFIGURATION

     

    Also, this should have been posted in the MVS thread.


  7. Yes I think Bob is correct. I did receive a "4th email", though it is the first I have received.

     

    USPS Methods uses ExpressMailRequest and PriorityMailRequest, which will not requires HTTPS integration according to the email.

     

    USPS Methods doesn't send any sensitive, private information except zip code, which is why I believe they will not require this new implementation.


  8. try authorize.net aim from the contributions section. This is a new module that you will have to install and configure in admin as well as authorize.net site.

     

    Otherwise, there are CVV recording contributions. Just search CVV in the contributions section. and you can use one of thsoe with the existing authorize.net contribution you have.


  9. i really don't want it in the url, because i have had past problems of users posting this ?value=xx on message boards and such, which causes a bit of headache.

     

    because if i filter it from SE's (url with ?value), then i lose a potential backlink.

     

    keeping it strictly session, i don't have to worry about that stuff.

    but evenso, that wouldn't help the cause of 404's being cached, which produces a 200/ok response on second page load. :)

     

    Makes sense....

     

    Then what you can do is look in application_top where page_cache has an if statement I believe to see if the customer is logged in or not. Add your check with regards to the session variable and don't load page cache if that session variable exists. Then just unregister the variable after the code is executed to make sure page cache gets enabled again when you no longer plan to use that variable.

×