Jump to content

xp02ed

Members
  • Content count

    52
  • Joined

  • Last visited

Everything posted by xp02ed

  1. xp02ed

    SiteMonitor

    sweet thanks jack its all working now see how it goes in the next week!
  2. xp02ed

    SiteMonitor

    also when i do the manual check it send me an email saying theres a new file each time wait period of 4-5 hours shoudl i wait at least 24 hours?
  3. xp02ed

    SiteMonitor

    hoping someone can help im getting this error when i click on the admin page Warning: array_merge() [function.array-merge]: Argument #1 is not an array in /location/sitemonitor_admin.php on line 66
  4. xp02ed

    Header Tags SEO

    props on update jack, awesome plugin and awesome documentation!
  5. xp02ed

    Simply Hide Products (SHP)

    awesome contrib! i had several contrib installed which it had a conflict and post prior diagnosed it was with the string replace of "where" in /catalog/includes/functions/database.php to fix it i went through several contributes and ensured that "where" on the query was on the same line as the whole query. example// $eg_query = tep_db_query("select distinct p.fr_currencies_id, p.products_id, p.products_image, pd.products_name, p.products_tax_class_id, products_price, IF(s.status, s.specials_new_products_price, NULL) as specials_new_products_price, specials_new_products_price from " . TABLE_PRODUCTS_XSELL . " xp left join " . TABLE_PRODUCTS . " p on xp.xsell_id = p.products_id left join " . TABLE_PRODUCTS_DESCRIPTION . " pd on p.products_id = pd.products_id and pd.language_id = '" . $languages_id . "' left join " . TABLE_SPECIALS . " s on p.products_id = s.products_id where xp.products_id = '" . $HTTP_GET_VARS['products_id'] . "' and p.products_status = '1' order by sort_order asc limit " . MAX_DISPLAY_XSELL); had to be changed to $eg_query = tep_db_query("select distinct p.fr_currencies_id, p.products_id, p.products_image, pd.products_name, p.products_tax_class_id, products_price, IF(s.status, s.specials_new_products_price, NULL) as specials_new_products_price, specials_new_products_price from " . TABLE_PRODUCTS_XSELL . " xp left join " . TABLE_PRODUCTS . " p on xp.xsell_id = p.products_id left join " . TABLE_PRODUCTS_DESCRIPTION . " pd on p.products_id = pd.products_id and pd.language_id = '" . $languages_id . "' left join " . TABLE_SPECIALS . " s on p.products_id = s.products_id where xp.products_id = '" . $HTTP_GET_VARS['products_id'] . "' and p.products_status = '1' order by sort_order asc limit " . MAX_DISPLAY_XSELL); MOVED the where up a line. i hope this helps people as i spent 2 hours figuring it out! not a pro coder :(
  6. hey guys ive been using this contrib for about a year now but using this version iOSC v1.4- mobile site fo iPhone (Update) bumbarash 3 Apr 2009 Big thanks to PIXCLINIC for pointing out, investigating and repairing this bug AJAX part didn't work correctly if you have quotes or space. addslashes() added to categories_js.php iOSC v1.3- mobile site fo iPhone bumbarash 17 Mar 2009 I see there is a new version, and a whole lot of new files which are added to the catalog directory. is there a major change? i see the files in the mobile directory have been moved to catalog but everything else seems the same? Also with the redirection, i implemented the detect browser which a few posts gave which worked perfectly but clicking on PC site now doesnt work eg : http://www.domain/?redirectCancelled=true
  7. xp02ed

    Article Manager v1.0

    hey jack got a question is there any plans to integrate the sort orders on articles? currently its by name on the function function tep_get_all_articles_array(
  8. xp02ed

    Article Manager v1.0

    i think i found the issue, its to do with special characters my content contains & and other characters and which it doesn't display!
  9. xp02ed

    Article Manager v1.0

    commenting the following out */ /* header("Content-type: text/xml"); echo "<?xml version=\"1.0\" encoding=\"UTF-8\"?>"; echo "<rss version=\"2.0\">"; */ it works and shows the data in <item> see here can't figure this out :S
  10. xp02ed

    Article Manager v1.0

    yup ive did that, i also changed the code.. here is the new article_rss.php file i modded to it shows up buy going to the url <?php /* $Id: index.php,v 1.1 2003/06/11 17:38:00 hpdl Exp $ osCommerce, Open Source E-Commerce Solutions http://www.oscommerce.com Copyright (c) 2003 osCommerce Released under the GNU General Public License */ header("Content-type: text/xml"); echo "<?xml version=\"1.0\" encoding=\"UTF-8\"?>\n"; echo "<rss version=\"2.0\">\n"; echo "<channel>\n"; require('includes/application_top.php'); function mysqlTimestamp2unix($input){ $y = substr($input,0,4);$m = substr($input,6,2);$d = substr($input,9,2); $h = substr($input,12,2);$min = substr($input,15,2);$s = substr($input,18,2); return mktime($h,$min,$s,$m,$d,$y); } //1234567890123456789 //2007-01-01 15:48:04 require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_ARTICLES_RSS); $language_query = tep_db_query("select code from " . TABLE_LANGUAGES . " where languages_id = '" . (int)$languages_id . "'"); $language_code = tep_db_fetch_array($language_query); $code_lang = $language_code['code']; echo "<title>" . NEWS_TITLE . "</title>\n"; echo "<link>" . HTTP_SERVER . "</link>\n"; echo "<description>" . NEWS_DESCRIPTION . "</description>\n"; echo "<language>" . $code_lang . "</language>\n"; echo "<docs>" . HTTP_SERVER . DIR_WS_CATALOG . FILENAME_ARTICLES_RSS . "</docs>\n"; $news_query_raw = tep_db_query("select a.articles_id, a.authors_id, a.articles_date_added, ad.articles_name, ad.articles_head_desc_tag, ad.articles_description, au.authors_name, td.topics_name, a2t.topics_id from " . TABLE_ARTICLES . " a left join " . TABLE_AUTHORS . " au using(authors_id), " . TABLE_ARTICLES_DESCRIPTION . " ad, " . TABLE_ARTICLES_TO_TOPICS . " a2t left join " . TABLE_TOPICS_DESCRIPTION . " td using(topics_id) where (a.articles_date_available IS NULL or to_days(a.articles_date_available) <= to_days(now())) and a.articles_status = '1' and a.articles_id = a2t.articles_id and ad.articles_id = a2t.articles_id and ad.language_id = '" . (int)$languages_id . "' and td.language_id = '" . (int)$languages_id . "' order by a.articles_date_added desc, ad.articles_name limit " . NEWS_RSS_ARTICLE); // use language_id for language support. while ($content_rec = tep_db_fetch_array($news_query_raw)) { echo "<item>"; $headline = $content_rec['articles_name']; $mydate = mysqlTimestamp2unix($content_rec['articles_date_added']); $date = date('r',$mydate); $content_1 = $content_rec['articles_description']; $content = strip_tags($content_1); // $content_1 = substr($content_rec['articles_description'], 0, NEWS_RSS_CHARACTERS); // $content = strip_tags($content_1); // if (strlen($content_rec['content']) > NEWS_RSS_CHARACTERS) { // $content = $content . "...."; // maybe read more here? // } $article_author= $content_rec['authors_name']; // $article_url= $content_rec['articles_url']; $article_topic= $content_rec['topics_name']; $item_link = tep_href_link(FILENAME_ARTICLE_INFO, 'articles_id=' . $content_rec['articles_id'], 'NONSSL', false); echo "<title>$headline</title>\n"; echo "<pubDate>$date</pubDate>\n"; echo "<description>$content</description>\n"; echo "<author>$article_author</author>\n"; echo "<category>$article_topic</category>\n"; echo "<link>$item_link</link>\n"; echo "<guid>$item_link</guid>\n"; echo "</item>\n"; } echo "</channel>"; echo "</rss>"; ?> my current articles won't show up but when removing the xml format and just showing it, it shows the details.. hopefully that makes sense see here
  11. xp02ed

    Article Manager v1.0

    Hey guys ive been using this for awhile and have checked the RSS feeds. i am using the latest version RSS feeds don't seem to pickup all my articles when running this query via SQL it shows all articles select a.articles_id, a.authors_id, a.articles_date_added, a.articles_date_available, ad.articles_name, ad.articles_head_desc_tag, ad.articles_description, au.authors_name, td.topics_name, a2t.topics_id from articles a left join authors au using(authors_id), articles_description ad, articles_to_topics a2t left join topics_description td using(topics_id) where a.articles_status = '1' and a.articles_id = a2t.articles_id and ad.articles_id = a2t.articles_id and ad.language_id = '1' and td.language_id = '1' order by a.articles_date_added desc, ad.articles_name limit 10 but in the article_rss.php file it only shows 3? when i alter dates etc they all disappear? anyone got any ideas? as i cant figure it out
  12. ended up removing your function to calculate to this if( is_object( $this->coupon ) ) { $applied_discount = 0; $discount = $this->coupon->calculate_discount( $this->products[$index], $valid_products_count ); if( $discount['applied_discount'] > 0 ) $valid_products_count++; //$shown_price = $this->coupon->calculate_shown_price( $discount, $this->products[$index] ); //$this->info['subtotal'] += $shown_price['shown_price']; //$shown_price = $shown_price['actual_shown_price']; $shown_price = tep_add_tax($this->products[$index]['final_price'], $this->products[$index]['tax']) * $this->products[$index]['qty'] * tep_friendly_pricing($this->products[$index]['fr_currencies_id'])- ( $discount['applied_discount'] + $discount['discount_tax'] ); $this->info['subtotal'] += $shown_price; } else { $shown_price = tep_add_tax($this->products[$index]['final_price'], $this->products[$index]['tax']) * $this->products[$index]['qty'] * tep_friendly_pricing($this->products[$index]['fr_currencies_id']); $this->info['subtotal'] += $shown_price; } would this be bad for anything? seems to be working though
  13. Hey i use friendly pricing which kidna conflicts on checkout showing the wrong price. ON catalog/includes/classes/order.php i use this to calculate the price $shown_price = tep_add_tax($this->products[$index]['final_price'], $this->products[$index]['tax']) * $this->products[$index]['qty'] * tep_friendly_pricing($this->products[$index]['fr_currencies_id']); which i have this if( is_object( $this->coupon ) ) { $applied_discount = 0; $discount = $this->coupon->calculate_discount( $this->products[$index], $valid_products_count ); if( $discount['applied_discount'] > 0 ) $valid_products_count++; $shown_price = $this->coupon->calculate_shown_price( $discount, $this->products[$index] ); $this->info['subtotal'] += $shown_price['shown_price']; $shown_price = $shown_price['actual_shown_price']; } else { $shown_price = tep_add_tax($this->products[$index]['final_price'], $this->products[$index]['tax']) * $this->products[$index]['qty'] * tep_friendly_pricing($this->products[$index]['fr_currencies_id']); $this->info['subtotal'] += $shown_price; } although it doesnt work obviously coz of this $shown_price = $this->coupon->calculate_shown_price( $discount, $this->products[$index] ); using that custom function, i cant seem to get it to calculate this to the formula too * tep_friendly_pricing($this->products[$index] any pointers please?
  14. xp02ed

    Header Tags SEO

    Hi jack i was wondering if implementing the top parent id ( top parent category ) can be easily added this is for the product_info.php page neway
  15. xp02ed

    Article Manager v1.0

    ignore this after waiting 1 hour and clearing caches started to show the stuff, looks like my nets cacheing
  16. xp02ed

    Article Manager v1.0

    Hey guys i have STS, header tags and article manager installed all latest version Header tags work but when you click on an article, the breadcrumb grabs the right info but the title of page doesnt. It just has the articles.php file details. Or is this how it is supposed to be?
  17. xp02ed

    Header Tags SEO

    funny enough i swapped the variable name of $catStr and $manStr on includes/header_tags.php $catStr = "select c.categories_htc_title_tag as htc_title_tag, c.categories_htc_desc_tag as htc_desc_tag, c.categories_htc_keywords_tag as htc_keywords_tag from " . TABLE_CATEGORIES_DESCRIPTION . " c, " . TABLE_PRODUCTS_TO_CATEGORIES . " p2c where c.categories_id = p2c.categories_id and p2c.products_id = '" . (int)$the_product_info['products_id'] . "' and language_id = '" . (int)$languages_id . "'"; $manStr = "select mi.manufacturers_htc_title_tag as htc_title_tag, mi.manufacturers_htc_desc_tag as htc_desc_tag, mi.manufacturers_htc_keywords_tag as htc_keywords_tag from " . TABLE_MANUFACTURERS . " m LEFT JOIN " . TABLE_MANUFACTURERS_INFO . " mi on m.manufacturers_id = mi.manufacturers_id where m.manufacturers_id = '" . (int)$the_product_info['manufacturers_id'] . "' and mi.languages_id = '" . (int)$languages_id . "' LIMIT 1"; to $manStr = "select c.categories_htc_title_tag as htc_title_tag, c.categories_htc_desc_tag as htc_desc_tag, c.categories_htc_keywords_tag as htc_keywords_tag from " . TABLE_CATEGORIES_DESCRIPTION . " c, " . TABLE_PRODUCTS_TO_CATEGORIES . " p2c where c.categories_id = p2c.categories_id and p2c.products_id = '" . (int)$the_product_info['products_id'] . "' and language_id = '" . (int)$languages_id . "'"; $catStr = "select mi.manufacturers_htc_title_tag as htc_title_tag, mi.manufacturers_htc_desc_tag as htc_desc_tag, mi.manufacturers_htc_keywords_tag as htc_keywords_tag from " . TABLE_MANUFACTURERS . " m LEFT JOIN " . TABLE_MANUFACTURERS_INFO . " mi on m.manufacturers_id = mi.manufacturers_id where m.manufacturers_id = '" . (int)$the_product_info['manufacturers_id'] . "' and mi.languages_id = '" . (int)$languages_id . "' LIMIT 1"; and the manufacturer showed but the category disappears
  18. xp02ed

    Header Tags SEO

    ok in the includes/header_tags.php file line 110 $manStr = "select mi.manufacturers_htc_title_tag as htc_title_tag, mi.manufacturers_htc_desc_tag as htc_desc_tag, mi.manufacturers_htc_keywords_tag as htc_keywords_tag from " . TABLE_MANUFACTURERS . " m LEFT JOIN " . TABLE_MANUFACTURERS_INFO . " mi on m.manufacturers_id = mi.manufacturers_id where m.manufacturers_id = '" . (int)$the_product_info['manufacturers_id'] . "' and mi.languages_id = '" . (int)$languages_id . "' LIMIT 1"; i did this query via phpmyadmin, obviously changing the defined tables and and entering a manufcaturers id which it does grab the correct info. the includes/functions/header_tags.php file is using this query right? if ($type == 'man' && ($pageTags['append_manufacturer'] || $defaultTags['default_logo_append_group'] || $defaultTags['default_logo_append_manufacturer'])) { $the_manufacturer_query= tep_db_query($manStr); $the_manufacturer = tep_db_fetch_array($the_manufacturer_query); $header_tags_array['manufacturer'] = $the_manufacturer['htc_title_tag']; //save for use on the logo $sortOrder['title'][$pageTags['sortorder_manufacturer']] = ''; $sortOrder['logo'][$pageTags['sortorder_manufacturer']] = ''; $sortOrder['description'][$pageTags['sortorder_manufacturer']] = ''; $sortOrder['keywords'][$pageTags['sortorder_manufacturer']] = '';
  19. xp02ed

    Header Tags SEO

    do you by any change have a sample of what these tables should look like? I only have STS, Header tags, and ultimate SEO installed or there a variable i can use in the product_info.php page to see if it picks up a manufacturer or any of its fields
  20. xp02ed

    Header Tags SEO

    yup, ok the details are there. when i click on a manufacturer its there too HERE thats a sample manufacturer when u click on any product it doesnt show, everything looks right though my manufacturers table : Full Texts manufacturers_id manufacturers_name manufacturers_image date_added last_modified Edit Delete 11 K&N 2008-11-14 16:18:24 NULL Edit Delete 24 3M 2010-04-11 21:16:22 NULL Edit Delete 19 GruppeM 2009-04-22 14:37:14 2010-07-23 01:11:17 Edit Delete 23 Neffy Wrap 2010-01-28 11:21:03 NULL My manufacturers_info table Full Texts manufacturers_id languages_id manufacturers_url url_clicked date_last_click manufacturers_htc_title_tag manufacturers_htc_desc_tag manufacturers_htc_keywords_tag manufacturers_htc_description Edit Delete 11 1 0 NULL K&N K&N K&N NULL Edit Delete 24 1 0 NULL 3M 3M 3M NULL Edit Delete 19 1 http://www.gruppem.co.jp 0 NULL GruppeM GruppeM GruppeM gruppem intake from japan Edit Delete 23 1 http://neffywrap.com 13 2010-03-28 01:24:31 Neffy Wrap Neffy Wrap Neffy Wrap NULL
  21. xp02ed

    Header Tags SEO

    i definately have manufacturer ticked and have a sort # on it on the product_info.php page. although not sure what you mean on the manufacturers edit page. I dont see a manufacturers.php page under "page control" But if you mean i go to the manufacturers list /admin/manufacturers.php then yes all details are filled out is there anything i have to put on the product_info.php page? OR everything is grabbed from the header_tag files?
  22. xp02ed

    Header Tags SEO

    that doesn't seem to have done anything, although no errors or no title tag for manufacturer. i have ticked manufacturer and put a sort ID and also ticked it on the default tags for product_info.php page also cleared caches
  23. xp02ed

    Header Tags SEO

    Awesome addon jack, Just one issue which i just noticed. Its seems that the product_info.php page the manufacturer is not showing up on the page title. I am using the latest contri, i know abit of php and had a look the manufacturers ID is getting picked up but the query in the header_tags.php doesn't seem to be grabbing it?
  24. hey guys i got this to work on my site http://xposed.com.au although trying to go one thing further. How would i go about getting the "users" from WP share the "Customers" from OSC? so a user can sign up once and it works on both? the password both use same encrption?
  25. xp02ed

    Who's Online Enhancement 1.4

    Hi Glen i use Firefox 3, although it doesnt really matter nemore! i just copied the header html tags from configuration.php ! thanks anywaiz!
×