Jump to content

ctec2001

Members
  • Content count

    198
  • Joined

  • Last visited

Posts posted by ctec2001


  1. HI Michael

    Try disable the osc_sec from working and try again, i think it might be this causing the blank screen.

    Once disabled you should see the blocked.php again, please let me know if that works otherwise i would need to have a peek

    Regards

     

    Nic

     

     

    Hey Nic,

     

    It must be something to do with osc_sec. I was blocked by ip trap and then was blocked by osc_sec which I intended to do. They both sent emails out after different attempts to gain access and added my ip to the banned list. However, I am getting a blank screen with both contributions. I just wanted to know if that was normal or not, because I should at least see the blocked page from ip trap, i think. What do you think? I might still have you banned as I don't remember your ip and their are about 5 in the list currently. What do you recommend?

     

    Thanks for your help,

     

    Mike


  2. HI Michael

    Try disable the osc_sec from working and try again, i think it might be this causing the blank screen.

    Once disabled you should see the blocked.php again, please let me know if that works otherwise i would need to have a peek

    Regards

     

    Nic

     

     

    Hello Nic,

     

    I would have liked to responded sooner, but just got real busy with the site. Anyway, I am going to attempt to remove osc Sec and see if that helpes the issue, but I am kind of leary on if I should now. Today I recv'd my first email from IP Trap as the following ip number was banned: 87.209.87.48. How would I check to see if this a hacker or bot or something. Just a little paranoid since I had to redesign th esite in oscommerce 2.3.1.

     

    Any help would be appreciated.

     

    Mike


  3. I would like to start off by saying thank you very much for this contribution. I do have one issue and it probably is a very quick fix. I have verified my site with W3C Validator and it states that I have get the following errors:

     

    Validation Output: 3 Errors

     

    Error Line 6, Column 95: end tag for "meta" omitted, but OMITTAG NO was specified

    …cription" content="GORDON IMPORTS, INC., Largest Selection of Amphicar Parts.">

     

    You may have neglected to close an element, or perhaps you meant to "self-close" an element, that is, ending it with "/>" instead of ">".

     

    Info Line 6, Column 1: start tag was here

    <meta name="description" content="GORDON IMPORTS, INC., Largest Selection of Am…

     

    Error Line 7, Column 81: end tag for "meta" omitted, but OMITTAG NO was specified

    <meta name="keywords" content="gordon,imports,largest,selection,amphicar,parts">

     

    You may have neglected to close an element, or perhaps you meant to "self-close" an element, that is, ending it with "/>" instead of ">".

     

    Info Line 7, Column 1: start tag was here

    <meta name="keywords" content="gordon,imports,largest,selection,amphicar,parts">

     

    Error Line 8, Column 62: end tag for "link" omitted, but OMITTAG NO was specified

    <link rel="canonical" href="http://gordonimports.com/store/">

     

    You may have neglected to close an element, or perhaps you meant to "self-close" an element, that is, ending it with "/>" instead of ">".

     

    Info Line 8, Column 1: start tag was here

    <link rel="canonical" href="http://gordonimports.com/store/">

     

    This happens when I made the following change on step 2 - File modifications:

     

    catalog/includes/template_top.php

     

    Find ..

    <title><?php echo tep_output_string_protected($oscTemplate->getTitle()); ?></title>

     

    Replace with ...

    <?php include_once DIR_WS_MODULES . 'kiss_meta_tags/kiss_meta_tags.php'; ?>

     

    Is there a fix for this?

     

    Thank you in advance.

     

    Mike


  4. Hi Mike,

    There are many different add ons for security out there, but i would say

    Security Pro

    osC_Sec

    Nic

     

     

    Hey Nic,

     

    I was able to actually get the IP Trap working.

     

    I had to do the following:

    * Insert 999.999.999.999 inside the IP_Trapped.txt file

    * Leave the Whitelist.txt blank

     

    I have a few contributions installed such as osC_Sec, Security Pro, Site Monitor and of course IP Trap. Now, when I attempt to access the folder I get the blocked.php page with the message and my ip becomes blocked. I attempt to access any page on the site after becoming blocked, I only see a blank page. Is this common? Do you think one of the contributions could have affected your contribution?

     

    See if it happens to you...Click Here

     

    Thank you in advance.

     

    Mike


  5. Hi Mike

    I just tested it and got banned and remiand banned.

    If you have a rapidly changing IP number then it will give the apearance of not working as the IP you got banned with has changed.

    As for your question about 777, it is not safe to run with permissions so high and you are running the very real risk of being hacked once again.

    For folders you should be looking at a max of 755 and files 644 (unless they need to be read / write, in this case 666)

    777 will get you hacked again and its not a matter of if but when

    Nic

     

     

    Nic,

     

    Thanks, I did reset the permissions to 644 and everything seems to be working. I did check the site from another IP and it blocked it as well. I also see your ip address in there as well. I have removed and put it in a white list.

     

    Thank you so much for your help. I guess my next step would be to rename the admin and so forth. What else would you recommend for protection on the site. I have the Site Monitor and IP Trap so far.

     

    Mike


  6. I am having an issue with the IP TRAP v 5.2 not working correctly. I have attempted to access the personal folder and it still directs me it the index.php. I have checked and double checked the installation and still am not able to see it. Any help would be greatly appreciated. I have a fresh site and want to get it secure before setting everything up.

     

    you can see what I mean by clicking Website

     

    Thank you in advance...

     

    Mike

     

     

    May I ask to have someone test the site to check to see if the IP Trap is working correctly. I would greatly appreciate it. It is kinda of a hit and miss when I am testing it out.

     

    Thank you in advance...

     

    Mike


  7. Hi Mike,

    After making sure it is installed corectly, try removing the IP numbers in the whitelist - see if that cures it

    Nic

     

    Hey Nic,

     

    I really like this contribution. I did have a hacked site and finally cleaned it out. I think it would be best to upgrade to os v 2.3.1 and ass some security. What do you think? I also reased all ip's from the whitelist and the contribution works. Thank you. I did notice that I had to change the permissions to 777, is that alright?

     

    Thank you again for such a great contribution.

     

    Mike


  8. I am having an issue with the IP TRAP v 5.2 not working correctly. I have attempted to access the personal folder and it still directs me it the index.php. I have checked and double checked the installation and still am not able to see it. Any help would be greatly appreciated. I have a fresh site and want to get it secure before setting everything up.

     

    you can see what I mean by clicking Website

     

    Thank you in advance...

     

    Mike


  9. WHEN I TRY TO EDIT A FILE WITH TEXT EDIT IT WILL NOT ALLOW ME TO BECAUSE OF SOME PREMISSION OR SOMETHING LIKE THAT

     

     

    Did you follow Step 3 correctly? The backups_textmaster folder/file should be given 755 or 777 permission. I would start with that. If you could, maybe take a screenshot of error.

     

    Hope this helps.

     

    Mike


  10. Hey Jack,

     

    Thanks for the Contribution. I was looking for something like this. Quick and Easy. Keep up the great work. Oh and I am using tinymce_3_2_1_1 with this contribution on RC2a.

     

    Also, had to remove the // from admin/textmaster.php line 156 to get the formatting functions to work correctly. It wouldn't insert underlines or centering of text.

     

    Just adding info here so that others who run into the same problem can maybe find some answers to their questions.

     

    Thanks again.


  11. I moved my site to a new temp DNS. Come Tuesday, the actual www account will be ready. This will happen when I change the server names Monday. Any, My problem is that everything seems to work with the exception of the SEO for the products. Please take a look at the site: Visit My Website, in the catagories when you click or hover over them, please look at the bottom of the browser. I get this wierd osc extenstion and just cannot figure this out. Please help.


  12. I moved my site to a new temp DNS. Come Tuesday, the actual www account will be ready. This will happen when I change the server names Monday. Any, My problem is that everything seems to work with the exception of the SEO for the products. Please take a look at the site: Click Here to go to site, in the catagories when you click or hover over them, please look at the bottom of the browser. I get this wierd osc extenstion and just cannot figure this out. Please help.


  13. Best thing is to enable logging, as described in the comments of upsxml.php, and compare what is sent to and received from UPS to what you are seeing on the web site. If you have negotiated rates available and enabled, you'll see a lower price.

     

     

    Thank you, but I figured this problem out. It was my error. When checking on the UPS Site, I was checking Quick Time and Cost (Package) and not Detailed Time and Cost. Everything was and is currently working great. Thank you again.


  14. This is sort of like the problem I had with skipping the login, the problem I had is my client's postage modules were setup so they are based on the postcode, as you skip the login there is no postcode so they don't show up.

     

    The only solution I came up with was to install the purchase without account module, remove all the boxes apart from what is required from the shipping module by the looks of it for UPS its City, State and Zip Code.

     

    Then set it up so when they click checkout on the shopping cart page they get direct to the purchase without account page, they only have to fill in these 3 boxes and they can continue checkout...

     

    That sounds like a solution. It might also work with FedEx and DHL. All the main couriers handle shipping roughly the same way. I will have to test drive what you wrote.


  15. I would assume UPS would know enough having a zip code but since it complains about a missing state abbreviation I guess not. As far as I know UPS XML is also used together with the Ship in Cart module (never looked at it really). Perhaps there are clues in that contribution to what you need to do to make UPS XML work with only a zipcode (leave out the state if empty?).

     

     

    UPS requires I believe City, State and Zip Code in order to determine shipping costs. This is true with the Shipping software UPS uses. Example of just inputting a Zip Code would fail, because some cities share the same Zip Code.


  16. is there a way i can setup my checkout to not complete the order when someone places an order so that i can figure out the shipping my self and then email the full order back to the customer and have them approve it?

     

     

    One way to do this would be in the shopping cart, on the confirm order button, instead of actually confirming order, send it to your email. This will still bring up the last page so that you could still enter a message saying that they will be emailed their invoice with the complete shipping costs added. just a thought.


  17. I cant find the words in this file

    this is the code

    ---------------

    <?php

    /*

    $Id: checkout_success.php,v 1.2 2004/06/09 08:30:24 mahendrak Exp $

     

    osCommerce, Open Source E-Commerce Solutions

    http://www.oscommerce.com

     

    Copyright © 2002 osCommerce

     

    Released under the GNU General Public License

    */

     

    define('NAVBAR_TITLE_1', 'Checkout');

    define('NAVBAR_TITLE_2', 'Success');

     

    define('HEADING_TITLE', 'Your Order Has Been Processed!');

     

    // Added by Susan Kulkarni as part of the Shipping Message Module on May 13, 2005

    require('includes/functions/shipping_funcs.php');

    $msg = get_shipping_msg($languages_id);

    define('TEXT_SUCCESS', $msg);

    // Added by Susan Kulkarni as part of the Shipping Message Module on May 13, 2005

     

    /* new code added on 9june 2004 from here to show different message if only gift vocuhers and downloadbale products have been selected*/

     

    define('TEXT_SUCCESS_VIRTUAL', 'Your order has been successfully processed!.');

     

    /* new code added on 9june 2004 till here to show different message if only gift vocuhers and downloadbale products have been selected*/

    define('TEXT_NOTIFY_PRODUCTS', 'Please notify me of updates to the products I have selected below:');

    define('TEXT_SEE_ORDERS', 'You can view your order history by going to the <a href="' . tep_href_link(FILENAME_ACCOUNT, '', 'SSL') . '">\'My Account\'</a> page and by clicking on <a href="' . tep_href_link(FILENAME_ACCOUNT_HISTORY, '', 'SSL') . '">\'History\'</a>.');

    define('TEXT_CONTACT_STORE_OWNER', 'Please direct any questions you have to the <a href="' . tep_href_link(FILENAME_CONTACT_US) . '">store owner</a>.');

    define('TEXT_THANKS_FOR_SHOPPING', 'Thanks for shopping with us online!');

     

    define('TABLE_HEADING_COMMENTS', 'Enter a comment for the order processed');

     

    define('TABLE_HEADING_DOWNLOAD_DATE', 'Expiry date: ');

    define('TABLE_HEADING_DOWNLOAD_COUNT', ' downloads remaining');

    define('HEADING_DOWNLOAD', 'Download your products here:');

    define('FOOTER_DOWNLOAD', 'You can also download your products at a later time at \'%s\'');

    ?>

    --------

     

    What do i change

     

    This part of the code look to be where your message may be:

     

    // Added by Susan Kulkarni as part of the Shipping Message Module on May 13, 2005

    require('includes/functions/shipping_funcs.php');

    $msg = get_shipping_msg($languages_id);

    define('TEXT_SUCCESS', $msg);

     

    Look at the shipping_funcs.php it might be in there. This is a little different layout than what I have.

     

    Let me know.


  18. on check out we get page

     

    Your Order Has Been Processed!

     

    Your order has been successfully processed! Your products will arrive at their destination within 10-15 working days.

    Please notify me of updates to the products I have selected below:

     

    my site makes custom photo bages this proces takes a few weeks how can i remove the :

     

    Your products will arrive at their destination within 10-15 working days.

     

    You can make the change in the includes/languages/english/checkout_success.php file


  19. Thanks, ctec2001. How do you link the OSC databata to retrieve the shipping info? Is that done through a contribution? If so, which one?

     

    Is there anything I need to do on the UPS side to enable this (other than have an UPS online account)?

     

    No contribution needed.

     

    Are you using UPS Online Or UPS Online Worldship?

     

    You will need to to download and install the MySql ODBC Driver. There is one item that needs to be completed in the PHP Admin and that is to add your IP Address of your PC to have access to the the DB. You then create and ODBC connection using the MySql ODBC Driver.

     

    Once that is established, you can link to the orders table and pull in the customers info.


  20. B271, thank you for your post. That must be what it is. The $2.20 surcharge you cite for rural delivery seems to be the difference. I wonder why the module I'm using for UPS shipping does not take that into account?

     

    notubes_pete, thanks for your post. I like the UPS shipping module that I'm using (whatever it is). However, if I can't figure how to get it to account for the rural surcharge, I think I will have to change to the XML module version.

     

    This is slightly off-topic but still involves UPS shipping. Do any of you use an automated or expedited method of creating UPS shipping labels? I have a UPS online account and current copy and paste shipping address info from OSC into the UPS online label form. I know that there has got to be a better way. Does anyone have any experiences or advice to share?

     

    Thanks

     

    You can link into the osC db to retrieve the customer ship to information. I deal with UPS every day. ;) and kinda know the ins and out of the software.

×