Jump to content

martinmacca

Members
  • Content count

    106
  • Joined

  • Last visited

Everything posted by martinmacca

  1. martinmacca

    Country-State Selector

    Ive got Human confirmation v1.2 installed & the only part on the create_account.php file that i couldnt change was I havnt got that, instead ive got // BOF // Contrib: Human confirmation v1.2 $thecode_okay = false; $process_okay = false; $noautomationcode = $HTTP_SESSION_VARS["noautamationcode"]; // -> v1.1 // Changed to work w/ random image names $img_dir = $HTTP_SESSION_VARS["noautamationdir"]; $img_name = $HTTP_SESSION_VARS["noautamationname"]; // Find and delete old images if (strlen($img_name) >= 6) { $dirHandle = dir($img_dir); while($fileHandle = $dirHandle->read()) { if (substr($fileHandle,0,strlen($img_name)) == $img_name) @unlink($img_dir.$fileHandle); } $dirHandle->close(); } // <- v1.1 // Changed to work w/ random image names $thecode_okay = (isset($HTTP_POST_VARS['thecode']) && ($HTTP_POST_VARS['thecode'] == $noautomationcode )); $process_okay = (isset($HTTP_POST_VARS['action']) && ($HTTP_POST_VARS['action'] == 'process')); if ( ($process_okay == true) && ($thecode_okay == true) ) { // EOF // Contrib: Human confirmation v1.2 $process = true; Any idea how i can put the 2 together?
  2. I have looked all through the forums and still cant find the answer. Basically ive got Down For Maintenance installed and want to change the date format for the maintenance page from YYYY-MM-DD to the UK format of DD-MM-YYYY or date_format_long. E.G. Website Maintenance was enabled at : 2004-09-28 11:32:55 but i want it to say Website Maintenance was enabled at : 28-09-2004 11:32:55 In catalog>down_for_maintenance.php i can see And further up the file The last modified time shows the UK format in admin, just not on the catalog down_for_maintenance page. Can anyone point me in right direction
  3. Has anyone changed the image store path for the extra images? By default any extra images are stored in catalog/images/. But i want to store the extra images in a subfolder e.g. catalog/images/Extra_Products_Images/ I noticed in admin/categories.php Ive tried changing the destination from to And have also tried creating a new image class DIR_FS_CATALOG_IMAGES_LARGE & using this instead & adding this to admin/configure.php as But neither of these attempts have worked as the images still go into catalog/images Any ideas ?
  4. martinmacca

    Products Attributes Sort v1.0

    For something so simple you make it look really difficult to understand :'( If adding a file to the database is this complicated then what chance do we stand we it comes to the real stuff ? Only kidding - justs it matter of logging into your PhpMyAdmin database-clicking on your database name at the top of the left hand column, then clicking on the SQL tab on the main page & pasting your SQL data into the the table. This is a breese compared to some of the modding you will come across! :blink:
  5. Nice Contri ;) If like me you want to have just 3 stock status's (in stock, limited stock, out of stock) then change includes>functions>general to : Here you can see that stock levels between 500 & 1000 will show as being in stock, 100 to 499 as limited stock & 0-99 as out of stock- you can change these to whatever you like. Ive shown this formula in admin when editing the quantity on a product by changing admin>categories line 1000ish approx find: to And then in admin>includes>languages>english>categories add: So when you change the quantity to the different status's in admin it will look like this Thanks John2b
  6. martinmacca

    RMA Returns error for 2.2 MS2

    Look at my thread near the top of the last page, that will show you how to amend the contri to add your tax rate!
  7. If i add a small image as the main product image & a large image for the popup, it works great on the product info page. But if i browse a categorie of products the large popup image is shown as the main product image instead of the small image. Any idea how i could change this ?
  8. martinmacca

    RMA Returns error for 2.2 MS2

    When i return a product & click the request button to complete the return & get an RMA number, the page gets redirected to the login screen. The user then has to login to get the RMA number. Does this happen to your stores or has anyone made a fix to skip the login page?
  9. martinmacca

    RMA Returns error for 2.2 MS2

    i had a similar problem with the tax not being added when returning a product. Try this: Catalog>return_product.php Find approx line 380 If you look at this echo ' <td class="main" align="right" valign="top">' . $currencies->format(($returned_products['final_price']+$returned_products['final_price']/100*17.5) * ($returned_products['products_quantity'])) . '</td>' . "\n" . in the above statement it has been coded to get the final product price & add 17.5% which is my tax rate. It works for me
  10. martinmacca

    UK Tax Configuration

    Go To Admin>Locations/Taxes>Tax Rates>New Tax Rate The Settings should be: Tax Class Title:Taxable Goods Tax Rate: 17.5000 Description:VAT Priority:0 ?85.11 + 17.5% = ?100 17.5% of ?85.11 is ?14.89 Your Total Price of ?100 is inclusive of tax and so the amount of tax charged in that ?100 is ?14.89 should say VAT:?14.89 which is how much VAT has been charged I would suggest making your shipping non taxable therefore the price shown for shipping is inclusive of tax, so the cost you charge to ship you goods is exactly what the customer pays You can change this in admin>modules>shipping> Edit the shipping methods you use so that the tax class=NONE If you then goto Admin>Modules>Order Total Change to the following Tax:1 SubTotal:2 Shipping:3 Total:4 It will look like: VAT: ?14.89 Sub-Total: ?100.00 Shipping: ?9.34 Total: ?109.34 I know it looks a bit confusing with the VAT at the top as customers might think that VAT hasnt been added so you could change it so it says: Amount charged in VAT ?14.89 SubTotal Inclusive of VAT ?100.00 Shipping: ?9.34 Total: ?109.34 The only other way is to install the VAT Display contribution & goto Admin>configuration>Display Prices with Taxes:False Change Admin>Modules>Order Total to SubTotal:1 Shipping:2 (which will be exclusive of tax) VAT:3 Total:4 So it will look like SubTotal:?85.11 Shipping:?7.95 VAT:?16.28 Total:109.34 Hope this gives you a better idea ;)
  11. Mine sends out the emails fine to both myself and the customer. I think support on this contri will be very limited as the creator of the Mod -Warren looks as if he has been banned from the forums. I still have problems with the page confirming the order has now been cancelled as it is just text - there are no borders, background or headers, but havnt received a reply in 4 months :( All i can suggest is try installing it again & if it still dont work then could be a conflict with a prev mod or you havnt done something right
  12. martinmacca

    Wolfen Featured Sets SUPPORT

    I have checked this function out and there is no issue, try my earlier post resolve of using the replacement pack file. Sorry My Fault! My Admin>categories.php file was modded with a previous mod-think it might be HTML for product descriptions? Found the error for my case was the last bit of the install file Replace code with I had to change mine to Shouldnt have rushed the install & i would have noticed the change Cheers for the help steve ;)
  13. martinmacca

    Wolfen Featured Sets SUPPORT

    are you sure that you don't need the button lowered. :D No the button looks fine where it is lol Ive just noticed that in admin>catalog>categories/products when i try to update or insert a categories image it wont save. No errors it at all - it behaves like it should when i press save except the image hasnt updated. Not a problem i thought, i'll just have a browse through the instructions for admin/categories.php, em theres ALOT of changes and dont no where to start. Its definitely that file as ive tried a backup file which is fine. Any idea which part of the change in that file might have something to do with the image update so i can compare my modded file to my backup
  14. Hi, ive installed this contribution Order Logging Before Payment Processing which works. I just need to know how to get it to include the product attributes as well in the holding table so i know what options the customer has chosen. I think it has something to do with including the products_options_name from the table products_options, and including products_options_values_name from the table products_options_values Heres the SQL file for the install, how would i put these options in the table holding_orders_products and get them to work? And heres the install file, i cant see anywhere to include these options so presume its all done on the SQL file? <?php /* $Id: orders_holding.php,v 1.1 2004-05-30 Nick Weisser, http://ganes.ch osCommerce, Open Source E-Commerce Solutions http://www.oscommerce.com Copyright (c) 2003-2004 osCommerce Released under the GNU General Public License */ require('includes/application_top.php'); require(DIR_WS_CLASSES . 'currencies.php'); $currencies = new currencies(); ?> <!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN"> <html <?php echo HTML_PARAMS; ?>> <head> <meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>"> <title><?php echo TITLE; ?></title> <link rel="stylesheet" type="text/css" href="includes/stylesheet.css"> </head> <body marginwidth="0" marginheight="0" topmargin="0" bottommargin="0" leftmargin="0" rightmargin="0" bgcolor="#FFFFFF"> <!-- header //--> <?php require(DIR_WS_INCLUDES . 'header.php'); ?> <!-- header_eof //--> <!-- body //--> <table border="0" width="100%" cellspacing="2" cellpadding="2"> <tr> <td width="<?php echo BOX_WIDTH; ?>" valign="top"><table border="0" width="<?php echo BOX_WIDTH; ?>" cellspacing="1" cellpadding="1" class="columnLeft"> <!-- left_navigation //--> <?php require(DIR_WS_INCLUDES . 'column_left.php'); ?> <!-- left_navigation_eof //--> </table></td> <!-- body_text //--> <td width="100%" valign="top"><table width="100%" cellpadding="5"> <tr> <td class="main"><p class="pageHeading">Holding Orders</p> <p>This module logs the order, products ordered and order total in three holding tables triggered at the checkout_confirmation.php page before the customer is passed to the payment processor. The process is seamless and doesn't interfere with the regular checkout process.</p> </td></tr> <tr> <td><table width="100%" class="smallText"> <tr class="dataTableHeadingRow"> <th>Customer</th> <th>Country</th> <th>E-mail</th> <th>checkout_confirmation.php</th> <th>Date purchased</th> <th>Checkout successful</th> </tr> <?php $holding_orders = tep_db_query("select customers_id, customers_name, customers_email_address, customers_country, date_purchased from " . TABLE_HOLDING_ORDERS . " order by date_purchased desc"); while ($row = mysql_fetch_array ($holding_orders)) { $checkout_success = tep_db_query("select date_purchased from " . TABLE_ORDERS . " where customers_id = '" . $row['customers_id'] . "'"); mysql_num_rows ($checkout_success) > 0 ? $flag = 'yes' : $flag = 'no'; $success = mysql_fetch_array ($checkout_success); ?> <tr<?php if ($flag == 'no') echo ' class="dataTableRowSelected"'?>;> <td><?php echo $row['customers_name']; ?></td> <td><?php echo $row['customers_country']; ?></td> <td><a href="mailto:<?php echo $row['customers_email_address'];?>"><?php echo $row['customers_email_address']; ?></a></td> <td><?php echo $row['date_purchased']; ?></td> <td><?php echo $success['date_purchased']; ?></td> <td><?php echo $flag ?></td> </tr> <?php } ?> </table></td></tr> </table> </td> <!-- body_text_eof //--> </tr> </table> <!-- body_eof //--> <!-- footer //--> <?php require(DIR_WS_INCLUDES . 'footer.php'); ?> <!-- footer_eof //--> <br> </body> </html> <?php require(DIR_WS_INCLUDES . 'application_bottom.php'); ?> Please help
  15. martinmacca

    [Contribution] Ship In Cart

    Wahey works like a dream, cheers ;)
  16. martinmacca

    Wolfen Featured Sets SUPPORT

    Cheers Steve thats sorted it ;)
  17. martinmacca

    Wolfen Featured Sets SUPPORT

    Ah ha forgot about that :lol: One thing thats bugging me is moving the buy it now button :angry: At the moment it looks like this And im trying to get it to look like this again on line 182 Ive tried putting the align in at the end before the start of the link but the button moves everywhere except to the right as in the 2nd pic :( E.G. Any ideas?
  18. martinmacca

    Wolfen Featured Sets SUPPORT

    To make images clickable too: open catalog>includes>modules>featured_products.php Find a style you are going to use or add it to all styles, in this example whilst logged into admin in the featured settings i have chose: Choose a featured products set layout - 3 Choose a featured products set style - 4 Now in featured products.php in this example line 182 Add So it looks like this Hope this helps someone ;)
  19. martinmacca

    Products Attributes Sort v1.0

    Running the SQL file doesnt mean just uploading it to your site. You have to log into you database & add the text that is in the file into the database. Bring up PhpMyAdmin and select the database that was created. There will be a section for running queries on the right side called SQL. Just under it will be a button for browsing to a file. Click that button and find your file_name.sql file. That will upload the file to PhpMyAdmin and it will read in the lines and execute them on MySql. Walla, you should be done. If you dont know how to do this then your gonna really struggle to add any contributions to your site as most have some sort of SQL file to add :blink:
  20. martinmacca

    Wolfen Featured Sets SUPPORT

    Doesnt seem to be so much of an issue now for some reason, the boxes only change width very slightly now-is it possible to all the boxes exactly the same width ? Suggestion for future updates is to make the image clickable so it is linked to product page :rolleyes:
  21. martinmacca

    Wolfen Featured Sets SUPPORT

    Ive got it installed, quite a big install-took me about an hour. Looks really good only ive got 1 problem. For some reason the box widths keep changing -sometimes stretching out of proporsion and squashing the end box. Im not sure how to fix it, is there anyway to manually set the width of the box so that the width is fixed so something like 50% of the page? Any ideas how i can stop the boxes stretching ?
  22. martinmacca

    cieto Featured Products 2.5 MS2

    All seems to be working except the main page. For some reason ive constantly got "whats new here" at the top of my index page, and the featured products seem to be moving all over the page when refreshed, i.e. sometimes the columns are out of proportion making some products out of line or squashed to the side or below. Examples shown below of some of the different layouts-also notice the whats new at the top Where have i gone wrong ? :blink:
  23. martinmacca

    Shadowbox (Support)

    The width of my righ hand column on certain pages seems to get stretched out of proporsion. Its fine when the user is logged in, but when browsing whilst logged off the right column gets stretched by about 20 pixels. Ive tried to manually set the width of the category boxes from to If i refresh the page when it happens the column gets resized back to normal but as soon as i click a link it happens again. Ive deleted the internet files on my comp incase it was using old pages but still no luck. Ive used find and replace to check i havnt missed a file but to no luck. Any ideas?
×