Jump to content

dc2lv2atl

Members
  • Content count

    19
  • Joined

  • Last visited

Profile Information

  • Real Name
    Ronald Ross
  1. Thanks for the reply Jack. My other two installations are on different servers, but at the same hosting company. I also set the permissions on those other two at 777 not 755. The error message in the admin of my new install tells me to set it to 755. I have to figure some way to check the server settings, but this one has me stumped, if anyone has any ideas please let me know. P.S. Jack: This is still a killer contribution and I for one appreciate the work that you put in on it. Thanks.
  2. Hey jack, I am adding the HTC contrib on my third site and this is the first time I've had a problem. I know that you have heard this before but all the conventional solutions have not worked to this point. Here's the issue: I have installed the contrib as usual, and set the permissions correctly. When I press the Update button, I get "The file isn't writable". Initially I got: Warning: chmod(): Operation not permitted in /home/xxxxxx/public_html/admin/includes/functions/header_tags.php on line 203 Cannot change the mode of file (../includes/languages/english/header_tags.php) so i opened: catalog/admin/includes/functions/header_tags.php and made the recommended changes. if (!is_writable($filename)) { if (!chmod($filename, 0666)) { echo "Cannot change the mode of file ($filename)"; exit; } } Replced that with the following code: if (!is_writable($filename)) { echo "The file isn't writable"; exit; /* if (!chmod($filename, 0666)) { echo "Cannot change the mode of file ($filename)"; exit; } */ } I pressed Update and got "The file isn't writable". Again I checked the permissions and they are set to 755. 777 doesn't work. What do you think?
  3. I have an Easy Populate question. I just installed EP 2.76f r1 ms2 on my OSC rc1 shop. When I try to "Create Then Download File" it holds for a minute then the download box pops up and says "You have chosen to open easypopulate.php which is a PHP file.....". I was expecting an EP.txt file to download. What could be the problem? Settings EP vers: 2.76f-MS2 r1 Temp Dir: /home/docandso/public_html/temp/ Temp Dir is Writable Magic Quotes is: off register_globals is: on Split files on: 300 records Model Num Size: 25 Price with tax: false Calc Precision: 2 Replace quotes: false Field seperator: comma Excel safe output: true Preserve tab/cr/lf: false Category depth: 7 Enable attributes: true SEF Froogle URLS: false More Pics: false Unknown Pics: false HTC: false SPPC: false Extra Fields: false
  4. dc2lv2atl

    Multi_Vendor_Shipping new thread

    Let me start with a thanks to everyone who has contributed to the MVS development. I've been using it successfully for quite a while. I want to incorporate MVS in my new site. Will MVS 1.1 function appropriately on an osCommerce 2.2RC1 site with STS 4.5.8 and HTC 2.6.3 contributions already installed?
  5. Chemo and everybody involved should be applauded for the Ultimate SEO URLs contribution. It’s perfect for my application. I just added the contribution and moved my site to the root directory. Unfortunately, I have an issue that I need help with. I used the osCommerce application that my ISP provided and it loaded to the /osCommerce/catalog directory that is generated at install. I moved the store from MyStore/osCommerce/catalog to MyStore/. Then I changed both configure.php files to reflect the move. The vDeck admin console they provide points to MyStore/osCommerce/catalog/admin. So I just typed in MyStore/admin and the new vDeck came up. So I assume that the changes to the admin/includes/configure.php file are good. I had to reset the permissions on several folders and the 2 header_tags.php files, but so far so good. The problem comes in when I go to my site, I get this fatal error message. Fatal error: Call to undefined function: tep_href_link() in /home/MyStore/public_html/includes/application_top.php on line 485 From my application_top.php: (line 485 is the last line) // include the breadcrumb class and start the breadcrumb trail require(DIR_WS_CLASSES . 'breadcrumb.php'); $breadcrumb = new breadcrumb; $breadcrumb->add(HEADER_TITLE_TOP, HTTP_SERVER); $breadcrumb->add(HEADER_TITLE_CATALOG, tep_href_link(FILENAME_DEFAULT)); What have I overlooked? What should I do to define the function? What’s the next logical step to fix the issue? I have attached the includes/configure.php file below. <?php /* osCommerce, Open Source E-Commerce Solutions [url="http://www.oscommerce.com"]http://www.oscommerce.com[/url] Copyright © 2003 osCommerce Released under the GNU General Public License */ // Define the webserver and path parameters // * DIR_FS_* = Filesystem directories (local/physical) // * DIR_WS_* = Webserver directories (virtual/URL) define('HTTP_SERVER', 'https://stxx.startlogic.com'); define('HTTPS_SERVER', 'https://stxx.startlogic.com'); define('ENABLE_SSL', true); // secure webserver for checkout procedure? define('HTTP_COOKIE_DOMAIN', 'mystore.com'); define('HTTPS_COOKIE_DOMAIN', 'st08.startlogic.com/~mystore'); define('HTTP_COOKIE_PATH', '/~mystore/'); define('HTTPS_COOKIE_PATH', '/~mystore/'); define('DIR_WS_HTTP_CATALOG', '/~mystore/'); define('DIR_WS_HTTPS_CATALOG', '/~mystore/'); define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/'); define('DIR_FS_CATALOG', '/home/mystore/public_html/'); define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/'); // define our database connection define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers define('DB_SERVER_USERNAME', 'mystore_p_os3'); define('DB_SERVER_PASSWORD', 'mypassword'); define('DB_DATABASE', 'mystore_p_os3'); define('USE_PCONNECT', 'false'); // use persistent connections? define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql' ?> Any help would be much appreciated.
  6. Chemo and everyone involved should be applauded for the Ultimate SEO URLs contribution. It’s perfect for my application. Thanks. I just added the contribution and moved my site to the root directory. Unfortunately, I have an issue that I need help with. I used the osCommerce application that my ISP provided and it loaded to the /osCommerce/catalog directory that is generated at install. I moved the store from MyStore/osCommerce/catalog to MyStore/. Then I changed both configure.php files to reflect the move. The vDeck admin console they provide points to MyStore/osCommerce/catalog/admin. So I just typed in MyStore/admin and the new vDeck came up. So I assume that the changes to the admin/includes/configure.php file are good. I had to reset the permissions on several folders and the 2 header_tags.php files, but so far so good. The problem comes in when I go to my site, I get this fatal error message. Fatal error: Call to undefined function: tep_href_link() in /home/MyStore/public_html/includes/application_top.php on line 485 From my application_top.php: (line 485 is last) // include the breadcrumb class and start the breadcrumb trail require(DIR_WS_CLASSES . 'breadcrumb.php'); $breadcrumb = new breadcrumb; $breadcrumb->add(HEADER_TITLE_TOP, HTTP_SERVER); $breadcrumb->add(HEADER_TITLE_CATALOG, tep_href_link(FILENAME_DEFAULT)); What have I overlooked? What should I do to define the function? What’s the next logical step to fix the issue? I have attached the includes/configure.php file below. <?php /* osCommerce, Open Source E-Commerce Solutions [url="http://www.oscommerce.com"]http://www.oscommerce.com[/url] Copyright © 2003 osCommerce Released under the GNU General Public License */ // Define the webserver and path parameters // * DIR_FS_* = Filesystem directories (local/physical) // * DIR_WS_* = Webserver directories (virtual/URL) define('HTTP_SERVER', 'https://stxx.startlogic.com'); define('HTTPS_SERVER', 'https://stxx.startlogic.com'); define('ENABLE_SSL', true); // secure webserver for checkout procedure? define('HTTP_COOKIE_DOMAIN', 'mystore.com'); define('HTTPS_COOKIE_DOMAIN', 'st08.startlogic.com/~mystore'); define('HTTP_COOKIE_PATH', '/~mystore/'); define('HTTPS_COOKIE_PATH', '/~mystore/'); define('DIR_WS_HTTP_CATALOG', '/~mystore/'); define('DIR_WS_HTTPS_CATALOG', '/~mystore/'); define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/'); define('DIR_FS_CATALOG', '/home/mystore/public_html/'); define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/'); // define our database connection define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers define('DB_SERVER_USERNAME', 'mystore_p_os3'); define('DB_SERVER_PASSWORD', 'mypassword'); define('DB_DATABASE', 'mystore_p_os3'); define('USE_PCONNECT', 'false'); // use persistent connections? define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql' ?> Any help would be much appreciated.
  7. I'm using EP 2.78 and MVS 1.1 and it's working great. I want to upload and add to the vendor_product_price that was added by the MVS contribution in addition to the standard fields. How do I customize the code in EP to allow for that. This seems like a typical request and I'm sure others have made this modification, but I can't find the answer through the search function. Can anyone point me in the right direction?
  8. I'm using EP 2.78 and MVS 1.1 and it's working great. I want to upload and add to the vendor_product_price that added by the MVS contribution in addition to the standard fields. How do I customize the code in EP to allow for that. This seems like a typical request and I'm sure others have made this modification, but I can't find the answer through the search function. Can anyone point me in the right direction?
  9. dc2lv2atl

    My Vender Manager page has an error

    Here's where I am now. I understand that a 1054 is a database error. I have found in line 583 of vendors.php file the "where clause" referred to in the error message. The challenge now is to understand way I'm getting the error when everything seems alright. In fact there is a column vendor_id in the vendor file of the database. So why the error?
  10. dc2lv2atl

    My Vender Manager page has an error

    Wants meant by "Search for the 1054 line on google."?
  11. dc2lv2atl

    My Vender Manager page has an error

    I'm using mysql 4.0.16
  12. dc2lv2atl

    My Vender Manager page has an error

    Sorry to reply to my own post but I wanted to add the source code from the page with the error. <!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN"> <html dir="ltr" lang="en"> <head> <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"> <title>osCommerce</title> <link rel="stylesheet" type="text/css" href="includes/stylesheet.css"> <script language="javascript" src="includes/general.js"></script> </head> <body marginwidth="0" marginheight="0" topmargin="0" bottommargin="0" leftmargin="0" rightmargin="0" bgcolor="#FFFFFF" onload="SetFocus();"> <!-- header //--> <table border="0" width="100%" cellspacing="0" cellpadding="0"> <tr> <td><img src="images/oscommerce.gif" border="0" alt="osCommerce" title=" osCommerce " width="204" height="50"></td> <td align="right"><a href="http://www.oscommerce.com" target="_blank"><img src="images/header_support.gif" border="0" alt="Support Site" title=" Support Site " width="50" height="50"></a> <a href="https://st08.startlogic.com/~docandso/osCommerce/catalog/"><img src="images/header_checkout.gif" border="0" alt="Online Catalog" title=" Online Catalog " width="53" height="50"></a> <a href="https://st08.startlogic.com/~docandso/osCommerce/catalog/admin/index.php"><img src="images/header_administration.gif" border="0" alt="Administration" title=" Administration " width="50" height="50"></a> </td> </tr> <tr class="headerBar"> <td class="headerBarContent"> <a href="https://st08.startlogic.com/~docandso/osCommerce/catalog/admin/index.php" class="headerLink">Administration</a></td> <td class="headerBarContent" align="right"><a href="http://www.oscommerce.com" class="headerLink">Support Site</a> | <a href="https://st08.startlogic.com/~docandso/osCommerce/catalog/" class="headerLink">Online Catalog</a> | <a href="https://st08.startlogic.com/~docandso/osCommerce/catalog/admin/index.php" class="headerLink">Administration</a> </td> </tr> </table><!-- header_eof //--> <!-- body //--> <table border="0" width="100%" cellspacing="2" cellpadding="2"> <tr> <td width="125" valign="top"><table border="0" width="125" cellspacing="1" cellpadding="1" class="columnLeft"> <!-- left_navigation //--> <!-- configuration //--> <tr> <td> <table border="0" width="100%" cellspacing="0" cellpadding="2"> <tr> <td class="menuBoxHeading" onmouseover="this.style.cursor='hand'" onclick="document.location.href='https://st08.startlogic.com/~docandso/osCommerce/catalog/admin/configuration.php?gID=1&selected_box=configuration'"> <a href="https://st08.startlogic.com/~docandso/osCommerce/catalog/admin/configuration.php?gID=1&selected_box=configuration" class="menuBoxHeadingLink">Configuration</a> </td> </tr> </table> <table border="0" width="100%" cellspacing="0" cellpadding="2"> </table> </td> </tr> <!-- configuration_eof //--> <!-- catalog //--> <tr> <td> <table border="0" width="100%" cellspacing="0" cellpadding="2"> <tr> <td class="menuBoxHeading" onmouseover="this.style.cursor='hand'" onclick="document.location.href='https://st08.startlogic.com/~docandso/osCommerce/catalog/admin/categories.php?selected_box=catalog'"> <a href="https://st08.startlogic.com/~docandso/osCommerce/catalog/admin/categories.php?selected_box=catalog" class="menuBoxHeadingLink">Catalog</a> </td> </tr> </table> <table border="0" width="100%" cellspacing="0" cellpadding="2"> </table> </td> </tr> <!-- catalog_eof //--> <!-- vendors //--> <tr> <td> <table border="0" width="100%" cellspacing="0" cellpadding="2"> <tr> <td class="menuBoxHeading" onmouseover="this.style.cursor='hand'" onclick="document.location.href='https://st08.startlogic.com/~docandso/osCommerce/catalog/admin/vendors.php?selected_box=vendors'"> <a href="https://st08.startlogic.com/~docandso/osCommerce/catalog/admin/vendors.php?selected_box=vendors" class="menuBoxHeadingLink">Vendors</a> </td> </tr> </table> <table border="0" width="100%" cellspacing="0" cellpadding="2"> <tr> <td class="menuBoxContent"><a href="https://st08.startlogic.com/~docandso/osCommerce/catalog/admin/vendors.php" class="menuBoxContentLink">Vendor Manager</a><br><a href="https://st08.startlogic.com/~docandso/osCommerce/catalog/admin/prods_by_vendor.php" class="menuBoxContentLink">Product Reports</a><br><a href="https://st08.startlogic.com/~docandso/osCommerce/catalog/admin/orders_by_vendor.php" class="menuBoxContentLink">Vendors Orders List</a><br><a href="https://st08.startlogic.com/~docandso/osCommerce/catalog/admin/move_vendor_prods.php" class="menuBoxContentLink">Move Products between Vendors</a></td> </tr> </table> </td> </tr> <!-- catalog_eof //--><!-- modules //--> <tr> <td> <table border="0" width="100%" cellspacing="0" cellpadding="2"> <tr> <td class="menuBoxHeading" onmouseover="this.style.cursor='hand'" onclick="document.location.href='https://st08.startlogic.com/~docandso/osCommerce/catalog/admin/modules.php?set=payment&selected_box=modules'"> <a href="https://st08.startlogic.com/~docandso/osCommerce/catalog/admin/modules.php?set=payment&selected_box=modules" class="menuBoxHeadingLink">Modules</a> </td> </tr> </table> <table border="0" width="100%" cellspacing="0" cellpadding="2"> </table> </td> </tr> <!-- modules_eof //--> <!-- customers //--> <tr> <td> <table border="0" width="100%" cellspacing="0" cellpadding="2"> <tr> <td class="menuBoxHeading" onmouseover="this.style.cursor='hand'" onclick="document.location.href='https://st08.startlogic.com/~docandso/osCommerce/catalog/admin/customers.php?selected_box=customers'"> <a href="https://st08.startlogic.com/~docandso/osCommerce/catalog/admin/customers.php?selected_box=customers" class="menuBoxHeadingLink">Customers</a> </td> </tr> </table> <table border="0" width="100%" cellspacing="0" cellpadding="2"> </table> </td> </tr> <!-- customers_eof //--> <!-- taxes //--> <tr> <td> <table border="0" width="100%" cellspacing="0" cellpadding="2"> <tr> <td class="menuBoxHeading" onmouseover="this.style.cursor='hand'" onclick="document.location.href='https://st08.startlogic.com/~docandso/osCommerce/catalog/admin/countries.php?selected_box=taxes'"> <a href="https://st08.startlogic.com/~docandso/osCommerce/catalog/admin/countries.php?selected_box=taxes" class="menuBoxHeadingLink">Locations / Taxes</a> </td> </tr> </table> <table border="0" width="100%" cellspacing="0" cellpadding="2"> </table> </td> </tr> <!-- taxes_eof //--> <!-- localization //--> <tr> <td> <table border="0" width="100%" cellspacing="0" cellpadding="2"> <tr> <td class="menuBoxHeading" onmouseover="this.style.cursor='hand'" onclick="document.location.href='https://st08.startlogic.com/~docandso/osCommerce/catalog/admin/currencies.php?selected_box=localization'"> <a href="https://st08.startlogic.com/~docandso/osCommerce/catalog/admin/currencies.php?selected_box=localization" class="menuBoxHeadingLink">Localization</a> </td> </tr> </table> <table border="0" width="100%" cellspacing="0" cellpadding="2"> </table> </td> </tr> <!-- localization_eof //--> <!-- reports //--> <tr> <td> <table border="0" width="100%" cellspacing="0" cellpadding="2"> <tr> <td class="menuBoxHeading" onmouseover="this.style.cursor='hand'" onclick="document.location.href='https://st08.startlogic.com/~docandso/osCommerce/catalog/admin/stats_products_viewed.php?selected_box=reports'"> <a href="https://st08.startlogic.com/~docandso/osCommerce/catalog/admin/stats_products_viewed.php?selected_box=reports" class="menuBoxHeadingLink">Reports</a> </td> </tr> </table> <table border="0" width="100%" cellspacing="0" cellpadding="2"> </table> </td> </tr> <!-- reports_eof //--> <!-- tools //--> <tr> <td> <table border="0" width="100%" cellspacing="0" cellpadding="2"> <tr> <td class="menuBoxHeading" onmouseover="this.style.cursor='hand'" onclick="document.location.href='https://st08.startlogic.com/~docandso/osCommerce/catalog/admin/backup.php?selected_box=tools'"> <a href="https://st08.startlogic.com/~docandso/osCommerce/catalog/admin/backup.php?selected_box=tools" class="menuBoxHeadingLink">Tools</a> </td> </tr> </table> <table border="0" width="100%" cellspacing="0" cellpadding="2"> </table> </td> </tr> <!-- tools_eof //--> <!-- header_tags_controller //--> <tr> <td> <table border="0" width="100%" cellspacing="0" cellpadding="2"> <tr> <td class="menuBoxHeading" onmouseover="this.style.cursor='hand'" onclick="document.location.href='https://st08.startlogic.com/~docandso/osCommerce/catalog/admin/header_tags_controller.php?selected_box=header tags'"> <a href="https://st08.startlogic.com/~docandso/osCommerce/catalog/admin/header_tags_controller.php?selected_box=header tags" class="menuBoxHeadingLink">Header Tags</a> </td> </tr> </table> <table border="0" width="100%" cellspacing="0" cellpadding="2"> </table> </td> </tr> <!-- header_tags_controller_eof //--> <!-- left_navigation_eof //--> </table></td> <!-- body_text //--> <td width="100%" valign="top"><table border="0" width="100%" cellspacing="0" cellpadding="2"> <tr> <td><table border="0" width="100%" cellspacing="0" cellpadding="0"> <td class="pageHeading">Vendor Manager</td> <td class="pageHeading" align="right"><img src="images/pixel_trans.gif" border="0" alt="" width="1" height="48"></td> <tr> <td><table border="0" width="100%" cellspacing="0" cellpadding="0"> <tr> <td valign="top"><table border="0" width="100%" cellspacing="0" cellpadding="2"> <tr class="dataTableHeadingRow"> <td class="dataTableHeadingContent">Vendor</td> <td class="dataTableHeadingContent">Contact</td> <td class="dataTableHeadingContent" align="center">Send Emails</td> <td class="dataTableHeadingContent" align="right">Action: </td> </tr> <tr id="defaultSelected" class="dataTableRowSelected" onmouseover="rowOverEffect(this)" onmouseout="rowOutEffect(this)" onclick="document.location.href='https://st08.startlogic.com/~docandso/osCommerce/catalog/admin/vendors.php?selected_box=vendors&page=1&vendors_id=1&action=edit'"> <td class="dataTableContent">My Store</td> <td class="dataTableContent">Store Owner</td> <td class="dataTableContent" align="center"> <img src="images/icon_status_green.gif" border="0" alt="Active" title=" Active " width="10" height="10"> <a href="https://st08.startlogic.com/~docandso/osCommerce/catalog/admin/vendors.php?action=setflag&flag=0&vendors_id=1"><img src="images/icon_status_red_light.gif" border="0" alt="Set Inactive" title=" Set Inactive " width="10" height="10"></a></td> <td class="dataTableContent" align="right"><img src="images/icon_arrow_right.gif" border="0" alt=""> </td> </tr> <tr> <td colspan="4"><table border="0" width="100%" cellspacing="0" cellpadding="2"> <tr> <td class="smallText" valign="top">Displaying <b>1</b> to <b>1</b> (of <b>1</b> vendors)</td> <td class="smallText" align="right">Page 1 of 1</td> </tr> </table></td> </tr> </table></td> <font color="#000000"><b>1054 - Unknown column 'vendors_id' in 'where clause'<br><br>select count(*) as total from products where vendors_id = '1'<br><br><small><font color="#ff0000">[TEP STOP]</font></small><br><br></b></font>
  13. I'm running a shop with OsC 2.2.2, STS 4.5.2 + HTC 2.6.3, and Easy Populate 2.78. I have tried to add MVS 1.1 on 4 different occasions and have not been able to it to work properly. I understand that there is a conflict with the HTC contribution, so I have tried the fixes provided for the admin/categories.php file with no luck. When I go into my Vendor Manager, I get the following error message. 1054 - Unknown column 'vendors_id' in 'where clause' select count(*) as total from products where vendors_id = '1' [TEP STOP] Can anybody tell me which file brings up the Vendor Manager screen and how I can address this error message?
  14. I have added SPPC 4.1.4 to my store and it works fine so far. I have a few other contribs that all work well together. The problem is when I try to go through the admin console to the catalog I get an error message: Parse error: parse error, unexpected $ in /home/docandso/public_html/osCommerce/catalog/admin/categories.php on line 1220. The last line is 1220, the offender. Can someone tell me whats wrong? //MVS start $contents[] = array('text' => '<br>' . TEXT_PRODUCTS_PRICE_INFO . '<b> ' . $currencies->format($pInfo->products_price) . '</b><br>Vendor: <b>' . $current_vendor_name . '</b><br>' . TEXT_VENDORS_PRODUCT_PRICE_INFO . '<b>' . $currencies->format($pInfo->vendors_product_price) . '</b><br>' . TEXT_PRODUCTS_QUANTITY_INFO . ' <b>' . $pInfo->products_quantity . '</b>'); //MVS end $contents[] = array('text' => '<br>' . TEXT_PRODUCTS_PRICE_INFO . ' ' . $currencies->format($pInfo->products_price) . '<br>' . TEXT_PRODUCTS_QUANTITY_INFO . ' ' . $pInfo->products_quantity); $contents[] = array('text' => '<br>' . TEXT_PRODUCTS_AVERAGE_RATING . ' ' . number_format($pInfo->average_rating, 2) . '%'); } } else { // create category/product info $heading[] = array('text' => '<b>' . EMPTY_CATEGORY . '</b>'); $contents[] = array('text' => TEXT_NO_CHILD_CATEGORIES_OR_PRODUCTS); } break; } if ( (tep_not_null($heading)) && (tep_not_null($contents)) ) { echo ' <td width="25%" valign="top">' . "\n"; $box = new box; echo $box->infoBox($heading, $contents); echo ' </td>' . "\n"; } ?> </tr> </table></td> </tr> </table> <?php } ?> </td> <!-- body_text_eof //--> </tr> </table> <!-- body_eof //--> <!-- footer //--> <?php require(DIR_WS_INCLUDES . 'footer.php'); ?> <!-- footer_eof //--> <br> </body> </html> <?php require(DIR_WS_INCLUDES . 'application_bottom.php'); ?>
  15. I am apparently missing some fields in my database. When I click on Easy Populate's "Download Complete tab delimited text file to edit" I get this error: 1146 - Table 'docandso_p_os1.TABLE_PRODUCTS_STOCK' doesn't exist select products_stock_quantity from TABLE_PRODUCTS_STOCK where products_id = '1' and products_stock_attributes = '3-5' I'm thinking that I need to update my database, but I don't know how. When I select the other options in EP I get similar errors. Why would I be missing these fields?
×