Jump to content

sychosyd_28

Members
  • Content count

    38
  • Joined

  • Last visited

  1. sychosyd_28

    Article Manager v1.0

    Is there a way to list all topics and subtopics in the articles infobox by default, without having to click on a topic name to reveal the subtopics there? I'm looking at the code in includes\boxes\articles.php and am having a hard time wrapping my complete-amateur-programmer brain around the finer points. I plan on having only 3 main topics, with maybe 3 or 4 subtopics each, and I would like to have every one of them displayed in the infobox at once. The infobox would become essentially a static table of contents (or tree, or whatever you'd like to call it). Can it be done?
  2. sychosyd_28

    Article Manager v1.0

    Can someone point out a good way to exclude one particular topic from showing up in the list in the Articles box? I want to use the Article Manager contrib to ... well... to manage articles in the "Information" section of my site, but I'd also like to use it as an easy way to post a message to a separate "Events" section. I don't want the "Events" topic to show up in the articles box because it's completely unrelated to any of the other articles. (I'm planning to hard-code a link to the events category elsewhere on the site so that it's accessible to readers.) I'm sure there's a way to do it, somewhere in includes\boxes\articles.php , but how?
  3. sychosyd_28

    Mail_Validation

    Does anybody know why any items inside the visitor cart disappear after following the account validation link in the email and successfully activating the account?
  4. Actually, what I was hoping to do was have these new products show up in the default view for admin/categories.php beneath the listing of the categories in my store so that they'd be easy to spot. So it seems like the way to go for that would be to not include the category field in the EP upload, and have that field set to NOT NULL and defaulted to 0 in my database. I'll get that part figured out eventually. At the moment I'm having a new, more important problem. When I upload the previously mentioned EP file (with v_manufacturers_name, v_products_name_1, v_products_model, v_products_quantity, and v_products_price fields, plus the EOR), all of my product descriptions and URLs are being erased. My question is, am I *supposed* to be uploading those two fields every time, or am I doing something wrong? Also, are other fields potentially being overwritten that I might not know about? Just so you know, my EP file doesn't have any fields with blank information in it -- the file only has those five fields mentioned above, with no gaps at all.
  5. I'm just starting to get the hang of EP on my testing site but am running into a strange issue that I'm sure someone has experienced before (I just can't find the answer in the archives). If I prepare a file that contains the v_manufacturers_name, v_products_name_1, v_products_model, v_products_quantity, and v_products_price fields (plus the EOR) and upload it through EP, all of the appropriate fields are updated like they should... unless they belong to new products that don't already exist in my catalog. In that case, I get the "NEW PRODUCT" message for that data, but I am then unable to find that product in my catalog. I can see the information in my database with phpMyAdmin, but can't get it to appear in my catalog. What fields or values am I missing that would allow me to see these new products in my admin/catalog?
  6. sychosyd_28

    NEW! Complete Order Editing Tool!

    I modded the code according to your post and got halfway there. :) The manufacturer's name shows up on the edit_orders.php page just like it should. I'd wanted it to show up on the orders.php page as well. But it looks like the SQL query for that comes from outside of your contrib, in admin\includes\classes\order.php Somewhere on this forum I once found a function to put in catalog\includes\functions\general.php that returns a manufacturer's name. Between realizing that I could put that same function in admin\includes\functions\general.php and then modify the query in admin\includes\classes\order.php to return the manufacturer's name, I'm all set now. Thanks!
  7. sychosyd_28

    NEW! Complete Order Editing Tool!

    I've posted screenshots at http://www.herbdavidguitarstudio.com/image/orders.png and http://www.herbdavidguitarstudio.com/image/edit_orders.png to illustrate. I would ideally like the manufacturer's name to appear in the place where "-All Manufacturers-" appears next to the product name in the orders.png graphic, and I can't say it really matters to me where it shows up in edit_orders.
  8. sychosyd_28

    NEW! Complete Order Editing Tool!

    This contrib is amazingly helpful and easy to use. Love it. Does anybody know how to modify the orders.php or edit_orders.php pages so that the manufacturer's name is displayed as well as the product's name?
  9. sychosyd_28

    Sort Products By Dropdown

    Awesome contrib. Can this be integrated into the advanced_search_result.php page ? I saw in the installation instructions for this contrib that you can tweak that page to always sort by Best Sellers, but I'd like to have the full-blown dropdown menu above the table. I tried making the same mods from catalog/index.php in the advanced_search_result.php file, as they were essentially the same. I did end up with a dropdown on the page, but when I tried changing the sort order through the dropdown, I ended up either: 1) at a product_listing page containing all the products for the manufacturer I had searched for 2) being redirected to index.php if I hadn't specified a manufacturer It seems to have something to do with this code: if (isset($HTTP_GET_VARS['manufacturers_id'])) { echo tep_draw_hidden_field('manufacturers_id', $HTTP_GET_VARS['manufacturers_id']); } else { echo tep_draw_hidden_field('cPath', $cPath); } ...but I'm not sure because I sort of suck at PHP and could be totally mistaken. :rolleyes: Any thoughts?
  10. sychosyd_28

    [Contribution] Additional Images Module

    I've just installed Additional Images and have been playing around with it for a few days. It's working well, except that I can't delete extra images through admin. If I pull up a product in the admin catalog and want to delete one of the additional images, clicking on the "Delete Image" button will send me back to the catalog page with all of the products in the current category -- and it doesn't delete the image, or any reference to the image in my product pages/listings/etc. Any ideas about what might be wrong?
  11. sychosyd_28

    Featured Product Support v1.5.4

    In the admin dropdown list, is it possible to either: 1) add a second dropdown to filter products by manufacturer; or 2) cause the manufacturer name to appear in front of the product name, and sort the whole dropdown by manufacturer name? My store has over 3,000 products, and one of those two solutions would make it a LOT easier to select the products I want to feature.
  12. This is a beautiful thing you've done here, friend. Installed, working great.
  13. After having a late-night moment of inspiration, I wondered if the problem from my last post might have something to do with the browser. I normally use Opera 9.21, which I was using when I had the problem. I fired up Internet Explorer 7 and the admin interface worked perfectly -- I could add new keywords and everything. So apparently this contrib is buggy in Opera, at least on the admin side. As far as I can tell, the only thing that didn't work properly was the functionality to add alternate keywords -- everything else was fine.
  14. Anybody have a problem with not being able to add or view replacement keywords in Admin? I just installed this and like the way it works, but I can't add any alternate keywords. In Admin when I click "View Word/Phrase List" I get an empty list with a "New Entry" button underneath. Clicking "New Entry" just brings me back to the list of previously searched terms. I've doublechecked the install instructions and can't find anything out of the ordinary that I might have missed. Am I not using this feature correctly?
×