Jump to content

acideddy

Members
  • Content count

    11
  • Joined

  • Last visited

Everything posted by acideddy

  1. acideddy

    Fancier Invoice & Packingslip v1.0

    I have installed this mod and on the whole it works well and the invoices look loads better. The only problem is that I dont get any order confirmations through now. I have STS and HSBC payment modules installed. The customer gets an order confirmation no prob. If I turn the HTML eMails off then I get one and the customer doesnt!! Any one any ideas? Eddy
  2. acideddy

    [Contribution] STS v4

    Does anyone know if there is a search engine friendly URL package that works with STS? I have one installed but it makes the images function incorrectly for some reason. Looks like I may have to uninstall it to get things working Eddy
  3. acideddy

    Seach Engine Friendly URL Support

    I had this mod up and running perfectly apart from the popups. Managed to fix it by adding the javascript to index.php and turning off my STS templates. Then they worked! At least I know now that there is a confict with STS templates and this mod. Can anyone tell me what I need to do to get my popups still to work when I turn STS on? Other than that it works perfectly. Something to do with STS looking at its version of product_info.php still instead of index? Thanks Eddy
  4. acideddy

    [Contribution] STS v4

    Thanks for your reply. I have the javascript bit in there as I have some javascript rollovers on my design. The pop ups dont seem to load either when STS is turned off. Also, when I upload a product, should I have a box to choose to upload a popup image along with the main image? I dont seem to have that option. If it helps, the site can be found at www.coffeebeanstealeaves.co.uk/catalog so you can see what error I get. Please note that the site isnt finished but I want to go live asap. thanks Eddy
  5. acideddy

    [Contribution] STS v4

    I cannot get my popups to work despite many frustrating hours looking at all of the forums! I am using STS and it looks great but I get an error when I click to enlarge the image. My Template page has the correct head section I think <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"> <html $htmlparams> <head> <meta http-equiv="Content-Language" content="en-us"> <!--$headcontent--> <link rel="stylesheet" type="text/css" href="stylesheet.css"> <script language="JavaScript" type="text/JavaScript"> And the code when displayed when I view online is <!-- start get_javascript(applicationtop2header) //--> <!-- end get_javascript(applicationtop2header) //--> <link rel="stylesheet" type="text/css" href="stylesheet.css"> <script language="JavaScript" type="text/JavaScript"> <!-- My header file in catalog/includes/header.php includes.... // START STS 4.1 $sts->restart_capture ('applicationtop2header'); // END STS 4.1 // check if the 'install' directory exists, and warn of its existence if (WARN_INSTALL_EXISTENCE == 'true') { if (file_exists(dirname($HTTP_SERVER_VARS['SCRIPT_FILENAME']) . '/install')) { $messageStack->add('header', WARNING_INSTALL_DIRECTORY_EXISTS, 'warning'); } } Can anyone shed any light on this please? Many thanks Eddy
  6. acideddy

    HSBC secure-epayment module

    After much sweat and blood, I have managed to get a lot further with this. I sorted the .so file (it suddenly started working after a few weeks!). Then I sorted the time stamp and order number. My last remaining problem was that customers were being returned to the site with an empty shopping cart. I tried all the mods suggested above with varying effects but none of them worked. Then, after messing around with the code again, I get the dreaded Hacking Attempt! The only two files I have been messing with to resolve this final issue are hsbc_return.php and checkout_process.php. Is there anyone who could have a quick look at my code for these files please and see what I have done wrong? I am sure it is something simple but with all the changes, I have lost where I am! Hope someone can help please :thumbsup: Thanks Eddy
  7. acideddy

    HSBC secure-epayment module

    I am still totally stuck and cant get past hacking attempt error while loading shared libraries. I have my testhash.e file in a writable folder on my Web site and my path to testhash is fine. My .so file has been uploaded by my host to /usr/lib and they tell me it is loading into ram. Could anyone tell me whether I still need to have the putenv line in of do I change it to point to /usr/lib? How does the teshhash.e file access the library? I am going out my mind here! Eddy
  8. acideddy

    HSBC secure-epayment module

    I am wondering if nobody understands what the issue here is with my HSBC installation. I have spend many weeks developing the site and paid my money to HSBC and it is extremely frustrating that I cant sell anything! I wish I had known that this was so problematic. Did I make a mistake using HSBC or OsCommerce? To cut a long story short....I am willing to pay someone to sort this issue out. Can someone please help me :rolleyes: Thanks, PM me if you can help. Fingers crossed there is someone out there who understands what to do
  9. acideddy

    HSBC secure-epayment module

    Many thanks for this I have passed this on to my host and got the following reply "The library is loading into ram: root@ns9 [/usr/lib]# ldconfig --verbose|grep libCcCpiTools.so libCcCpiTools.so -> libCcCpiTools.so Also, we presently support the other lib, version 6.0.3: root@ns9 [/usr/lib]# ldconfig --verbose|grep stdc ldconfig: Cannot stat /usr/lib/libGLU.so: No such file or directory libstdc++.so.6 -> libstdc++.so.6.0.3" I asked them to put the .so file in /usr/lib and yet the also seemed to refer to it being in /usr/bin What would the path to this file be? Below is an extract of the relevant section of hsbc.php //Path where the TestHash.e executable is located $path='/home/edwa7063/public_html/cgi-bin/hsbc'; putenv("LD_LIBRARY_PATH='/usr/lib'"); I am still getting error while loading library every time. Hope someone can help me. This is ridiculously difficult! Thanks in anticipation
  10. acideddy

    HSBC secure-epayment module

    Please help? I have not got very far and cant seem to even get past the hacking attempt and am now getting this message: Hacking atempt! - orderHash=Kz6nZow0yWO3J3+GQHZV9aAhDog= hash=error while loading shared libraries I have uploaded TestHash.e and the .so files to the cgi-bin, set the path correctly and set permissions on both files to 755. The server is not running in safe mode. I have even tried placing the files in the payment folder with the same results. Can anyone suggest how I can get over this hurdle? If anyone needs to know, the site is at www.coffeebeanstealeaves.co.uk/catalog Thanks
  11. acideddy

    HSBC secure-epayment module

    Please help? I have not got very far and cant seem to even get past the hacking attempt and am now getting this message: Hacking atempt! - orderHash=Kz6nZow0yWO3J3+GQHZV9aAhDog= hash=error while loading shared libraries I have uploaded TestHash.e and the .so files to the cgi-bin, set the path correctly and set permissions on both files to 755. The server is not running in safe mode. I have even tried placing the files in the payment folder with the same results. Can anyone suggest how I can get over this hurdle? If anyone needs to know, the site is at www.coffeebeanstealeaves.co.uk/catalog Thanks
×