Jump to content

RBA

Members
  • Content count

    11
  • Joined

  • Last visited

About RBA

  • Birthday 05/14/1954

Profile Information

  1. RBA

    Official PayPal IPN Support Thread

    Hi Mark Here is the post for the Debug Script from Terra: http://forums.oscommerce.com/index.php?sho...t&p=1052191 Our configure.php pages are not the problem. That is just where we changed settings for http and https to try both Shared SSL and Full SSL to see if it made a difference. It looks like our ipn.php is found and verified from Paypal, but orders_id errors and never changes from 0. We need some more help from Terra to go from here. Russ
  2. RBA

    Official PayPal IPN Support Thread

    We have searched this forum relentlesly and have tried all the fixes that we found but with no avail. We have tried configure.php both ways with Shared SSL or Full SSL with our own signed certificate. Shared SSL returns to the login page after clicking on PayPals order confirmation. Full SSL returns to the success page but does not list the items for you to be notified about for updates ( $products_displayed = array() We found your Debuging script and replaced the ipn.php in the ext folder. Here are the results that we get for both Shared and Full SSL Shared SSL .36.161.21] PP TEST start [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST PayPal is accessing the ipn file [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST we have successfuly loaded application top and language file [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST we are assembling the reply: cmd=_notify-validate&mc_gross=37.43&invoice=0&address_status=confirmed&payer_id=US47LYCGZ6BCA&tax=0.00&address_street=1+Test+Drive&payment_date=21%3A38%3A50+Aug+08%2C+2007+PDT&payment_status=Completed&charset=windows-1252&address_zip=77777&first_name=Joe&mc_fee=1.39&address_country_code=US&address_name=Joe+Doe&notify_version=2.4&custom=8&payer_status=verified&business=tp%40testproducts.com&address_country=United+States&address_city=Test&quantity=1&verify_sign=Am.FyT.qDvCioumFuC8z...i-xucA1JiU6WZxzZYAbHYxoXSAoX3bEPw&payer_email=joet%40test.com&contact_phone=&txn_id=62T998558G0587400&payment_type=instant&last_name=Doe&address_state=AK&receiver_email=tp%40testproducts.com&payment_fee=1.39&receiver_id=JTBF38NK28FP4&txn_type=web_accept&item_name=VisionServer&mc_currency=USD&item_number=&residence_country=US&test_ipn=1&payment_gross=37.43&shipping=0.00 [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST PayPal server is www.sandbox.paypal.com [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST option1 - fsocket is true, port 443 [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST fp is okay [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST option1+3 we start to send string [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST option1+3 we receive PayPal reply [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST option1+3 we receive PayPal reply [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST option1+3 we receive PayPal reply [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST option1+3 we receive PayPal reply [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST option1+3 we receive PayPal reply [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST option1+3 we receive PayPal reply [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST option1+3 we receive PayPal reply [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST option1+3 we receive PayPal reply [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST option1+3 we receive PayPal reply [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST option1+3 REPLY: VERIFIED [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST result is VERIFIED [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST order id is :0 [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST order id problem - cannot verify order id [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST end SSL t 69.36.161.21] PP TEST start [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST PayPal is accessing the ipn file [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST we have successfuly loaded application top and language file [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST we are assembling the reply: cmd=_notify-validate&mc_gross=37.43&invoice=0&address_status=confirmed&payer_id=US47LYCGZ6BCA&tax=0.00&address_street=1+Test+Drive&payment_date=21%3A38%3A50+Aug+08%2C+2007+PDT&payment_status=Completed&charset=windows-1252&address_zip=77777&first_name=Joe&mc_fee=1.39&address_country_code=US&address_name=Joe+Doe&notify_version=2.4&custom=8&payer_status=verified&business=tp%40testproducts.com&address_country=United+States&address_city=Test&quantity=1&verify_sign=Am.FyT.qDvCioumFuC8z...i-xucA1JiU6WZxzZYAbHYxoXSAoX3bEPw&payer_email=joet%40test.com&contact_phone=&txn_id=62T998558G0587400&payment_type=instant&last_name=Doe&address_state=AK&receiver_email=tp%40testproducts.com&payment_fee=1.39&receiver_id=JTBF38NK28FP4&txn_type=web_accept&item_name=VisionServer&mc_currency=USD&item_number=&residence_country=US&test_ipn=1&payment_gross=37.43&shipping=0.00 [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST PayPal server is www.sandbox.paypal.com [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST option1 - fsocket is true, port 443 [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST fp is okay [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST option1+3 we start to send string [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST option1+3 we receive PayPal reply [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST option1+3 we receive PayPal reply [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST option1+3 we receive PayPal reply [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST option1+3 we receive PayPal reply [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST option1+3 we receive PayPal reply [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST option1+3 we receive PayPal reply [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST option1+3 we receive PayPal reply [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST option1+3 we receive PayPal reply [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST option1+3 we receive PayPal reply [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST option1+3 REPLY: VERIFIED [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST result is VERIFIED [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST order id is :0 [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST order id problem - cannot verify order id [Wed Aug 08 22:38:58 2007] [error] [client 69.36.161.21] PP TEST end Please Help we are so close. Thank You
  3. RBA

    Official PayPal IPN Support Thread

    I have installed the PayPal_IPN_v2.2 Directories are: /var/www/html/plugins/vsc/catalog/ IPN directories are installed: catalog/ext/ catalog/includes/ The ipn seems to post to paypal with no problem and paypal makes the transaction correctly and returns to the checkout_success.php page and tells you that your order is processing and thanks you, but does not list the items for you to be notified about for updates ( $products_displayed = array() Also the IPN does not post back from PayPal to update oscommerce. It shows that no orders were made. Although it does store them when you look through phpMyAdmin. We have searched the ssl error logs and it seems that the ext directory cannot be found. Here is the message that PayPal cannot find the directory: [Tue Aug 07 08:31:43 2007] [error] [client 66.211.170.66] File does not exist: /var/www/html/plugins/vsc/ext Our ext directory is inside catalog (see above) but is not included in the error message. Where can we adjust the path to include catalog/ext? Or is there some other problem we are missing? Thanks in advance
  4. RBA

    PayPal_IPN_v2.2

    I have installed the PayPal_IPN_v2.2 Directories are: /var/www/html/plugins/vsc/catalog/ IPN directories are installed: catalog/ext/ catalog/includes/ The ipn seems to post to paypal with no problem and paypal makes the transaction correctly and returns to the checkout_success.php page and tells you that your order is processing and thanks you, but does not list the items for you to be notified about for updates ( $products_displayed = array();). Also the IPN does not post back from PayPal to update oscommerce. It shows that no orders were made. Although it does store them when you look through phpMyAdmin. We have searched the ssl error logs and it seems that the ext directory cannot be found. Here is the message that PayPal cannot find the directory: [Tue Aug 07 08:31:43 2007] [error] [client 66.211.170.66] File does not exist: /var/www/html/plugins/vsc/ext Our ext directory is inside catalog (see above) but is not included in the error message. Where can we adjust the path to include catalog/ext? Or is there some other problem we are missing? Thanks in advance
  5. RBA

    Supplier Admin Area Contribution

    I removed the idadmin direcory from: suppler/includes/configure.php define('DIR_WS_INCLUDES', '../idadmin/includes/'); Changed to: define('DIR_WS_INCLUDES', '../includes/'); Now I get error: Warning: main(../includes/classes/logger.php) [function.main]: failed to open stream: No such file or directory in /var/www/html/catalog/supplier/includes/application_top.php on line 74 Warning: main(../includes/classes/logger.php) [function.main]: failed to open stream: No such file or directory in /var/www/html/catalog/supplier/includes/application_top.php on line 74 Fatal error: main() [function.require]: Failed opening required '../includes/classes/logger.php' (include_path='.:/php/includes:/usr/local/lib/php:/usr/local/php/lib/php') in /var/www/html/catalog/supplier/includes/application_top.php on line 74 I found in the file: suppler/includes/application_top.php // initialize the logger class require(DIR_WS_CLASSES . 'logger.php'); I cannot find any other reference to logger.php? Can you please help. This sounds like a great contribution
  6. Below is my code from 315 to 341. From the cap mod there are some alterations from the clean OSC around 820 along with the stripslashes taken out at line 550 and 585. // copy image only if modified $cid = explode('_', $cPath); foreach($cid as $key => $value){ $cdat = tep_db_query("SELECT categories_name FROM categories_description WHERE categories_id = '" . $value . "' && language_id = '1'"); $cat = tep_db_fetch_array($cdat); $categoryfile .= $cat[categories_name] . "/"; $_SESSION['categoryfile'] = $categoryfile; } $products_image = new upload('products_image'); $products_image->set_destination(DIR_FS_CATALOG_IMAGES . DIR_FS_PRODUCTS_IMAGES . $categoryfile); if ($products_image->parse() && $products_image->save()) { $products_image_name = DIR_FS_PRODUCTS_IMAGES . $categoryfile . $products_image->filename; } else { $products_image_name = (isset($HTTP_POST_VARS['products_previous_image']) ? $HTTP_POST_VARS['products_previous_image'] : ''); } break; } } // check if the catalog image directory exists if (is_dir(DIR_FS_CATALOG_IMAGES . DIR_FS_PRODUCTS_IMAGES . $categoryfile . $subcfile)) { if (!is_writeable(DIR_FS_CATALOG_IMAGES . DIR_FS_PRODUCTS_IMAGES . $categoryfile . $subcfile)) $messageStack->add(ERROR_CATALOG_IMAGE_DIRECTORY_NOT_WRITEABLE, 'error'); } else { $messageStack->add(ERROR_CATALOG_PRODUCT_IMAGE_DIRECTORY_DOES_NOT_EXIST, 'error'); unset($_SESSION['categoryfile']); }
  7. As a test I changed the name of my folder from products to artists, also changed the config file to artist and the error message can't find artists so I know it's getting that far. Also tried changing the images folder name it is getting past images just cant seem to find the next folder?? Also tried a fix mentioned earlier OPEN: catalog/admin/categories.php find (about line 115): Did not help.
  8. Yes I'm sure the directory is correct. The other mod did not change anything around your mod. This is the only difference in or around your instructions that I found. Open: catalog/admin/categories.php find (about line 80): //your instructions find this code code to replace if ($categories_image->parse() && $categories_image->save()) { tep_db_query("update " . TABLE_CATEGORIES . " set categories_image = '" . tep_db_input($categories_image->filename) . "' where categories_id = '" . (int)$categories_id . "'"); } // this is the code in my page that I replaced (os commerce version 2.2) if ($categories_image = new upload('categories_image', DIR_FS_CATALOG_IMAGES)) { tep_db_query("update " . TABLE_CATEGORIES . " set categories_image = '" . tep_db_input($categories_image->filename) . "' where categories_id = '" . (int)$categories_id . "'"); } :'(
  9. Thanks, I have that code in the catalog/admin/includes/languages/english/categories.php still get the same error. One other thing that might be interfering is I had previously added the "Customer Add Products" contribution which made changes to the admin/categories.php file??
  10. Great contribution! Looks like just what we are looking for. I'm getting the same error that is in your screen shot. My error message: Error: Destination does not exist. Error Error: Catalog products images directory does not exist: /var/www/html/plugins/vsc/catalog/images/products/ the above is from our root directory Checked spelling numerous times, everything is identical. Categories structure set up from my admin reads in the top pulldown Go to: Top painting acrylic Folder structure is: catalog/images/products/painting/acrylic admin/includes/config.php is: define('DIR_FS_MANUFACTURERS_IMAGES', 'manufacturers/'); define('DIR_FS_CATEGORIES_IMAGES', 'categories/'); define('DIR_FS_PRODUCTS_IMAGES', 'products/'); What am I missing??? Please help.
  11. RBA

    Add image subdirectories

    Great Contribution :thumbsup: When I upload images into the sub directories they are put in the correct folder but the product info and image do not appear in admin in any categories. Before I installed subdirectories I had also installed Featured_Products_v4.3.4 which worked with categories until I installed the subdirectories. Now the products and images in subcatagories only show in the featured products admin section. Any help or ideas where I can look? RBA
×