Latest News: (loading..)

TommyBerlin

Members
  • Content count

    58
  • Joined

  • Last visited

  • Days Won

    1

TommyBerlin last won the day on September 30 2011

TommyBerlin had the most liked content!

1 Follower

About TommyBerlin

Profile Information

  • Real Name
    Thomas Pohle
  • Website
  1. You have it already in includes/languages Just click on Import, there you can choose the german language (or others the system can find in the folder "languages" First, the definitions have to be stored in the database (osc_languages and osc_laguages_definitions) Regards Tommy
  2. I also hope, something like sppc will come up for osC 3. But I think, first it is necessary to pass the Alpha... In the current version you can handle the stock of product variants very well - a good job was made there. Regards Tommy
  3. That it is easy. Someone removed my lik or I forgot to put it in the answer. But you will find it following the install-instruction... Regards Tommy
  4. That Templates are running well and to install one of them it just takes a few minutes. Regards Tommy
  5. Thats true! I also wanted to make the admin all in german for the german, austrian and swiss-guys, but coudn't solve that problem until now. But I work on it and let you know... Regards Tommy
  6. In this file and also in \templates\default\content\products\info.php - there are hard-coded english words. To make your shop multilingual, you should change this (also in the english language files). Regards Tommy
  7. Just go to the admin-area and edit the german language. There you can set local and character_set to utf-8... Regards Tommy
  8. Then move it there :lol: :lol: Or what you think language files are? Regards Tommy
  9. Translate it! And because of missing a contrib-page for this version here you get the example for the german translation (@Harald: which can be put into the download-version of cource). For Spain you need to change de_DE to es_ES. Then import via admin ->configuration ->languages Regards Tommy
  10. Hi Harald, Thanks for that link! How can I publish my file de_DE.xml on that site? It's not there. Or will there be soon an extra site for the osCommerce 3 contribs? Regards Tommy
  11. Great contribution, thank you a lot! the only problem I have is the entry of Header Tags Categories Description. I use the Spaw-editor in the textarea and it doesn't write into the database. An existing entra in the database (made with mysqldumper) is read out, but with the update it will be deleted. When I change the textarea field into an input field, everything works fine! I hope, somebody knowns that problem and fixed it already... Thanks Tommy
  12. I had the same problem today with Online Merchant v2.2 RC1. Fixed it in that way (application_top.php): //-MS- SEO-G Added if( !isset($g_seo_flag) || $g_seo_flag !== true) { // start the timer for the page parse time log define('PAGE_PARSE_START_TIME', microtime()); $debug = array(); // set the level of error reporting error_reporting(E_ALL & ~E_NOTICE); // Set the local configuration parameters - mainly for developers if (file_exists('includes/local/configure.php')) include('includes/local/configure.php'); // include server parameters require('includes/configure.php'); if (strlen(DB_SERVER) < 1) { if (is_dir('install')) { header('Location: install/index.php'); } } // define the project version define('PROJECT_VERSION', 'osCommerce Online Merchant v2.2 RC1'); // set the type of request (secure or not) $request_type = (getenv('HTTPS') == 'on') ? 'SSL' : 'NONSSL'; // set php_self in the local scope if (!isset($PHP_SELF)) $PHP_SELF = $HTTP_SERVER_VARS['PHP_SELF']; if ($request_type == 'NONSSL') { define('DIR_WS_CATALOG', DIR_WS_HTTP_CATALOG); } else { define('DIR_WS_CATALOG', DIR_WS_HTTPS_CATALOG); } // include the list of project filenames require(DIR_WS_INCLUDES . 'filenames.php'); // include the list of project database tables require(DIR_WS_INCLUDES . 'database_tables.php'); // customization for the design layout define('BOX_WIDTH', 200); // how wide the boxes should be in pixels (default: 125) // include the database functions require(DIR_WS_FUNCTIONS . 'database.php'); // make a connection to the database... now tep_db_connect() or die('Unable to connect to database server!'); // set the application parameters $configuration_query = tep_db_query('select configuration_key as cfgKey, configuration_value as cfgValue from ' . TABLE_CONFIGURATION); while ($configuration = tep_db_fetch_array($configuration_query)) { define($configuration['cfgKey'], $configuration['cfgValue']); } //-MS- SEO URLs Support Added require(DIR_WS_CLASSES . 'seo_url.php'); $g_seo_url = new seoURL; //-MS- SEO URLs Support Added EOM } //-MS- SEO-G Added EOM // some code to solve compatibility issues require(DIR_WS_FUNCTIONS . 'compatibility.php'); Whats the difference? I moved that "compatibility issues..." outside (under) the seo-g and deleted the "check support for register_globals...", because I don't need it. Then I was running into the next error: unable to determine the page link - but until that break the page was "running" Fine world! I hope it is, because some configuration-tables in the mySQL are missing (the fields witch have a 'true/false'-switch). I'll find out tomorrow. And I also hope, it will help you a bit... Regards Tommy
  13. upps, I found the solution for my problem in this forum: $dltype=$_REQUEST['dltype']; I don't see a mismatch in your columns. They are like they are. SPPC start counting from 0, EP starts from one. Maybe you can change if (EP_SPPC_SUPPORT == true) { $ep_additional_layout_pricing .= '$filelayout[\'v_customer_price_1\'] = $iii++; $filelayout[\'v_customer_group_id_1\'] = $iii++; $filelayout[\'v_customer_price_2\'] = $iii++; $filelayout[\'v_customer_group_id_2\'] = $iii++; $filelayout[\'v_customer_price_3\'] = $iii++; $filelayout[\'v_customer_group_id_3\'] = $iii++; $filelayout[\'v_customer_price_4\'] = $iii++; $filelayout[\'v_customer_group_id_4\'] = $iii++; '; } to if (EP_SPPC_SUPPORT == true) { $ep_additional_layout_pricing .= '$filelayout[\'v_customer_price_0\'] = $iii++; $filelayout[\'v_customer_group_id_0\'] = $iii++; $filelayout[\'v_customer_price_1\'] = $iii++; $filelayout[\'v_customer_group_id_1\'] = $iii++; $filelayout[\'v_customer_price_2\'] = $iii++; $filelayout[\'v_customer_group_id_2\'] = $iii++; $filelayout[\'v_customer_price_3\'] = $iii++; $filelayout[\'v_customer_group_id_3\'] = $iii++; $filelayout[\'v_customer_price_4\'] = $iii++; $filelayout[\'v_customer_group_id_4\'] = $iii++; '; } Tommy
  14. Hey everybody, i also have a problem with this great contribution. But first lets help lao: You should install this also very great contrib called "header Tags Controller". If you don't want to do this, just look in your easypopulate.php vor define ('EP_HTC_SUPPORT', true); and set it to false.... My Problem with the version 2.76f-MS2 r1 is this part of code: // $EXPORT_TIME=time(); // start export time when export is started. $EXPORT_TIME = strftime('%Y%b%d-%H%I'); if ($dltype == 'froogle'){ $EXPORT_TIME = "FroogleEP" . $EXPORT_TIME; } else { $EXPORT_TIME = "EP" . $EXPORT_TIME; ... // set the type if ( $dltype == 'froogle' ){ $endofrow = "\n"; } else { // default to normal end of row $endofrow = $ep_separator . 'EOREOR' . "\n"; } $filestring .= $endofrow; It just doesn't work on my website, instead of getting a froogle file, I always get a normal file called EP...txt and with the ending EOREOR... I'm running php version 5.1.2 with MySQL 5.0.18 and the osCommerce Online Merchant v2.2 RC1. I hope, somebody can help me with this... Tommy
  15. Hello, its a great contribution! But one thing I'm missing: I want to see the extra images in the categorie-tree, but I don't get them into an array. I tried like that (categories.php -round line 1044): But all I see is the first picture, not any extra picture... Maybe someone out there has any idea, what I did make wrong. Regards Tommy