Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

mattski

Members
  • Content count

    7
  • Joined

  • Last visited

Profile Information

  • Real Name
    MattSmith
  • Location
    Australia
  1. mattski

    [Contribution] STS v4

    I wish it was. But I tried this with a completely fresh installation. Matt.
  2. mattski

    [Contribution] STS v4

    I've found another solution to our  problem... Open (/includes/sts_templates/test/)sts_template.html with a text editor, select all of the text and copy it to the clipboard (<ctrl>c). (now either delete the original file or move to another directory) Create a new (empty) file and (re)name it 'sts_template.html'. Open the new file with a text editor and paste in the content from the clipboard (<Ctrl>v). Save it and upload it.... Annoying characters gone!! Matt.
  3. I had exactly the same problem... I'm guessing that you're looking at it using Firefox. Have a look using Internet Explorer - I think you'll find that they don't appear. Have a read from this post onwards. Matt.
  4. mattski

    [Contribution] STS v4

    Yes, you have. :) Thanks very much Bill. What I have now done is this: I've edited includes/languages/english.php ... changing this: // charset for web pages and emails define('CHARSET', 'iso-8859-1'); to this: // charset for web pages and emails define('CHARSET', 'utf-8'); which now makes Firefox use UTF-8 encoding, whilst I assume IE continues doing its own thing and uses UTF-8 anyway. This is now working for me :D ... But can you foresee this causing me any problems later, when I add other contributions, for instance? (I can see that iso-8859-1 appears in the code elsewhere) ... and I'm still unsure why it was happening anyway... Thanks again. Matt.
  5. mattski

    [Contribution] STS v4

    (for some reason I was unable to edit my last post..?) I meant to mention that I'm currently using the unedited /includes/sts_templates/test/sts_template. ... and that for FTP, I'm using FileZilla on WinXP and have been using it for a while with no problems. Matt.
  6. mattski

    [Contribution] STS v4

    Thanks Bill, I didn't think think to try looking at it through another browser, as I assumed they would all get the same source code (which shows my lack of understanding of character encoding, I guess...) I can now tell you that there is no problem when the page is displayed in IE6 or IE7. In IE, if I go to: View -> Encoding ->, it shows it is using UTF-8. The characters show in Firefox (on 3 different PCs). If I go to (in Firefox): View -> Character Encoding -> I see that it is using ISO-8859-1. If I change this to UTF-8, the characters disappear... then refreshing the page switches back to ISO-8859-1 and the characters reappear. I don't understand what's happening there: In all cases the "charset", in the source <head> is being set: <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"> but IE is selecting UTF-8 instead (and has no problem), but Firefox is using the correct encoding, but displaying those  characters! Temporarily commenting out the content-type line from includes/classes/sts.php (effectively removing the meta-tag line above from the doc head) does fix it for firefox. It shows the page using UTF-8. (I can bring the characters back if I specifically tell Firefox to use ISO-8859-1) So. I guess this means that it is an "encoding issue". But where do I go from here? Cheers, Matt.
  7. mattski

    [Contribution] STS v4

    Hi all, These forums have been an invaluable mine of information for me in setting up osC and STS, but I can't find the answer to this one... I'm having a problem in that STS is putting this:  at the top of all catalog pages. When I view the html source of the page, these characters appear at the top before the document type declaration like this: <!DOCTYPE HTML blah... It is not there if I change "Use Templates?" to "false" in Admin->modules->STS->Default. I've checked sts_template.html in /test/ (the one I'm using): there are no characters before the doctype there. I've also checked the files that I've most recently edited - replacing them with their original versions. No difference. I'm guessing that some so-called non-printable-characters have found there way into a php file somewhere, but I have no idea which files I should be checking... (I'm using the new osC v2.2 RC1 with the updated STS 4.5.3, and I've imported the database from my previous installation, adding the additional administrators table) Any ideas? Cheers, Matt.
×