Jump to content

scartier

Members
  • Content count

    31
  • Joined

  • Last visited

Everything posted by scartier

  1. scartier

    Contribution Tracker

    I solved it modifying admin/contrib_tracker.php from: case 'quick_insert': if (is_numeric($HTTP_POST_VARS['contrib_quick_insert'])){ $date_updated =date("Y-m-d H:M:S"); $date_added =date("Y-m-d H:M:S"); to: case 'quick_insert': if (is_numeric($HTTP_POST_VARS['contrib_quick_insert'])){ $date_updated =strtotime($HTTP_POST_VARS['last_update']); $date_updated=strftime ($format, $date_updated); $date_added =strtotime($HTTP_POST_VARS['note_created']); $date_added=strftime ($format, $date_added); I don't know if it's correct since I'm not a PHP expert but it works... Sébastien
  2. scartier

    Contribution Tracker

    Hi Steve, Great contrib but I get this error: 1292 - Incorrect datetime value: '2009-10-29 12:Oct:th' for column 'note_created' at row 1 insert into contrib_tracker (contr_id, contrib_osc_id, contrib_name, contrib_link, contrib_support, config_comments, note_created, contr_last_modified, status, last_update, contrib_vers) values (NULL, '6853','H2EPAYMENT OSCommerce plugin','http://addons.oscommerce.com/info/6853','','', '2009-10-29 12:Oct:th', '2009-07-02 00:00:00', '1', '2009-10-29 12:Oct:th', '' ) Sébastien
  3. Hi I have a problem with Explorer not handling various css files. In that case, it doesn't look fwr_suckertree_css_menu.php file and only apply directives from stylesheet.css. What can I do? Sébastien
  4. scartier

    One Page Checkout Support

    Hi Is there a way to make One Page Checkout work with TPV Virtual Servired, Pago en Mano + Retirar en mano and Transferencia Bancaria which are common payment methods here in Spain? Sébastien
  5. scartier

    One Page Checkout Support

    Hi Steve I had to change all $Qxxx queries in includes/classes/onepage_checkout.php to make it work: From (line 80): $QcustomerEmail = tep_db_query('select customers_email_address, customers_telephone from ' . TABLE_CUSTOMERS . ' where customers_id = "' . $customer_id . '"'); to: $QcustomerEmail = tep_db_query("select customers_email_address, customers_telephone from " . TABLE_CUSTOMERS . " where customers_id = '" . $customer_id . "'"); From (line 208): $Qcheck = tep_db_query('select customers_id from ' . TABLE_CUSTOMERS . ' where customers_email_address = "' . tep_db_prepare_input($emailAddress) . '"'); to: $Qcheck = tep_db_query("select customers_id from " . TABLE_CUSTOMERS . " where customers_email_address = '" . tep_db_prepare_input($emailAddress) . "'"); From (line 524) $QcInfo = tep_db_query('select * from ' . TABLE_COUNTRIES . ' where countries_id = "' . $country . '"'); to: $QcInfo = tep_db_query("select * from " . TABLE_COUNTRIES . " where countries_id = '" . $country . "'"); From (line 588): $Qaddress = tep_db_query('select ab.entry_firstname, ab.entry_lastname, ab.entry_company, ab.entry_street_address, ab.entry_suburb, ab.entry_postcode, ab.entry_city, ab.entry_zone_id, z.zone_name, ab.entry_country_id, c.countries_id, c.countries_name, c.countries_iso_code_2, c.countries_iso_code_3, c.address_format_id, ab.entry_state from ' . TABLE_ADDRESS_BOOK . ' ab left join ' . TABLE_ZONES . ' z on (ab.entry_zone_id = z.zone_id) left join ' . TABLE_COUNTRIES . ' c on (ab.entry_country_id = c.countries_id) where ab.customers_id = "' . (int)$customer_id . '" and ab.address_book_id = "' . (int)$addressID . '"'); to: $Qaddress = tep_db_query("select ab.entry_firstname, ab.entry_lastname, ab.entry_company, ab.entry_street_address, ab.entry_suburb, ab.entry_postcode, ab.entry_city, ab.entry_zone_id, z.zone_name, ab.entry_country_id, c.countries_id, c.countries_name, c.countries_iso_code_2, c.countries_iso_code_3, c.address_format_id, ab.entry_state from " . TABLE_ADDRESS_BOOK . " ab left join " . TABLE_ZONES . " z on (ab.entry_zone_id = z.zone_id) left join " . TABLE_COUNTRIES . " c on (ab.entry_country_id = c.countries_id) where ab.customers_id = '" . (int)$customer_id . "' and ab.address_book_id = '" . (int)$addressID . "'"); From (line 664): $Qcheck = tep_db_query('select address_book_id from ' . TABLE_ADDRESS_BOOK . ' where address_book_id = "' . $_POST['address_id'] . '" and customers_id = "' . $customer_id . '"'); to: $Qcheck = tep_db_query("select address_book_id from " . TABLE_ADDRESS_BOOK . " where address_book_id = '" . $_POST['address_id'] . "' and customers_id = '" . $customer_id . "'"); and from (line 875): $Qcustomer = tep_db_query('select customers_firstname, customers_lastname, customers_email_address from ' . TABLE_CUSTOMERS . ' where customers_id = "' . $customer_id . '"'); to: $Qcustomer = tep_db_query("select customers_firstname, customers_lastname, customers_email_address from " . TABLE_CUSTOMERS . " where customers_id = '" . $customer_id . "'"); Sébastien
  6. scartier

    One Page Checkout Support

    Hi, After installing v 1.08 on an heavily modified RC2 shop (STS, PWA, Ultimate SEO...), I get the following error: 1054 - Unknown column '2' in 'where clause' select customers_email_address, customers_telephone from customers where customers_id = "2" Any idea? Thanks Sébastien
  7. scartier

    All Products SEO

    Thanks. Now it works fine. Next time I'll read instructions better...
  8. scartier

    All Products SEO

    Hi Jack, Great contrib as usual but I have a small problem with the all_pages.php accessed from categories. Everything looks correct but when I choose products beginning by A, i get a 404 Not Found error because it's looking for page http://mysite/all-products.php-by-A.html which obviously doesn't exist. Do you have any idea? Thanks, Sébastien
  9. Hi Jack, very nice contribution but I have a problem since version 2-2.2d-3, already mentioned in this forum: when I change seo.class.php from version 2 (which works) to version 3 o 4, I get a blank page when trying to load a page of my site. I tried reseting SEO URL Cache, reseting the FWR categories menu, forcing the use of cookies but no way... Do you have any idea? Thanks, Sébastien
  10. Surfalot, I solved my problem; it appeared to be a database problem, a conflict with table 'specials'. Sorry for my insisting so much and thank you for your job and help. Sébastien
  11. Sorry, I suppose you reffer to the link to the .txt archive... Here it is: http://www.mendikirolak.com/CalzadoSalomon1.txt Thank you Sébastien
  12. Hi, EP worked well but an error ocurred since I updated my host to Apache/2.2.11 and PHP/5.2.8: products are created but not the relation product to categories. I get the following message: Easy Populate 2.76g-MS2 - Default Language : espanol(1) File uploaded. Temporary filename: C:\Documents and Settings\Administrador\Configuración local\Temp\PHP\upload\php4CB.tmp User filename: CalzadoSalomon1.txt Size: 9781 | 278434 | Cosmic 4D | Bota de tr | | Cosmic 4D | Cosmic 4D | Cosmic 4D | Cosmic 4D | Bota de tr | | Cosmic 4D | Cosmic 4D | Cosmic 4D | SS09/Salom | 172.371 | 4 | 1.41 | 01/02/2009 | 02/02/2008 | | Botas | Botak | | | | | | | | | | Salomon | 4 | Salomon M | Salomon M | 46 | 6,5 UK | 6,5 UK | | | 47 | 7 UK | 7 UK | | | 48 | 7,5 UK | 7,5 UK | | | 49 | 8 UK | 8 UK | | | 50 | 8,5 UK | 8,5 UK | +0.0000 | 1 | 51 | 9 UK | 9 UK | +0.0000 | 1 | 52 | 9,5 UK | 9,5 UK | +0.0000 | 1 | 53 | 10 UK | 10 UK | +0.0000 | 1 | 54 | 10,5 UK | 10,5 UK | | | 55 | 11 UK | 11 UK | | | 56 | 11,5 UK | 11,5 UK | | | 57 | 12 UK | 12 UK | | | 58 | 12,5 UK | 12,5 UK | | | 59 | 13 UK | 13 UK | | | 60 | 13,5 UK | 13,5 UK | | | 5 | Salomon W | Salomon W | 61 | 3,5 UK | 3,5 UK | | | 62 | 4 UK | 4 UK | | | 63 | 4,5 UK | 4,5 UK | | | 64 | 5 UK | 5 UK | | | 65 | 5,5 UK | 5,5 UK | | | 66 | 6 UK | 6 UK | | | 67 | 6,5 UK | 6,5 UK | | | 68 | 7 UK | 7 UK | | | 69 | 7,5 UK | 7,5 UK | | | 70 | 8 UK | 8 UK | | | 71 | 8,5 UK | 8,5 UK | | | 72 | 9 UK | 9 UK | | | 73 | 9,5 UK | 9,5 UK | | | 74 | 10 UK | 10 UK | | | 75 | 10,5 UK | 10,5 UK | | | IVA | Active !New Product! 1054 - Unknown column '1200' in 'field list' INSERT INTO products_to_categories (products_id, categories_id) VALUES ("1200", "19") I have the following configuration: EP vers: 2.76g-MS2 osCommerce Online Merchant v2.2 RC2a OS: HTTP: Apache/2.2.11 (Win32) PHP/5.2.8 DB: MySQL 5.1.30-community PHP: 5.2.8 (Zend: 2.2.0) Temp Directory: C:/Archivos de programa/Apache Software Foundation/Apache2.2/htdocs/XXX/temp/ Temp Dir is Writable Magic Quotes is: off register_globals is: off Split files on: 300 records Model Num Size: 12 Price with tax: false Calc Precision: 2 Replace quotes: false Field seperator: tab Excel safe output: false Preserve tab/cr/lf: false Category depth: 4 Enable attributes: true SEF Froogle URLS: false More Pics: false Unknown Pics: false HTC: true SPPC: false Extra Fields: false Could somebody give me a hand please? Cheers, Sébastien
  13. Hi, EP worked well but an error ocurred since I updated my host to Apache/2.2.11 and PHP/5.2.8: products are created but not the relation product to categories. I get the following message: Easy Populate 2.76g-MS2 - Default Language : espanol(1) File uploaded. Temporary filename: C:\Documents and Settings\Administrador\Configuración local\Temp\PHP\upload\php4CB.tmp User filename: CalzadoSalomon1.txt Size: 9781 | 278434 | Cosmic 4D | Bota de tr | | Cosmic 4D | Cosmic 4D | Cosmic 4D | Cosmic 4D | Bota de tr | | Cosmic 4D | Cosmic 4D | Cosmic 4D | SS09/Salom | 172.371 | 4 | 1.41 | 01/02/2009 | 02/02/2008 | | Botas | Botak | | | | | | | | | | Salomon | 4 | Salomon M | Salomon M | 46 | 6,5 UK | 6,5 UK | | | 47 | 7 UK | 7 UK | | | 48 | 7,5 UK | 7,5 UK | | | 49 | 8 UK | 8 UK | | | 50 | 8,5 UK | 8,5 UK | +0.0000 | 1 | 51 | 9 UK | 9 UK | +0.0000 | 1 | 52 | 9,5 UK | 9,5 UK | +0.0000 | 1 | 53 | 10 UK | 10 UK | +0.0000 | 1 | 54 | 10,5 UK | 10,5 UK | | | 55 | 11 UK | 11 UK | | | 56 | 11,5 UK | 11,5 UK | | | 57 | 12 UK | 12 UK | | | 58 | 12,5 UK | 12,5 UK | | | 59 | 13 UK | 13 UK | | | 60 | 13,5 UK | 13,5 UK | | | 5 | Salomon W | Salomon W | 61 | 3,5 UK | 3,5 UK | | | 62 | 4 UK | 4 UK | | | 63 | 4,5 UK | 4,5 UK | | | 64 | 5 UK | 5 UK | | | 65 | 5,5 UK | 5,5 UK | | | 66 | 6 UK | 6 UK | | | 67 | 6,5 UK | 6,5 UK | | | 68 | 7 UK | 7 UK | | | 69 | 7,5 UK | 7,5 UK | | | 70 | 8 UK | 8 UK | | | 71 | 8,5 UK | 8,5 UK | | | 72 | 9 UK | 9 UK | | | 73 | 9,5 UK | 9,5 UK | | | 74 | 10 UK | 10 UK | | | 75 | 10,5 UK | 10,5 UK | | | IVA | Active !New Product! 1054 - Unknown column '1200' in 'field list' INSERT INTO products_to_categories (products_id, categories_id) VALUES ("1200", "19") I have the following configuration: EP vers: 2.76g-MS2 osCommerce Online Merchant v2.2 RC2a OS: HTTP: Apache/2.2.11 (Win32) PHP/5.2.8 DB: MySQL 5.1.30-community PHP: 5.2.8 (Zend: 2.2.0) Temp Directory: C:/Archivos de programa/Apache Software Foundation/Apache2.2/htdocs/XXX/temp/ Temp Dir is Writable Magic Quotes is: off register_globals is: off Split files on: 300 records Model Num Size: 12 Price with tax: false Calc Precision: 2 Replace quotes: false Field seperator: tab Excel safe output: false Preserve tab/cr/lf: false Category depth: 4 Enable attributes: true SEF Froogle URLS: false More Pics: false Unknown Pics: false HTC: true SPPC: false Extra Fields: false Could somebody give me a hand please? Cheers, Sébastien
  14. scartier

    Site Search Plus

    Hi Jack, very nice contrib that works like a charm but I had a little problem with W3C specifications. After looking for a while, it appears to be caused by the search box and more especifically by $catBoxWidth. W3C needs to know if the width is % or px and the solution I found is to modify the includes/boxes/search.php file and change line 28 from $catBox = ($showCatBox ? '<tr><td height="3"></td></tr><tr><td class="infoBoxContents" valign="top" colspan="3">' . BOX_ADVSEARCH_CAT . '</td></tr><tr><td class="infoBoxContents" valign="top" colspan="3">' . tep_draw_pull_down_menu('categories_id', tep_get_categories(array(array('id' => '', 'text' => BOX_ADVSEARCH_ALLCAT))), '', 'style="width:' . $catBoxWidth . ';"') . '</td></tr>' : ''); to: $catBox = ($showCatBox ? '<tr><td height="3"></td></tr><tr><td class="infoBoxContents" valign="top" colspan="3">' . BOX_ADVSEARCH_CAT . '</td></tr><tr><td class="infoBoxContents" valign="top" colspan="3">' . tep_draw_pull_down_menu('categories_id', tep_get_categories(array(array('id' => '', 'text' => BOX_ADVSEARCH_ALLCAT))), '', 'style="width:' . $catBoxWidth . 'px' . ';"') . '</td></tr>' : ''); and it seems to work. Is it correct ? Sébastien
  15. scartier

    Sitemap SEO

    It works. Thank you. Sébastien
  16. scartier

    Sitemap SEO

    Great contrib that works fine with an RC2 modificated shop. Just one issue: I have Information Pages Unlimited (1026) and in spite of the information page asked for, Sitemap SEO displays an http 404 error page because it takes the id of the information page which obviously lead to nowhere (ex: www.mypage.com/1 instead of www.mypage.com/information.php?info_id=1) I'm not sure it's the right forum to comment my problem but as I don't know which contrib you reffer to as InfoPages, and because I think many users could be interested, I decided to post it here. Sorry if I was wrong and thanks you for you help if not. Sébastien
  17. First of all, thank's for your help. I'm no so quite sure it is not a SEO URL problem since the direction shows correctly if Force Cookie use set to True and wrongly when set to False; in fact, it looks like if Add cPath to Product URL was set to True when it is not the case. Could it have something to see with your contrib 5942 ? Sébastien
  18. Hello, Great contrib but I have a little problem: When Force Cookie use is set to True, direction show the correct way: http: //localhost/tienda_base/microsoft-intellimouse-explorer-p-26.html but I can't add the item to the cart (it leaves me to the cookies' page) But when Force Cookie use is set to False (which is the option I want not to lose sells), direction shows the following way http://localhost/tienda_base/microsoft-int...u6gokvmmu51lmq0 and it that case I can add the item to cart. Could anybody give me a idea please? Sébastien Note: the shop is not located in the root
  19. scartier

    Header Tags SEO

    Hi all I was trying to install Header Tags SEO on a OsCommerce RC2 shop with STS 4.58 on a windows server and it always gave me the following error: on Test page, the Test result was correct but on Page Control, right column works fine but left one not: after introducing data for any of the pages of the list I get the following error: 1366 - Incorrect integer value: '' for column 'sortorder_title' at row 1 insert into headertags (page_title, page_description, page_keywords, page_logo, append_default_title, append_default_description, append_default_keywords, append_default_logo, append_category, append_manufacturer, append_product, append_root, sortorder_title, sortorder_description, sortorder_keywords, sortorder_logo, sortorder_category, sortorder_manufacturer, sortorder_product, sortorder_root, page_name, language_id) values ('products new home', 'products new description', 'products new keywords1,keywords2', 'products logo text', '0', '0', '0', '0', '0', '0', '1', '1', '', '', '', '', '', '', '10', '1', 'product_info.php', '7') [TEP STOP] For those who have the same problem, I solved the problem changing the configuration of MySQL from STRICT_TRANS_TABLES mode to ANSI mode. Sébastien
  20. scartier

    [Contribution] TinyMCE Anywhere

    Hi everybody, I have TinyMCE installede on an OSCommerce RC2 shop with ACA 2.63, STS 4.58, Header Tags SEO 3.07 and others mods and I have a little problem with product description: the TinyMCE editor only appears for the predeterminated language, not for the other one I use. I tried to change mode from "exact" to "textareas" and it worked... to well: image field and tags fields also became editable fields. What could I do to make the two languages product description's fields editable? Thank's in advance Sébastien
  21. scartier

    Header Tags SEO

    Hi Jack, First of all, thank you for this great contrib and for your help. I've been looking the database but all fields are correct and correspond to the correct version of Header Tags SEO. I tried to enter data with something like: INSERT INTO `headertags` ( `page_name` , `page_title` , `page_description` , `page_keywords` , `page_logo`, `append_default_title` , `append_default_description` , `append_default_keywords`, `append_default_logo`, `append_category`, `append_manufacturer`, `append_product`, `append_root`, `sortorder_title` , `sortorder_description` , `sortorder_keywords` , `sortorder_logo` , `sortorder_category` , `sortorder_manufacturer`, `sortorder_product`, `sortorder_root`, `language_id` ) VALUES ('privacy.php', 'New Home Page Title', 'new description', 'new keywords1,keywords2', 'new logo text', '0', '0', '0', '0', '0', '0', '1', '1', '0', '0', '0', '0', '0', '0', '10', '1', '1'); and it works fine. I have been replacing and verifying all files, but no way... It seems like if the header_tags_seo.php page wasn't sending the right instruction (or no data as ,", suggests, which could explain the incorrect integer error)... The only way to make it work is to mark ALL options and sort order numbers. Sébastien
  22. scartier

    Header Tags SEO

    Hi all I'm trying to install Header Tags SEO on a OsCommerce RC2 shop with STS 4.58 on a windows server (and localhost) and it always give me the following errors: 1/ on Test page, the Test result is: Permissions Error: Permissions settings for the C:/Program Files/Apache Software Foundation/Apache2.2/htdocs/Pruebas/mendishop//includes/header_tags.php file appear to be incorrect. Change to 777 Missing Code in File The Header Tags head code for the index.php file cannot be found. The Header Tags head code for the product_info.php file cannot be found. The Header Tags head code for the product_reviews.php file cannot be found. The Header Tags head code for the product_reviews_info.php file cannot be found. The Header Tags head code for the product_reviews_write.php file cannot be found. The Header Tags head code for the specials.php file cannot be found. 2/ on Page Control, right column works fine but left one not; after introducing data for any of the pages of the list I get the following error: 1366 - Incorrect integer value: '' for column 'sortorder_title' at row 1 insert into headertags (page_title, page_description, page_keywords, page_logo, append_default_title, append_default_description, append_default_keywords, append_default_logo, append_category, append_manufacturer, append_product, append_root, sortorder_title, sortorder_description, sortorder_keywords, sortorder_logo, sortorder_category, sortorder_manufacturer, sortorder_product, sortorder_root, page_name, language_id) values ('products new home', 'products new description', 'products new keywords1,keywords2', 'products logo text', '0', '0', '0', '0', '0', '0', '1', '1', '', '', '', '', '', '', '10', '1', 'product_info.php', '7') [TEP STOP] Could somebody give me an hand please? Sébastien
  23. Hi, I have OSCommerce 2.2 RC2 working without any problem with Easy Populate, QTPro, TinyMCE, STS, ACA and LonginBox among others but for some reason, I have a problem with Small, Medium an Large Images (cont. 695). When I activate the ACA product module for this contrib and try to create a new product, the preview page doesn´t display any image: only upload succes, banenr, header and colum left... Can somebody help me? Thank you
  24. Hi I recently installed the Visitor Webstats 3.1 contribution in spanish and ther is no way to get it work. Counter remains in 0 and the chart only shows the day of the month (chart by day this month). Could somebody helps me. Thanks Sébastien
  25. scartier

    "New products in" always in english ?

    I had the same problem with spanish language and I solved it changing from @setlocale(LC_TIME, 'sp'); to @setlocale(LC_TIME, 'es_ES.ISO_8859-1'); in includes/languages/espanol.php. As for German, I think you should set it as follow : // on RedHat try 'de_DE' // on FreeBSD try 'de_DE.ISO_8859-1' // on Windows try 'de' or 'German' @setlocale(LC_TIME, 'de_DE.ISO_8859-1'); //would be the configuration for German in a FreeBSD server. Unfortunately, I didn't solved the proble for euskera (basque language) and if somebody know how to set it, it would be great ;) Thanks Sébastien
×