Jump to content

PerlSOL

Members
  • Content count

    64
  • Joined

  • Last visited

Everything posted by PerlSOL

  1. Thank you very much for that :thumbsup: (sorry for the delayed reply) again, many thanks.
  2. Hi again Surfalot... could you help me please when you have some spare time, I have added your latest update to a fresh MS2, all I have done is I emptied the default install using the empty/truncate contrib. I am trying to import a backup from two versions back and am getting this error? 1364 - Field 'manufacturers_url' doesn't have a default value INSERT INTO manufacturers_info( manufacturers_id, languages_id ) VALUES ( 2, '1' ) any idea's please! Thanks
  3. PerlSOL

    coolMenu

    may seem a daft question but how would one go about linking to an external page, as it all comes from the database I can't see how I would add a custom page to the menu... I can work out how to do it if i append to the end of the create box but not to be in the middle of the menu? shop link1> shop link2> shop link3> ext link1> (other.php) shop link4> shop link5>
  4. PerlSOL

    New Attribute Manager Released..

    thanks for that... i'll try it shortly as I havn't installed it yet... looking into things before I dive ;)
  5. PerlSOL

    New Attribute Manager Released..

    did anyone get this to work with reg. globals off after?
  6. PerlSOL

    Dynamic SiteMap

    Thanks for pointing this out... how one missed that I don't know! I can stop banging my head on the wall now ;)
  7. PerlSOL

    Protx Direct v2.22

    I am having a problem when I restore the db from a backup... 1067 - Invalid default value for 'txtime' create table protx_direct ( id int(11) unsigned not null auto_increment, customer_id int(11) default '0' not null , order_id int(11) default '0' not null , vendortxcode varchar(40) , txtype varchar(16) , value decimal(15,4) , vpstxid varchar(50) , status varchar(15) , statusdetail varchar(100) , txauthno varchar(10) , securitykey varchar(10) , avscv2 varchar(50) , address_result varchar(20) , postcode_result varchar(20) , CV2_result varchar(20) , 3DSecureStatus varchar(12) , CAVV varchar(32) , txtime timestamp default 'CURRENT_TIMESTAMP' not null , UNIQUE id (id) ) [TEP STOP] I have to then go and rem out the section in the sql file and then I can fix it with phpmysql my searches show there are a few posts about the error 1067 - Invalid default value for 'txtime' but nothing that talks about the restore of a database... can anyone help please as this is driving me nuts. [edited] forgot to say I am using v4.3 [/edited]
  8. I keep getting problems every time I backup or restore i have tried to remove the table an put it back in but it wont let me, its as if there is still some ref: to a table!!! if I google anti_robotreg.frm I get nothing #1005 - Can't create table '.\blabla\anti_robotreg.frm' (errno: 121) I'm using the most recent of everything... SQL PHP... here is the SQL code drop table if exists anti_robotreg; create table anti_robotreg ( session_id char(32) not null , reg_key char(5) not null , timestamp int(11) unsigned default '0' not null , PRIMARY KEY (session_id) ); insert into anti_robotreg (session_id, reg_key, timestamp) values ('e9tdfk5f4a9guhh92us7r5iln2', 'DMNZN', '1183862880'); Has anyone else come across this?
  9. Thanks for getting back to me, I did look at the source to see how one would go about it, and ended up looking for another method, I am now updating these fields via openoffice - mySQL DB link that I just got working :-" ... which is no where near as good as this mod. thanks again for this great contrib.
  10. Hi surfalot, would you know how I can add 'categories_description' and 'categories_heading_title' to this amazing feature? ...when I say amazing I really do meen it, the amount of work this MOD has saved me is beyond words, Many thanks for your hard work, efforts and commitment. :thumbsup:
  11. I have worked out the solution to my problem... (HURRAY!) ... Maximum Content-Length in the server's config.ini Maximum Content-Length = 2-MB Maximum User Content-Length = 10-MB ...and while i'm at it i'll fix that timing out issue you all talked about back about a billion pages ;) php.ini: max_execution_time = 120 ; Maximum execution time of each script, in seconds max_input_time = 120 ; Maximum amount of time each script may spend parsing request data Now I can import a file and all is very happy :) now I can go try it all out, oh and make that dropdown box i knocked up work! :blush: :-" Just to collate some keywords in one post to (help) make this site's search function work can't upload files php5 empty $_POST $_FILES POST problem sambar server config.ini :thumbsup:
  12. Sorry, didn't think you would need the header row...I have followed the code all the way through and found the problem to be with enctype="multipart/form-data"... At first I thought it was all POST data is not working but it just seems to be this multipart/form-data! there are many threads out ther on this subject but no cure found yet :( I have tried the latest PHP being 5.2.3, I have yet to try downgrading not that I want to but if that works!!! eitherway I will post my findings here for all. I'll post the header line if I run into problems once I pass the enctype problem :) thanks again for the replies.
  13. Import EP file from Temp Dir - dropdown box MOD I havn't even got it to work 100% yet and this was annoying me LOL... having to go and see what the filename was called each time and cut n paste the name in the box... so I knocked up the code to populate a drop down box of all the .txt files within the temp folder... if there are no files in there then it shows the original input field. I hope you find it of some use find: <INPUT TYPE="text" name="localfile" size="50"> replace with: <?PHP // <INPUT TYPE="text" name="localfile" size="50"> $the_array = Array(); $handle = opendir($tempdir); while (false!== ($file = readdir($handle))) { if ($file!= "." && $file!= ".." &&!is_dir($file)) { $namearr = split('\.',$file); if ($namearr[count($namearr)-1] == 'txt') $the_array[] = $file; } } closedir($handle); $array_size = count($the_array); if($array_size == 0){ echo (' <INPUT TYPE="text" name="localfile" size="50">' . "\n"); } else { echo (' <select name="localfile" size="1">' . "\n"); foreach ($the_array as $list){ echo (' <option value="' . $list . '">' . $list . '</option>' . "\n"); } echo (' </select>' . "\n"); } ?>
  14. so sorry I forgot to post some example data... it's as given to me from the export: "300","300 Base Unit.gif","300mm Base Unit","<p>300mm Base Unit</p>","","38.7","0.00","","2007-04-07 23:55:19","99","1","Color","2","Size","1","115 x 596","","2","175 x 596","","3","140 x 496","","4","140 x 596","","5","283 x 496","","6","283 x 596","","7","140 x 996","","8","283 x 996","","9","355 x 596","","10","335 x 496","","11","450 x 596","","12","495 x 596","","13","570 x 596","","14","895 x 596","","15","(2) 715 x 296 ICB Door Set","","16","715 x 296","","17","715 x 396","","18","715 x 446","","19","715 x 496","","20","715 x 596","","21","1245 x 296","","22","1245 x 496","","23","1245 x 596","","24","(3) 140 x 496 with (1) 283 x 496","","25","(1) 140 x 596 with (2) 283 x 596","","26","(1) 140 x 996 with (2) 283 x 996","","27","715 x 396 Glazed","","28","715 x 496 Glazed","","29","1200 x 496 Glazed Dresser Door","","30","(1) 715 x 296 with (1) 1245 x 296","","31","(1) 715 x 496 with (1) 1245 x 496","","32","(1) 715 x 596 with (1) 1245 x 596","","33","300 larder door - 715 x 296 & 1245 x 296","","34","500 larder door - 715 x 496 & 1245 x 496","","35","600 larder door - 715 x 596 & 1245 x 596","","36","Worktop (40mm) 1500 x 600","","37","Worktop (40mm) 3000 x 600","","38","Worktop (40mm) 3000 x 640","","39","Worktop (40mm) 3650 x 900","","3","Left/Right","40","L/H","","41","R/H","","4","Slide Type","42","Standard","","43","Blum Tandem ~ Soft Close","","Athens","CONTEMPORARY","ATHENS","BASE UNITS (18mm)","","Taxable Goods","Active",EOREOR
  15. Hi Surfalot thanks for the reply please see below Windows 2k (SAMBAR) oscommerce-2.2ms2-051113 PHP Version 5.2.3 MySQL 5.0.27 $curver = '2.76d-MS2'; I have tried the two links you highlight and had applied these changes (and read ALL these pages) but to no avail, It has been a buggy bumpy ride but one keeps going! ...i've modified the rest of the shop with the register globals patches ok and all is settled and running fine so far, just this fact I can't upload... I can download no problem and followed it going through the GET (IF's) but I cant suss out where it's bailing out... I dont get an error as such just page cannot be displayed, I even tried moving the $split to POST as a hidden form element LOL (digging deep!) I think it's a FILES upload problem but i'm new to php and just stabbing in the dark now! any idea's??? (sit's down scratching one's head)
  16. Has anyone got this to work with PHP5 with globals off yet This GLOBALS is the problem from what I can see though i'm only a newbie to php I have gone through so much many many times and tried everything mentioned but I still can not upload any data
  17. PerlSOL

    [Contribution] Admin Notes

    ignore the above sorry :blush: just after I worked that out I found the same info on the contributions update (DOH!) The only remaining problem I have now is this SYNTAX ERROR with ' LOL, I wouldn't know where to start in PHP so I will leave this for someone else to come up with a solution ;)
  18. PerlSOL

    [Contribution] Admin Notes

    Warning: array_merge() [function.array-merge]: Argument #2 is not an array in C:\xxx\xxx\Catalog\Admin\admin_notes.php on line 279 upon installation i had errors on the array_merge function, I readup about it on php.net and it is summit to do with php5 changes ??? find this $sInfo_array = array_merge($admin_quer, ''); replace with this $aa = array(); $sInfo_array = array_merge((array)$admin_quer, (array)$aa); Many thanks for a great contrib :thumbsup:
  19. || (strlen($antirobotreg) != ENTRY_VALIDATION_LENGTH) :angry: after much time I found that if I removed the above it worked, from what I can work out it is pointless anyhow with the compare check. TFFT! I hope this helps others from banging one's head :blink:
  20. did you find out why after? it might help me... I had mine working at one stage then I went and sorted out the register globals issue (which I left till last) and now I have this problem where I enter the correct code but it keeps saying Invalid Validation Code. I am close to removing this MOD as it is taking far too much time to try and solve, I cant revert and undo what I have done as I need the register globals off. Im sure is was to do with sessions.php but i'm only learning!!! PLEASE, PLEASE, PLEASE, can anyone help me
  21. after playing about I found a quick fix for my CONFIG_CALCULATE_IMAGE_SIZE=='true' issue Changed: $validation_images = tep_image('validation_png.php?rsid=' . $new_guery_anti_robotreg['session_id']); To: $validation_images = tep_image('validation_png.php?rsid=' . $new_guery_anti_robotreg['session_id'], '', '260', '50'); I saw sizes in the admin so i'm quite sure the height and width could be extracted from there (it should be!) but I will leave that up to the better PHP coders :blush:
  22. I have the CONFIG_CALCULATE_IMAGE_SIZE=='true' issue but I must have it set true... has anyone found any knock-on effect problems after installing the posted fix for this, there has not been anything more said about this yet and was wondering whats other thought ?
  23. every time I add a mod things keep breaking :angry: (rant over) PLEASEEEEEEEE can you help me (pretty please) After installing this mod I signed up a test customer, I had to type into "County/State" Glamorgan (this later turned into a dropdown box???) and then I went into "MyAccount" to see If it all looked right... Aberdeenshire was there in place of Glamorgan??? but then when I selected Glamorgan and tried to save it I was then told... required field: Your Post Code must contain a minimum of 4 characters. ...only to notice that the postcode field isnt even there!!! I have read sort/part of the same questions on here but can't seem to find a solution :( anyone Please
  24. PerlSOL

    [Contribution] Category Descriptions MS2

    I see no-one has posted in here for some time now... but guess what, I have many problems :'( I installed categories description and followed the install intructions with great detail but... first time round it didnt work and had to resort to my backup, second time round I got it working (hurray!) but then I noticed the sub-catagories didnt work, so I added the rest of it to make that work... and at a quick glance it seemed to work fine and then I noticed (none of this adding was simple mind as my code has been heavily moddified and none of the code was where it was supposed to be or look like what is was supposed too)... my problems: If a catagory had sub-catagories with other sub-catagories within that the catagory description would be listed twice... once as normal text where it should be and again in with the title in big bold letters, this would also loose the column_right... If the catagory didn't have any other sub-catagories then the page would be fine. There are more problems with this but 1 at a time! PLEASE can anyone help me with this.?
  25. PerlSOL

    coolMenu

    I have managed to cure all my coolmenu problems despite the lack of help... and, I have even managed to combine the cool menu with the image rotator using mouse over commands, I am so impressed with this coolmenu... the only 1 downside to it is it's position control as its cord start from 0,0... If I wanted to centre the shop (which I tried) I run into problems, however... as it is not my shop it can stay full screen. Many thanks to the creators and all who helped produce this mod.
×