Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

tyveris

Members
  • Content count

    14
  • Joined

  • Last visited

  1. tyveris

    Official PayPal IPN Support Thread

    Hello, my english isnt very good, i hope you understand me: I have a question: On the Contribution-Site http://addons.oscommerce.com/info/2679 there is the last version from "Paypal_IPN 3.0 next Version GER aplein 22 Jan 2010" But there is no sql-file or a complete "installation-file". So can you help me please with the LAST-STABLE PayPal_IPN Module for OSC 2.2 ? I've also searched the site http://addons.oscommerce.com/category?search=paypal+ipn but i found only this one. Which Version is also the last stable which i should use? I search the normal IPN Module, not the "New ExpressCheckout" Module. Thanks a lot. tyv
  2. SPAMMER - plz block him!

  3. tyveris

    [Contribution] SEO-G

    Hu, i found the problem. Im useing another application_top for elmar ... so after i modified it, all works great ... my fault. It was a long time ago, so dont remember all changes ... Great Contrib, thanks
  4. tyveris

    [Contribution] SEO-G

    Hello, did anybody use elmar with this contribution ? Does it work ? I cant get it work, alwaays the same error. I installed the update 1.20, enabled seo in elmar, .. but the same error: Fatal error: Call to a member function on a non-object in /var/www/vhost/damrotech-test/includes/functions/html_output.php on line 76 Line 76 in html_output.php: $link = $g_seo_url->get_seo_url($link, $separator); Hum, anybody any idea ?
  5. tyveris

    [Contribution] SEO-G

    Hi, i just tried to exclude the file, but the file isnt in root directory, so i cant add it. How can i add a file when it isnt in the root-directory ? I have take a look in the DB, but there is an "seo_exclude_key" ... So, is this possible ? TIA Tyv
  6. tyveris

    [Contribution] SEO-G

    So, i found a new problem ^^ I see some error messages in m ylog files like this: apache2: PHP Fatal error: main(): Failed opening required 'ipn.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/vhost/damrotech/root.php on line 146 This "ipn.php" is a file from the PayPalIPN Module. Now i see PayPal cant "call" back to the server and confirm the order. I think this is a greater problem for someone (we use other software to verify) The root.php says on line 146: // Signal SEO-G translation. $g_seo_flag = true; require(basename($PHP_SELF)); } elseif( file_exists(basename($osc_parse['path']))) { $PHP_SELF = $HTTP_SERVER_VARS['PHP_SELF'] = $_SERVER['PHP_SELF'] = $_SERVER['SCRIPT_NAME'] = $osc_parse['path']; if(basename($_SERVER['PHP_SELF']) == 'root.php' ) { echo '<b>SEO-G Error</b>: Invalid Self-Request, passed URI Request: ' . $_SERVER['REQUEST_URI']; exit(); } in " if( $g_seo_url->get_osc_url($g_server . $_SERVER['REQUEST_URI'], $osc_url, $osc_params, $osc_parse) ) {" Hope the problem isnt big and we can solve it. Tyv
  7. tyveris

    [Contribution] SEO-G

    Hello, i have a problem now with the contribution. Normally it works great. But if i want to start elm@r i get an error: Fatal error: Call to a member function on a non-object in /var/www/vhost/damrotech/includes/functions/html_output.php on line 74 Here is line 73 to 75: //-MS- SEO-G Added $link = $g_seo_url->get_seo_url($link, $separator); //-MS- SEO-G Added EOM I have enabled in elm@r the define('ELMAR_SEO_URLS', true); but it dont work. Every time the same error. I have also excluded the file in the admin section of seo-g but with nor result. Same error. Can anybody help me ? The contribution is working great, and i have no problems bevor ... Thanks. Tyv
  8. Hello, im still interested on this "modul/script". Did you share it ? Tyv
  9. tyveris

    [Contribution] SEO-G

    Hu, sorry, i found all my errors and fixed it! (i think) Now, after i have read the first 3 pages of this topic i solve my problems with the categories and the "header already send" ... Thanks for the great contribution! Tyv
  10. tyveris

    [Contribution] SEO-G

    Hu, i have a question: When i have categories with the same name like 4x, 8x, 16x .. is this a problem ? Beacause it seems so.... If i click on the main banner "Top Angebot" then categories opens, and i see 8x and 16x in the "DVD+R printable Rohlinge" categorie, but when i click on 8x in "DVD+R printable Rohlinge" it will change to "DVD+RW Rohlinge" .... this is bad .. wahhh .... Should i rename my categories or should i define for every categorie a link titel for seo ? Thanks Tyv P.S.: I think i have found my error at the first install: in the main apache config for the vhost there was the option "Options FollowSymLinks" without the "+". I have changed it, i think this was the problem ? (or not ... huuu) ;-)
  11. tyveris

    [Contribution] SEO-G

    Hu, so, it works. But i have a problem. The problem is not from the seo contrib. But now the main categories dont work. Can you take a look and give me a hint ?! http://88.198.164.75/index.php I can post my categories.php box file, but it is large .. tyv EDIT: If you click on a link in the head like "Samsung Brenner", then hte categories opens and then the second categories will work ... hummmmm.... It change in the main categorie allways to index.html ... but i dont know why
  12. tyveris

    [Contribution] SEO-G

    Hello, i think i found a little thing: "seo_url_admin.php" This file isnt on the list of new_files. And there is also no information about it. There is also no information to copy this file. I think it is a little error in file-list. It is just a comment from me ;-) Tyv
  13. tyveris

    [Contribution] SEO-G

    hmm, thanks, but i have diff all files manually in ultraedit, to find changes ... but, ... i will install it again. its a test shop. so nothing is important on the shop. if you say it is definitiv an install error, i will install it again. i will write tomorrow my answere after installed it. thanks for your help. tyv
  14. tyveris

    [Contribution] SEO-G

    thanks for quick replay. i have add this: //-MS- SEO-G Added global $request_type, $session_started, $SID, $g_seo_url; //-MS- SEO-G Added EOM i use the html_output from your contrib.... but it doesent work ^^
  15. tyveris

    [Contribution] SEO-G

    Hello, i get this problem, and i have search the last 3 days ... but i dont find anything that can help me: Fatal error: Call to a member function on a non-object in /var/www/vhost/damrotech-test/includes/functions/html_output.php on line 57 and this is in html_output.php: //-MS- SEO-G Added $link = $g_seo_url->get_seo_url($link, $separator); //-MS- SEO-G Added EOM So, i have: PHP Version 4.3.10-19 Apache 2.0 Handler register_globals On On Zend Loader enabled apache2handler Loaded Modules core mod_access mod_auth mod_log_config mod_logio mod_env mod_setenvif prefork http_core mod_mime mod_status mod_autoindex mod_negotiation mod_dir mod_alias mod_so mod_actions mod_deflate mod_php4 mod_rewrite .htaccess: Options +FollowSymLinks RewriteEngine On RewriteBase / RewriteRule ^(.*).html$ root.php?$1.html&%{QUERY_STRING} Im useing no other seo-contrib, i have explicit read the "readme/install" and verify all oscommerce-admin-config switches.... I have no idea why it isnt working ... can you help me please ?! I hope this information is enough ^^
×