Jump to content

allaboutwicker

Members
  • Content count

    455
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by allaboutwicker

  1. allaboutwicker

    [Contribution] Discount Coupon Codes

    Hi, I believe the actual place for the text that shows up on the screen is in: includes/languages/english/modules/order_total/ot_discount_coupon
  2. Hi, have you checked the download contrib section for updated files? I am not sure what contrib you used but I think you might need to do a bug fix. Go to the contrib section and check it out, optional combo fix or Bug Fix for subtotals problem: http://www.oscommerce.com/community/contributions,4269
  3. Hi, I'll give this one last shot before going to bed. Check your catalog/includes/modules/payment file folder to make sure all of your different payment module files are still in there. This could be it, I hope!
  4. Hi, it appears that you may be missing info in either your includes/database_tables.php or in your includes/filenames.php Check to make sure you didn't accidentally delete your modules in these files.
  5. Hi, I am trying to find something to help. Check out this thread I found with a google search of your error: http://forums.oscommerce.com/index.php?act...=7&t=283428 I didn't quite understand it, but maybe it makes sense more to you or someone else on this forum. I am not a programmer, so only know what have learned by working with this oscommerce stuff. I know the answer is out there and it bothers me not to be able to find it!
  6. I believe this is telling you that you have a line of code in header.php which is calling for category. It is saying that it is called already in categories.php. I looked at my header.php and could not find any mention of category it. Take a look at your coding in that file. Did you add something regarding category there?
  7. allaboutwicker

    [Contribution] STS v4

    Hi there, I am considering installing this STS v4 contribution, but before I do can someone tell me if it will be of benefit? I have a heavily modified site so I am thinking it might be very complicated and not work. The main reason I am looking at this modification is that I now take credit cards besides paypal and google checkout. I do not like the fact that my customers cannot see the total order details, products purchasing + shipping = total order amount, before they input their credit card info. With paypal or google checkout they are taken to the final screen where that info is. I am hoping that with this contrib I will somehow be able to add that info in either the shopping cart screen or the checkout shipping page. I saw a screen shot of oscommerce 3.0 shopping cart page which had the info right on it! Too bad that is not here yet. Anyway, can anyone advise me on this as I have been looking for a contribution to get this done for a while now. Thanks so much in advance!!!
  8. allaboutwicker

    [Contribution] Discount Coupon Codes

    I am not sure but look at this thread comment I found. It seems to mean the problem is actually from checkout_payment.php. Check that file! QUOTE(Brian_C @ Apr 15 2007, 09:33 PM) * Thanks for the contrib! I installed, configured a coupon code, and when I input the coupon code on checkout_payment.php I get this error. "Warning: Invalid argument supplied for foreach() in /../includes/classes/discount_coupon.php on line 62" Anybody know why? I couldn't find anything on it in the thread. Then he responded: Disregard my post, forgot to upload one file......doh!
  9. allaboutwicker

    [Contribution] Discount Coupon Codes

    Yes, that is it. Sorry for they delay had to go away from computer for a minute. Have you had any luck with it yet?
  10. allaboutwicker

    [Contribution] Discount Coupon Codes

    Sorry for not posting the link before for Discount Coupon Codes 2.0 coupon class file bugfix: http://addons.oscommerce.com/info/4269
  11. allaboutwicker

    [Contribution] Discount Coupon Codes

    I am having a little trouble understanding your English, but I did go into the contributions section on this website and saw there is an update file to fix some problems to the 2.0 version. Maybe if you install that fixed file, it will solve the problem. Try it and post back if it doesn't fix it.
  12. allaboutwicker

    [Contribution] Discount Coupon Codes

    Can you tell me if you are just installing this now or has it worked in the past and just now stopped working? Also, what version of this contrib are you using?
  13. allaboutwicker

    [Contribution] Discount Coupon Codes

    Hi, I checked my coding in that file and the only time I see foreach bla, bla, bla it looks like this around it: } else if( MODULE_ORDER_TOTAL_DISCOUNT_COUPON_DISPLAY_SUBTOTAL == 'true' ) { $subtotal = $total; foreach( $this->applied_discount as $discount ) { $subtotal += $discount; } I know that there are several versions of this contrib to download, so I am not sure if this will work. I am not a programmer. Please make back-up of any files you are changing, if you haven't already, prior to change just in case it doesn't go as planned. Not a fun situation. Hope that helps!
  14. allaboutwicker

    Seach Engine Friendly URL Support

    Hi, I have done a file compare on your product info file and the original oscommerce file I have and found these discrepencies: You have: <script language="javascript"><!-- function popupWindow(url) { window.open(url,'popupWindow','toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=no,res izable=yes,copyhistory=no,width=100,height=100,screenX=150,screenY=150,top=150,l eft=150') } //--></script> while the original has: <script language="javascript"><!-- function popupWindow(url) { window.open(url,'popupWindow','toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=no,res izable=yes,copyhistory=no,width=100,height=100,screenX=150,screenY=150,top=150,le ft=150') An then down further you have: <script language="javascript"><!-- document.write('<?php echo '<a href="java script:popupWindow(\\\'' . tep_href_link(FILENAME_POPUP_IMAGE, 'pID=' . $product_info['products_id']) . '\\\')">' . tep_image(DIR_WS_IMAGES . $product_info['products_image'], addslashes($product_info['products_name']), SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT, 'hspace="5" vspace="5"') . '<br>' . TEXT_CLICK_TO_ENLARGE . '</a>'; ?>'); //--></script> while the original has: <script language="javascript"><!-- document.write('<?php echo '<a href="java script:popupWindow(\\\'' . tep_href_link(FILENAME_POPUP_IMAGE, 'pID=' . $product_info['products_id']) . '\\\')">' . tep_image(DIR_WS_IMAGES . $product_info['products_image'], addslashes($product_info['products_name']), SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT, 'hspace="5" vspace="5"') . '<br>' . TEXT_CLICK_TO_ENLARGE . '</a>'; ?>'); //--></script> Try changing these sections back to the original and see if this fixes the problem.
  15. allaboutwicker

    Seach Engine Friendly URL Support

    Hi, I am not sure by your post that this problem has anything to do with the SEO contrib. If not, you should be posting in the general support section of the forums. I am a little confused on what it is you are describing. It sounds like you changed your product info file. If so, just use a compare file program to find any difference from the original and the one you changed to diagnose what you may have deleted or changed that would cause these problems. I do hope you made a back up copy before making changes! I didn't do that once and WOW bad move! Please post back if you still need help
  16. allaboutwicker

    [Contribution] Discount Coupon Codes

    Hi, I am a little confused on exactly what your situation is. If I am understanding correctly, you are having 2 separate problems. 1 with your table shipping module and 1 with your discount coupons. I think we should first make sure that the shipping is being calculated properly without any coupon applied at all. Is it working besides when you input a coupon??
  17. allaboutwicker

    [Contribution] Discount Coupon Codes

    Hi, sorry I am not familiar with that contribution as I am in the US, but I do remember it was tricky getting the 2 to work together. Of course, as I have a terrible memory of technical things, I can't remember exactly what I did to get it to work just right. Post back if you still haven't figured it out soon and I might have time later to download the NZ bank transfer mod and take a look and see if it is similar to the paypal one. Best Regards!
  18. allaboutwicker

    [Contribution] Discount Coupon Codes

    Hi, I have just started reviewing this thread for some solutions to my problems with integration of discount coupons with Fast Easy Checkout. Didn't find the answers yet, however, I saw your post and am trying to figure out your situation. From what I can gather, when a customer uses a coupon code during checkout, you are not getting the attributes in your admin order. I was just wondering if you use paypal ipn for your payment module. Sorry if this was already stated before. please post back
  19. allaboutwicker

    Linkpoint API Problems

    Has anyone else had these issues or is it just me? I have a heavily modified site, so it is hard sometimes to get new contributions installed properly. I hate to leave credit card payment turned on in this state, but I have now gotten another payment this way instead of paypal or google and can't afford to miss any more sales!
  20. allaboutwicker

    [Contribution] Discount Coupon Codes

    I am not sure what version you downloaded, but my catalog/admin/coupons.php has a lengthy bit of code in it. It came that way with the download. I just copied it to my catalog.
  21. allaboutwicker

    [Contribution] Discount Coupon Codes

    Hi, I had this contrib working fine intill I installed the Fast Easy Checkout contrib. Now I can't get the discount coupon option to show anywhere during checkout plus the comment box disappeared too! Any suggestions?
  22. allaboutwicker

    Linkpoint API Problems

    Hi, I have installed the linkpoint contrib which sort of works, but need help. The credit card and order info is going to Yourpay and being processed, however, the order is not being sent to my admin at all. Plus a customer told me that she did not get a any kind of confirmation screen. Thanks in advance for any help.
  23. allaboutwicker

    Links Manager II

    Hi Jack, I have started to enter my links from other sites from my old link page to this link program. I have done a few so far myself and all have gone through. So far the only one that didn't work was the one I posted about earlier where I got this error message Link Check Result: Error Reading URL Here is their URL of where my link was put I still haven't figure that one out, but approved the link, because I can physically see my link there. I was wondering if it has something to do with the URL or the length of it?? Not too big of a deal, but I am trying to learn and understand as much of this oscommerce stuff as I can. Now I have found that when I went in to turn a link category on I got the following: Fatal error: Call to undefined function: tep_set_link_categories_status() in store/admin/link_categories.php on line 40 When I went into edit the category and enable it there it worked, but I was wondering if I should be concerned about this error I am getting. Thanks for all your help!!!
  24. allaboutwicker

    Links Manager II

    Thanks again for all your help!! I have to log off now, but I did get a chance to download new version and at least uploaded the admin/links.php file which did fix the error message when I changed from ALL to Pending! I will have to work on this more tomorrow. Have a Blessed evening!!!!
  25. allaboutwicker

    Links Manager II

    Hi Jack, Thanks for helping me. I am not sure I understand your last comment. I have been trying to figure this out and also found that when I go into admin then Links and try to switch to anything other then ALL, I get the following error: 1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'l.links_status = '1' and' at line 1 select count(*) as total from links l left join ( links_description ld ) on ( l.links_id = ld.links_id ) l.links_status = '1' and I cannot find any other post regarding this error either. Thanks, Leslie
×