Jump to content

quin

Members
  • Content count

    211
  • Joined

  • Last visited

Everything posted by quin

  1. quin

    NEW! Complete Order Editing Tool!

    I have a new problem, I think- and yes, I checked to make sure the module was installed :) If I select PayPal as my payment choice and then go to order it doesn't show a payment at all- it's just blank- and when I go into edit_orders and look at the payment method dropdown it shows PayPal, followed by a blank, followed by Other- and the blank is showing as the payment for that particular order. Anyone else run into this?
  2. quin

    NEW! Complete Order Editing Tool!

    cc_validation belongs in includes/classes rather than includes/languages/english/modules/payment and is called by cc.php rather than directly from oe. One thing you might try is a different cvv contrib- if a different one works then you know the cause lies with cvv2 rather than oe- the one I'm using that does work is: http://www.oscommerce.com/community/contributions,99/
  3. quin

    NEW! Complete Order Editing Tool!

    I use a cvv contrib and didn't do all of this- I did as follows (of course, you would need to change where I have cvvnumber to match cvv2) and it works fine with OE: in admin/edit_orders cc_expires = '" . tep_db_prepare_input($_POST['update_info_cc_expires']) . "', cvvnumber = '" . tep_db_prepare_input($_POST['update_info_cvvnumber']) . "', shipping_tax = '" . tep_db_prepare_input($_POST['update_shipping_tax']) . "'"; farther down, same page <tr> <td class="main"><?php echo ENTRY_CREDIT_CARD_EXPIRES; ?></td> <td class="main"><input name="update_info_cc_expires" size="4" value="<?php echo $order->info['cc_expires']; ?>" maxlength="4" /></td> </tr> <tr> <td class="main"><?php echo ENTRY_CREDIT_CARD_CVVNUMBER; ?></td> <td class="main"><input name="update_info_cvvnumber" size="4" value="<?php echo $order->info['cvvnumber']; ?>" maxlength="4" /></td> </tr> </table> in admin/languages/english/edit_orders define('ENTRY_CREDIT_CARD_EXPIRES', 'Card Expires:'); define('ENTRY_CREDIT_CARD_CVVNUMBER', 'CVV Number:'); define('ENTRY_SUB_TOTAL', 'Sub Total:');
  4. quin

    NEW! Complete Order Editing Tool!

    Worked perfectly- thank you! And adding a cvv number to it was easy enough to make me feel like I had a clue LOL!
  5. quin

    NEW! Complete Order Editing Tool!

    dj- just wanted to let you know that I figured out the shipping problem this morning- I'm embarrassed to say that somehow I had turned off shipping in the order totals module and once it got turned back on it worked perfectly. Now I'm having an issue with the credit card fields not showing up but it looks like you've got a fix for that in the newest package so hopefully that will square it away- thanks again!
  6. quin

    NEW! Complete Order Editing Tool!

    No- it's on, I had problems with that last year when I was running a cron job so if it goes off (for example, when they moved my site onto a new server without telling me) I always know right away because the cron doesn't work. I'm going to look into the free shipping/minimum amount mod- maybe there's something in there screwing things up with the edit. Thanks for trying though!
  7. Yep- just what Rachael said, double-check that you're using the username/password that froogle/google gave you when you signed up.
  8. Thank you very much- I'm going to try that out later today!
  9. It is until a feed is created and stored there- did you upload the new files to your server? I think, and you would need to double-check your folder as I normally delete anything extra so I won't inadvertently add it to mine, that would be everything except column_left- so, for example, to store/admin/ you would add: froogle_de.php froogle_uk.php froogle_us.php yahoo.php bizrate.php feeders.php
  10. quin

    NEW! Complete Order Editing Tool!

    I've put through 4 test orders this morning (making sure to keep them under $25 so they won't qualify for free shipping) and all 4 of them show the right total WITH shipping but when I go to the database they only list the total (sort order 6) and sub-total (sort order 1) and no shipping (even as ot_custom) at all. When I go in to the edit_orders and click update they lose the shipping completely and nothing changes in the database. I thought maybe there was a conflict with something else so I searched for 'ot_custom' using Dreamweaver and edit_orders is the only file using it in the entire site.
  11. the feeds.sql file shouldn't break your store- just open it in Notepad and copy the entire thing- use 'Select All' so you don't miss anything- then open phpMyAdmin and navigate to that database and click on the 'sql' tab at the top of the right frame. Paste the contents of the feeds.sql file that you just copied into the text area (the heading on the box is: 'Run SQL query/queries on database') and then click on the button that says 'go'. When you go back into the Admin area of your store and click on the Configuration area you should then see a line that says 'Feed Settings' where you will input your username/password etc for the assorted feeds.
  12. quin

    NEW! Complete Order Editing Tool!

    Nope- no change, still drops the shipping.
  13. I would double-check the configuration settings- the file is located at store/includes/configure.php- and make sure your database connection is properly defined and in particular the password. It is the last section of code and begins with: // define our database connection define('DB_SERVER', 'localhost'); // eg, localhost - should not be NULL for productive servers
  14. try to find the configuration file and re-upload it or, if you have the sql backed up, go into phpmyadmin, click on the database you use for the store and then on 'Import' and from there it's pretty self-explanatory. You could also, if you've been using the Admin section to do your backup's, try to 'backdoor' in by going straight to the backup page and telling the store to restore to an earlier date. The URL should be: http://charmedbystarr.com/store/admin/backup.php
  15. quin

    NEW! Complete Order Editing Tool!

    No- I actually created a new test order when you asked for the information so I know it hadn't been edited/messed with at all.
  16. When you downloaded the contrib and unzipped it there was a folder inside the folder named new installation that is called 'catalog' and contains all of the files you need. If you simply uploaded that folder onto your server as is then your store isn't going to find them- you will need to rename the folder 'store' and upload it again- if you've already modded your oscommerce files though you will need to go through and only reupload the new files for this contrib: /store/admin/froogle_us.php /store/admin/froogle_uk.php /store/admin/froogle_de.php /store/admin/feeders.php /store/bidhopper.com
  17. quin

    NEW! Complete Order Editing Tool!

    It's listed as ot_custom: text value class $2.55 2.5500 ot_custom
  18. quin

    NEW! Complete Order Editing Tool!

    Hmm- it comes up as custom: $2.55 2.5500 ot_custom
  19. I was notified today that I needed to update my feed to meet google base's new requirements and installed this and am really liking it (particularly the feature where it doesn't include $0 products!) but I'm not sure it meets the minimum requirements as I'm understanding them from Google's site- for example, according to their page (http://base.google.com/base/products.html) the following attributes are required: * brand * condition * description * expiration_date * id * image_link * link * price * product_type * title But the feed is missing these: * brand * condition * expiration_date * product_type Is there a way to add these to the feed? Or even to hardcode for attributes that are the same for everything (for example, expiration date or the non-required attribute of payment)?
  20. quin

    NEW! Complete Order Editing Tool!

    When a new order comes in it looks fine and shipping is included in the total though it's not displayed (it shows sub-total and then total and the total is correct WITH shipping so it's being added in even though it's no longer displayed) since I added this. When I click on 'edit' as long as I hit 'back' without actually editing anything it's still fine but if I click on 'update' at the bottom, whether I change anything or not, shipping is simply dropped completely from the total. Somewhere, it seems to me but I'm guessing since I really don't 'know' php but just generally muddle my way through (let's hear it for cut and paste!), it's not passing the shipping variable properly but I haven't even the first clue which section to start looking for the problem.
  21. quin

    NEW! Complete Order Editing Tool!

    Ah darn it- I was really hoping for a simple fix- thank you though.
  22. quin

    NEW! Complete Order Editing Tool!

    This is interesting- when I checked my table for this I found that the numbers are being carried but not properly for either the Total or Coupons- they have <b> and </b> around it. Could this be why my shipping is being dropped? Or is it, since it seems to show up for Total from the very first order before I ever modded anything, nothing to worry about? (example: title text value Total: <b>$8.12</b> 8.1200 Discount Coupons:c3b359: <b>-$3.28</b> 3.2800)
  23. There's a fix here you can try: http://forums.oscommerce.com/index.php?sho...mp;#entry763574 Looks like the assorted fixes are hit and miss- some work for some people and some work for others.
×