Jump to content

psxgunman

Members
  • Content count

    14
  • Joined

  • Last visited

Everything posted by psxgunman

  1. psxgunman

    [contribution] Tracking Module

    It might help if I was skilled enough to cut and paste the correct bits the url is this to be entered into the module tracking box https://www.royalmail.com/track-your-item?trackNumber= And its all working fine as I have just checked it the parcel force one might work as well but the code would need adjusting to filter the result
  2. psxgunman

    [contribution] Tracking Module

    Royal mail have changed the URL slightly its now http://www.parcelforce.com/portal/pw/track?trackNumber= If the module ever stops working add in a debug line around line 79 in /catalog/rm_tracking.php $grab_data = $data; Add echo $grab_data; And you will see what response you are getting from the Royal Mail (or any other site!) if the url changes you will see the redirect message and the new url to use.
  3. psxgunman

    [contribution] Tracking Module

    Just before you all moan noticed another change that needed to be done to give the clickable link In /catalog/rm_tracking.php about line 101 Change $content = str_replace("the button below", "<a target=\"_blank\" href=\"" . $url . "\">here</a>", $content); // replace click here to view POD with link to RM page. to $content = str_replace("Printed", "Signature", $content); $content = str_replace("Print", "<a target=\"_blank\" href=\"" . $url . "\">Click Here</a>", $content); // replace click here to view POD with link to RM page.
  4. psxgunman

    [contribution] Tracking Module

    The Url to use is this https://www.royalmail.com/track-your-item?trackNumber= Won't work unless its https as the site auto 301 directs And I have only spent about 5 mins looking at this but to make it work again for Royal Mail Change the line in /catalog/rm_tracking.php around line 95 from $text = preg_match('/<div id="tnt-results">(.*)<input type="hidden" name="form_build_id"/i', $grab_data, $content); to $text = preg_match('/"status result-row padding20lr">(.*)"result-row form margin20lr"/i', $grab_data, $content); Anytime they change it you just need to look at the source html code and select the start and end tags either side of the info you want to display I'll await an avalanche of thanks written on 5 pound notes
  5. psxgunman

    Support for Stripe.com?

    Had a look at the zen one so I converted it to OsCommerce 2.2 Its a simple convet for anyone who knows what they are doing
  6. psxgunman

    photo gallery for oscommerce

    In gallery.php if you have installed your shop to a seperate directtion ie /catalog/ Then all the java script calls are wrong For example line 25 <script type="text/javascript" src="<?php echo HTTP_SERVER ?>/highslide/highslide.js"></script> needs to be <script type="text/javascript" src="highslide/highslide.js"></script> And in the style parts (these really need taking out from this files and adding to the main stylesheet You need to remove all the ?php echo HTTP_SERVER ?> as well to correct this error. You also need to add after this line echo '<input type="text" name="comment_naam" value="'.TEXT_NAME.'" onClick="this.value=\'\'">'; this echo '<input type="hidden" name="osCsid" value="'. $_GET['osCsid'].'">'; To prevent the logging out errors The same fix is also needed in gallery_user.php
  7. psxgunman

    photo gallery for oscommerce

    It's because the function has been hardcoded to a figure of 25 and unless you have 25 or more images in the gallery it will give this error change in /includes/boxes/gallery.php $rand_keys=array_rand($pictures,25); to this $rand_keys=array_rand($pictures,count($pictures)); And that will fix the error
  8. psxgunman

    [contribution] Tracking Module

    I have seen this error mentioned a couple of times in this thread Error calling tracking script. Please try later. [x] Close Having had the error myself and not havign seen the solution in this thread I thought I would post it to help anyone else out open /catalog/includes/classes/tracking_module.php and look for $path = empty($admin) ? "" : "../"; $wait = TRACKING_AJAX_WAIT; and replace it with this (ideally this is how the code should be and you should really as security measure move the admin folders from within the catalog ones) $path = empty($admin) ? "" : DIR_WS_CATALOG; $wait = TRACKING_AJAX_WAIT; Great contribution by the way ;)
  9. psxgunman

    Warning: htmlspecialchars()

    Scroll down a bit from the above change where you add the [title] and find $statecomma = ''; $streets = $street; if ($suburb != '') $streets = $street . $cr . $suburb; if ($country == '') $country = tep_output_string_protected($address['country']); if ($state != '') $statecomma = $state . ', '; and change that to $statecomma = ''; $streets = $street; if ($suburb != '') $streets = $street . $cr . $suburb; if ($country == '') $country = tep_output_string_protected($address['country']['title']); if ($state != '') $statecomma = $state . ', '; That should do it
  10. www.scootersoftware.com and look for Beyond Compare v2
  11. Its because the original script put the created password into the database and didnt encrypt it. When the customer then tries to login the script matches an encrypted version of what is typed against the unencrypted database contents. Hence no login. This was a reason i changed it to a default of changeme as it avoids this problems and the countless emails from customers saying ' I cant login' Changes to make to an existing install if yours is working fine to do this are in /admin/create_account_process.php Rem out the randomize script part below And make this small change to the email sent at the bottom
  12. I found even when following the helpful advice given in this thread i couldnt edit any manually created customer accounts and traded the problem to the error being the wrong figure being put into the database for the address book reference. I also changed the created accounts password to a default of changeme as I foudn the random created one was being put into the database unencrypted and hence the customer wasnt able to log in. Sorry for the double post but i pressed submit before i was ready and you cant edit posts here
  13. I had an edit and made this wonderful idea work with my MS2 store. I didnt keep any notes of what i changed so you would have to look at the files and compare. Hopefully this will help someone else http://www.oscommerce.com/community/contributions,1526
×