Jump to content

JetSet27

Members
  • Content count

    14
  • Joined

  • Last visited

About JetSet27

  • Birthday 05/10/1952

Profile Information

  1. JetSet27

    USPS Rate V4, Intl Rate V2 (official support thread)

    When a problem appears, it is rare that you find reports from others with the exact same issue. It is even more unusual to find a simple fix which works immediately. Our UK clients were getting the same USPS module error which was mentioned here earlier by @TomB01. Thank you @kymation for providing the quick solution!!
  2. JetSet27

    FedEx - Web Services v9

    I don't know how to link to it, so let me re-post a message I wrote on this topic last June. This has never been addressed, and we are still having the same problem. Maybe it's the same as your problem? = = = = = = = = Many thanks for this contribution! After installing Fedex Web Services 9 on our site (osc 2.2), it seemed to be working fine. But just to be sure I compared the rates which were being quoted on our store with the rates we get simply by logging into the FedEx website. The rates for "FedEx 2 Day" and "FedEx Express Saver" match to the penny. But the rates for "Standard Overnight" and "Priority Overnight" are way off. Just to experiment, I zero'd out all our handling fees, and tried it both with displaying "list" and "account" rates. The numbers do change, but they're still wrong. Here's an example. We currently have the FedEx shipping module set to display ACCOUNT rates, and add a $5 handling charge. Let's use a hypothetical .8 pound package going from Dallas 75227 to Chicago 60601. Our OSC store quotes the following: Priority Overnight - $46.90 Standard Overnight - $42.66 But logging into fedex.com and getting a rate quote for the same package with our same account number, we get: Priority Overnight - $25.41 Standard Overnight - $23.66 Even adding the $5 handling fee to the FedEx quote, you can see that the rates shown on our store are > $15 higher. And yet the rates for FedEx 2 Day and FedEx Express Saver agree perfectly. (These are the 4 services we are offering, so I did not compare any of the other possible rates.) How can this be happening? And, more importantly, can anyone suggest a fix? I would encourage everyone to try a similar test to make certain that the prices you are displaying have some basis in reality. Thanks.
  3. JetSet27

    FedEx - Web Services v9

    Can you please post the details of what you changed or added so I can try it? Thank you for (1) confirming that the problem exists and (2) working on a solution.
  4. JetSet27

    FedEx - Web Services v9

    Many thanks for this contribution! After installing Fedex Web Services 9 on our site (osc 2.2), it seemed to be working fine. But just to be sure I compared the rates which were being quoted on our store with the rates we get simply by logging into the FedEx website. The rates for "FedEx 2 Day" and "FedEx Express Saver" match to the penny. But the rates for "Standard Overnight" and "Priority Overnight" are way off. Just to experiment, I zero'd out all our handling fees, and tried it both with displaying "list" and "account" rates. The numbers do change, but they're still wrong. Here's an example. We currently have the FedEx shipping module set to display ACCOUNT rates, and add a $5 handling charge. Let's use a hypothetical .8 pound package going from Dallas 75227 to Chicago 60601. Our OSC store quotes the following: Priority Overnight - $46.90 Standard Overnight - $42.66 But logging into fedex.com and getting a rate quote for the same package with our same account number, we get: Priority Overnight - $25.41 Standard Overnight - $23.66 Even adding the $5 handling fee to the FedEx quote, you can see that the rates shown on our store are > $15 higher. And yet the rates for FedEx 2 Day and FedEx Express Saver agree perfectly. (These are the 4 services we are offering, so I did not compare any of the other possible rates.) How can this be happening? And, more importantly, can anyone suggest a fix? I would encourage everyone to try a similar test to make certain that the prices you are displaying have some basis in reality. Thanks.
  5. We have been using osC-2.2ms2 for a couple of years, and have modified the look, text and functions as needed. We have not installed the QPBPP contribution before, but now want to add the most up-do-date version of it. I am having a little trouble determining which version to download. There are many choices here, but several appear to be fixes or improvements of earlier versions. I need to install the whole thing (manually, so as to preserve our existing mods). So which download file has everything in it that we need (including install instructions)? Suggestion: It would be handy if contributors would add a sentence like "this package includes the original contribution and all upgrades and fixes through this date" (if applicable) because it would eliminate the need for silly questions like this. Thanks!
  6. JetSet27

    The middle 8 digits of a credit card number

    Never mind... I found it in cc.php (duh). :blush:
  7. Where in osCommerce is the code which composes the e-mail containing the middle 8 digits of the customer's credit card number? Which php module is it in? I understand the concept of the program only storing a partial cc # and e-mailing the rest for security, and it's working. I'd just like to change the format of the e-mail message a little, but can't find where it's coming from. Thanks-
  8. Hi- I'm using the FedEx shipping module, which seems to work fine for domestic (US) shipments. It's not returning the discounted rates that we're entitled to, even though it knows our account number, but I can live with that. (unless there's a quick fix?) The real problem is that when shipping from the US to Canada (or any international destination), it says "No Rates Returned". I put the module in Debug mode and this is what I got. But I don't know how to interpret the data, so I don't know what it's trying to tell me. (I've deliberately x'd out a few digits of our account number.) In this test, I'm trying to ship from Dallas Texas to Toronto Ontario: Data sent to Fedex for Rating: 0,"25"10,"075xxxx14"498,"7746352"8,"TX"9,"75227"117,"US"17,"M4T1Y1"16,"ON"50,"CA"75,"LBS"1116,"I"1401,"1.3"1529,"1"1415,"69.00"68,"USD"440,"N"1273,"01"1333,"5"1529,"2"99,"" Data returned from Fedex for Rating: 0,"125"1133,"1"2399-1,"0"2405-1,"Y"1273-1,"01"1274-1,"92"1090-1,"USD"431-1,"N"1402-1,"2.0"1416-1,"10.75"1417-1,"0.48"1418-1,"0.00"1419-1,"11.23"1530-1,"10.75"1507-1,"0.48"1531-1,"0.00"1528-1,"11.23"1525-1,"0.00"3058-1,"4"99,"" Can anyone help me with this? Many thanks.
×