Jump to content

ari

Members
  • Content count

    53
  • Joined

  • Last visited

1 Follower

Profile Information

  • Real Name
    Ari
  • Location
    NYC
  • Website
  1. Is there a contribution out there that allows me to manually enter the total cost for a given order so that later on I can calculate the net profit for that order. The contribution that allows you to enter the cost of every product is not so helpful since there are always changes - to the cost, cost of shipping and other expenses related to one prticular order. thanks Ari
  2. thanks devx, I am running Apache/2.0.51 (Fedora) and PHP Version: 4.3.11 (Zend: 1.3.0) with the Plesk CP. Hope this tells you the mode in which my PHP is running. Can you tell me what changes to the redirect code I might need? thanks, Ari
  3. Hi all, I have upgraded my SEO URL from V2.0 to V2.1d. I had the older version for some time, using URL format cName, and all my Google links look like this: http://www.beforeyoubuy.org/product_info.php?pName=bioque-serum-xl-1-ounce-bottle With v2.1d I have to use the URL Rewrite Type and my links look like this: http://www.beforeyoubuy.org/bioque-serum-ounce-bottle-p-485.html Enable automatic redirects is set to True, but the page isn't redirecting properly. It seems to be stuck in a loop of redirect attempts. I really wanted to make the switch and keep the old links working. Is it at all possible? thanks Ari
  4. I did not upgrade since - do you know where I should look for this method? Ari
  5. Is there a way to activate a coupon code via a URL so that when the customer clicks on the link (in an email or banner ad) the coupon will be in the cart? I find that customers are reluctant to create an account to see if the deal is for real. Thanks ? Ari
  6. I am guessing it is not caching the product description, only the name - is this correct? Finally 24h ago I deployed the contribution to my production server and except for little annoyances it seems to be working well. If someone cares to check - Exit15.com. It took me some time to test because I had a few issues to deal with that needed tweaking. I will share them here for the sake of the feedback and helping others: First, was the need to make it work with the manufacturer (mName). That's only partially working - the pull down menu is still calling up manufacturers by ID, but SE don't follow forms so I don't really care. Secondly, I needed to make sure it works with my Article Manager contribution. Thanks to a fellow named Matti and a little tweaking, it is now working. Third, was the effort to make it work with a mod I put in a while ago to prevent Robots from adding items to the cart (they did it even without getting a session id). This item works well in most templates (we must not mess with add to cart) except for one minor annoyance - the "alt text" on the buy button in the ?advanced_search_results.php? refuses to get the actual text displayed and Instead I have the ?TEXT_BUYTEXT_NOW?. I tried everything to fix it, but it needs a fresh eye. Fourth, I had a redirection problem - if I turn the contribution OFF through the admin, application_top.php attempts to redirect the regular URL to itself resulting in an endless loop. I went live with this problem hoping not to have to turn the SEO URLs off (if I do, I can simply comment out the line requiring the redirect file in application top) Last, is the caching issue ? I am missing something or there is a small bug in the contribution. The fist request to the site after re-setting the cache, comes back with an error. Consequent requests are ok, so I figured I will simply make the first request myself if, for whatever reason, I need to reset the cache. Ari
  7. I had the same problem and then I remembered that I changed my "add to cart" to form submission rather then href - so whenever you have somthing like this... case 'buy_now' : ? ? ? ?if (isset($HTTP_GET_VARS['products_id'])) change it to HTTP_POST_VARS
  8. Any idea why when I set the ?Enable SEO URL?s? to false, my category links start spinning in an endless redirect loop? Shouldn?t is be include only if ?Enable SEO URL?s? set to ?true?? Ari
  9. folks, I am trying to gather some support, help and feedback for the SEO Popularity Engine at this topic: http://forums.oscommerce.com/index.php?showtopic=139239 this could be a site changing event...
  10. I had the same problem installing the SEO for articles enhancement - and then I read your post in this thread suggesting to comment out one line of code. Magic - it did work! Did you had any other issues with this? - really want to go live with this.
  11. Hi, I just moved my osCommerce site from a shared hosting outfit to a VPS / Plesk 7.1.5. Unfortunately, the keyword show contribution stopped working. I tried the host's support and searched this forum, but could not find an answer, Perhaps someone here has an idea. Here's what's happening: I supplied the script with the absolute path to the log file /home/httpd/vhosts/mydomain.com/statistics/logs/access_log - nothing works? I then copied the file access_log to /tmp and to /httpdocs just to test the script using the following paths: /home/httpd/vhosts/mydomain.com/tmp/access_log and /home/httpd/vhosts/mydomain.com/httpdocs/access_log, respectively. The script runs successfully when pointed to /httpdocs. I noticed that the permissions on the /statistics are not the same as /httpdocs, so I asked the host to give the ftp user for that domain rights on /statistics... it did not help. The error by the way is the same error one would get when supplying the WRONG path: in /home/httpd/vhosts/exit15.com/httpdocs/admin/keyword_show.php on line 82 Warning: gzclose(): supplied argument is not a valid stream resource in /home/httpd/vhosts/exit15.com/httpdocs/admin/keyword_show.php on line 116 Keywords, search from Google Warning: gzgets(): supplied argument is not a valid stream resource in /home/httpd/vhosts/exit15.com/httpdocs/admin/keyword_show.php on line 121 And so on.... So I am guessing that somehow the PHP engine or the script cannot read files outside /httpdocs. My previous host had a similar structure, (htdocs and logs) and it worked fine there. What can the problem be? Thanks Ari
  12. Thanks Steve, I tried it, it worked - the button goes away (I used Firefox with User Agent Switcher to browse the site). But I ended up turning all the URL actions into FORM, there are a few templates that have this problem and I wanted to make sure I covered all of them. product_reviews.php product_reviews_info.php products_new.php all_products.php I will now go and post this solution in another thread that a similar discussion. thanks again Ari
  13. Thanks Steve, I think I see what's happening -- the product detail page i.e. "product_info.php" uses a FORM action which is not causing any problem with robots, but the category listing or whatever template is used by this "/index.php?cPath=11_22" template is using a URL action to add to the cart (the action name is "buy_now"). How did this happen? I don't know. I am sure there are more templates that are doing the same (search_results.php, etc.) There is a contribution out there that explains how to change everything back to a FORM action. I didn't want to use it because I thought there was a reason for making it a URL action. Now that I find some templates are using FORM and others URL, I think I will just change all of them to FORM. What do you think? Lots of folks, on other threads, have described the same problem. If you confirm this solution, we should post this message on a few other threads. Ari
  14. What do you use if not "buy now" (or "add to cart")? - I did not play with that function at all. Your idea is a good one - some people suggested changing the "add to cart" to a FORM function which is ignored but all robots. How would you go about ot showing the button if the session is not started? Ari
  15. thanks Steve, ...ooglebot sounds good... My settings are fine - googlebot does not create a session, it is just trying to "buy" and then it is being sent to the cookie_usage page. here's a sample I have about 200 products, but with this "new" behavior (it started doing it recently) googlebot is hitting about 1000 pages a day. What a waste! --- Someone suggested adding a disallow for the cookie usage page in robots.txt. That might cut the number of pages in 1/2, but we really need to prevent it from following the "action=buy_now&products_id=xyz" link. Any idea? Ari
×