Jump to content

kewldude_3001

Members
  • Content count

    365
  • Joined

  • Last visited

Everything posted by kewldude_3001

  1. kewldude_3001

    [Contribution] STS v4

    hey, its me again, I had a question, this is probably simple, but what I'm trying to do is change my background color for the page, but in order for it not to affect the rest of the contents in the middle of the page, i guess i need to add a table around everything, but when i just add <table><tr><td> at the very top and then try to close it at the very end, it mess's up. can you help me with that.
  2. kewldude_3001

    Need help with my new template

    My solution for you is go get a fresh install of oscommerce the new version and then install the STS templates system and associate the template you bought with STS and everythign should be fine
  3. kewldude_3001

    a little bit problems

    if your trying to add a seal, trying adding a new infobox and then adding the code there
  4. kewldude_3001

    [Contribution] STS v4

    hey bill, im basically done with the major editing of the site, check it out :) Site Thanks for all the help from you and anyone else that has contributed :), lol sorry for some non-sts related or "dumb" questions, because im post happy :)
  5. kewldude_3001

    [Contribution] STS v4

    YAYYYYYYYY i did it, i fixed it, i read through the contributions for this: http://addons.oscommerce.com/info/5236 and fixed it, the key thing is to download the latest from the guy's site and then follow the first instructions by Erik Svensson and then do this lil part Edit: includes/modules/sts_inc/product_info.php About in line 80 find: ------------------------------------------------------------------------------------------------- $template_pinfo['product_popup']= '<script language="javascript"><!--'."\n". 'document.write(\'<a href="java script:popupWindow(\\\'' . tep_href_link(FILENAME_POPUP_IMAGE, 'pID=' . (int)$products_id) . '\\\')">' . $template_pinfo['imagesmall'] . '<br>' . TEXT_CLICK_TO_ENLARGE . '</a>\');'."\n". '//--></script>'."\n". '<noscript>'."\n". '<a href="' . tep_href_link(DIR_WS_IMAGES . $product_info['products_image']) . '" target="_blank">'.$template_pinfo['imagesmall'] . '<br>' . TEXT_CLICK_TO_ENLARGE .'</a>'."\n". '</noscript>'."\n"; } else { $template_pinfo['imagesmall'] =''; $template_pinfo['imagelarge'] =''; $template_pinfo['product_popup']='' } ------------------------------------------------------------------------------------------------- Replace with: ------------------------------------------------------------------------------------------------- $template_pinfo['product_popup']= '<a rel="lightbox" href="' . tep_href_link(DIR_WS_IMAGES . $product_info['products_image']) . '" title="'. $product_info['products_name'] .' - '. $manufacturer['manufacturers_name'] .'">'.$template_pinfo['imagesmall'] . '<br>' . TEXT_CLICK_TO_ENLARGE .'</a>'."\n"; } else { $template_pinfo['imagesmall'] =''; $template_pinfo['imagelarge'] =''; $template_pinfo['product_popup']=''; } ------------------------------------------------------------------------------------------------- As you can see it's the $template_pinfo['product_popup'] that has to be changed. That's all. Good luck. Check out how it works if you dont know how it works already :) My Site lol sorry for all the posts, but it helps me to see what the problem is, i bet if i waited to try everything then i wouldnt have posted at all :)
  6. kewldude_3001

    [Contribution] STS v4

    lol funny thing, i turned off popup_image from the admin side and deleted the javascript from the product_info.php.html (inside the content folder) and it started working. But its not using the lightbox effect for the window. i thought if i didnt use a template it would execute like the default and its not :( i see one for sts :), i'll let u know how it turns out :)
  7. kewldude_3001

    [Contribution] STS v4

    im doing something wrong with the template, cause it worked when i turned off sts :( i just installed lightbox which is a cool way of showing the popup image, will that work with sts?
  8. kewldude_3001

    [Contribution] STS v4

    yayyyyy :), it opens it, now to make it actually show the larger images. i changed my popup_image.php to contain this so what else do i need to do to make it show the larger images instead of the smaller ones <body onLoad="resize();"> <?php echo tep_image(DIR_WS_IMAGES.'/images_big/'.$products['products_image'], $products['products_name']); ?> </body>
  9. kewldude_3001

    [Contribution] STS v4

    my images (big) are located under catalog/images/images_big i think i did something to make the images_big work before but i dont remember, do i have to do something??? i copied the code but it still gives me the error saying object expected this is whats inside my popup_image.php.html <?php define ('STS_END_CHAR', '}'); ?> <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"> <html $htmlparams}> <head> <!--$headcontent--> <script language="javascript"><!-- function resize() { var i=0; var MarginW = 60; var MarginH = 140; if (document.layers) i=40; if (document.prodimage.width>document.bannerimage.width) {Width=document.prodimage.width +MarginW} else Width = document.bannerimage.width+MarginW; Height = document.prodimage.height+document.bannerimage.height+MarginH; window.resizeTo(Width,Height); self.focus(); } //--></script> <script language="javascript"><!-- function popupWindow(url) { window.open(url,'popupWindow','toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=no,res izable=yes,copyhistory=no,width=100,height=100,screenX=150,screenY=150,top=150,le ft=150') } //--></script> <?php // BOF: More Pics 6 ?> <meta http-equiv="Page-Enter" content="blendTrans(Duration=0.5)"> <meta http-equiv="Page-Exit" content="blendTrans(Duration=0.5)"> <?php // EOF: More Pics 6 ?> </head> <body onLoad="resize();"> <table width="100" border="5" align="center" cellpadding="5" bgcolor="#FFFFFF" id="table1"> <tr> <td> <table border="0" cellpadding="0" cellspacing="0" style="width: 100%; border-collapse:collapse" bordercolor="#111111"> <tbody> <tr> <td> <img border="0" src="images/oscommerce.gif" name="bannerimage"></td> </tr> </tbody> </table> <p align="center"><font face="Arial">$productname}</font><font color="#808080" size="2">[$productmodel}]<br> </font>$popupimage}</td> </tr> </table> </body> </html>
  10. kewldude_3001

    [Contribution] STS v4

    forget about the featured products question, my new question is im trying to get the popup_image to work, i installed it in admin, and i copied the template from the full example just to see if it works and placed it sts_templates/mytemplate/popup_image.php.html and when i click on the click to enlarge, it doesnt do anything, shows an error on the bottom left.
  11. kewldude_3001

    [Contribution] STS v4

    happy birthdayyyyyy and happy new year bkellum!!!!!!
  12. kewldude_3001

    [Contribution] STS v4

    ooooo I have an STS question :), how can i get the header for Featured Products to display??? i have the header ready and in the content folder named infobox_featured_header.php.html. thanks
  13. kewldude_3001

    [Contribution] STS v4

    i just had to make the .... colspan to 2 to make it expand, im starting to think it might not exactly look like the one below but im going to try though!
  14. kewldude_3001

    [Contribution] STS v4

    Ok, can you help me fix the remaining part??? I tried but its not doing anything. Site 1) Change the Product color, even though i have the class set to the appropriate class, its still not changing. 2) Align things properly, and show the entire product name. 3) And add the border around the entire featured products table.
  15. also i need some help rearranging the way, the product is shown in the box, and also I want to add a header that says FEATURED PRODUCTS, so how can i insert that into the featured.php (module), like what part
  16. kewldude_3001

    [Contribution] STS v4

    <tr> <td background="images/infobox_module/left.gif" width="14"> </td> <td align="center" class=mws_boxCenter_module><a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $featured_products['products_id']) . '">' . tep_image(DIR_WS_IMAGES . $featured_products['products_image'], $featured_products['products_name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT) . '</a><br><br> <a href="' . tep_href_link(FILENAME_FEATURED_PRODUCTS). '">' . tep_image(DIR_WS_LANGUAGES . $language . '/images/buttons/featured.gif', IMAGE_FEATUREDPRODUCT). '</a> </td> <td class=mws_boxCenter_module2>'. strip_tags($description['products_description']) . '<a href="' . tep_href_link(FILENAME_PRODUCT_INFO, "products_id=" . $featured_products["products_id"]). '"><b>' . DESCR_READ_MORE . '</b></a><br><br> <s>' . $currencies->display_price($featured_products['products_price'], tep_get_tax_rate($featured_products['products_tax_class_id'])) . '</s><br><a href="' . tep_href_link(FILENAME_DEFAULT, tep_get_all_get_params(array('action')) . 'action=buy_now&products_id=' . $featured_products['products_id']) . '">' . tep_image_button('cart_buy.gif', IMAGE_BUTTON_IN_CART) . '</a> <span class="productSpecialPrice">' . $currencies->display_price($featured_products['specials_new_products_price'], tep_get_tax_rate($featured_products['products_tax_class_id'])) . '</span></td> <td background="images/infobox_module/right.gif" class="smallText" width="14"><img src="images/infobox_module/right.gif" width="14" height="149" /></td> </tr> how should i edit that to make it look like the featured products below it?? on my site.
  17. kewldude_3001

    [Contribution] STS v4

    its done, so what would i name the file that i want to use as the template of those individual boxes?
  18. hey, i have a question, Its about the product description, I would like to show only the book condition on the main page and when they click on the more info, it can show the rest of the information. how can i do that?
  19. kewldude_3001

    [Contribution] STS v4

    i decided to install that individual boxes contribution :) i stopped after step 4, since im not using it for the new products, or specials modules. and i am about to start with the featured add on install
  20. kewldude_3001

    [Contribution] STS v4

    lol i guess i prolly did it the hard way, why is it showing the placeholders???
  21. kewldude_3001

    [Contribution] STS v4

    sorry about the other questions, i'll do that next time. about the featured_products i made one called infobox_featured_products.php.html with the following design, now how can i get that to apply for the featured products on the main page?
  22. kewldude_3001

    [Contribution] STS v4

    i only need to add this code right? $sts->start_capture(); include(DIR_WS_INCLUDES . 'boxes/featured.php'); $sts->stop_capture('featuredbox'); now if i make an infobox template exactly like the one i have on the site (the bottom one), do i just insert productname1, productname 2 and so on so it displays each one or do i have to do some kind of loop????
  23. kewldude_3001

    [Contribution] STS v4

    which featured_products.php would i even start to edit so i can change how it looks on the index.php
  24. kewldude_3001

    [Contribution] STS v4

    lol, i started to backup my files, so i could replace them with the modified files, and i the first file i replaced was the index.php and for some reason i decided to see if that changed everything and guess what? it showed up so i didnt have to change anything else :) now the hard part of making that look like the featured products below it :(
  25. kewldude_3001

    [Contribution] STS v4

    lol sigh :(, i'll try i used that one since i alreay had that version installed on my other site and since im using the same database i didnt want to run the same query but i'll try. the one i installed was Featured Products 1.5.9 Complete Pack (installation guide modified)
×