Jump to content

kewldude_3001

Members
  • Content count

    365
  • Joined

  • Last visited

1 Follower

About kewldude_3001

  • Birthday 09/29/1987

Profile Information

  • Real Name
    Ash
  • Gender
    Male
  • Location
    Texas
  1. kewldude_3001

    [Contribution] STS v4

    hey, its me again, I had a question, this is probably simple, but what I'm trying to do is change my background color for the page, but in order for it not to affect the rest of the contents in the middle of the page, i guess i need to add a table around everything, but when i just add <table><tr><td> at the very top and then try to close it at the very end, it mess's up. can you help me with that.
  2. kewldude_3001

    Need help with my new template

    My solution for you is go get a fresh install of oscommerce the new version and then install the STS templates system and associate the template you bought with STS and everythign should be fine
  3. kewldude_3001

    a little bit problems

    if your trying to add a seal, trying adding a new infobox and then adding the code there
  4. kewldude_3001

    [Contribution] STS v4

    hey bill, im basically done with the major editing of the site, check it out :) Site Thanks for all the help from you and anyone else that has contributed :), lol sorry for some non-sts related or "dumb" questions, because im post happy :)
  5. kewldude_3001

    [Contribution] STS v4

    YAYYYYYYYY i did it, i fixed it, i read through the contributions for this: http://addons.oscommerce.com/info/5236 and fixed it, the key thing is to download the latest from the guy's site and then follow the first instructions by Erik Svensson and then do this lil part Edit: includes/modules/sts_inc/product_info.php About in line 80 find: ------------------------------------------------------------------------------------------------- $template_pinfo['product_popup']= '<script language="javascript"><!--'."\n". 'document.write(\'<a href="java script:popupWindow(\\\'' . tep_href_link(FILENAME_POPUP_IMAGE, 'pID=' . (int)$products_id) . '\\\')">' . $template_pinfo['imagesmall'] . '<br>' . TEXT_CLICK_TO_ENLARGE . '</a>\');'."\n". '//--></script>'."\n". '<noscript>'."\n". '<a href="' . tep_href_link(DIR_WS_IMAGES . $product_info['products_image']) . '" target="_blank">'.$template_pinfo['imagesmall'] . '<br>' . TEXT_CLICK_TO_ENLARGE .'</a>'."\n". '</noscript>'."\n"; } else { $template_pinfo['imagesmall'] =''; $template_pinfo['imagelarge'] =''; $template_pinfo['product_popup']='' } ------------------------------------------------------------------------------------------------- Replace with: ------------------------------------------------------------------------------------------------- $template_pinfo['product_popup']= '<a rel="lightbox" href="' . tep_href_link(DIR_WS_IMAGES . $product_info['products_image']) . '" title="'. $product_info['products_name'] .' - '. $manufacturer['manufacturers_name'] .'">'.$template_pinfo['imagesmall'] . '<br>' . TEXT_CLICK_TO_ENLARGE .'</a>'."\n"; } else { $template_pinfo['imagesmall'] =''; $template_pinfo['imagelarge'] =''; $template_pinfo['product_popup']=''; } ------------------------------------------------------------------------------------------------- As you can see it's the $template_pinfo['product_popup'] that has to be changed. That's all. Good luck. Check out how it works if you dont know how it works already :) My Site lol sorry for all the posts, but it helps me to see what the problem is, i bet if i waited to try everything then i wouldnt have posted at all :)
  6. kewldude_3001

    [Contribution] STS v4

    lol funny thing, i turned off popup_image from the admin side and deleted the javascript from the product_info.php.html (inside the content folder) and it started working. But its not using the lightbox effect for the window. i thought if i didnt use a template it would execute like the default and its not :( i see one for sts :), i'll let u know how it turns out :)
  7. kewldude_3001

    [Contribution] STS v4

    im doing something wrong with the template, cause it worked when i turned off sts :( i just installed lightbox which is a cool way of showing the popup image, will that work with sts?
  8. kewldude_3001

    [Contribution] STS v4

    yayyyyy :), it opens it, now to make it actually show the larger images. i changed my popup_image.php to contain this so what else do i need to do to make it show the larger images instead of the smaller ones <body onLoad="resize();"> <?php echo tep_image(DIR_WS_IMAGES.'/images_big/'.$products['products_image'], $products['products_name']); ?> </body>
  9. kewldude_3001

    [Contribution] STS v4

    my images (big) are located under catalog/images/images_big i think i did something to make the images_big work before but i dont remember, do i have to do something??? i copied the code but it still gives me the error saying object expected this is whats inside my popup_image.php.html <?php define ('STS_END_CHAR', '}'); ?> <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"> <html $htmlparams}> <head> <!--$headcontent--> <script language="javascript"><!-- function resize() { var i=0; var MarginW = 60; var MarginH = 140; if (document.layers) i=40; if (document.prodimage.width>document.bannerimage.width) {Width=document.prodimage.width +MarginW} else Width = document.bannerimage.width+MarginW; Height = document.prodimage.height+document.bannerimage.height+MarginH; window.resizeTo(Width,Height); self.focus(); } //--></script> <script language="javascript"><!-- function popupWindow(url) { window.open(url,'popupWindow','toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=no,res izable=yes,copyhistory=no,width=100,height=100,screenX=150,screenY=150,top=150,le ft=150') } //--></script> <?php // BOF: More Pics 6 ?> <meta http-equiv="Page-Enter" content="blendTrans(Duration=0.5)"> <meta http-equiv="Page-Exit" content="blendTrans(Duration=0.5)"> <?php // EOF: More Pics 6 ?> </head> <body onLoad="resize();"> <table width="100" border="5" align="center" cellpadding="5" bgcolor="#FFFFFF" id="table1"> <tr> <td> <table border="0" cellpadding="0" cellspacing="0" style="width: 100%; border-collapse:collapse" bordercolor="#111111"> <tbody> <tr> <td> <img border="0" src="images/oscommerce.gif" name="bannerimage"></td> </tr> </tbody> </table> <p align="center"><font face="Arial">$productname}</font><font color="#808080" size="2">[$productmodel}]<br> </font>$popupimage}</td> </tr> </table> </body> </html>
  10. kewldude_3001

    [Contribution] STS v4

    forget about the featured products question, my new question is im trying to get the popup_image to work, i installed it in admin, and i copied the template from the full example just to see if it works and placed it sts_templates/mytemplate/popup_image.php.html and when i click on the click to enlarge, it doesnt do anything, shows an error on the bottom left.
  11. kewldude_3001

    [Contribution] STS v4

    happy birthdayyyyyy and happy new year bkellum!!!!!!
  12. kewldude_3001

    [Contribution] STS v4

    ooooo I have an STS question :), how can i get the header for Featured Products to display??? i have the header ready and in the content folder named infobox_featured_header.php.html. thanks
  13. kewldude_3001

    [Contribution] STS v4

    i just had to make the .... colspan to 2 to make it expand, im starting to think it might not exactly look like the one below but im going to try though!
  14. kewldude_3001

    [Contribution] STS v4

    Ok, can you help me fix the remaining part??? I tried but its not doing anything. Site 1) Change the Product color, even though i have the class set to the appropriate class, its still not changing. 2) Align things properly, and show the entire product name. 3) And add the border around the entire featured products table.
  15. also i need some help rearranging the way, the product is shown in the box, and also I want to add a header that says FEATURED PRODUCTS, so how can i insert that into the featured.php (module), like what part
×