Jump to content

MarcellaE

Members
  • Content count

    134
  • Joined

  • Last visited

  • Days Won

    1

Reputation Activity

  1. Like
    MarcellaE reacted to raiwa in [Contribution] iOSC - mobile version of OSC on your iPhone   
    Hello @@MarcellaE,
     
    Another Modification to fix all tep_image calls on SSL pages.
    In: includes/configure.php:
     
      (defined('MOBILE_SESSION') ? define('DIR_WS_IMAGES', ((getenv('HTTPS') == 'on')? HTTPS_SERVER . DIR_WS_HTTPS_CATALOG : HTTP_SERVER . DIR_WS_HTTP_CATALOG) . 'images/') : define('DIR_WS_IMAGES', 'images/'));
     
    regards
    Rainer
  2. Like
    MarcellaE got a reaction from raiwa in [Contribution] iOSC - mobile version of OSC on your iPhone   
    Nice Contribution. Installed without a hitch except for the Language gif images. All browsers told me that those images were non-secure on the SSL. Took forever to figure out how to resolve that.
     
    In mobile/includes/modules/options.php
    (around line 17)
     
    reset($lng->catalog_languages);
              while (list($key, $value) = each($lng->catalog_languages)) {
                  if ($language == $value['directory']) {
                      $icon = 'check';
                      $datatheme = 'b';
                    $selectedLanguage = '<span style="position:relative; top:2px"><img src="' . HTTPS_SERVER . DIR_WS_HTTPS_CATALOG . 'includes/languages/' .  $value['directory'] . '/images/' . $value['image'] . '" alt="' .  $value['name'] . '"></span>';
                  } else {
                      $icon = 'arrow-r';
                      $datatheme = 'a';
                  }
                  $path = tep_mobile_link(basename($PHP_SELF), tep_get_all_get_params(array('language', 'currency', 'style')) . 'language=' . $key, $request_type);
                  $optionsOutput .= '<li data-theme="' . $datatheme . '" data-icon="' . $icon . '" data-iconpos="right"><a href="' . $path . '"><img src="' . HTTPS_SERVER . DIR_WS_HTTPS_CATALOG . 'includes/languages/' .  $value['directory'] . '/images/' . $value['image'] . '" alt="' .  $value['name'] . '" class="ui-li-icon ui-corner-none">' . $value['name'] . '</a></li>';
     
    You have to change all instances of HTTP to HTTPS.
×