Jump to content

Aprilrobin

Members
  • Content count

    25
  • Joined

  • Last visited

3 Followers

About Aprilrobin

  • Birthday 04/27/1976

Profile Information

  • Real Name
    April
  • Gender
    Female
  • Location
    New Jersey
  • Website
  1. Ma'm m a new bie to osc nd ve just installed STS... but i ve no clue where to start ... cn u please guide me through .. i wud b very grateful

    thank you

    ahmar siddiqui

    ahmar.siddiqui@gmail.com

  2. Aprilrobin

    [Contribution] STS v4

    Oh my gosh, wow. That answer is almost too easy. I gotta get a grasp of php. Thanks once again Bill!
  3. Aprilrobin

    [Contribution] STS v4

    Agh. Can I make a template for my search box only? My client wants it to be as smple as possibe in the upper right corner of her site. A search text field and submit button only... no background or borders or anything. I can't fugure out what I'd need to remove from search.php, so I'm hoping sts can help. thank you!
  4. I have my site finished up and now my client that previously didn't want a search feature wants a search box in the upper right hand corner of the site. I pretty much only need the search text field and a sumbit button.... real standard. Any suggestions on an easy way to do this? Thanks!
  5. Aprilrobin

    [Contribution] STS v4

    Oh boy, I seem to have confused myself beyond belief once again. In a nutshell. My site has only a few categories with no subgcategories (a few products listed directly in each category.) I need to create a template for the $content on this page because the default looks like hell with my client's wants. One template is fine for the whole site. When I say "this page" I mean the immediate product listings on the category page. But, I am confusing myself way too badly. What file can I copy and turn into a template to do this? Where should this template exist? Directly in my "test" folder or do I need a "content" folder inside of "test"? Or is it supposed to go in modules somwhere? ugh ugh.
  6. Aprilrobin

    [Contribution] STS v4

    Afternoon Bill. I thought I had it, but I didn't! I totally understand the category template naming - not a problem. However, I am confused on the $urlcat_1 and /or $cat_1. I un-commented out the section pertaining to this in sts_user_code.php and reuploaded. BUT, if I use either placeholder in my main template and upload it, it displays the entire URL for the category page. I guess I need to define these in filenames.php? If so, how would I name the categories pages there? It doesn't seem to me like it would follow the protocal of a placeholder for a page such as "shipping.php" If I just make a regulat text link and link to the long url for the category like such http://www.domain.com/catalog/index.php?cPath=1 will that break the session? OK, i just answered my own question for that last bit, I need to use relative URLs. So I guess I don't really need to bother with placeholder if I don't want to?
  7. Aprilrobin

    [Contribution] STS v4

    Bill, you are the best. Thank you! I'll integrate this later tonight!
  8. Aprilrobin

    [Contribution] STS v4

    Can I add a template for each category in my catalog? I already added new pages using the $newpage add-on and it went swimmingly (thank you for that, Bill). However, I want a new template for each category page in my catalog. My catalog is relatively small - 5 categories with no sub categories and just a handful of products each. Really, I just want the ability to change a main image and a few lines of text for each category page. I guess I want to be able to give each category a $pagename and not use $categorybox at all - if possible. Any instructions or direction would be much appreciated. I looked, but maybe i'm using the wrong terms to seach. Thank you, April
  9. Aprilrobin

    [Contribution] STS v4

    Good news. I just backed everything up and copied all the necessary sts files over what was there. Somehow fixed the problem. Some file just either didn't get copied or copied to the wrong place. THIS problem solved. thanks again.
  10. Aprilrobin

    [Contribution] STS v4

    Thanks a bunch Bill. I've got all that covered. I think something may have gone awry while my network admin was helping me adjust an error today. I suppose it could be anywhere. *sigh* Thanks for for taking the time!
  11. Aprilrobin

    [Contribution] STS v4

    Oh lordy I don't know what I'm doing wrong. I have oscommerce-2.2rc2a installed and seemingly working properly. I have STS4 and RC2 files ftp'd to the server. I was able to go to modules and install STS. Set it to true and all the template folders seem to be fine and in the right places. But when I alter sts_template.html in dreamweaver and copy it over to the server, my storefont doesn't reflect the changes. did i forget to modify some setting somewhere? any ideas?
  12. Aprilrobin

    Install STS AND RC2?

    Forgive me, I meant to post this in the STS4 topic. Maybe I should just go to bed.
  13. Aprilrobin

    Install STS AND RC2?

    I think maybe I'm losing my mind. It's been a while since I touched Oscommerce and now STS has changed. I have oscommerce-2.2rc2a installed. To use STS do I need to copy over the files from the STS folder AND the RC2 folder from the download? I've tried it both ways and when I go into my modules from admin, STS is not there.
  14. Aprilrobin

    [Contribution] STS v4

    ah thank you Dano, yes, unfortunately the horizontal fly-out is what I was looking for. I should have mentioned that. Thank you much for your help.
  15. Aprilrobin

    [Contribution] STS v4

    STS 4.5 & Dynamenu problem. well, I had the store all up and running beautifully until I decided to mess with Dynamenu! I followed Bill Kellum's directions of how to make it work with STS and my problem is that the fly-outs didn't work. So, I went to add <?php echo $GLOBALS['dmfooter']; ?> to the bottom of application_bottom.php and I am getting funky error message. Now, I'm not all that familiar with Php. I know the directions said to add the code before the ending ?> So, should the last line now just look like this? <?php echo $GLOBALS['dmfooter']; ?> does the ?> at the end of the inserted code combine with the ending ?> I'm supposed to insert it in front of or should there be two? (?>)'s? I tried several ways and nothing seems to be working but that could and probably is just because I don't know what I'm doing. gah, any advice on how to get this to work with the fly-outs? really appreciated.
×