Jump to content

cunga_lunga

Members
  • Content count

    37
  • Joined

  • Last visited

  1. cunga_lunga

    OSC-Affiliate

    osC Affiliate NOTE: Do not use version 2.7, use the ones before, this in is in German and its not made like other contributions so it could be harder for you to change anything if you want to!
  2. cunga_lunga

    Table Rate Calculates Wrong Amount

    Don't say that. Can you just please tell me what shipping module you are you using, the basic one? If you want you can send me code in pm or here of your shipping module, so I can help you with your problem, ok? Milos M.
  3. cunga_lunga

    OSC-Affiliate

    I really don't know if affiliate_application_top will require that file if you put require_once in affiliate_application_top, but why would you do that, you can simply delete that line, if you have it in affiliate_application_top.php, because of this: affiliate_affiliate.php (require) affiliate_application_top.php (require) affiliate_functions.php, so basicly every affiliate_xxxxx.php file can get to affiliate_functions.php through affiliate_application_top.php and ONLY once which is important, so you don get redeclare function error!
  4. cunga_lunga

    OSC-Affiliate

    This should be simple solution. Anyway the problem is that your page call affiliate_functions.php twice. So you should look up in the affiliate_affiliate.php and in affiliate_application_top.php if you have this: require(DIR_WS_FUNCTIONS . 'affiliate_functions.php'); If you have in both files than you should delete or comment out that line in affiliate_affiliate.php. The main thing is that affiliate_function.php must be required only ONCE! So all affiliate pages includes affiliate_application.php, and than in that case only affiliate_application.php shoud require affiliate_functions.php. If this is not helping you,(but it has to), than you should see where and what file require or includes affiliate_functions.php. Just make sure that page is included only ONCE!
  5. I think I know what is your problem, I am currently working on shipping thing on my site too and when I tried to put in my cart 10 items the module calculate the shipping price like there is two packages to send, so it calculates double shipping. I think this is the problem for you too, but I did not had time to look it through! Try to install Zone International - Table Rate module it shows you a total weight in checkout shipping and see if this is the problem. I use it for my site, and when I tried to put more items in cart and shipping is displayed like this: Shipping to US (by weight) : 2 x 40 - so it means TWO packages I saw it now, that this is displayed and calculated because weight of this items is 80 and my last weight price in table is set to 64, so thats why he is calculating like this. Anyway you should have NO problem with this, because your last size is 100, but maybe this can help you. Try to put these 55 items in you cart see the shipping, than lower down number of items by one and see in what moment he will calculate the shipping right, see what number of items needs to be in cart to get your shipping price, than try to change to table rates.... This is the easiest way to find the problem. Good Luck.
  6. cunga_lunga

    OSC-Affiliate

    I am not sure what do you mean about 1st thing, so can you just please tell me how it suppose to look like? Anyway I think the 2nd thing is more important and the problem as I can see it is that your php files for affiliate program is messed up with html codes (tags)? I had similar problems while I was working with my site and only way I can manage it is too print down to entire HTML code of that page thats messed up and follow HTML tags (<table>, </table>, <td>, </td> etc.) and than you see where the problem is? Anyway another thing to do is to see what html tags generates your affiliate program and see if that matched with your header, footer, column left and right html tags, when you merge them in one page, if you do not understand here is the whole idea: You MUST have exact number of opening HTML tags for table, row or cell (<table>, <tr>, <td>) as closing tags for them (</table>, </tr>, </td>). So in you site (one page) this numbers don't match so you get that! You get one table tag opened in header and closed in affiliate file, but it should be closed in footer file - for example! If you are not familiar with all this, I am willing to help you, so you can pm, anytime or ask here, it doesn't matter!
  7. cunga_lunga

    Sub-manufacturer

    Anyone, please?
  8. cunga_lunga

    Sub-manufacturer

    Hell people. I need some contribution that can make SUB-manufacturer!? As you can make subcategories in category menu, I need this so I can make sub-category but for manufacturers, i call it sub-manufacturer?! Example if I have list of manufacturers, one of them will be "OTHER DESIGNERS"! So I must make sub folder (sub-manufacturer) in manufacturer list, where I can make a list of this others designers?! Is there anything like this? Thank you a lot? Milos M.
  9. cunga_lunga

    OSC-Affiliate

    D4, can you tell me what version of this contrib you have? I am not sure what can be the problem, but can you send me affiliate_signup.php so I can try it here? And one more thing, when this page reloads, as you say, does the info you enter stays or every fields is clear again?
  10. cunga_lunga

    OSC-Affiliate

    Ok that is why you receiving this error. Just to know that this has nothing with other affiliate tables. Affiliate SQL: makes 11 affiliate_xxxx tables, and insert new data in tables configuration_group (1 row) and configuration (14 rows)! Here is the code to delete this row: DELETE * FROM configuration WHERE configuration_id = 0; I don't know how you make this in your database, because configuration_id is an auto_increment and begins from 1, therefore please make sure you check your sql code that you import to your database, for this field in all insert into statements, it needs to be BLANK ('')! Hope you will get this time!
  11. cunga_lunga

    OSC-Affiliate

    D4 you can try this... See whats configuration_id in table configuration should have affiliate address and try this, with that ID?! INSERT INTO configuration VALUES (' HERE PUT THAT ID ', 'E-Mail Address', 'AFFILIATE_EMAIL_ADDRESS', '<affiliate@localhost.com>', 'The E Mail Address for the Affiliate Program', 900, 1, NULL , now( ) , NULL , NULL)
  12. cunga_lunga

    OSC-Affiliate

    Please can you export this table and put the code here or you can attach it, if it is not a problem, if it is, than delete everything except for that applies to affiliates?!
  13. cunga_lunga

    OSC-Affiliate

    OH I forgot to say you can not copy files from main catalog dir into language dir, because even they have the same name they are different! In language files are defined all text that appears on your pages, no codes, no programming.... you should know this!
  14. cunga_lunga

    OSC-Affiliate

    First of all its not the same error, but you should know that you MUST have these files in catalog/includes/language/english/ : affiliate_affiliate.php, affiliate_banners.php, affiliate_banners_banners.php, affiliate_banners_build.php, affiliate_banners_build_cat.php, affiliate_banners_category.php, affiliate_banners_product.php, affiliate_banners_text.php, affiliate_clicks.php, affiliate_contact.php, affiliate_details.php, affiliate_details_ok.php, affiliate_faq.php, affiliate_info.php, affiliate_logout.php, affiliate_news.php, affiliate_newsletter.php, affiliate_password.php, affiliate_password_forgotten.php, affiliate_payment.php, affiliate_reports.php, affiliate_sales.php, affiliate_signup.php, affiliate_signup_ok.php, affiliate_summary.php, affiliate_terms.php! You can either copy this files from german language directory and translate them, or download some earlier english version and just put the language files (they should be compatible), but my BEST advice is to download this version 2.62 or 2.6 + fixes and install it from beginning, v2.7 (I think you have this one) is so bad! Here is the link: osC Affiliate!
  15. cunga_lunga

    OSC-Affiliate

    Hey D4. I am not sure why you get this error, but my advice is to delete all from your database that applies to affiliate contribution (delete all affiliate_xxxx tables from your database, delete a row from table configuration_group where configuration_group = 900, delete from table configuration all that applies to affiliate (all rows that has configuration_group = 900)) And start from begining! Next my advice is for you is first to upload the sql codes that applies only on configuration tables and see if you will get all options for Affiliate Program in Admin -> Configuration?! Than apply rest of the sql code and make affiliate_xxxx tables NOTE: before anything, please just make a BACKUP of your database (phpMyAdmin -> Export)!
×