Jump to content
Latest News: (loading..)

B.C.

Members
  • Content count

    56
  • Joined

  • Last visited

Posts posted by B.C.


  1. 12 hours ago, BrockleyJohn said:

    That looks ok but your error showed that the import thought the first line read

    
    phpMyAdmin SQL Dump SET SQL_MODE = "NO_AUTO_VALUE_ON_ZERO" 

     

    Did you open the exported file on your computer in an editor like notepad or something and then save it? This might break it. You should not.

    Yeah, I bet that's it, because I opened it in Notepad to rename it. Since I am trying to move it to a different hosting account, the naming scheme is different, that whole "account_dbname" thing, so I think I'll do what you suggest, but stop trying to move the db to a different server, since I think that's where the problem is.


  2. Yeah, it's failing on the import.........it could be buggy phpmyadmin, could be because of different versions of mysql on the different servers.....I don't know........another day of futilely grinding away at what is supposed to be so easy.........This is exactly why I put off even thinking about upgrading for years........Unfortunately your help is wasted on me at this point, I'm in the weeds again...I think I'll scrub everything and start the whole thing again fresh on the same server, just to hopefully avoid the import/export situation being the culprit. Thanks again, though, it is appreciated.


  3. Dan, it seems to be failing at the import with the above error message.....there are no errors on the new store, just no products, no categories, etc...Maybe I should have been doing all of this on the same server........I think all the advice here is exact and correct, I'm just screwing it all up by trying to export to another server/host.......


  4. 59 minutes ago, BrockleyJohn said:

     

    You seem to be losing contents from the file along the way. I would expect it to be formatted like this:

    
    -- phpMyAdmin SQL Dump
    -- version 4.4.10
    -- http://www.phpmyadmin.net
    --
    -- Host: 10.169.0.146
    -- Generation Time: Jul 02, 2017 at 08:14 PM
    -- Server version: 5.7.17
    -- PHP Version: 5.3.3
    
    SET SQL_MODE = "NO_AUTO_VALUE_ON_ZERO";

     

    this is what i have..........

     

    -- phpMyAdmin SQL Dump
    -- version 4.0.10.14
    -- http://www.phpmyadmin.net
    --
    -- Host: localhost:3306
    -- Generation Time: Jul 02, 2017 at 01:10 PM
    -- Server version: 5.1.73-cll
    -- PHP Version: 5.4.31

    SET SQL_MODE = "NO_AUTO_VALUE_ON_ZERO";
    SET time_zone = "+00:00";


    /*!40101 SET @OLD_CHARACTER_SET_CLIENT=@@CHARACTER_SET_CLIENT */;
    /*!40101 SET @OLD_CHARACTER_SET_RESULTS=@@CHARACTER_SET_RESULTS */;
    /*!40101 SET @OLD_COLLATION_CONNECTION=@@COLLATION_CONNECTION */;
    /*!40101 SET NAMES utf8 */;

    --
    -- Database: `newshop_oldStore`
    ------------------------------------------------------------

    -- Table structure for table......etc, etc...


  5. 2 hours ago, BrockleyJohn said:

    @B.C. the instructions you're following might be labelled 'for dummies' but they seem overcomplicated to me. All this business of exporting and importing tables is an alternative approach to the database conversion script.

     

    I'm starting to get clear on that, it's making more sense. In my particular case, I'm rebuilding the new store on a different server with a different host, so I'm having to export/import tables and/or databases after running the update scripts on them....I'm successfully running the scripts you guys have made, I'm just hitting errors on the attempt to import the updated database into the new store..........I think I'm going to give up on updating the old stuff......I have installed the new shop (2.3.4 responsive) and all I really need from my old shop is the products/attributes and customer reviews.....Maybe it is easier to do that? A lot of my old contributions are stock in the new package anyway.......But I probably shouldn't clutter up this thread with it.....I assume I'll need help and I'll try to start a new thread in the appropriate place.


  6. OK, I have copied the old database, run the SQL changes script, run Burt's db update script to get it up to 2.3.4 Responsive. I exported that db to import it over the other server where I'm trying to set up the new store, but I'm hitting errors on the import:

    Error

    Static analysis:

    2 errors were found during analysis.

     

    1. Unexpected beginning of statement. (near "phpMyAdmin" at position 0)
    2. Unrecognized statement type. (near "SQL" at position 11)

     

    SQL query:

    phpMyAdmin SQL Dump SET SQL_MODE = "NO_AUTO_VALUE_ON_ZERO"

    MySQL said: Documentation

    #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'phpMyAdmin SQL Dump

    SET SQL_MODE = "NO_AUTO_VALUE_ON_ZERO"' at line 1

     

    Not sure what that calls for?


  7. Brockley John--definitely time for a break, but thanks for the control click tip, I have never heard of that before.

    Dan- OK, light at the end of the tunnel, thanks, I'll do that and report back.....

     I graduated high school in prison, never went to college, and I just silk screen shirts....99% of all of this computer stuff is over my head.....what seems obvious to you is Latin to me. That's why for years I just Google and tinker and try not to bother the smart folks.....but this 2.3.4 stuff seems like a whole new ball game. Thanks for taking the time to help me........


  8. Dan, yes, absolutely, but I think I am using the version of that that goes up to 2.3.4, not just 2.3.3 or whatever....

    But yes, I copied my database and renamed it "oldStore" then followed the instructions in this thread above and deleted everything that wasn't needed, and imported it.

    Now I'm on Step 4 of "Converting from OSC 2.2 to 2.3x, for dummies" where I'm supposed to select only certain tables for a custom export, which should then be able to be imported into the new store. But I can't select only certain tables. I can select all or deselect all.


  9. Dan, yes, I read that, and yes, that's exactly what he said. Then immediately after that, he said:

    Quote

     

    Since the BS version is not directly compatible with other versions, the following steps will be needed:

    • Install the BS version into a new location
    • Convert the database. See this thread for help with that.

     

    •  And the thread he linked to was all about updating from BS 2.3.4 to Responsive 2.3.4. So, like I said, it seemed (to me, of course) like that post was all about showing you how to go from BS to Responsive. You may have to allow for the possibility that what someone says and what my limited understanding of what was said may not correspond, exactly. So if I express what I think was said and ask for clarification, I hope that isn't interpreted as an attempt to contradict anybody. I know I'm the deficient moron in this situation, humbly asking for assistance, so I appreciate any help.

    So anyway, does anyone have any idea why I can't select only certain tables for a custom export?


  10. 7 hours ago, BrockleyJohn said:

    That means that you don't need the first two steps in the file (the ones labelled RC1 SQL and RC2 SQL). Just delete from the beginning until the file starts

    
    ############
    #2.3.0 SQL
    ############

    and then try again.

    How I missed that I don't know, but thanks, that worked for that step.

    Now I'm on the next step of doing the custom export of oldStore, but you say in your instructions to only export certain tables. For some reason I can either select all or deselect all, if I try to only select certain tables, I can't. If I select one, then go to select another, it deselects the previous one, like playing Wack-a-Mole. Normally I would Google and tinker and figure it out myself, but I'm so brain dead on this project I'm going to strictly go by the instructions exactly and post my results and hope you guys are patient enough to point out my obvious errors.

    So, if I can't do selective table exports, should I just select all tables and export?

     


  11. Thanks Dan........

    Seems like Jack was mostly talking about going from Boot Strap to 2.3.4 Responsive in that post.  I'm trying to make the jump from 2.2 to 2.3.4 Responsive. I was mainly using trying this by using Converting from OSC 2.2 to 2.3x, for dummies:

    https://docs.google.com/document/d/1AI6RquhcmO-u9GLAofk3RX2w9SWv0ddejdiRemUhWLo/edit

    I copied the database and renamed it oldStore, as per instructions. I imported " sql_changes_ms2.2_to_2.3.4" that everybody links to and got the first error:

    Error

    SQL query:

    ALTER TABLE specials ADD INDEX idx_specials_products_id( products_id ) ;

    MySQL said: Documentation
    #1061 - Duplicate key name 'idx_specials_products_id'

    When I google this error, I read a lot of stuff, but still don't know what, exactly, to do to solve it.

    Any help is appreciated.


  12. I've used 2.2 for more than 12 years, thought I knew some stuff about OSC. Recently decided to take the plunge and update to 2.3.4-Responsive and after several days of frustrated futility, found out that I apparently am retarded. I believe I have read every single thread about updating from 2.2 to 2.3.4 and I haven't managed it. After 7.5 hours just today I can't even describe what I have tried.......download, backup, import, run sql scripts that are supposed to do whatever, you name it. Everything breaks everything.

    I thought it was easier: export old database, drop tables in new database, import old db into new shop, import that sql script that makes all the changes between 2.2 and 2.3.4, but it's all errors and broken pages. So I scrub everything, do a fresh install of the 2.3.4 and try again, after re-reading every thread.

    Now my brains are spaghetti and nothing makes sense anymore.

    If anybody out there has had a similar experience trying to figure this out and can point me in the right direction, that would be great.


  13. On 5/11/2017 at 8:53 PM, Jack_mcs said:

    Those orders would probably be considered orphaned at this point. The code will delete orders that are attached to a customer that is being deleted. But if the customer for those orders doesn't exist, they won't get deleted. Take a look at one of the orders in admin, copy the email address or last name (something unique) and then go to the customers section and search for it. If it doesn't show a customer then that is what the problem is.

    I think I did something similar by accident. First I ran option A, I think, since it was the default and I didn't change it. So it deleted customers but not orders......Then I realized what happened and switched it to Option B, I think, to delete customers and orders, but 34,000 orders remain. How can I now delete all of these old orders?


  14. This site must use  a url rewriter then, as the category (and product) pages end in  .html ...........I guess this site has  seo url contribution or something, so I toggled that off in admin (made "enable seo url" false) but that broke something and made category pages unreachable, so I turned it back on right quick. Whatever, I'm just a monkey pushing buttons at random, basically, and shouldn't be tinkering with anything at this point.


  15. Thanks for the response, but I don't quite understand. I took my site back over from a crooked webmaster years ago and what little has sunk into my brain isn't quite enough to understand your help completely. If I just rename the index file, how does that help me see changes to a category page? I don't know if my site uses a url rewriter or not, or what that is.


  16. Jack, apparently I installed this contribution to one of my sites with no problems years ago, mostly for the SEO benefits. I was recently trying to find a way to add text to the category page, and read that this could also be done with Header Tags SEO. I had never noticed or realized that. But I can't see how to do this. I ran the test and there were no problems really, but when I add text to the Header Tags Categories Description box and save my changes in admin....none of it appears on the category page of the site. Am I overlooking something simple? Any help appreciated in advance.


  17. Come on someone has to know how to install this properly or know of a simpler GUEST CHECKOUT MODULE that I could install.

     

     

     

    I bought Better Checkout from Toste & Jensen........It takes your customer straight to checking out, and at the end it offers them the option to save all of their info (creating an account) or they can click, "No thanks," and be on their way without setting up an account. Works great, didn't cost much, and they can install it for you if you need them to.

     

    Here is the description:

    http://www.tostejensen.com/better-checkout.html

     

    Or you can click straight on the demo:

    http://www.bettercheckout.com/

     

    Good luck..........


  18. The general forum is the place for general help .. like errors.

     

    Oh, how stupid of me. Is there, like, a nerd dictionary you use that informs you that something like page errors are obviously, "general," as opposed to, say "specific," or whatever else morons like the rest of us might be inclined to assume? Because if I had that, I'd hang around message boards and jump at every chance to act like everything is obvious. Then I would be so cool.......


  19. I would love to be able to use this contribution, but, even though I am on PHP5, I get a blank page when I go to mysite/catalog/includes/kiss_error_handler.php.

     

    Any ideas or common causes for this? All I saw earlier in this thread was a guy running PHP4.

     

    Hate to reply to myself, but I figured it out. The instructions say to "open up" that page to set all the variable. I was trying to go there in my browser window, like it was a web page.

     

    OK, so now I have tons of errors, but Google isn't really helping me figure any of them out. If you don't this thread used for errors, where should we go?

×