Jump to content

wormington

Members
  • Content count

    94
  • Joined

  • Last visited

Profile Information

  • Real Name
    Mark Warren
  1. wormington

    Europe Cookie Laws

    I was looking for a solution to the cookies issue and came across the following website that has a solution that will work on both php and non php sites http://www.cookiesdirective.com I hope this of some use to you.
  2. wormington

    wysiwyg editor for index page in 2.3.1

    Thanks for the comprehensive reply, some interesting thoughts there. I think for the moment I'll probably just get the owner to email me any updates and implement them myself as this would avoid him messing the page layout etc up. Thanks again for your help.
  3. wormington

    wysiwyg editor for index page in 2.3.1

    This is the add on for 2.2 http://addons.oscommerce.com/info/7255/v,22
  4. wormington

    wysiwyg editor for index page in 2.3.1

    It is the content of the homepage that I need to be able to edit. I can do it myself easily in notepad, dreamweaver etc as I have some html experience. The solution I want is for the store owner to be able to update his home page with news updates, etc. As I said earlier there is an add on for osCommerce 2.2 for editing the homepage, conditions of use etc pages but it is table based and not CSS. Thanks for your reply Mark
  5. Hi Is there an wysiwyg editor for osCommerce 2.3.1 that will allow me to edit the homepage and I also Shipping & Returns, Privacy Notice, Conditions of Use etc? There is an add on for osCommerce 2.2 but that is table based not CSS based. There are also plenty of editors that allow you to edit your products description for 2.3.1. Thanks Mark
  6. wormington

    "Dynamenu" for osCommerce

    Is there anyone there who has had the same problem as me and can help please, I've tried everything I can think of to resolve my problem. Mark
  7. wormington

    "Dynamenu" for osCommerce

    I'm still pulling my hair out over this one, why when I set $show_dmcats_as_box = false; in dm_categories.php does the javascript not show in the resulting page. I'm getting the categories listed but no drop down menus. All the relevant code is showing for the categories and the drop down menus at the base of the page. I have checked everything but just can't see why this is happening, can anyone please help. Thanks Mark
  8. wormington

    "Dynamenu" for osCommerce

    To add to the above post I am using STS 4.6 and Dynamenu and have followed all the instructions religiously
  9. wormington

    "Dynamenu" for osCommerce

    Hi All This add-on is brilliant when it's working. I thought I had resolved my issue in my post above concerning the lack of drop down menus when I had this $show_dmcats_as_box = false; in dm_categories.php by copying and pasting the various javascript files that are before the menu. I then didn't realise that part of it is dynamically generated and when I changed the stores categories it messed it up. I now only get a drop down menu when the $show_dmcats_as_box is set to true, but get the menu all out of line with the site layout, when I set the above setting to false the main categories show but there are no drop down menus due to the fact that there is no javascript files showing above the menu. Everything else is there in the page. Any help on this would be greatly appreciated, thanks Mark
  10. wormington

    "Dynamenu" for osCommerce

    Hi Great contribution but it took me days!!! to get it working properly, I am using STS 4.6 and Dynamenu. I wanted to have a horizontal menu without the box around it - so to display the menu output only. Could I get this to work - yes eventualy, my problem was that if I had $show_dmcats_as_box = true; in boxes/dm_categories.php the menu worked fine but there was a box around the menu that didn't fit in with the design. If I set it to $show_dmcats_as_box = false; the main categories were displayed correctly but now drop down menus appeared whatever I tried. I eventually copied the following and pasted it just before the $dmbox$ in my design and all is fine, for some reason when the $show_dmcats_as_box = was set to false the javascript did not appear. <script language="JavaScript" type="text/javascript"> <!-- // PHP Layers Menu 3.2.0-rc (C) 2001-2004 Marco Pratesi - http://www.marcopratesi.it/ DOM = (document.getElementById) ? 1 : 0; NS4 = (document.layers) ? 1 : 0; // We need to explicitly detect Konqueror // because Konqueror 3 sets IE = 1 ... AAAAAAAAAARGHHH!!! Konqueror = (navigator.userAgent.indexOf('Konqueror') > -1) ? 1 : 0; // We need to detect Konqueror 2.2 as it does not handle the window.onresize event Konqueror22 = (navigator.userAgent.indexOf('Konqueror 2.2') > -1 || navigator.userAgent.indexOf('Konqueror/2.2') > -1) ? 1 : 0; Konqueror30 = ( navigator.userAgent.indexOf('Konqueror 3.0') > -1 || navigator.userAgent.indexOf('Konqueror/3.0') > -1 || navigator.userAgent.indexOf('Konqueror 3;') > -1 || navigator.userAgent.indexOf('Konqueror/3;') > -1 || navigator.userAgent.indexOf('Konqueror 3)') > -1 || navigator.userAgent.indexOf('Konqueror/3)') > -1 ) ? 1 : 0; Konqueror31 = (navigator.userAgent.indexOf('Konqueror 3.1') > -1 || navigator.userAgent.indexOf('Konqueror/3.1') > -1) ? 1 : 0; // We need to detect Konqueror 3.2 and 3.3 as they are affected by the see-through effect only for 2 form elements Konqueror32 = (navigator.userAgent.indexOf('Konqueror 3.2') > -1 || navigator.userAgent.indexOf('Konqueror/3.2') > -1) ? 1 : 0; Konqueror33 = (navigator.userAgent.indexOf('Konqueror 3.3') > -1 || navigator.userAgent.indexOf('Konqueror/3.3') > -1) ? 1 : 0; Opera = (navigator.userAgent.indexOf('Opera') > -1) ? 1 : 0; Opera5 = (navigator.userAgent.indexOf('Opera 5') > -1 || navigator.userAgent.indexOf('Opera/5') > -1) ? 1 : 0; Opera6 = (navigator.userAgent.indexOf('Opera 6') > -1 || navigator.userAgent.indexOf('Opera/6') > -1) ? 1 : 0; Opera56 = Opera5 || Opera6; IE = (navigator.userAgent.indexOf('MSIE') > -1) ? 1 : 0; IE = IE && !Opera; IE5 = IE && DOM; IE4 = (document.all) ? 1 : 0; IE4 = IE4 && IE && !DOM; // --> </script> <script language="JavaScript" type="text/javascript" src="includes/functions/dynamenu/libjs/layersmenu-library.js"></script> <script language="JavaScript" type="text/javascript" src="includes/functions/dynamenu/libjs/layersmenu.js"></script> <!-- beginning of menu header - PHP Layers Menu 3.2.0-rc (C) 2001-2004 Marco Pratesi - http://www.marcopratesi.it/ --> <script language="JavaScript" type="text/javascript"> <!-- menuTopShift = 0; menuRightShift = 4; menuLeftShift = 4; var thresholdY = 1; var abscissaStep = 140; toBeHidden = new Array(); toBeHiddenLeft = new Array(); toBeHiddenTop = new Array(); listl = ['L1','L10','L14']; var numl = listl.length; father = new Array(); for (i=1; i<=20; i++) { father['L' + i] = ''; } father_keys = ['L2','L3','L4','L5','L6','L7','L8','L9','L11','L12','L13','L15','L16','L17','L18','L19','L20']; father_vals = ['L1','L1','L1','L1','L1','L1','L1','L1','L10','L10','L10','L14','L14','L14','L14','L14','L14']; for (i=0; i<father_keys.length; i++) { father[father_keys[i]] = father_vals[i]; } lwidth = new Array(); var lwidthDetected = 0; function moveLayers() { if (!lwidthDetected) { for (i=0; i<numl; i++) { lwidth[listl[i]] = getOffsetWidth(listl[i]); } lwidthDetected = 1; } if (IE4) { for (i=0; i<numl; i++) { setWidth(listl[i], abscissaStep); } } var catmenuTOP = getOffsetTop('catmenuL1'); var catmenuHEIGHT = getOffsetHeight('catmenuL1'); setTop('L1', catmenuTOP + catmenuHEIGHT); moveLayerX1('L1', 'catmenu'); setTop('L10', catmenuTOP + catmenuHEIGHT); moveLayerX1('L10', 'catmenu'); setTop('L14', catmenuTOP + catmenuHEIGHT); moveLayerX1('L14', 'catmenu'); } back = new Array(); for (i=1; i<=20; i++) { back['L' + i] = 0; } // --> </script> I hope this tip helps others in the same position.
  11. No it wasn't but once I had made it so all uploaded correctly. I got slightly confused over the numbering of the field in the table. Many many thanks Mark
  12. I'm sure I did here is the following part of easypopulate.php that refers to the custom fields:- $custom_fields[TABLE_PRODUCTS] = array(); // this line is used if you have no custom fields to import/export $custom_fields[TABLE_PRODUCTS_DESCRIPTION] = array( 'short_desc_1' => 'Short Description'); // this line is used if you have no custom fields to import/export I tried commenting out the first line but it threw up an error that is linked to this line: foreach ($custom_fields[TABLE_PRODUCTS] as $key => $name) { The error being: Warning: Invalid argument supplied for foreach() in /home/c/h/charlesellis/public_html/admin/easypopulate.php on line 472 and each product throws out 2 error warnings about that line in the code at line 2213 and line2751. I did read through the document at the beginning of the easypopulate file to make sure I had everything else right. Can I supply any more info that might point to where I am going wrong. Thanks Mark
  13. Hi I have a field in the products_description table called short_desc_1 and while it appears that easypopulate is uploading all the fields when I ask it to this field is not appearing in the database Here are a few lines of the updating of products in the database, the field I am having problems with is the 5th one in, everything else is fine. | 636 | Active | Vinca mino | Lesser Per | | A mat-form | | 3.95000004 | 1 | 0 | 30/11/1999 | 03/01/2010 | | Shrubs | | | | | | | | | | | | | | --none-- Updated | 308 | Active | Vinca mino | Lesser Per | | A mat-form | | 0.20000000 | 1 | 0 | 30/11/1999 | 03/01/2010 | | Shrubs | | | | | | | | | | | | | | --none-- Updated | 309 | Active | Viola rivi | A dense sp | | A dense sp | | 3.95000004 | 1 | 0 | 30/11/1999 | 03/01/2010 | | Perennials | | | | | | | | | | | | | | --none-- Updated | 821 | Active | Viola soro | Northern W | | A stemless | | 3.95000004 | 1 | 0 | 30/11/1999 | 03/01/2010 | | Perennials | | | | | | | | | | | | | | --none-- Updated Here is the Settings and Info Settings & Info EP vers: 2.76g-MS2 osCommerce Online Merchant v2.2 RC2a OS: HTTP: Apache/1.3.33 (Unix) mod_ssl/2.8.22 OpenSSL/0.9.7d DB: MySQL 4.1.19-standard-log PHP: 4.4.1 (Zend: 1.3.0) Temp Directory: /home/c/h/charlesellis/public_html/temp/ Temp Dir is Writable Magic Quotes is: off register_globals is: on Split files on: 300 records Model Num Size: 12 Price with tax: false Calc Precision: 2 Replace quotes: false Field seperator: comma Excel safe output: true Preserve tab/cr/lf: false Category depth: 7 Enable attributes: true SEF Froogle URLS: false More Pics: false Unknown Pics: false HTC: false SPPC: false Extra Fields: false Any advice would be greatly appreciated as I want to add more custom fields that I can then incorporate into the product_info.php page Thanks Mark Warren
  14. wormington

    Custom fields issue

    Hi I have a field in the products_description table called short_desc_1 and while it appears that easypopulate is uploading all the fields when I ask it to this field is not appearing in the database Here are a few lines of the updating of products in the database, the field I am having problems with is the 5th one in, everything else is fine. | 636 | Active | Vinca mino | Lesser Per | | A mat-form | | 3.95000004 | 1 | 0 | 30/11/1999 | 03/01/2010 | | Shrubs | | | | | | | | | | | | | | --none-- Updated | 308 | Active | Vinca mino | Lesser Per | | A mat-form | | 0.20000000 | 1 | 0 | 30/11/1999 | 03/01/2010 | | Shrubs | | | | | | | | | | | | | | --none-- Updated | 309 | Active | Viola rivi | A dense sp | | A dense sp | | 3.95000004 | 1 | 0 | 30/11/1999 | 03/01/2010 | | Perennials | | | | | | | | | | | | | | --none-- Updated | 821 | Active | Viola soro | Northern W | | A stemless | | 3.95000004 | 1 | 0 | 30/11/1999 | 03/01/2010 | | Perennials | | | | | | | | | | | | | | --none-- Updated Here is the Settings and Info Settings & Info EP vers: 2.76g-MS2 osCommerce Online Merchant v2.2 RC2a OS: HTTP: Apache/1.3.33 (Unix) mod_ssl/2.8.22 OpenSSL/0.9.7d DB: MySQL 4.1.19-standard-log PHP: 4.4.1 (Zend: 1.3.0) Temp Directory: /home/c/h/charlesellis/public_html/temp/ Temp Dir is Writable Magic Quotes is: off register_globals is: on Split files on: 300 records Model Num Size: 12 Price with tax: false Calc Precision: 2 Replace quotes: false Field seperator: comma Excel safe output: true Preserve tab/cr/lf: false Category depth: 7 Enable attributes: true SEF Froogle URLS: false More Pics: false Unknown Pics: false HTC: false SPPC: false Extra Fields: false Any advice would be greatly appreciated as I want to add more custom fields that I can then incorporate into the product_info.php page Thanks Mark Warren
×