Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

ldb

Members
  • Content count

    11
  • Joined

  • Last visited

1 Follower

Profile Information

  • Real Name
    Lisa
  1. ldb

    Error in RMA

    I have discoverd another problem. After the return has been processed if a customer attempts to view the order the return was made on he will get the following error instead of the order details. (the order pages appears correctly, just the products portion has the below error instead of the products ordered. 1146 - Table 'store.TABLE_RETURNS_PRODUCTS_DATA' doesn't exist I have chekced the database and the info is there, the return id and all other fields. Any ideas on this one?
  2. I have discoverd another problem. After the return has been processed if a customer attempts to view the order the return was made on he will get the following error instead of the order details. (the order pages appears correctly, just the products portion has the below error instead of the products ordered. 1146 - Table 'store.TABLE_RETURNS_PRODUCTS_DATA' doesn't exist I have chekced the database and the info is there, the return id and all other fields. Any ideas on this one?
  3. That took care of the problem, everything works great now. Thanks for your help
  4. Since my last post I have been able to isolate my problem to the following: <td class="main" valign="top">' . $order->products[$i]['name'] . ' ' . $return_link. .'<br><small><i>' . $desc['products_description'] . '</i></small>'; As long as this part of the mod is in account_history_info the page will be blank, if I revert it back to its original code: <td class="main" valign="top">' . $order->products[$i]['name']; the page displays correctly(without the RMA part) even with all the other mods made, any ideas? As for the problem I had with order.php, I had some misplaced items there, its fixed now.
  5. I have a similer problem. I can log on and go to "My Account" then click on the order but the page comes back blank. I replaced the modified catalog/account_history_info.php and the includes/classes/order.php with the originals and the order page will display. As long as either of these modified files are in place the order history page returns blank. I have more than tripple checked the files for accuracy but see nothing wrong. I get no errors, just a blank page. I am using MS2. I did notice that the instructions call to add code after the following line for ($i=0; $i<sizeof($order->products); $i++) { but the file I have does not contain this exactly but rather has for ($i=0, $n=sizeof($order->products); $i<$n; $i++) { Anyone knowing what I need to do in MS2 to get it working please help. The admin seems to work fine with the exception of the following after the lists of reasons, methods and other pages. TEXT_DISPLAY_NUMBER_OF_TICKET_STATUS
×