Jump to content

bsreinstra

Members
  • Content count

    14
  • Joined

  • Last visited

Profile Information

  • Real Name
    Brian Reinstra
  1. bsreinstra

    Automatically send data feed to Froogle

    I hope someone can help me. I don't know php coding very well. Is there any way to modify the code in googlefeeder.php: if (OPTIONS_ENABLED_GTIN == 1 && strlen(OPTIONS_GTIN) == 0) { $extraFields .= ' products.products_gtin as gtin, '; To pull from the database: products_to_products_extra_fields.products_extra_fields_value I have the Products Extra Fields contribution with about 6 extra fields and I would like to populate the outfile with some of these fields, but I have no idea how. Any help would be appreciated. Brian
  2. Solution found. Turn off the "enable automatic redrects" in the Seo url contrib.
  3. SO I have been working on this for the last 24 hours with no luck...... My tech support at my host says: I've carefully investigated the issue and I managed to reproduce the problem on my end. I accessed the website using my HTC Android phone and when I attempted to access a product I got the error. In order to find out why the redirection occurs I used the Apache mod_rewrite RewriteLog debugging feature. When enabled, this option of mod_rewrite adds information to a text file regarding the way redirects in your .htaccess file are processed. The text file accessible at: http://www.luggage-logic.com/rewrite.txt According to the information in the file there is a problem between your OS Commerce mobile website contribution and your Ultimate SEO URLs plugin. The rules in your .htaccess file redirect all requests to the following OS Commerce files: product_info.php index.php popup_image.php articles.php article_info.php product_reviews.php product_reviews_info.php information.php Unfortunately, the mobile version contribution redirects the user again because it detects that the request comes from a mobile device. That said, you need to contact the developers of the two extensions and ask for assistance. After all, they have created the software packages and only they will be able to assist you. I am sure that there are other people using the contributions and they will be glad to fix this bug. Let us know if we can do anything else for you! Another odd thing - with certain products the shopping cart works (adds product and takes you to cart) for others it does not. At first I thought it was products with more than one picture that weren't working but I was wrong. The shopping cart works for both products: http://www.luggage-logic.com/mobile_products.php?cPath=65 The shopping cart doesn't work for any of these EXCEPT the "pack-flat back up bag": http://www.luggage-logic.com/mobile_products.php?cPath=41 I am about ready to give up....... As an idea, could a mobile URL field be put in the database and just have the program call that instead of using redirects? Thanks, Brian
  4. This is a really awesome contrib - Thank you! Everything works on my site for the most part, but I have two problems. 1) When you click to submit the credit card info - instead of a confirmation page - it just reloads the same page. It works fine with the check or money order module but not the credit card. and 2) When I click on a product (on my android phone) The browser returns "The page has too many server redirects" When I click on my regular browser on my computer it goes to the non-mobile page. I have ultimate SEO enabled on the main site and I have the define ('SEO_ENABLED', false); line in my configure.php We recently changed our domain from www.elanteluggage.com to www.luggage-logic.com There is a 301 redirect in the htaccess file to redirect traffic from the old site to the new one. The iOSC install is stock, I am using: // require_once(DIR_WS_FUNCTIONS . 'iosc.php'); define(DIR_MOBILE_CLASSES , 'mobile/includes/classes/'); require(DIR_MOBILE_CLASSES . 'mobile_redirect.php'); $mobileRedirect = new mobileRedirect; In application_top.php This is my htaccess: RewriteEngine On RewriteCond %{HTTP_HOST} ^elanteluggage.com [OR] RewriteCond %{HTTP_HOST} ^www.elanteluggage.com RewriteRule ^(.*)$ http://www.luggage-logic.com/$1 [L,R=301] # $Id: .htaccess,v 1.3 2003/06/12 10:53:20 hpdl Exp $ # # This is used with Apache WebServers # # For this to work, you must include the parameter 'Options' to # the AllowOverride configuration # # Example: # # <Directory "/usr/local/apache/htdocs"> # AllowOverride Options # </Directory> # # 'All' with also work. (This configuration is in the # apache/conf/httpd.conf file) # The following makes adjustments to the SSL protocol for Internet # Explorer browsers #<IfModule mod_setenvif.c> #<IfDefine SSL> #SetEnvIf User-Agent ".*MSIE.*" \ #nokeepalive ssl-unclean-shutdown \ #downgrade-1.0 force-response-1.0 #</IfDefine> #</IfModule> # If Search Engine Friendly URLs do not work, try enabling the # following Apache configuration parameter # # AcceptPathInfo On # Fix certain PHP values # (commented out by default to prevent errors occuring on certain # servers) # #<IfModule mod_php4.c> # php_value session.use_trans_sid 0 # php_value register_globals 1 #</IfModule> # Ultimate SEO URLs BEGIN #Options +FollowSymLinks RewriteEngine On #RewriteBase /home/elantelu/public_html/ RewriteCond %{HTTP_HOST} ^elanteluggage.com [NC] RewriteRule (.*) http://www.elanteluggage.com/$1 [R=301,QSA,L] RewriteBase /~elantelu RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING} RewriteRule ^(.*)-m-([0-9]+).html$ index.php?manufacturers_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-pi-([0-9]+).html$ popup_image.php?pID=$2&%{QUERY_STRING} RewriteRule ^(.*)-t-([0-9]+).html$ articles.php?tPath=$2&%{QUERY_STRING} RewriteRule ^(.*)-a-([0-9]+).html$ article_info.php?articles_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-pr-([0-9]+).html$ product_reviews.php?products_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-pri-([0-9]+).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-i-([0-9]+).html$ information.php?info_id=$2&%{QUERY_STRING} # Ultimate SEO URLs END Any help would be appreciated!!!
  5. Hi, I have a newb question, and I am sorry if this sounds stupid I have SEO URLS 2.1d installed and working Also have XML Sitemap 1.3 installed I was getting the error with seo_cache so I got rid of that file as it said on this forum... The question: Are the sitemaps supposed to have the SEO Names as in: http://my domain.com/travelpro-walkabout-20-inch-expandable-carry-on-suiter-p-36.html or are the sitemaps just supposed to have this: http://my domain.com/product_info.php?products_id=36 Does it matter????? Thank You, Brian
  6. bsreinstra

    coolMenu

    I have looked and looked but no one seems to be able to fix the size issue between "categories" and "cool menu"... The problem is that "categories" expands depending on the number of subcategories in the parent category - and cool menu doesn't so..... Has anyone tried this as a fix? 1. Make the Category menu a constant and set height. 2. Then anyone using this can just alter the dimensions of cool menu to make it always fit? I am a newb but it sounds to me like this would work. I don't know where to start with this but if anyone can tell me the code to change to try, I will try it and post to the forum. -Brian
  7. Okay, I am still stumped.... I have poured over the code and still can't figure out what is wrong.... When I select a manufacturer it pulls up all of the product for the manufacturer, and lists the manufacturers id number as in: http://www.domain.com/index.php?manufacturers_id=13 When I select a category from the page it lists the products from that manufacturer in that category and looks like this: http://www.domain.com/index.php?manufactur...mp;filter_id=45 When I click on the "next page" of products for that manufacturer I get this: http://www.domain.com/index.php?page=2&amp...=hewlet-packard but it takes me back to the main page and not page 2 I want it to appear with the manufacturer name on ALL of the pages. Is this an: index.php issue functions/general issue html_output issue something I haven't thought of yet????? I am on a windows server so htaccess won't help me, I am not using the rewrite method I am using the cname/pname method so the best I can figure is that I am missing a definition somewhere for the manufacturer id to manufacturer name. I don't have a clue where to find it. I am php challenged so please help..... please..... plese..... pls..... p.... :'(
  8. I searched and searched but I couldn't find a solution already posted on the forum When I select a manufacurer on the main page it lists the products for the manufacturer but it has the manufacturers id. Like this: http://www.mydomain.com/index.php?manufacturers_id=13 But when I try to click on page '2' of the products or 'next page' it goes back to the main page and gives me this: http://www.mydomain.com/index.php?page=2&a...me=briggs-riley Can someone please tell me what is wrong or at least tell me what file I should be looking at! Thank you - Thank You - Thank You!!!!
  9. bsreinstra

    Google XML Sitemap w/ Admin support

    Does anyone know how to un-install this contrib? I installed it into my www.mydomain.com/catalog/ And it worked brilliantly!!! Today I got rig of the "/catalog/" portion and changed the root to www.mydomain.com/ Now it doesn't work anymore. I get a failure on all 3 files so I would like to try to uninstall then reinstall. Thanks
  10. bsreinstra

    Google XML Sitemap w/ Admin support

    Does anyone know how to un-install this contrib? I installed it into my www.mydomain.com/catalog/ And it worked brilliantly!!! Today I got rig of the "/catalog/" portion and changed the root to www.mydomain.com/ Now it doesn't work anymore. I get a failure on all 3 files so I would like to try to uninstall then reinstall. Thanks
×