Jump to content

nt13

Members
  • Content count

    9
  • Joined

  • Last visited

Profile Information

  • Real Name
    Nigel Titley
  1. nt13

    NEW! Complete Order Editing Tool!

    This is really helpful. If I just detect that I have a non NULL VAT number stored for the customer then I can zero the tax. I'll have a look at this today.
  2. nt13

    NEW! Complete Order Editing Tool!

    OK, so I think you are saying that there is no way that Order Editor can be used in Europe by a VAT registered company to make cross border sales to other VAT registered companies. The only workaround that I can think of is to have a discount equal to the amount of the tax. I'm not entirely sure that this is legal so I'll have to check with the tax authorities. I may bodge around this by writing a standalone invoice printing module that marries up the discount and the tax and doesn't print the tax if the two are equal. The alternative, I suppose is to modify the ot_tax module to apply zero shipping tax if the total of the product tax is zero (which roughly is what the European tax law requires). I'll have to take a look at this too. Anyway, thanks very much for all the work you have done. Really nice contribution. Nigel
  3. nt13

    NEW! Complete Order Editing Tool!

    Yes, so do I. No real problem. Just install Manual Order Maker 1.3 as well as Order Editor v5. Nigel
  4. nt13

    NEW! Complete Order Editing Tool!

    Sorry, I should have mentioned this. I'm using the TVA Intracomm contribution. However, I'm not really asking for the integration of this code, just a means to zero the entire tax on a per order basis, manually. Making the tax field writeable would be more than adequate, if possible.
  5. nt13

    NEW! Complete Order Editing Tool!

    It appears both on the edit order screen itself (but only after updates, not at the first load) and also in the email that goes out to customers when you press the update email request.
  6. nt13

    NEW! Complete Order Editing Tool!

    Thanks for the response, but that's actually a different (although I suspect related) problem. I've already applied the patch above to fix the problem with odd characters in the shipping description field. My problem is with currency symbols (specifically the pounds sterling symbol) in both the order editing screen and the notification emails. Nigel
  7. nt13

    NEW! Complete Order Editing Tool!

    Installed V5 Beta 1 and after applying all the patches it is working really well for me with a couple of exceptions: 1. My currency symbol is £ (pounds sterling). When I first enter Order Editor the symbol is displayed correctly, however, whenever I do an update the symbol is redisplayed but with a strange carat A in front. This is a pretty minor issue 2. The email sent to the customer when the order is changed also has the carat A in front of the currency symbol. This is a more worrying problem as it is customer facing 3. Finally I have an issue with tax (VAT). In Europe, where I have a customer whose VAT number I know and have verified then I ship without tax and in this special case, the tax on the shipping is zero also. Otherwise tax on shipping is calculated as normal. There seems to be no way to cover this situation unless I'm missing something. I'd be very grateful if anyone can suggest fixes for the above. Thanks Nigel
  8. nt13

    Fancier Invoice & Packingslip v1.0

    So as usual, after posting the question I figure it out myself. The problem was actually in my mailers. The character encoding was set wrong. Switching to UNICODE fixed the problem. Everything now displays nicely....
  9. nt13

    Fancier Invoice & Packingslip v1.0

    Installed this contribution, and must say it looks really nice. One little problem though... (there's always one) I'm a UK site, and my default currency is GBP (surprise). The emailed HTML invoice has a strange symbol inserted in front of every £ symbol. This symbol looks like a capital A with a carat symbol on the top. Now, the rest of the site is fine, the fancy invoices display and print properly from admin mode, it is just the emailed invoices that are wrong. It is the same for all three included invoice templates, and it is the same for a variety of mailers. I wonder if anyone has any thoughts about what this could be and how to fix it.
×