gmltw

Members
  • Content count

    60
  • Joined

  • Last visited

Community Reputation

0 Neutral

1 Follower

About gmltw

  • Birthday 04/01/1970

Profile Information

  • Real Name
    Gary
  • Gender
    Male
  • Location
    US - Texas
  • Interests
    http://libertygunsandarmor.com

    http://libertygunsandarmor.co

    http://libertyguns.co

Contact Methods

  1. Awesome contribution!! Installed today and followed your common problems info and fixed every problem. However, (you knew that was coming didn't ya :blink: ) I see a need. While searching through this thread a ran across this being mentioned by another person but I never saw a solution mentioned so I wanted to bring it up again. Imagine for a moment. If a customer loads their cart and begins to check out, say - maybe they want to see what the shipping will cost or maybe they can't add very good and they want to see what the total is before adding more stuff to their cart, whatever the reason. They go to the order total page and they have input their coupon code (Because they can't add and want to see what the total is or whatever.) and then they decide - "Hey, I still gots me a bit a money to spend." So they go back surfing through my store and add a few more products. Finally they are pretty sure that they are at their limit and want to check out. Only when they get to the place to put the coupon in again and they do so it says they already used it. Now, these simple minded folk are not about to E-mail me and let me know they want another coupon, nope they are going to walk right out my door (figuratively of course) and find another business that doesn't waste their time. You see where I am going with this? This needs to be fixed. The code should not be recorded as being used by the customer until they have committed their money and checked out. Perhaps this is the way it is and there is a problem with my store, I don't know. If anyone has a suggestion I am all ears. :lol: Have a look if you like. http://gscoffeeclub.com Please realize this store is live and you will be charged if you go through with the order. I say again, this is an awesome contribution. Thanks, Gary
  2. Just to update for all who are needing the MVS and OS Commerce PayPal IPN to work together. I am probably not the best person for the job but it seems like no one else wants to take it on. I am in the process of getting them to work nicely with each other without throwing too many temper tantrums. It is proving to be more than I expected but I don't give up so don't loose hope. :) I have received many PMs concerning these two contribs and I promise that as soon as I get it solid it will be in the MVS files. I am hoping that I can finish in a week or less. If anyone would like to help or knows more than I do I am not proud, I will accept help. :) I have succeeded in getting the extra email and the update from Preparing [PayPal IPN] to whatever you have it set to update to when paypal verifies the money. The rest will take a bit more time. Thanks, Gary
  3. phi148, I was just reviewing the known issues of the OS COmmerce PayPal IPN and noticed that the number one issue seems to coincide with the problems we are having with the E-Mail. This could be why we are not receiving order emails. Just a thought. Gary
  4. I just noticed something about google xml sitemaps that seems little sneaky to me. At the bottom of the sitemapindex.xml page you will notice that there are links. These links are to other sites that have to do with site maps and not necessarily this contrib ( as far as I could see). It seems to me that this would drive these web sites rank way up because every time google looks through our site map it finds these links which is one of the main things (relevant links to your site from other sites) google looks at. I would not have a problem with this if it were made clear in the installation notes AND if the sites that are linked would reciprocate the links. Otherwise, I feel like I have been a little taken advantage of. I just wanted to point that out in case others might feel the same way and wanted to do something about it. Gary
  5. OK, after three days and too many hours that I care to admit, I have a (maybe partial) solution. If after you have installed google xml sitemap and you run it and get back your xml generated link page you have links that look something like - http://gourmetsoiree.com/admin/configuration.php?gID=1&cID=11 but you have Ultimate SEO URLS or some other SEO contrib that makes your URLs look more friendly for the search engines more like - http://gourmetsoiree.com/classic-hand-rolled-milk-chocolate-truffles-p-191.html . If you are able to turn on the OSCs and get the results you want in the XML generated pages for google but can't leave on all the time because you keep getting the on some of your pages. This should fix your problem until someone can come out with something better. In application_top.php find // make a connection to the database... now tep_db_connect() or die('Unable to connect to database server!'); Directly after place this code: //Start - Set SEF's if this page was called from googlesitemap.php or sitemaps.index.php to true - gmltw April 21-07 if(strpos($_SERVER['REQUEST_URI'], 'googlesitemap.php') || strpos($_SERVER['REQUEST_URI'], 'sitemaps.index.php')) { tep_db_query("update " . TABLE_CONFIGURATION . " set configuration_value = '" . tep_db_input('true') . "', last_modified = now() where configuration_id = 11 "); } //End - Set SEF's Then at the very end before the last ?> place this code: //Start - Set SEF's if this page was called from googlesitemap.php or sitemaps.index.php back to false - gmltw April 21-07 if(strpos($_SERVER['REQUEST_URI'], 'googlesitemap.php') || strpos($_SERVER['REQUEST_URI'], 'sitemaps.index.php')) { tep_db_query("update " . TABLE_CONFIGURATION . " set configuration_value = '" . tep_db_input('false') . "', last_modified = now() where configuration_id = 11 "); } //End - Set SEF's That's it. What this will do is - check to see if google xml sitemap is running. If it is it will set the Search Engine friendly URLs to true just long enough to run the script and then it will set it back to false so that it doesn't fuddle with your other pages. As you may know, application_top.php is called every time a page is loaded so we can't very well let it turn the SEFs to true every time, that is why we check for the referring or rather in this case the page that begin the request for application_top.php. This way we can have it change only if the google xml sitemap was requester. The only thing I am not sure on is whether this will cover the case of CRON doing the calling. If you do not have CRON setup to automatically run your google xml sitemap then you shouldn't have anything at all to worry about. I will be trying to determine the CRON issue so if I figure it out, I'll post it here. Hope this helps someone. Gary
  6. I don't know why this got posted twice. Something was going on with the OSC Site????? Anyway, the above code does not work. It seems to return true no matter what the calling page is. I assume that it has something to do with the code that I took from PHPNuke. I could use a little help if anyone knows what to do. Thanks, Gary
  7. OK, I tried setting the value to true in the sitemaps.index.php during run time but it seems that it is going to have to be done in the application_top.php instead. I remember that PHPNuke has a similar argument in it's code for verifying whether the page is being called from the index or not (it's a safety protocol). This is what I have now: /* ___________________________________________________________________________ _______ */ //Start - Set SEF's if this page was called from googlesitemap.php gmltw April 21-07 if (!eregi("googlesitemap.php", $_SERVER['PHP_SELF'])) { tep_db_query("update " . TABLE_CONFIGURATION . " set configuration_value = '" . tep_db_input('true') . "', last_modified = now() where configuration_id = 11 "); } elseif (!eregi("sitemaps.index.php", $_SERVER['PHP_SELF'])) { tep_db_query("update " . TABLE_CONFIGURATION . " set configuration_value = '" . tep_db_input('true') . "', last_modified = now() where configuration_id = 11 "); }else{ // Do nothing } //End - Set SEF's if this page was called from googlesitemap.php gmltw April 21-07 /* ___________________________________________________________________________ _______ */ I placed this directly after the // make a connection to the database... now tep_db_connect() or die('Unable to connect to database server!'); in application_top.php and again at the end before the closing ?> except the one before the closing ?> was set to false instead of true. It works when I am clicking on it from within the Admin Panel under Tools\google site maps but I don't know if it will work when called from CRON. I was hoping that when it is called from CRON that the sending file would be sitemaps.index.php but I have no idea. Can anyone help me with the CRON issue. That is the main one because I need to leave the SEF's set to false all of the time except when the google site maps are generated. Since most of us have CRON setup to do this on regular intervals we need this to indentify calls from CRON as well. I am thinking that the elseif statement will not accomplish this task because of where it is checking to see where it came from. Anyone have any ideas? Also, I am sure that someone that knows the proper syntax might be able to clean my code up a bit. I know that you should be able to have this be one if statement with or in the first conditional statement. instead of splitting it up into if and elseif. If anyone knows how to do this it would more streamline this code. Thanks, Gary
  8. OK, I tried setting the value to true in the sitemaps.index.php during run time but it seems that it is going to have to be done in the application_top.php instead. I remember that PHPNuke has a similar argument in it's code for verifying whether the page is being called from the index or not (it's a safety protocol). This is what I have now: /* ___________________________________________________________________________ _______ */ //Start - Set SEF's if this page was called from googlesitemap.php gmltw April 21-07 if (!eregi("googlesitemap.php", $_SERVER['PHP_SELF'])) { tep_db_query("update " . TABLE_CONFIGURATION . " set configuration_value = '" . tep_db_input('true') . "', last_modified = now() where configuration_id = 11 "); } elseif (!eregi("sitemaps.index.php", $_SERVER['PHP_SELF'])) { tep_db_query("update " . TABLE_CONFIGURATION . " set configuration_value = '" . tep_db_input('true') . "', last_modified = now() where configuration_id = 11 "); }else{ // Do nothing } //End - Set SEF's if this page was called from googlesitemap.php gmltw April 21-07 /* ___________________________________________________________________________ _______ */ I placed this directly after the // make a connection to the database... now tep_db_connect() or die('Unable to connect to database server!'); in application_top.php and again at the end before the closing ?> except the one before the closing ?> was set to false instead of true. It works when I am clicking on it from within the Admin Panel under Tools\google site maps but I don't know if it will work when called from CRON. I was hoping that when it is called from CRON that the sending file would be sitemaps.index.php but I have no idea. Can anyone help me with the CRON issue. That is the main one because I need to leave the SEF's set to false all of the time except when the google site maps are generated. Since most of us have CRON setup to do this on regular intervals we need this to indentify calls from CRON as well. I am thinking that the elseif statement will not accomplish this task because of where it is checking to see where it came from. Anyone have any ideas? Also, I am sure that someone that knows the proper syntax might be able to clean my code up a bit. I know that you should be able to have this be one if statement with or in the first conditional statement. instead of splitting it up into if and elseif. If anyone knows how to do this it would more streamline this code. Thanks, Gary
  9. Well, the solution wasn't a complete success I am sorry to say. I am having a problem with getting an error "Unable to determine the page link!" Which is associated with having "Use Search-Engine Safe URLs (still in development)" set to true on a few pages. They are generally not the main pages or product pages so I haven't found the correlation. The only reason I need this set to true is for this contrib. So I was wondering, why can't we set the "Use Search-Engine Safe URLs (still in development)" to true on the fly in the file sitemaps.index.php and then back to false when it has finished it's magic? I would try this but I am not exactly familiar with PHP syntax. Can anyone give me a little code to help me on my way and I'll try it out? If someone could give me the proper code I think I can figure out where to put it. This would fix all of my problems with this mucking up the rest of my store. Thanks for a great contrib! Gary
  10. Sure, no problem. PM me your Email and I'll send you the files. Gary
  11. Hi Craig, I searched all of the language files and every php file in my entire store for any occurrence of the two letters kg. The only result I received was a partial match in the site certificate key. :blink: Not only did I search the entire store but I also physically reviewed all of the code that I could think of that might have anything to do with this. In every place that you think you would find it there was lb. instead (just like I want it). I also searched my database for the off chance that it might be in there somewhere. No luck there either. This one has me stumped. It doesn't make any sense. I am not going to loose sleep over it though. It will just have to stay until I stumble across it some day or someone happens to tell me where it is hiding. <_< I am searching for the handling charge post, thanks for the response. If I ever figure out where the weight is being set, I'll share the news. :thumbsup: Gary
  12. I am really not sure about the changes you are talking about. I have slept since I did this install and I really don't remember that far back. :blink: I know that when I installed it I just followed the instructions that came with the OSC PayPal IPN and I don't remember making any modifications to it from MVS. Not saying that I didn't, I just don't remember doing it. What I do remember and know is (because I keep a change log) I installed the MVS contribution before I installed any other contrib. I found it easier this way for me. I did not install the PayPal IPN contrib until much later in the game and the more I think about it the more I am pretty sure I did not make any mods to the PayPal IPN. I don't think you have to. Hopefully if I am wrong someone who knows will correct us. I am not having any issues with the OSC PayPal IPN working with my store. If you would like, I can PM you the code from my checkout_process.php file. I think I must have misunderstood what you were asking for. I thought you wanted something that gave a total of all of the shipping charges at the bottom of the shipping page. Sorry!
  13. Since this is in a Pop up, how can I go about getting it to load with the address bar so that I can enter the debug code? I guess I could add it to the filenames link (or where ever it was I named that link). It's late and my eyes are beginning to cross but I am going to have another look at the query tomorrow. I agree with you on the language being in the join. Not sure why I did that? >_< Maybe it'll come to me after I have slept a little. Maybe! Yes on the sts_popup_image.php module Can you verify that I am covering all bases with where I have my code located. I have a view_more_info.php located in the catalog/ folder which will work if STS is set to false. A copy of sts_pop_up.php called sts_view_more_info.php and modified so that the class is correct and all variables are correctly named. A file that I created for the sts_inc folder where I set the values of my sts tags. Similar to the pop_up.php file in the sts_inc folder but with different variables and a different query (of course). The template for my view_more_info.php file located in my template folder - catalog/includes/sts_templates/gourmet_soiree/ called view_more_info.php.html. If I am understanding the way this is working, the catalog/includes/module/sts_inc/view_more_info.php should be taking the place of the catalog/view_more_info.php if I have it turned on in Admin (which is controlled by the file located in the sts folder). Is that correct? Do I have to keep the view_more_info.php located in the catalog/ for it to work without errors? Does this look like I have everything covered or have I missed something as far as files go? Thanks for your help! Gary
  14. I am not sure I follow you. You may remove or add as many or as few of the STS tags as you want. You can completely remove all of the tables if you want. If you know how, you can create your page with css only and forget about the tables all together (from what I understand). The template files are very very simple with one word tags so I am not sure what you mean by the unnecessary code. You can leave out and remove any unneeded tables or tags ( like $cartbox ) you are not using or don't need. For instance, this is the complete html for the template file for my log in page: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"> <?php DEFINE ('STS_END_CHAR', '$'); ?> <html $htmlparams> <head> <!--$headcontent--> <link href="stylesheet.css" rel="stylesheet" type="text/css"> </head> <body marginwidth="2px"> <table align="center" width="100%" border="0" cellpadding="0"> <tr> <td align="center">$topsearch$</td> </tr> </table> <table width="100%" align="center" margin="3"> <tr class="headerNavigation"> <td class="headerNavigation"> $breadcrumbs$ </td> <td align="right" class="headerNavigation"> $blog$ | $myaccountlogoff$ | $cartcontents$ | $checkout$ </td> </tr> </table> <table width="100%" border="0" cellpadding="0"> <tr><td align="left">$catmenu$</td></tr> </table> <table width="100%" border="0" align="center" cellpadding="3" cellspacing="0"> <tr> <td valign="top" width="20%"> <table border="0" width="100%" cellspacing="0" cellpadding="4"> <tr><td>$cartbox$</td></tr> <tr><td>$orderhistorybox$</td></tr> <tr><td>$specialfriendbox$</td></tr> </table> </td> <td valign="top" class="main"> <p>$content$</p> <p> </p> </td> </tr> </table> <table border="0" width="100%" align="center" cellspacing="0" cellpadding="1"> <tr class="footer"> <td class="footer"> $date$ </td> <td align="right" class="footer"> $numrequests$ </td> </tr> </table> <br> <table border="0" width="100%" align="center" cellspacing="0" cellpadding="0"> <tr> <td align="center" class="smallText"> $footer_text$ </td> </tr> </table> <br> <table border="0" width="100%" align="center" cellspacing="0" cellpadding="0"> <tr> <td align="center"> $banner_only$ </td> </tr> </table> <table border="0" width="100%" align="center" cellpadding="3" cellspacing="0"> <tr> <td align="center" class="smallText"> Simple Template System by DiamondSea.com<br> STS v4.3 by osc-help.net<br> </td> </tr> </table> </body> </html> With the above I could very easily add any number of tags that I felt might benefit or remove any that I felt were unnecessary. If I don't want the customers history box to show on this page I would simply remove <tr><td>$orderhistorybox$</td></tr> and it would not show. If you are asking how to edit or where to edit the data that is returned through the tags, there is a little more to that. Sorry if this does not help. I am not quit sure what you are asking. Gary
  15. The best way is to change it in the stylesheet.css file. If you need to have different formats for the left and right columns then create a new class in the stylesheet.css file and then make sure that you are using the class where you want it changed. Apply the class in the template files. For Instance - If you only have one STS template for the entire site you would simply apply the changes in the the catalog/includes/sts_templates/YOUR_TEMPLATE/index.php.html file. If you have other templates you will need to apply them in there as well. Apply the class to each <td> tag like this - <td class="ProdName">. In your stylesheet.css file you will have the class ProdName (or whatever you call it). Like this: .ProdName { font-family: "Lucida Handwriting", ChopinScript, Georgia, "Lucida Calligraphy"; font-size: 24px; text-align: left; vertical-align: top; } You can apply whatever css style you wish to whatever you want this way. Hope this is what you were looking for. By the way, the thread for the STS template system is http://forums.oscommerce.com/index.php?showtopic=58541 if you have more questions about it you will probably get quicker answers there because people monitor that thread. Just for you info. B) Gary