Jump to content

rosshand

Members
  • Content count

    42
  • Joined

  • Last visited

Everything posted by rosshand

  1. HI, I've installed this on a heavily modified site and cannot find how to buy gift vouchers through the catalog. I tried installing this on a test server on a clean install and still couldnt see how to purchase gift vouchers through the catalog side. I can email vouchers, and set up discount coupons etc. Its just the purchasing of vouchers that I cant seem to work out!
  2. rosshand

    Protx Direct v2.22

    Superb!! Thankyou!!!!
  3. rosshand

    Protx Direct v2.22

    HI, it just says Invalid Card number, for newer Visa cards
  4. rosshand

    Protx Direct v2.22

    I've been using Protx Direct 2.2 for a long while now. However recently customers are complaining saying that their cards are being bounced saying they are invalid. It seems to happen on newish visa cards. It isnt a protx problem as it happends in the checkout_payment page. Can anyone help I'm loosing a lot of custom over this. I am using hte dropdown menus for customers to select the card tehy want to use.
  5. rosshand

    RMA Returns error for 2.2 MS2

    Help! I'm using Multi Vendor shipping , and nothing seems to work on the RMA contrib! Any ideas where I can start to look?
  6. rosshand

    ASN Forum for osCommerce

    I get this error when I try to post a reply Fatal error: Call to a member function on a non-object in /path_to/includes/header.php on line 51 Can any one help?
  7. rosshand

    Offical Google Checkout module for osCommerce Support Thread

    Hi all, excellent contrib. however Orders are not being shown in Oscommerce, but are being processed fine through Google checkout. It takes you back to the order success page on our site, however no order is added into the database! I think its an issue with Multi vendor Shipping.Has anyone got it to work with this? Please help!
  8. PLEASE can some one help SEO urls are working fine but I am trying to add SEO urls for a new box that I have had made for my site. It introduces a new file + variable which is for example cat.php?m_id=288 The m_id is the manufacturers id. I HAVE done the following in seo.class.php around line 548 I have added: $seo_pages = array(FILENAME_DEFAULT, FILENAME_PRODUCT_INFO, FILENAME_POPUP_IMAGE, /// New Addition for cat.php FILENAME_CAT, ///end new addition for cat.php FILENAME_PRODUCT_REVIEWS, FILENAME_PRODUCT_REVIEWS_INFO); Around line 587 I have added: $this->reg_anchors = array('products_id' => '-p-', 'cPath' => '-c-', 'manufacturers_id' => '-m-', 'pID' => '-pi-', ///New Addition for cat.php 'm_id' => '-ma-', ///End addition for cat.php 'tPath' => '-t-', 'articles_id' => '-a-', 'products_id_review' => '-pr-', 'products_id_review_info' => '-pri-', 'info_id' => '-i-' ); Around Line 820 case 'manufacturers_id': switch(true){ case ($page == FILENAME_DEFAULT && !$this->is_cPath_string($params) && !$this->is_product_string($params) && strlen($this->get_manufacturer_name($p2[1]))>0 ) : $url = $this->make_url($page, $this->get_manufacturer_name($p2[1]), $p2[0], $p2[1], '.html', $separator); break; case ($page == FILENAME_PRODUCT_INFO): break; default: $container[$p2[0]] = $p2[1]; break; } # end switch break; ///Addition for cat.php case 'm_id': switch(true){ case ($page == FILENAME_CAT && !$this->is_cPath_string($params) && !$this->is_product_string($params) && strlen($this->get_manufacturer_name($p2[1]))>0 ) : $url = $this->make_url($page, $this->get_manufacturer_name($p2[1]), $p2[0], $p2[1], '.html', $separator); break; default: $container[$p2[0]] = $p2[1]; break; } # end switch break; /// End Addition for cat.php I have also added the following line into includes/filnames.php define('FILENAME_CAT', 'cat.php'); I have also changed .htaccess file to add: RewriteRule ^(.*)-ma-([0-9]+).html$ cat.php?m_id=$2&%{QUERY_STRING} BUT IT STILL DOESNT WORK , the links I get still read .../cat.php?m_id=288 If I type www.mysite.com/my-manufacturer-ma-288.html then it works fine, its just the links arent linking to it! Any help or advice or if you spot something silly i've missed would be greatly appreciated, I am starting to pull my hair out :(
  9. rosshand

    Offical Google Checkout module for osCommerce Support Thread

    Orders are not being shown in Oscommerce, but are being processed fine through Google sand box. It takes you back to the order success page on our site, however no order is added into the database! We have a few mods inc Auction Blox, Multi vendor Shipping, and purchase without account. Could this be the issue?
  10. Hi Can anyone help with exporting orders to a csv file (or something smiliar) so that it does this automatically at the end of the day , and adds a new line for each order rather than a new file for each order. I have this contrib installed http://www.oscommerce.com/community/contributions,4181/ (Export orders to CSV) but you have to manually put in the order number range, and then it creates a unique file each time
  11. HI Excellent Contrib. I have an odd problem though. SEO urls work fine on my https, and did work on my HTTP but now all the links from the index.php and productinfo.php are in the NON seo format . BUT if you type in what the seo url should be, it finds it ok! Any ideas which files I need to look at my HTTPS is hereMotorbikes and Parts HTTPS my Htto is here http://www.motorbikesandparts.co.uk
  12. HI , How can I get rid of the numbers at the end of my URLS For example my Product "Givi E450 45 litre topbox" has -p-10476 at the end. How do I get rid of that part? http://www.motorbikesandparts.co.uk/givi-e...ox-p-10476.html
  13. Its now fixed, I had to change the tep_href to be differnt on the HTTPS server.
  14. I have disabled it temporarly on the HTTPS server but not the HTTP, otherwise no one could place any orders. If you browse the HTTP only then all the seo urls work. but if you turn on seo urls on the https, the urls work, but no orders can be processed
  15. HELP HELP HELP! Just installed Ultimate SEO Urls on www.motorbikesandparts.co.uk and now NO ORDERS ARE BEING ACCEPTED! It seems to give all potential orders the number 0 and no billing or delivery address info is visible!!!!! Please can anyone help, we cannot take any orders while this is like it is
  16. HI I have installed Google XML Sitemap w/ Admin Cant get it to work on my new shop though , this error is thrown up each time I try to generate Warning: fopen() [function.fopen]: open_basedir restriction in effect. File(/sitemapproducts.xml) is not within the allowed path(s): (/home/httpd/vhosts/motorbikesandparts.co.uk/httpsdocs:/tmp) Can you tell me why it is putting a ":" colon before the "/tmp" as this seems to be the problem Thanks in advance
  17. Excellent contrib, Cant get it to work on my new shop though , this error is thrown up each time I try to generate Warning: fopen() [function.fopen]: open_basedir restriction in effect. File(/sitemapproducts.xml) is not within the allowed path(s): (/home/httpd/vhosts/motorbikesandparts.co.uk/httpsdocs:/tmp) Can you tell me why it is putting a ":" colon before the "/tmp" as this seems to be the problem Thanks in advance
  18. rosshand

    Multi_Vendor_Shipping new thread

    HI Having an odd problem with Multi_vendor_shipping . Some customers can log in and order fine, others get this error at the choosing shipping stage: Warning: Invalid argument supplied for foreach() in /home/httpd/vhosts/motorbikesandparts.co.uk/httpsdocs/includes/modules/vendor_shipping.php on line 97 The code from line 95 to 104 in that file is $products_ids = $vendor_data['products_id']; foreach ($products_ids as $product_id) { $products_query = tep_db_query("select products_name from " . TABLE_PRODUCTS_DESCRIPTION . " where products_id = '" . (int)$product_id . "' and language_id = '" . (int)$languages_id . "'" ); $products = tep_db_fetch_array($products_query); ?> ANY ideas what could be causing this on some customers computers but not others????????
  19. Hi I have multi vendor shipping installed, and when I try to use batch print centre, all I get in the products name and products ID field is "x" Does anyone have any idea what could be causing this?
  20. HI Can anyone help I'm trying to reduce the amount of text in the shipping page because i have multi vendor shipping installed which has a different shipping method for each vendor. So can anyone point me in the right direction as to how to make the shipping options dropdown menus rather than box clicking options Any help greatly appreciated
  21. HI, I wonder if you can help? I am using easypopulate and am really really stuck. I have different products which have the same product model, but different product id, and others have same product id but different product model. So is it possible to change easypopulate so that it compares BOTH product id and product model to decide wheather to update or insert a new product ? Hope you can help, or point me in the right direction. Thanks again R
  22. rosshand

    Multi_Vendor_Shipping new thread

    Hi , Excellent module! I am trying to offer customers ONE OVERALL set of options for delivery prices, instead of one per vendor. But I still want the backend functionality of MVS Can you tell me if someone has already done this, if not is it possible, and can a novice like me tackle it?? Thanks
  23. rosshand

    Protx Direct v2.22

    Thanks so much for your help. When I took it out of test mode it worked (after changing the "Authorisation type" in the admin from "AUTHENTICATE" to "PAYMENT") . It would not work in Authenticate mode. Is this normal?
  24. rosshand

    Protx Direct v2.22

    Thanks very much for that, however now I get this error "StatusDetail=4020 : Information received from an Invalid IP address. The value was 83.138.142.194." But I have enabled that IP address and it was working previously. The only thing I can see that is different is that in the PROTX control pannel they automatically insert a 0 at the start so it says 083.138.142.194 Do you think that is causing hte problem?
×