Jump to content

c1badmofo

Members
  • Content count

    17
  • Joined

  • Last visited

Profile Information

  • Real Name
    chris

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. c1badmofo

    Master Products - MS2

    So no one has configured product notifications to work with slave products?
  2. c1badmofo

    Master Products - MS2

    I am trying to configure product notifications to work with slave products. What I need to do, is take the products_id from $listing['products_id'] from master_listing.php page Then in the application_top.php case 'notify' : if (tep_session_is_registered('customer_id')) { if (isset($HTTP_GET_VARS['products_id'])) { $notify = $HTTP_GET_VARS['products_id']; } elseif (isset($HTTP_GET_VARS['notify'])) { $notify = $HTTP_GET_VARS['notify']; } elseif (isset($HTTP_POST_VARS['notify'])) { $notify = $HTTP_POST_VARS['notify']; } else { tep_redirect(tep_href_link(basename($PHP_SELF), tep_get_all_get_params(array('action', 'notify')))); } if (!is_array($notify)) $notify = array($notify); for ($i=0, $n=sizeof($notify); $i<$n; $i++) { $check_query = tep_db_query("select count(*) as count from " . TABLE_PRODUCTS_NOTIFICATIONS . " where products_id = '" . $notify[$i] . "' and customers_id = '" . $customer_id . "'"); $check = tep_db_fetch_array($check_query); if ($check['count'] < 1) { if($HTTP_POST_VARS['listing'] != '') //ADD SOME SORT OF CHECK TO DETERMINE IF SLAVE EXIST { tep_db_query("insert into " . TABLE_PRODUCTS_NOTIFICATIONS . " (products_id, customers_id, date_added) values ('" . slave_id . "', '" . $customer_id . "', now())"); }else{ tep_db_query("insert into " . TABLE_PRODUCTS_NOTIFICATIONS . " (products_id, customers_id, date_added) values ('" . $notify[$i] . "', '" . $customer_id . "', now())"); } } } tep_redirect(tep_href_link(basename($PHP_SELF), tep_get_all_get_params(array('action', 'notify')))); } else { //////////////////////////////////////////////////////////////////////////////// I guess the simple answer I am asking... how do I get the variable $listing['products_id'] (master_listing.php), which is the product_id of the slave to be called/read on the application_top.php page Thanks,
  3. c1badmofo

    Master Products - MS2

    Thanks,.... Nice site, can I ask what 'products Tab' contrib are you using?
  4. c1badmofo

    Master Products - MS2

    Can someone post screen shots... I didn't see any in the packages like they were claim in previous forums. Thanks,
  5. c1badmofo

    Featured Product Support v1.5.4

    I was wonder if someone could tell me what needs to be changed so I can have the picture image and price center align and the description text left align. I know how to change the alignment of all of them, but I would like to center only picture and price, and left align text. It seems the code for this is located in /includes/modules/featured.php around line 140. but I dont know how to modify it correctly. thanks
  6. I have installed Discount Coupon Codes 3.34 - xinxi, all is working fine. I do have one change I would like to make if someone could guide me in the right direction. I have added free shipping to products based on the categories they are, which works correctly deducting the shipping cost. However, if you add a product from a free shipping categories and a product that is excluded from free shipping the full amount is still deducted. Is there a way to only deduct the shipping amount from the products with free shipping?
  7. How would one go about fixing this problem? Is there a minor change I could make somewhere and keep the htaccess the way it is... redirecting default.php to the main site. and have this contribution work?
  8. No, I can add products that I viewed to my shopping not logged in, and they are not lost, but my Recently View box still disappears. As I click on other products, and add them to my shopping cart, the Recently View box will sometimes disappear, then reappear when view another product.
  9. I am having the same problem where only my categories are not working correctly and redirecting to the homepage. Individual products displays the links correctly. I have also noticed when I use diagnostic code ?profile=on, it displays Array ( [sTANDARD_URLS] => Array ( [PRODUCTS] => Array ( But there is no [CATEGORIES] => Array , it is missing Using: Ultimate SEO 2-2.2d-9 htaccess file located in catalog/ directory looks like: Options +FollowSymLinks RewriteEngine on RewriteCond %{HTTP_HOST} ^myexample.com [NC] RewriteRule ^(.*)$ http://www.myexample.com/$1'>http://www.myexample.com/$1 [L,R=301] DirectoryIndex index.php index.php3 index.phtml index.cgi index.shtml index.html index.htm index.wml index.pl index.cgi index.php4 index.phtml index.swf default.htm default.php default.html Default.htm Default.html main.htm main.html php_flag display_errors off RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /([^/]+/)*default\.php\ HTTP/ RewriteRule ^(([^/]+/)*)default\.php$ http://www.myexample.com/ [R=301,L] RewriteBase /catalog/ RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING} RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING} RewriteRule ^(.*)-by-(.*).html$ all-products.php?fl=$2&%{QUERY_STRING} RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING} RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-au-(.*).html$ articles.php?authors_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-f-(.*).html$ faqdesk_info.php?faqdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-fc-(.*).html$ faqdesk_index.php?faqPath=$2&%{QUERY_STRING} RewriteRule ^(.*)-fri-(.*).html$ faqdesk_reviews_info.php?faqdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-fra-(.*).html$ faqdesk_reviews_article.php?faqdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-links-(.*).html$ links.php?lPath=$2&%{QUERY_STRING} RewriteRule ^(.*)-pm-([0-9]+).html$ info_pages.php?pages_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-n-(.*).html$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-nc-(.*).html$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING} RewriteRule ^(.*)-nri-(.*).html$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-nra-(.*).html$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-po-([0-9]+).html$ pollbooth.php?pollid=$2&%{QUERY_STRING} In addition, I have checked the files above u mentioned for redirects, in the code, but I find nothing.
  10. I will describe the problem the best I can. I have successfully installed Recently Viewed 2.0, all seems to be working well for the most part, however, while viewing the site, not logged in, sometimes the recently view box will disappear when clicking on products, and/or it will not record all products viewed, this only seems to occur when a user is not logged in. If a user is logged in, everything functions normally it seems... My products_info.php is cached, to less server load. Any one have a similar problem, or know a fix for this?
  11. c1badmofo

    [Contribution] Cross Sell (X-Sell) Admin

    Thank you, it works. You did mention that I would have to disable cache, but I currently need to have cache on to cut down on server load. Is there a way to leave caching on, but have the 'we also recommend' box of items not be cached and change everytime the page is re-called
  12. c1badmofo

    [Contribution] Cross Sell (X-Sell) Admin

    I have install XSell version 2.7.2, but have a couple of changes I would like to make, if they are easy to do, and someone could suggest what would have to be changed in order for it to work. How can I randomize the results displayed, so the same products are not displayed every time. In addition, how can I only display item currently in-stock.
  13. c1badmofo

    Dynamic SiteMap

    I install Dynamic Sitemap v 2.0 by kit I see that it is based on MS2, but I am using 2.2rc2a Does this sitemap work on 2.2rc2a? I have read from page 20 and up and can't seem to find answer to my problem. I have two errors that are shown below: Any help would be appreciated. Site Map data = array(); while ($categories = tep_db_fetch_array($categories_query)) { $this->data[$categories['parent_id']][$categories['categories_id']] = array('name' => $categories['categories_name'], 'count' => 0);} } //end class osC_CategoryTree function buildBranch($parent_id, $level = 0) { $result = $this->parent_group_start_string; //starts the tag if (isset($this->data[$parent_id])) { foreach ($this->data[$parent_id] as $category_id => $category) { $category_link = $category_id; $result .= $this->child_start_string; // prints if (isset($this->data[$category_id])) {$result .= $this->parent_start_string;} //prints nothing if ($level == 0) {$result .= $this->root_start_string;} //prints nothing $result .= str_repeat($this->spacer_string, $this->spacer_multiplier * $level) . ''; $result .= $category['name']; $result .= ''; if ($level == 0) {$result .= $this->root_end_string;} //prints nothing if (isset($this->data[$category_id])) {$result .= $this->parent_end_string;} //prints if (isset($this->data[$category_id]) && (($this->max_level == '0') || ($this->max_level > $level+1))) { $result .= $this->buildBranch($category_id, $level+1);} $result .= $this->child_end_string; //prints }// end foreach } // end if (isset $result .= $this->parent_group_end_string; // return $result; } //end function function buildTree() { return $this->buildBranch($this->root_category_id);}} ?> Fatal error: Class 'osC_CategoryTree' not found in C:\Program Files\EasyPHP\www\catalog\dynamic_sitemap.php on line 58 And in Admin panel when I click on "sitemap" I receive the following message: Sitemap '.TEXT_EXCLUDE_FOR_UNREG.tep_draw_radio_field('ex_type','unreg');?> '.TEXT_EXCLUDE_FOR_UNREG.tep_draw_radio_field('ex_type','unreg');?> ('.( $exclude['exclude_type'] == 1 ? TEXT_ALL : TEXT_UNREG ).') '.TEXT_INCLUDE.' '; } ?> ('.( $exclude['exclude_type'] == 1 ? TEXT_ALL : TEXT_UNREG ).') '.TEXT_INCLUDE.' '; } ?>
  14. c1badmofo

    NEW! Complete Order Editing Tool!

    I have currently installed the lastest version of Order Editor v2.8.5, and I like to thank everyone for there contributions. The question I have is on the order_editor.php. If I click on "Add a Product" to the existing order, the order total weight is updated and recalculated correctly, but the total for the shipping weight has not change nor updated based on the new total weight. Is there a simple fix for this?
×