Jump to content
Latest News: (loading..)

Patrick73

Members
  • Content count

    65
  • Joined

  • Last visited

Profile Information

  • Real Name
    Patrick
  • Gender
    Male
  • Location
    Montreal,QC, Canada
  1. Patrick73

    canada.post.rest.rate.service.oscommerce.V2.3

    Hey Bruce, The propblem is Canada post server related as we can no longer get quotes since the 28th, so there was obviously a change on the Canada posts server. I haven't looked at the problem yet but there is going to be an update to the shipping modules, so keep posted.
  2. I don't know if this might help but I was having the same problem when viewing mobile site with google chrome that was displaying wrong because of unsecured items on page. When viewing over iphone/ipad or firefox, the problem was nor present.
  3. Thanks for reply Rainer, I've figured out that The images problem over ssl has no incidence on mobile devices, it was a problem while browsing mobile site with chrome. Everything else works perfectly well with iphone, but does not redirect automatically over ipad. Great work Rainer!!!!!!!
  4. Basically the ssl problem is that the images from the mobile/images file are not secured
  5. Hello Rainer, This is an amazing contribution thanks a lot. 1. In update rev 6 from rev5 there is : But in mobile osc rev5, that code is a bit different it is mobile_url if I am not mistaking. Also, I have a shipping module that uses data from a file /classes. When trying to check out on the mobile site, checkout shipping would be blank so I modified my code in the shipping module as follow and it works on the sides of the store classic and mobile, but is it all right? Was require_once(DIR_FS_CATALOG . DIR_WS_CLASSES . "way2ship_osc.php"); Now require_once((defined('MOBILE_SESSION') ? '../includes/classes/way2ship_osc.php' : 'includes/classes/way2ship_osc.php')); Last but not least, I have searched the fix this issue but can not find the problem. Pages that load in ssl have no css or images from the mobile/images file. If I load the page without ssl, everything is fine. Thanks for your support, Patrick
  6. Patrick73

    ULTIMATE Seo Urls 5 - by FWR Media

    There is an issue with multi language that many people seem to have and here's more input in to the problem that I've not found so far in the thread. Once multi language is set to true: A click on a language other than default language flag in language box =http://mysite/index.php/En where everything is ok. Links to shipping.php, privacy, specials, products_new all work fine in the following form:=http://mysite/shipping.php/En Products_review box header click works and opens =http://mysite/reviews.php/En but click to follow product review link to a product does not=http://mysite/product_reviews_info.php/En/product-name-928?reviews_id=384 opens the review in the default language if the review exists. Every link that has the something after the /EN/ will follow the link but redirect to the default language. Patrick
  7. Patrick73

    PayPal Automated Labels, Support Thread

    Hey Alexei, I'm getting a failed sanity check at step two in the second part of the process from what I can see. https://www.paypal.com/ca/cgi-bin/webscr?cm...15521baa3d60b80 HTTP/1.1 200 OK Date: Fri, 21 Aug 2009 20:46:51 GMT Server: Apache Set-Cookie: login_email=%3cMYSITE%40MYHOST.ca%3e; expires=Wed, 17-Feb-2010 20:46:52 GMT; domain=.paypal.com; path=/ Set-Cookie: navlns=0; expires=Thu, 16-Aug-2029 20:46:52 GMT; domain=.paypal.com; path=/ Set-Cookie: pNTcMTtQfrJuaJiwEnWXQ6yNxfq=2CCIyH2m2cCfJBaHr-NwfoVbYkic4ktOphW86LvV3RCLej8eaGLa9_0ou55uo6Are9h8q6fReYWb2EByD8hwGCjjZGZygjVlng 1Re-b5C0rTVpBiiuSnlcsB_wLjPftHpqpH-PS7BSiKGSd7IZU2Xd2krhy5wSjYg05uu2iC-db5FdAoTySfDC33vB6FG7FotSwBMq4Km6QbFNBpBniK5UPXwp8ax8UlE6e5NkX4tywi86iVfow0JRpwB dvXmgHJHY3K4iyM-PLZT5azDrMjNjZLSFY_D6GTo7JXZyuEDaohhuKG4jbivk7hwATL-GX37cqAe-00KCuK2rN7k5wAfXy5I82JZ6xoP0lSUiNIdo4h2ani; domain=.paypal.com; path=/ Set-Cookie: feel_cookie=a%205%20_flow%20b%209%20_ship-now%20c%206%20webscr%20d%206%20webscr%20e%2026%20Customer%2fgeneral%2fAbort.xsl%20f%2026%20Customer%2fgeneral%2fLogin.xsl%20g%205%20en_US%20h%205%20en_US%20i%2026%20xpt%2fCustomer%2fgeneral%2fAbort%20j%2011%20p%2fgen%2flogin%20k%2023%20Page%20Not%20Found%20-%20PayPal%20l%2023%20Page%20Not%20Found%20-%20PayPal%20; expires=Wed, 31-Dec-1969 23:59:59 GMT; domain=.paypal.com; path=/ Set-Cookie: Apache=10.191.114.16.1250887611890216; path=/; expires=Thu, 09-Jul-03 14:18:35 GMT Vary: Accept-Encoding Transfer-Encoding: chunked Content-Type: text/html; charset=UTF-8 <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd"> <html> <head> <meta http-equiv="Content-Type" content="text/html; charset=UTF-8"> <!-- Script info: script: webscr, cmd: _flow, template: xpt/Customer/general/Abort, date: Aug. 20, 2009 02:43:39 PDT; country: CA, language: en_US, xslt server: web version: 59.0-1026427 branch: AHOD_590_0820_int content version: - pexml version: 59.0-1023115 page XSL: Customer/default/en_US/general/Abort.xsl hostname : FwD-B3L0GIZo-EM8MGmhQ3jm8UgvvrkfKj9eQU6FoMo rlogid : FwD%2bB3L0GIZo%2bEM8MGmhQ%2bsarfx02bgP%2fn2cDmT7iCXWCwDqIIrE8g%3d%3d_1233eb63674 --> <title>Online Payment, Merchant Account - PayPal</title> <!--googleoff: all--> <meta name="description" content="PayPal is the safer, easier way to pay online without revealing your credit card number."> <!--googleon: all--> <link media="screen" rel="stylesheet" type="text/css" href="https://www.paypalobjects.com/WEBSCR-590-20090814-1/css/core/global.css"> <!--[if IE 7]><link media="screen" rel="stylesheet" type="text/css" href="https://www.paypalobjects.com/WEBSCR-590-20090814-1/css/browsers/ie7.css"><![endif]--> <!--[if lte IE 6]><link media="screen" rel="stylesheet" type="text/css" href="https://www.paypalobjects.com/WEBSCR-590-20090814-1/css/browsers/ie6.css"><![endif]--> <link media="print" rel="stylesheet" type="text/css" href="https://www.paypalobjects.com/WEBSCR-590-20090814-1/css/core/print.css"> <style type="text/css"> div.abort div.layout1 {margin:0; background:#fff url(/en_US/i/scr/blue_white_gray_gradient.jpg) bottom center repeat-x} div.abort div.layout1 .messageBox.notification {margin-bottom:0; padding:5px 40px 15px 70px; border:1px solid #ccc; background-position:20px 20px; background-color:transparent}</style> <script type="text/javascript"> if (parent.frames.length > 0){ top.location.replace(document.location); }</script><script type="text/javascript" src="https://www.paypalobjects.com/WEBSCR-590-20090814-1/js/lib/min/global.js"></script><link rel="shortcut icon" href="https://www.paypalobjects.com/WEBSCR-590-20090814-1/en_US/i/icon/pp_favicon_x.ico"> <link rel="apple-touch-icon" href="https://www.paypalobjects.com/WEBSCR-590-20090814-1/en_US/i/pui/apple-touch-icon.png"> </head> <body> <noscript><p class="nonjsAlert">NOTE: Many features on the PayPal Web site require Javascript and cookies. You can enable both via your browser's preference settings.</p></noscript> <div class="abort" id="page"> <div id="header" class="std"> .....<h1>Sorry — your last action could not be completed</h1>.... I've tried changing the <title> to the french title of the paypal site without success. I believe that I am getting pass the first sanity check Any idea???
  8. There seems to have been a modification with the Canada posts website log in as of june 29th. I'm running in to the same problem. Most likely someone will post a fix in a little bit.
  9. For those having problem with the new log in procedure : http://forums.oscommerce.com/index.php?sho...78107&st=20
  10. Well it makes us appreciate it even more!!!! Has I have told Alexei in the past, this is the most usefull tool on my store. Hint to everyone using it, a little 20$ donation to the supporters is well deserved. Saves me hours a week in label generation. :thumbsup:
  11. Hey, Is it just me or has the new Canada post site caused this contribution to go down or your sites also ??
  12. Fianlly got it to work again, after countless hours of searching... I simply sent the problem to the customer support of my new host with as much info on the problem as possible and all they had to do was to change server version from php 4.4.8 to 4.4.9 Seems to be working fine now.
  13. How do I turn off php safe mode??? I've found this: http://au.php.net/manual/ro/function.curl-setopt.php#71313 Might be interesting for your next version ...
  14. Hey, I don't think that I fixed anything with the setting to false except for the error message that stopped showing up. I still can't use the contrib. I think something on my new server (php5?) causing the problem because of this error message: CURLOPT_FOLLOWLOCATION cannot be activated when in safe_mode or an open_basedir And the error message from the debug mode replies" HTTP/1.1 302 Moved Temporarily Date: Thu, 27 Nov 2008 23:46:35 GMT Location: https://est-oee.canadapost-postescanada.ca/...&formId=111 Content-Length: 385 Content-Type: text/html <html><head><title>302 Moved Temporarily</title></head> <body bgcolor="#FFFFFF"> <p>This document you requested has moved temporarily.</p> <p>It's now at <a href="https://est-oee.canadapost-postescanada.ca/shipping/estShipping.jsp?locale=en_CA&amp;formId=111">https://est-oee.canadapost-postescanada.ca/shipping/estShipping.jsp?locale=en_CA&amp;formId=111</a>.</p> </body></html> I've underlined the difference, there is something now pointing to a wrong address ???? Any idea, and this is new since moving to a new server.. Thanks Pat
  15. I've worked around the curl issue which is probably related to my new server running with php 5. I've set line 610 CURLOPT_FOLLOWLOCATION to false. If that can clue anyone...
×