Jump to content
Latest News: (loading..)

Optimalkiller

Members
  • Content count

    64
  • Joined

  • Last visited

Profile Information

  • Real Name
    OptimalKiller
  • Gender
    Male
  1. SQL & PHP Expert needed

    Problem Now Resolved
  2. All Customers Report

    Problem now resolved. just do the following. This was fixed by member name:- jocg $customers_query_raw = "SELECT c.customers_id , c.customers_default_address_id, c.customers_email_address, c.customers_fax, c.customers_telephone, a.entry_company, a.address_book_id, a.customers_id, a.entry_firstname, a.entry_lastname, a.entry_street_address, a.entry_suburb, a.entry_city, a.entry_state, a.entry_postcode, a.entry_country_id, a.entry_zone_id, z.zone_code, co.countries_name FROM " . TABLE_CUSTOMERS . " c JOIN " . TABLE_ZONES . " z ON a.entry_zone_id = z.zone_id JOIN " . TABLE_COUNTRIES . " co ON a.entry_country_id = co.countries_id LEFT JOIN " . TABLE_ADDRESS_BOOK . " a ON c.customers_id = a.customers_id and c.customers_default_address_id = a.address_book_id ORDER BY $db_orderby $sorted"; WITH: $customers_query_raw = "SELECT c.customers_id , c.customers_default_address_id, c.customers_email_address, c.customers_fax, c.customers_telephone, a.entry_company, a.address_book_id, a.customers_id, a.entry_firstname, a.entry_lastname, a.entry_street_address, a.entry_suburb, a.entry_city, a.entry_state, a.entry_postcode, a.entry_country_id, a.entry_zone_id, z.zone_code, co.countries_name FROM " . TABLE_CUSTOMERS . " c, ". TABLE_ZONES ." z, " . TABLE_ADDRESS_BOOK . " a, " . TABLE_COUNTRIES . " co WHERE a.entry_zone_id = z.zone_id AND a.entry_country_id = co.countries_id AND c.customers_id = a.customers_id AND c.customers_default_address_id = a.address_book_id ORDER BY $db_orderby $sorted";
  3. Orderlist contrib

    Problem now resolved.
  4. SQL & PHP Expert needed

    I think this bit of code is doing the same thing. for ($i=0, $n=sizeof($order->products); $i<$n; $i++) { // BEGIN associate Manufacturer To Product $v_query = tep_db_query("select manufacturers_id from " . TABLE_PRODUCTS . " where products_id = '" . $order->products[$i]['id'] . "'"); $v = tep_db_fetch_array($v_query); // Select appropriate Manufacturers Name $mfg_query = tep_db_query("select manufacturers_id, manufacturers_name from " . TABLE_MANUFACTURERS . " where manufacturers_id = '" . $v['manufacturers_id'] . "'"); $mfg = tep_db_fetch_array($mfg_query); // END associate Manufacturer To Product ?> <b><a href="<?php echo tep_href_link(FILENAME_CATEGORIES, 'action=new_product_preview&read=only&pID=' . $order->products[$i]['id'] . '&origin=' . FILENAME_ORDERLIST . '&oID=' . (int)$orders['orders_id']); ?>"><?php echo '<br><font color="0000FF">' . $order->products[$i]['qty'] . ' x ' . $order->products[$i]['name']; ?></font></a></b><br>
  5. SQL & PHP Expert needed

    O.k. now I have modify the script to this. $mfg_query4 = mysql_query("SELECT products_id FROM orders_products where orders_id = '" . (int)$orders['orders_id'] . "'"); while ( $row = mysql_fetch_array( $mfg_query4 ) ) { { echo $row['products_id'] . ' '; }} see below for the output. what I would like to see is each Product ID under each item not have all the product Id repeated the each item, (at least I'm getting all the correct Products ID) 1 x MP3 Player Manufacturer Unavailable Product Item 1653 287 392 1 x USB Stick Manufacturer Unavailable Product Item 1653 287 392 1 x MP3 CD Player Manufacturer Unavailable Product Item 1653 287 392 Help!!!!
  6. SQL & PHP Expert needed

    I'm trying to list all the products with there product id numbers in an Invoice and this is the code that I'm am useing. $mfg_query3 = tep_db_query("SELECT products_id FROM orders_products where orders_id = '" . (int)$orders['orders_id'] . "'"); $result3 = tep_db_fetch_array($mfg_query3); echo $result3['products_id']; when youy run the SQL script in PHPMyadmin it list the 3 items fine with the different Products ID. now when running this via a PHP script what seems to happen is that the same product number is repeated per product item it should have a diffrent number per product Example 1 x MP3 Player Manufacturer Unavailable Product Item 1653 1 x USB Stick Manufacturer Unavailable Product Item 1653 1 x MP3 CD Player Manufacturer Unavailable Product Item 1653 Can anyone help me out to fix this problem Please :) Thanks Optimal
  7. Orderlist contrib

    I also have the same problem has anyone been able to resolve this?
  8. All Customers Report

    Hi all I'm getting this error message when running all_customers.php can any kind soul help me out. 1054 - Unknown column 'a.entry_zone_id' in 'on clause' Thanks Optimal
  9. New Products Icon

    Can anyone help me on this one I;m getting this error message when viewing product_listing.php Parse error: parse error, unexpected '.' in C:\Program Files\xampp\htdocs\catalog\includes\modules\product_listing.php on line 110 This is the line in 110 "Product_listing.php" $lc_text = . $img_new_product' <a href="' . tep_href_link(FILENAME_PRODUCT_INFO, ($cPath ? 'cPath=' . $cPath . '&' : '') . 'products_id=' . $listing['products_id']) . '">' . $listing['products_name'] . '</a> '; } And this is the function call // added for New Product Icon contribution // 2592000 = 30 days in the unix timestamp format if ( ($today_time - strtotime($listing['products_date_added'])) < 2592000) { $img_new_product = ' ' . tep_image_icon('icon_newarrival.gif', TEXT_ICON_NEW_PRODUCT . ' : ' . $listing['products_name'] ); } // end addition
  10. [Contribution] phpBB-osCommerce Bridge

    This is how I have setup my catalog and PhpBB and works without a problem www.domainname.com/catalog/ = OsCommerce www.domainname.com/catalog/phpbb2/ = Forums so all you need to do is to create another folder in the catalog folder and call it PHPBB2 and install it from there. Optimal
  11. [Contribution] phpBB-osCommerce Bridge

    To be honest this one has got me stumped, All I can suggest is to redo the PHP Integration mod again and see if that error disappears there must be a typo error somewhere else. Sorry Optimal.
  12. [Contribution] phpBB-osCommerce Bridge

    Did the error start occuring after you made the change in the create_account.php or was it happening before that?
  13. [Contribution] phpBB-osCommerce Bridge

    O.k. remove that code that i told you to put in and do the following search for this. session_begin($customer_id, encode_ip(tep_get_ip_address()), PAGE_INDEX, FALSE, $autologin, 0); and replace it with this // session_begin($customer_id, encode_ip(tep_get_ip_address()), PAGE_INDEX, FALSE, $autologin, 0); this should be done in the create_account.php and tell me if the error disappears. Optimal
  14. [Contribution] phpBB-osCommerce Bridge

    Do the following. #-----[ OPEN ]------------------------------------------------------------------ # /catalog/create_account.php # #-----[ FIND ]------------------------------------------------------------------ # require('includes/application_top.php'); # #-----[ BEFORE, ADD ]----------------------------------------------------------- # # Note that you have to manually enter your acutal RELATIVE phpBB path again, # since this chunk of code takes place before we define any variables. # // Added for phpBB-osCommerce Bridge define("IN_LOGIN", true); define('IN_PHPBB', true); $phpbb_root_path = './phpbb2'; include($phpbb_root_path . 'extension.inc'); include($phpbb_root_path . 'common.'.$phpEx); // End phpBB-osCommerce Bridge This should resolve your issue!!!!! also you must specify your forum location!!!!! in the line thats been marked in Bold Regards Optimal
  15. NEW: Anti Robot Registration Validation

    Need help again :( Got the Anti Robot Validation system installed got one small problem. when makeing a change to the account details, for example changeing the telephone number i get an error message when submiting the details saying Error: Invalid Validation Code even though the Validation code I typed in was correct. Help!!!! Also when users register and use the contact Us button with Validation enabled all works well!!!!!
×