mackieco

Members
  • Content count

    109
  • Joined

  • Last visited

Community Reputation

0 Neutral

About mackieco

Profile Information

  • Real Name
    Michael Williams
  1. Hi well, I already had this file set to AUD instead of USD but what I found out is that I had to change all instances of USD to AUD in the following file: catalog>includes>modules>payment>paypal.php After doing this this the subtotal on the paypal site is now displaying correctly on the paypal site. However since doing this I have received two payments through paypal for orders but the orders have not come through to the admin. Does anyone know why this would happen?
  2. Hi I have a strange problem with my Paypal account... I have an Australian store linked to an Australian PAypal account with the primary currency set to AUD (Australian) however if my customers choose the Paypal method and are taken to the Paypal site for payment the total is shown in USD instead of AUD. Does anyone know how I can fix this? Any suggestions greatly appreciated. Cheers. Michael.
  3. Hi Jorge, Thanks got it all looking great now. I have one last question.... When setting up a new type of order status through admin>localisation>Orders Status I have found that I am not able to edit an existing one but am only able to create a new one as the changes to existing status' don't seem to want save when I try. This isnt too much of a problem however I am also unable to delete old ones no longer in use. I have two that I want to delete that are no longer in use. I receive two different types of error messages for each one I want to delete: 'Error: This order status is currently used in the order status history.' and: 'Error: This order status is currently used in orders.' Is there a way I can go ahead and delete these anyway? Its just that I have multiple users in the admin of my store and think it is inevitable that someone will accidently use one of the old status' to update an order thus sending out the old standard emails. Any ideas? Cheers, Michael.
  4. Hi Jorge, I have another quick question for you. For some reason when I receive the change status email there is quite a lot of white empty space before the email starts. I can't see anywhere in the code why this is happening. Do you have any idea why? Also I have tried adding my logo to the email but this wont work either. I tried inserting it using the code: <img src='../../../../images/oscommerce.gif' width='170' height='230'> But this just results in a red 'x' appearing in the email where the image should be. Do you know how to insert it? Thanks in advance. Michael.
  5. Hi Jorge, Thanks for the reply. You were absolutley right...I had everything set up except I hadnt uploaded the inprocess.php file. All working fine now. Great contribution! Thanks again. Michael.
  6. These are the errors I am receiving: Warning: include(/home/inmy/public_html/admin//includes/languages/english/inprocess.php) [function.include]: failed to open stream: No such file or directory in /home/inmy/public_html/admin/orders.php on line 73 Warning: include() [function.include]: Failed opening '/home/inmy/public_html/admin//includes/languages/english/inprocess.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/inmy/public_html/admin/orders.php on line 73 Warning: Cannot modify header information - headers already sent by (output started at /home/inmy/public_html/admin/orders.php:73) in /home/inmy/public_html/admin/includes/functions/general.php on line 22 I receive these errors after updating the order status in admin. If I go to line 73 of admin/orders.php it is the code: include ($filename); in: $payment = MODULE_PAYMENT_MONEYORDER_PAYTO; include ($filename); } else { I receive an email still but it is empty with only the subject field (which is correct). If I comment out line 73 in admin/orders.php and test again I do not receive the errors when updating the order status but the email I receive is still empty. Any ideas on how I can fix this? Thanks in advance.
  7. Is this forum still active? I have some questions re debugging a few lines of code from errors I am receiving from installing this contrib
  8. Thanks, that worked well. Cheers.
  9. Changing the delivery times?? Does anyone know how I can change the estimated delivery time on the Order Confirmation screen? I presume this time is calculated by the drc site depending on the postcodes of dispatch Vs delivery addresses. My client wants it to state something like: 'Items will arrive within 10 business days'. Anyone know how I can do this? Thanks in advance.
  10. I wonder if there is anyway to have warning from Auspost if they ever have site maintenance etc in the future. As long as they are down then customers can't checkout and will be presented with all of the errors which would most definitley scar them off. I know I would be.
  11. Thanks for the confirmation. Good to know I havent done anything wrong here. How did you find out it was down?
  12. DRC link problems??? Hi, I was wondering if anyone has been experiencing problems with the auspost modules in the last 24 hours? I was working on my site yesterday and was checking products out of my store with no problems then today all of a sudden I am experiencing a major problem when checking out. It takes a long time for the Delivery information screen to load and when it does finally I have the following errors on the top of the screen: Warning: file(http://drc.edeliver.com.au/ratecalc.asp?Pickup_Postcode=4032&Destination_Postcode=4105&Country=AU&Weight=210&Service_Type=STANDARD&Height=100&Width=100&Length=100&Quantity=1) [function.file]: failed to open stream: Connection timed out in /home/inmy/public_html/includes/modules/shipping/auspost.php on line 80 Warning: Invalid argument supplied for foreach() in /home/inmy/public_html/includes/modules/shipping/auspost.php on line 81 Warning: file(http://drc.edeliver.com.au/ratecalc.asp?Pickup_Postcode=4032&Destination_Postcode=4105&Country=AU&Weight=210&Service_Type=EXPRESS&Height=100&Width=100&Length=100&Quantity=1) [function.file]: failed to open stream: Connection timed out in /home/inmy/public_html/includes/modules/shipping/auspostexpress.php on line 81 Warning: Invalid argument supplied for foreach() in /home/inmy/public_html/includes/modules/shipping/auspostexpress.php on line 82 I have looked in the two files where these errors are occuring and it is where the drc url appears. Also when the page finally loads each auspost option has the following error: "ERROR: The delivery rate for this option cannot be determined at this time If you prefer to use this option as your shipping method, please contact the store owner." I have not made any changes to these modules in the last 24 hours so why this is suddenly happening I dont know. Is it possible that the drc site is down or under maintenance or the url for the rate calculator has changed? Any ideas?
  13. Images not displaying?? Hi I have had this contribution installed for a while and everything is fine except I have recently changed the logo and name that is displayed on invoices/packing slips etc. When I change this name in the appropriate locations: english/invoice.php and english/packingslip.php a red x is now only displaying on the packing slip and invoice from admin. If I change it back to the old name it displays again. I have uploaded the image to the correct folder as it is displaying other locations. Any ideas? Thanks.
  14. ok thanks. Well I think that my only option is to either uninstall one or the other and try to find another way to do this or to find someone who may be able to help. Do you know of anyone who may be able to help me customize my script? Thanks.
  15. Hi, Thanks for your response. Unfortunately I arent much of a programmer and I arent really sure how I go about making your suggested change. I can easily enough install contributions but dont know how to go about combining the two. Is there an easier way to deal with my problem or do you think the code changes could be minimal and easy enough to combine? I ceratinly couldnt figure out to change the pwa code to use the active countries code. Any suggestions? Thanks.