Jump to content
Latest News: (loading..)

MaNoLiA

Members
  • Content count

    24
  • Joined

  • Last visited

1 Follower

Profile Information

  • Real Name
    René
  1. you did a mistake with replacing... look the . before the } sais that there should come something more but it doesn't... so there should be a ; to say that that was it! maybe you just pasted it in the wrong order... If it doesn't work now, just try to change the order of the catalog.php in your first post so the ; is at the end! try for example this: <?php $heading = array(); $contents = array(); $heading[] = array('text' => BOX_HEADING_CATALOG, 'link' => tep_href_link(FILENAME_CATEGORIES, 'selected_box=catalog')); if ($selected_box == 'catalog') { $contents[] = array('text' => '<a href="' . tep_href_link(FILENAME_CATEGORIES, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_CATEGORIES_PRODUCTS . '</a><br>' . '<a href="' . tep_href_link(FILENAME_PRODUCTS_ATTRIBUTES, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES . '</a><br>' . '<a href="' . tep_href_link(FILENAME_MANUFACTURERS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_MANUFACTURERS . '</a><br>' . '<a href="' . tep_href_link(FILENAME_REVIEWS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_REVIEWS . '</a><br>' . '<a href="' . tep_href_link(FILENAME_SPECIALS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_SPECIALS . '</a><br>' . // define_mainpage '<a href="' . tep_href_link(FILENAME_DEFINE_MAINPAGE, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_DEFINE_MAINPAGE . '</a><br>' . // define_mainpage_eof // define_bestseller '<a href="' . tep_href_link(FILENAME_BESTSELLERS2, '', 'NONSSL') . '" class="menuBoxContentLink">' . 'Best Sellers' . '</a><br>' . // define_bestseller '<a href="' . tep_href_link(FILENAME_PRODUCTS_EXPECTED, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_PRODUCTS_EXPECTED . '</a>'; } $box = new box; echo $box->menuBox($heading, $contents); ?>
  2. ### POINTS AND REWARDS MODULE V1.00 ###

    before I solved the problem I had because of register_globals=off I programmed a little extra point to "Change points into money."... so if a customers had 1000 points valued $10 he had the possibility to request his money by sending a email with bankkonto... if you can't solve your problem you should think about this solution ;P
  3. Google XML Sitemap w/ Admin support

    no... its useless unless you are able to understand english... a sitemap is just a collection of links... you dont need any language for it... its just for the admin. the last update.... contains english german... if you use english admin, this is enough for you, if not, add the other language files.
  4. Automatically send data feed to Froogle

    grrrrr still not working cause Strato disabled the ftp_connect function: Call to undefined function: ftp_connect() Someone got a solution for this?? :(
  5. Automatically send data feed to Froogle

    Ok I added the language option for product title and description: lines 119-140 WHERE products.products_id=products_description.products_id AND products.products_id=products_to_categories.products_id AND products_to_categories.categories_id=categories.categories_id AND categories.categories_id=categories_description.categories_id //add this: AND products_description.language_id=2 // end ORDER BY products.products_id ASC "; $catInfo = " SELECT //add this: categories_description.language_id, // end categories.categories_id AS curCatID, categories.parent_id AS parentCatID, categories_description.categories_name AS catName FROM categories, categories_description WHERE categories.categories_id = categories_description.categories_id //add this: AND categories_description.language_id=2 // end "; you should change this to a $language var that is editable by users in the next update? ;)
  6. Automatically send data feed to Froogle

    ok fixed the problem now... for $productURL = '../product_info.php?products_id='; use the full http:// address... I have a problem with the language... I have 3 languages... and there is a mix of english and spain :(
  7. Automatically send data feed to Froogle

    hmm hi... dont know why in the readme it says... $imageURL = 'CHANGEME-http://www.yourwebsite.com/yourimagesdirectory/'; if my admin folder is http://www.yourwebsite.com/catalog/admin/ I have to change this http wrapper to $imageURL = '../images/'; ../ means I go one folder back out of admin and into /images/ maybe someone has the same problem... my configuration looks like this now: $OutFile = "../feeds/froogle.txt"; //"CHANGEME-full-path-to-file-with-777-dir-and-file-permissions-your-outfile.txt"; $destination_file = "froogle.txt"; //"CHANGEME-filename-to-upload-to-google.txt"; $source_file = $OutFile; $catalogURL = '../'; $imageURL = '../images/'; $productURL = '../product_info.php?products_id='; $already_sent = array(); its working with this configuration but the codes that are made include the wrong link....
  8. ### POINTS AND REWARDS MODULE V1.00 ###

    jasonabc: there is no possibility to use only some points... you have to use all... but as you think about the sense of redeeming only some points you will get to see that there is no reason why someone should redeem only some points... chooch: register globals= on is not that safe as off... and on later versions of php... php 6 or something it will be deactivated so the script won't work no more.
  9. ### POINTS AND REWARDS MODULE V1.00 ###

    hmm ok everything is working with this register globals on... but I am a bit scared because I have the register_globals=off patch for oscommerce and the autor of this patch wrote that I MUST deactivate register globals, because there would be bad consequences if I dont... and don't try to use my code please, it's just working for confirmation page and only for register_globals=off, so if you put this on a register_globals=on page there will be mistakes... maybe someone could write a solution for register_globals= off?
  10. ### POINTS AND REWARDS MODULE V1.00 ###

    hey... I sad to inform you that there is another problem... there are no points subtracted in the email when you order something with register_globals=off; and no points substracted on the my_points page... In checkout_process.php I found this: // customer shoppping points account balanced if ($customer_shopping_points_spending) { tep_redeemed_points($customer_id, $insert_id, $customer_shopping_points_spending); } } it's the function of functions/redemption.php and I think it is responsible for substracting the points... I tried to replace $customer_shopping_points_spending with $_POST['customer_shopping_points_spending'] again... but no effect this time... I think it is the same problem as before but now I really need help please... :(
  11. ### POINTS AND REWARDS MODULE V1.00 ###

    YES YES YES I fixed the problem... the solution was the same as I described above.... For all having trouble with register_globals=off; use this code: in catalog\includes\modules\order_total\ot_redemptions.php search for: // if customer is using points to pay if ($customer_shopping_points_spending > 0){ $order->info['total'] = $order->info['total'] - (tep_calc_shopping_pvalue($customer_shopping_points_spending)); $this->output[] = array('title' =>''. MODULE_ORDER_TOTAL_REDEMPTIONS_TEXT . ':', 'text' => '<font color="FF0000">-'.$currencies->format(tep_calc_shopping_pvalue($customer_shopping_points_spending), true, $order->info['currency'], $order->info['currency_value'].'</font>'), 'value' => tep_calc_shopping_pvalue($customer_shopping_points_spending)); } and replace with: // if customer is using points to pay if ($_POST['customer_shopping_points_spending'] > 0){ $order->info['total'] = $order->info['total'] - (tep_calc_shopping_pvalue($_POST['customer_shopping_points_spending'])); $this->output[] = array('title' =>''. MODULE_ORDER_TOTAL_REDEMPTIONS_TEXT . ':', 'text' => '<font color="FF0000">-'.$currencies->format(tep_calc_shopping_pvalue($_POST['customer_shopping_points_spending']), true, $order->info['currency'], $order->info['currency_value'].'</font>'), 'value' => tep_calc_shopping_pvalue($_POST['customer_shopping_points_spending'])); } Thanks all for help!
  12. ### POINTS AND REWARDS MODULE V1.00 ###

    hmm yes but for register_globals= off; what is in my opinion better it should work too... I think I found the mistake but I have no idea how to fix it... in catalog\includes\modules\order_total\ot_redemptions.php function process() { global $order, $currencies, $customer_shopping_points_spending; // if customer is using points to pay if ($customer_shopping_points_spending > 0){ $order->info['total'] = $order->info['total'] - (tep_calc_shopping_pvalue($customer_shopping_points_spending)); $this->output[] = array('title' =>''. MODULE_ORDER_TOTAL_REDEMPTIONS_TEXT . ':', 'text' => '<font color="FF0000">-'.$currencies->format(tep_calc_shopping_pvalue($customer_shopping_points_spending), true, $order->info['currency'], $order->info['currency_value'].'</font>'), 'value' => tep_calc_shopping_pvalue($customer_shopping_points_spending)); } } I removed the if if ($customer_shopping_points_spending > 0){ } now there is shown this on the checkout_confirmation.php: Points Redeemed: -0.00EUR so $customer_shopping_points_spending seems to be not set or 0... I looked for the worth of the var with phpinfo(); (in checkout_confirmation.php) and it shows this: _POST["customer_shopping_points_spending"] 49.9 so it seems as te function cannot get the var for some reason... As the problem was solvable with register_globals= on; I tried to change $customer_shopping_points_spending to $_POST['customer_shopping_points_spending'] but with no effect... somebody knows how to fix that problem?
  13. ### POINTS AND REWARDS MODULE V1.00 ###

    hey... just wanted to say, that we found the reason why checkout_confirmation.php didn't show the points redeemed... We set register_globals = Off and it works... now as there are many people with register_globals = off there should be written a fix for this problem... I try to write a fix but I cannot promise to have success with this ;)
  14. ### POINTS AND REWARDS MODULE V1.00 ###

    skatejunkcom: I don't see the problem with that... This is what checkout_payment.php shows, when I buy something for 2,50EUR + 2,49EUR shipping: "Shopping Points Redemptions You have a credit balance of 8.00EUR ,would you like to use it to pay for this order? The estimated total of your purchase is: 4.99EUR . Tick here to use Maximum Points allowed for this order. (50 points 4.99EUR) ->(check-box)" so it shows the total without points, but I think that's just how it should be. --> But for what, if not for this?
  15. ### POINTS AND REWARDS MODULE V1.00 ###

    that's strange, you have the same php and mysql version as skatejunkcom... chooch: can you maybe make a screenshot of your settings in configuration of points... and what version do you have? I'm not able to test restriction cause I see nothing on confirmation page ;) hmm I see a way to prevent this negative worth... I think it can be fixed in a non-point-system-file (maybe checkout_confirmation.php or checkout_process.php?)... just use a if ( int.total<0 ) {int.total ==0; } else {do what you usually do}... ask silver to make a fix for this ;) (it's just an idea not a solution)
×