Jump to content

zefeena

Members
  • Content count

    537
  • Joined

  • Last visited

Everything posted by zefeena

  1. My apologies, as I know I have asked this question before, but it seems I still have the problem, and I cannot find the thread from previous discussion. Sometimes - and it appears not every time, when a customer check out and successfully creates an order 1 - the basket does not empty 2 the stock does not decrease The basket not emptying isn't really a problem to me, except that by not emptying it appears it is not decreasing the stock - which is a BIG deal, as I have thousands of items and need my stock control to work. The last order that I notice this has happened to, this is the 'comment' I get from Worldpay. Anybody any idea what is wrong? thanks,
  2. I have a very old website, and I need to start afresh! I was hoping to put a fresh install (link to the best current one would be appreciated) onto my cpanel, so I could edit it, put add-ons and test it etc, but so no-one else is going to end up on it until I'm ready to swap over, and hopefully upload my current database to it for seamless changeover!! My website is still live and I can't switch it off for any period of time, as its my only income. Currently it appears my install is simply in 'public_html', would I create a new folder in there , and then upload to it? and would I then need to download it once complete and re-load where my current one is? Any guidance on this initial step would be appreciated so I can 'have a play' with the latest download Thanks
  3. Thanks. I feel reasonable confident I could add the site to a new folder/secure it etc. I think I will probably even be able to make the database compatible. The most difficult things for me, will be all the add-ons, and ensuring the likes of Paypal and Worldpay still work okay. These have always caused me the most trouble and really vital. I'm going to have a look at shopify and decide if the time spent on oscommece would be better spent improving my business to pick up the shopify bill! For the moment I'm going to leave my site as it is and de-register for vat tomorrow, to save a few thousand a year!
  4. Hi, With the looming Brexit, I need to de-register for vat (I'm UK), as my relevant turnover will be under the registration threshold once EU sales are no-longer counted. When I registered a few years ago, I used the following code to switch on VAT and change my prices globally. I'd like to do the same thing to switch it off and change prices again. Down side is that I use the 'price break' and this code will not change the additional 3 pricing bands that I have. Will this code still work as an sql query, and can I 'add' anything to make it work for the price break prices too? I'm running V2.3.4. If there is an easy on/off button to globally remove vat that would be nice to know about too! thanks SQL - making all items taxable UPDATE products SET `products_tax_class_id` =2 where '2' is the number of the tax class you've previously created in admin. On changing prices shopwide - backup the products table (always wise if I've suggested anything) and then do something like for 50% hike UPDATE `products` SET `products_price` = `products_price` * 1.5 or easier to visualise UPDATE `products` SET `products_price` = `products_price` + ( `products_price` *50 /100 ) you can change the plus to a minus and the 50 to any percentage that you like or have a look at http://addons.oscommerce.com/info/4663 or for a 15% reduction UPDATE `products` SET `products_price` = `products_price` * 0.85 REMEMBER THIS WILL ONLY UPDATE YOUR MAIN PRICE IF YOU HAVE QUANTITY PRICE BREAKS OTHER PRICES WILL NOT BE CHANGED
  5. zefeena

    Removing VAT and price changes

    Thanks I'll have a go with it when the site is quiet!
  6. zefeena

    Removing VAT and price changes

    Thank you, found it now! I understand that will show my items without tax, but it appears, it will still then add the tax at checkout? Obviously if I set all my tax rates to 0%, then no tax will actually get added, but that might still look like I'm vat registered but charging vat at 0%? Will turning this off remove the vat column from the invoice, or does it really not make any difference if I have a vat column showing 0%. In other words: Am I being unnecessarily pedantic?!!!
  7. zefeena

    Removing VAT and price changes

    If the previous price hike code worked, I'm presuming it still will? this was: for 50% hike UPDATE `products` SET `products_price` = `products_price` * 1.5 or for a 15% reduction UPDATE `products` SET `products_price` = `products_price` * 0.85 I'm, therefore, assuming that if the above works for my base price, then the following would work for the price_break items: UPDATE `products_price_break` SET `products_price` = `products_price` * 1.5 or for a 15% reduction UPDATE `products_price_break` SET `products_price` = `products_price` * 0.85
  8. zefeena

    Removing VAT and price changes

    I'm not sure I have that option on my version. The price change add-on looks far more complex than what I did before! It isn't likely that I will want to change the prices in this way often, so I thought running the sql code would do the trick quickly, as a one off.
  9. Programming might come very easy for you, but it is very unnatural to me. To suggest someone is not making an effort is rather unkind. I am far from lazy, but if I make programming/learning computer stuff etc the main stay of my day, how on earth do I fit in listing products, buying stock, packing orders etc? I would have added, fitting in a social life, but I never managed to find the time for that! Rant over - more important stuff to do!
  10. Seriously!!! NO! shame on you for suggesting it! I do not do ebay, complete waste of time, only ebay makes any money from ebay! My 'listings' on my website, cost me next to nothing per annum (just hosting ), if I switched to ebay, I'd be looking at bills for £1000's every year, and very few sales. I've survived 20 years without it, and I don't plan to use it now. Its fine if you sell your unwanted tack, but if you actually need to make a living, then its a non-starter. I think I might have to go this way. Theres just not enough hours in the day to try to wear every hat, which is what I have done since setting up. at the start it was necessary, now I guess I need to try to let go of the reins again - I did so a couple of years ago, and now have a crap website, and started to do my own accounts again too, so currently the 'hat wardrobe' is very full!
  11. Well that has just scared me to death! I am used to OSC now so I don't really want to change and have to learn something new. On the other hand, having had my current site built by someone else (and hating it) I feel like I need to be able to know something of the site so I can make changes and 'mend' things when they go wrong. I would prefer to have an easier set up, as programming language hurts my head! but I have thousands of products and customers, and I think changing to 'something new' may mess up my business. currently I am not sure I'm really getting that much traffic because of google rankings or seo. I do not understand or involve myself in either, and at least 50% of my business comes from repeat custom. And I think the majority of new customers are driven to me, via my own promotion and word of mouth. I am far from stupid, but computer work does not interest me, hence I find it difficult to learn, and easy to forget! I always have to rely on the clever people on here to advise me, and I usually get sorted in the end, but it can sometimes take me a ludicrous amount of time, and I'm sure it could be better spent. Thee seems to be so many 'versions' of OSC, and I never seem to know which one anyone is talking about - ie. which version is 'frozen' because the downloads all have numbers, not names. Its very confusing! Do I stick with OSC or would moving to a ready made provider be more suitable to someone like me?
  12. zefeena

    newsletter never be able to send out

    apologies for the duplication!
  13. zefeena

    newsletter never be able to send out

    MrPhil, I'm fed up of trying to get sense from my host - see support screenshots! The order emails don't even send, and I get constant moans about that from customers. I have tried everything, and now given up! Unfortunately, all of this is really beyond me, and I have wasted so many hours on trying to get the emails to work, its easier for me to just respond to my customers personally when they email me about the lack of email! I have just joined Mailchimp (free) and uploaded 2000 email addresses from my newsletter csv file. I will probably get blocked as it seems a fair few people sign up (they have to tick yes to join the newsletter) and then decide when they get an email to report it as spam rather than simply unsubscribing! But hey ho, its worth a go!
  14. zefeena

    newsletter never be able to send out

    I have not tried to send emails from the cpanel, though ideally I just wanted to upload my entire list and simply drop everyone a quick email with an offer code before Christmas! It was just a one off really as I need to claw back my business as it seems I may have inadvertently allowed a competitor to steal my customer database a few years ago!
  15. zefeena

    newsletter never be able to send out

    I have never got my email to work since moving to my new host, and it turns out they don't 'approve' of marketing email! - which probably explains why nothin ever gets sent. I have over 3500 people who have subscribed (opted in voluntarily) to my newsletter - but I can't send any! I just thought I'd try the TinyLetter.com and first attempt they blocked me - I'm apparently too high a risk!!! TinyLetter is free, but part of MailChimp, so I concerned the same will happen if I try Mailchimp. I don't think it helps because I sell items for making bra and lingerie - not weird stuff - but apparently the TinyLetter folk don't wear pants! I need to upload my csv file and send a newsletter with an offer (ASAP!), has anyone uploaded a file of similar size? and been able to send without trouble? - if so which company did you use. It will literally be 1-2 times per year, so I am thinking of splitting the file into two halves, though could do without the added effort.
  16. Hi, a little off-topic I guess, but I'm really struggling to get any sense from my host, so I was hoping someone could help. This morning my partners website appeared to go off-line, when in fact it was only that we were unable to access it (any of it, i.e website/admin/cpanel) over our wifi. We were only able to access it over a 3/4G connection on our mobile phones. Eventually after much tennis email with the host, it turns out the SSl cert expired and wouldn't auto-renew as I had made changes to the htaccess file. I have now 'pressed' the auto renew button on the SSL over 6 hours ago, and I'm still unable to access anything over the wifi. The host is being unhelpful saying the site is working fine. Our mobile phone single is very poor, and the printers are on wi-fi, so its not possible to run our business from a mobile phone! Does anyone have any clue how we might resolve this? thank you
  17. this is sorted now. I suspect the host removed the old certificate after I informed them of the advice here.
  18. The host said this 'The SSL certificate, if it's taken from autossl, expires every 3 months. Normally, it gets automatically renewed, however, if there are redirections done on your website or other htaccess changes, letsencrypt ceritificate authority might reject it.I'm assuming this is what happened today, as the certificate expired and renewal didn't work. So I'm presuming I did in fact need to remove the old certificate first - which I didn't do. where would I find the old certificate? They have asked me to do the following - no clue what any of this means! Ping has started…PING van-creations.co.uk (91.148.184.26): 56 data bytesRequest timeout for icmp_seq 0Request timeout for icmp_seq 1Request timeout for icmp_seq 2Request timeout for icmp_seq 3Request timeout for icmp_seq 4Request timeout for icmp_seq 5Request timeout for icmp_seq 6Request timeout for icmp_seq 7Request timeout for icmp_seq 8--- van-creations.co.uk ping statistics ---10 packets transmitted, 0 packets received, 100.0% packet loss IP address 192.168.1.103.Traceroute has started…traceroute to van-creations.co.uk (91.148.184.26), 64 hops max, 72 byte packets1 192.168.1.1 (192.168.1.1) 3.773 ms 3.843 ms 3.977 ms2 185.44.251.41 (185.44.251.41) 16.146 ms 15.054 ms 15.975 ms3 core-mre1.quickline.co.uk (185.44.250.129) 20.003 ms 15.638 ms 15.465 ms4 core-mre2.quickline.co.uk (151.249.77.165) 20.064 ms 15.069 ms 15.931 ms5 core-lth1.quickline.co.uk (151.249.77.188) 23.947 ms 22.875 ms 28.101 ms6 202.88.80.arpa.orbital.net (80.88.202.244) 32.185 ms 25.531 ms 25.262 ms7 linx-224.retn.net (195.66.224.193) 27.989 ms 23.050 ms 32.216 ms8 ae0-1.rt.tlp.sof.bg.retn.net (87.245.232.126) 67.937 ms 71.175 ms 63.844 ms9 gw-belcloud.retn.net (87.245.240.133) 76.074 ms 65.663 ms 65.371 ms10 * * *11 * * *12 * I have to turn the wifi off the mobile, so it is connecting to my Vodafone 3g service, not through my home wifi, otherwise it won't connect to the site. No devices will connect to the site if they are using the home wifi. My Mac is actually plugged into an Access point which is connected tot he router via an ethernet cable. The AP has been installed for a while now, and I've had the same internet provider since 2015!
  19. zefeena

    product Quantity

    Hio, I'm trying to add the following code to a frozen install. and its throwing up various errors. anyone any ideas. It works fine on my old site: ta TO ADD THE PRODUCT MODEL NUMBER & QUANTITY: IN: admin/categories.php FIND THIS: <td class="dataTableHeadingContent"><?php echo TABLE_HEADING_CATEGORIES_PRODUCTS; ?></td> ADD THIS AFTER: <td class="dataTableHeadingContent" align="center"><?php echo TABLE_HEADING_MODEL; ?>&nbsp;</td> <td class="dataTableHeadingContent" align="center"><?php echo TABLE_HEADING_STOCK; ?>&nbsp;</td> <td class="dataTableHeadingContent" align="center"><?php echo TABLE_HEADING_PRICE; ?>&nbsp;</td> ********* FIND THIS: <td class="dataTableContent”>. <?php echo '<a href="' . tep_href_link('categories.php', 'cPath=' . $cPath . '&pID=' . $products['products_id'] . '&action=new_product_preview&read=only') . '">' . tep_image('images/icons/preview.gif', ICON_PREVIEW) . '</a>&nbsp;' . $products['products_name']; ?></td> CHANGE IT TO THIS: <td class="dataTableContent"><?php echo '<a href="' . tep_href_link(‘categories.php’, 'cPath=' . $cPath . '&pID=' . $products['products_id'] . '&action=new_product') . '">' . tep_image(‘images/icons/edit.gif', ICON_EDIT) . '</a>'; ?> <?php echo '<a href="' . tep_href_link(‘categories.php’, 'cPath=' . $cPath . '&pID=' . $products['products_id'] . '&action=new_product_preview&read=only') . '">' . tep_image(‘images/icons/preview.gif', ICON_PREVIEW) . '</a>&nbsp;' . $products['products_name']; ?></td> <td class="dataTableContent" align="center"> <?php echo '<a href="' . tep_href_link(‘categories.php’, 'cPath=' . $cPath . '&pID=' . $products['products_id']) . '">' . '</a>' . $products['products_model']; ?></td> <td class="dataTableContent" align="center"> <?php echo '<a href="' . tep_href_link(‘categories.php’, 'cPath=' . $cPath . '&pID=' . $products['products_id']) . '">' . '</a>' . $products['products_quantity']; ?></td> <td class="dataTableContent" align="center"> <?php echo '<a href="' . tep_href_link(‘categories.php’, 'cPath=' . $cPath . '&pID=' . $products['products_id']) . '">' . '</a>' . $products['products_price’]; ?></td> ************************************************************** IN: /admin/includes/languages/LANGUAGE/categories.php FIND THIS: define('TABLE_HEADING_CATEGORIES_PRODUCTS', 'Categories / Products'); ADD THIS AFTER: define('TABLE_HEADING_MODEL', 'Model'); define('TABLE_HEADING_STOCK', 'Quantity'); define('TABLE_HEADING_PRICE’, ‘Price’); ***************************************************************************************************************************************************************************************************** IN: /admin/includes/languages/LANGUAGE.php FIND THIS: define('ICON_ERROR', 'Error'); ADD THIS AFTER: define('ICON_EDIT', 'Edit'); ***************************************************************************************************************************************************************************************************** ADD THIS: edit.gif preview.gif (optional - better image than stock one) TO THIS FOLDER: /admin/images/icons/
  20. Hi, Just recently I noticed customers putting through their orders multiple times. I think after they pay, when it goes to either checkout confirmation it loads a blank white page, so they press return again (and again, and again) creating multiple orders, though only paying once. I am not sure if its also messing my stock control up. I recently adjusted items in the configuration file, and also made changes to orders.php so I'm wondering if one of those might be causing the problem. My sales have dropped dramatically recently so I think people are being put off, hence need to fix it quick! thanks
  21. zefeena

    Checkout confirmation blank white page

    Thank-you everyone I managed to find the correct checkout_process_fix.php you provided, and it seems to have worked Fingers crossed. I am just going to go and drink copious amounts of alcohol now! and thank you for that suggestion. I will certainly see if I can get hold of a back-up from 30 days ago, so I can at least revert to that if the fix hasn't worked.
  22. zefeena

    Checkout confirmation blank white page

    configuration files
  23. zefeena

    Checkout confirmation blank white page

    The order get to checkout_confirmation, the white screen appears on checkout_process and goes no further, no order is processed, nothing happens and the only recourse is to shut the site page, or press the back key (turning to checkout confirmation). ordering is now effectively stuck in a loop I was trying to get back to how it was a few days ago, and I can't figure out that. I have that many back-ups of files and when I download them they all end up in a download folder, so I've really lost the plot now. I looked back and before all this started the problem started when I put a 'returns' form on the site. in a folder called PDF. and added the few lines on my invoice - I didn't touch the checkout of other files. What I remember is that I couldn't get the pdf to load when I went to view it, but then I found it did actually load from the customer side, so I 'may' have been looking at the confirmation files (god only knows which one, as there are so many), to check the file path was defined correctly. http://sewingchest.co.uk/product_info.php?products_id=1270
  24. zefeena

    Checkout confirmation blank white page

    I did change my admin name - its wonderfully unguessable! The site is completely broken now and will not process orders at all. So I'm now absolutely desperate. This is my only source of income and the busiest time of year and my sales are now effectively zero. So please be patient with your instructions as I am very stressed and I get very confused at the best of times, right now I'm in melt-down/panic mode! [11-Nov-2018 07:59:56 UTC] PHP Warning: require(classes/payment.php): failed to open stream: No such file or directory in /home/(USERNAME)/public_html/checkout_process.php on line 45 [11-Nov-2018 07:59:56 UTC] PHP Warning: require(classes/payment.php): failed to open stream: No such file or directory in /home/(USERNAME)/public_html/checkout_process.php on line 45 [11-Nov-2018 07:59:56 UTC] PHP Fatal error: require(): Failed opening required 'classes/payment.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/sewingchestco/public_html/checkout_process.php on line 45
  25. zefeena

    Checkout confirmation blank white page

    I am working my way through this thread as the situation as worsened, and now the orders don't get placed at all - it just goes round and round (if you want to see the problem you can create an order and go through the rpocess using 'admin only' as the payment method - no money is taken, its the COD module that has been re-named) I looked at the quote above and there is in fact a 'local folder'. at public/includes/local all I have in it is a txt file contents as follows This directory contains local configuration information. It also must contain a file named configure.php that can be used to override the defaults set in application_top.php Remember to execute PHP commands the file needs to start with <?php and end with ?> There has never been a configure.php file in my install - obviously that had been missed! As for the definitiions. I do NOT have a catalog folder.
×